Cannot delete a PPA

Bug #392887 reported by Michael Marley on 2009-06-27
374
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Julian Edwards

Bug Description

A while back, the ability was added to create new PPAs. This is great, but I have just discovered that there is no method to delete PPAs. Is there any way to get a PPA deleted?

Related branches

Julian Edwards (julian-edwards) wrote :

Thank you for reporting this bug. We plan on tackling this problem later this year.

Changed in soyuz:
importance: Undecided → Low
status: New → Triaged
tags: added: feature ppa
Michael Nelson (michael.nelson) wrote :

Do we want to actually delete a PPA? Could we not instead disassociate a PPA from a team/person. That is, if it is deactivated, could we simply not list it on the person/team pages, but still leave the url traversal there? That would be quite an easy fix and might meet most peoples needs (It seems that most people requesting PPA deletion/deactivation are really just keen for it to not appear as one of their PPAs).

<ripps> Is there going to be the possibility to delete ppa's in the future?
<noodles775> ripps: afaiui, we'd always want to keep a history of the publishing (like any other publishing system). Why do you want to delete the history of an old PPA?
* adeuring (<email address hidden>) has joined #launchpad
<ripps> noodles775: I was considering creating a seperate ppa for testing new libmpdclient2 apps, but once they've hit fullsteam, I wanted to move the packages to their respected primary ppas
<ripps> I suppose I should just use my personal staging ppa for that.
* poolie (n=mbp@canonical/launchpad/poolie) has joined #launchpad
<ripps> It seems unneccsary to have an empty ppa in my teams page
<noodles775> ripps: yeah, either way that'd be fine, but I still don't see why you'd need or want to delete the history of publishing to that test ppa.
<noodles775> ripps: right
<noodles775> ripps: so perhaps we should investigate the ability to dis-associate a ppa with a team/person.
<ripps> noodles775: actually, yes. That probably be better
<noodles775> ripps: great. I'll see if there's already a bug, if not I'll file it.
<ripps> noodles775: thanks :)
<ripps> noodles775: Oh, I have an even better question, if I could indeed disassciate a ppa from my team, could I make the leftover address of that old ppa forward to a new one. It seems I might need to merge 2 ppas in the near future.

tags: added: oem-services
Max Bowsher (maxb) wrote :

For phase one of this, could we just allow registrants to toggle the disabled flag of their own PPAs?

Or are there other concerns that mean a LOSA must be able to disable a PPA in a way that a registrant is not permitted to undo?

dysmann (dysmann) wrote :

The ability to completly remove a PPA would be great for users who whant to change their name.

We could otherwise change our name, the PPA address would be changed to but the former address would work too if the PPA was not empty

If a PPA is empty, it would be great to remove it.

Julian Edwards (julian-edwards) wrote :

Max, good question, and I'm not sure I have an answer. We could easily add the extra field on the +edit form.

And if you create a PPA which is named improperly, for some reason (could be testing), it would be nice to be able to remove it.

Also, it would be nice to be able to rename the PPA key, which is named after the first PPA created, which might not be a meaningful name ;-)

Since this blocks user renames for anyone with a PPA, and we (LOSAs) get quite a lot of requests for that we should do one of two things:

- Decide we won't rename anyone's account by any method (even manual workarounds) if they have a PPA
- Fix this bug so they can rename their PPA (with appropriate warnings about implications for PPA breakage)

Currently the workaround which users are often told the LOSAs can do is error prone and cumbersome.

summary: - Cannot delete PPA
+ Cannot delete or rename a PPA
Oumar Aziz OUATTARA (wattazoum) wrote :

Hi,

If the renaming or deletion is such a problem, wouldn't it be reasonable to think about a "deprecation" feature that would allow to hide the PPA at least ?

My point is that the existence of these PPAs on the front page is misleading for users, so I would be more than happy if I could hide mine.

Julian Edwards (julian-edwards) wrote :

Yes, this is already possible although only an admin can do it. It's possible to make a change so that the PPA owner can do it themselves so I filed bug 495975 to do that.

I just want to delete my PPA because I want to change my name and thus my @ubuntu.com e-mail address.

Tom Haddon (mthaddon) wrote :

Julian, I don't think it's okay to say this is possible for admins to do it. Per my comment above, that method is time consuming and error prone. We should either support this through the UI or not do it at all.

Comment prompted by more PPA rename requests assigned to ~canonical-losas.

Split renaming of PPAs into bug #546209

Changed in soyuz:
assignee: nobody → Cody A.W. Somerville (cody-somerville)
status: Triaged → In Progress
summary: - Cannot delete or rename a PPA
+ Cannot delete a PPA
Changed in soyuz:
milestone: none → 10.03
status: In Progress → Fix Committed
tags: added: qa-needstesting

Stupid bot, it's not fixed yet :)

Changed in soyuz:
status: Fix Committed → In Progress
tags: removed: qa-needstesting
Changed in soyuz:
milestone: 10.03 → none
Ursula Junque (ursinha) wrote :
Changed in soyuz:
milestone: none → 10.04
status: In Progress → Fix Committed
tags: added: qa-needstesting

Bad bot, please leave my bugs alone.

Changed in soyuz:
status: Fix Committed → In Progress
tags: removed: qa-needstesting
Ursula Junque (ursinha) wrote :
Changed in soyuz:
status: In Progress → Fix Committed
tags: added: qa-needstesting
Changed in soyuz:
status: Fix Committed → In Progress
tags: removed: qa-needstesting
Changed in soyuz:
assignee: Cody A.W. Somerville (cody-somerville) → Julian Edwards (julian-edwards)

How do I use commited-fix? I want to remove my PPA

The fix is not yet committed, the previous status changes were done by a bot that didn't know the full story.

However, if you are in the beta testers team, tomorrow you'll be able to try out the new deletion functionality as I'll be adding a "Delete PPA" menu item on the PPA.

Andrew (and471) wrote :

It is great to see progress on this bug :-)

Ursula Junque (ursinha) wrote :
Changed in soyuz:
status: In Progress → Fix Committed
tags: added: qa-needstesting
Philip Muškovac (yofel) wrote :

When trying to delete an empty and disabled ppa I had on

https://edge.launchpad.net/~yofel/+archive/dep/+delete

I got a confirmation dialog and then OOPS-1581EB1167

tags: added: qa-ok
removed: qa-needstesting
Hugh Saunders (hughsaunders) wrote :

I also tried to delete a PPA using edge and got OOPS-1581ED1403

Thanks for the OOPS reports, it only seems to happen when the archive is already disabled. If you re-enable before deleting it should work. In the meantime, we'll get that fixed.

tags: added: qa-needstesting
removed: qa-ok
rww (rww) wrote :

Confirmed. Having re-enabled my PPA, I was able to delete it without getting an OOPs report, and got the message "Deletion of 'PPA for Robert Wall' has been requested and the repository will be removed shortly."

Oleg Shparber (trollixx) wrote :

I deleted two PPAs several days ago, but they didn't dissapeared from my PPA list. They became greay and corresponding label appeared inside. Will they be removed completely, f.e. will I be able to change my nick ever?

The fix and QA for the oops during deletion of disabled PPAs is documented in bug 574246.

tags: added: qa-ok
removed: qa-needstesting

I have been waiting for months to get rid of my stale PPA and still dont
have the delete button available yet.

What do I have to do to get into the beta testing team?

Felix Geyer (debfx) wrote :

You just need to join the launchpad-beta-testers team: https://launchpad.net/~launchpad-beta-testers

Philip Muškovac (yofel) wrote :

No need to join the beta testing team if you just want to test this one feature. Just use https://edge.launchpad.net instead of launchpad.net. All the beta team membership does is auto-redirect you to edge when you open a launchpad page.

Fionn (fbe) wrote :

Am Montag, den 03.05.2010, 14:21 +0000 schrieb Philip Muškovac:

> No need to join the beta testing team if you just want to test this
> one feature

No problem! I'll gladly report on other features as well as long as I
get the impression that people read and react.

Regarding the PPA deletion:

Reason No#1 for people requesting this feature in Launchpad was probably
the same that I have: They wanted to rename their account and that is
impossible with a PPA in the account.

When I was new to LP I created a test PPA, not immediately recognizing
that a part of my email-adress had been used to automatically name my
account in a way that I really do not like.
When I realized what happened, I already had contributed to numerous bug
reports and didnt want to lose track of it all by abandoning the account
and creating a new one. But unless my account gets a new name, I will
keep my "private" repository on my own server and wont create new PPAs
on launchpad, although I would like to.

That said, I honestly do NOT regard this bug as fixed because:
The "deleted" PPA is still there! It is sort-of-marked-as-zombie and
even still visible on my profile page. I pretty much fail to see ANY
difference between the PPA being disabled or deleted at all.
Moreover, it is still impossible to change the account name because
"This user has a PPA and may not be renamed.". So, the primary goal of
all the fuzz has entirely been missed, IMHO.

Just my 2c on the issue...

Andrew (and471) wrote :

I am afraid that my issue is exactly the same as Fionn's, if the username cannot be renamed, then this bug cannot be marked as fixed as the PPA has not really been deleted.

Please don't take this as we don't value and appreciate what you have done, we DO and please keep up the good work :-)

> I pretty much fail to see ANY difference between the PPA being disabled or deleted at all.

The fix in place deletes the external repository, so there's quite a difference.

Deleting the PPA permanently is quite complicated so we're doing this in 2 stages. This first stage, which is important to many people, is to get the external repository deleted while keeping the internal history in place.

The second stage is to delete all the internal Launchpad references and remove all trace of it.

The reason this second stage is hard is because a PPAs packages can be copied and shared between other PPAs so it's not a simple case of blitzing the database rows.

If anyone wants to get involved and accelerate the implementation of this second stage, patches are extremely welcome.

Regarding renaming of accounts, I think we can enable that now once a person has deleted all their PPAs. Please see bug 386167

Changed in soyuz:
status: Fix Committed → Fix Released
Felix Lechner (felix.lechner) wrote :

After reading Julian's comment #35, I fear that my deleted PPAs will remain grayed out and block the names forever.

Being relatively new to Launchpad, I uploaded like crazy to my PPAs 'linphone' and 'linphone-snapshots' to experiment. Then I deleted both them in hope of recreating them fresh and empty. Unfortunately, it looks like the delete button is a bit of a misnomer. If the deleted PPAs are not going away. Is there a way I can reactivate them to reuse the names?

The PPAs are intended for publication. I would like to use the names again.

I have no problem using the old ones. I was just trying to get rid of junk on Launchpad servers, such as multiple orig.tar.gz submissions.

This is, a feature request for an 'undelete' button, I suppose---given the constrains outlined by Julian in comment #35.

Felix, re-enabling is not fully supported yet. If anyone wants to write a patch I can show you what to do.

Scott McLeod (halcyonblue) wrote :

I'm new to PPAs and wanted to recreate my PPA. I'm really dissapointed that now I can't use this PPA name at all! I would never have pressed the delete button if I had known that it worked this way. It should be labeled, "Disable the ability for this PPA to exist for eternity." If you aren't going to support truly deleting PPAs, then maybe it would make more sense to simply have a UI feature that hides PPAs in a way that isn't permanent.

If there's anyway I can get my ppa reactivated it's https://launchpad.net/~halcyonblue/ffmpeg

Thanks.

On Monday 13 December 2010 22:54:39 you wrote:
> If there's anyway I can get my ppa reactivated it's
> https://launchpad.net/~halcyonblue/ffmpeg

Go into the Edit PPA page and you can re-enable it.

Scott McLeod (halcyonblue) wrote :

Thank you!

On Dec 13, 2010, at 6:17 PM, Julian Edwards <email address hidden> wrote:

> On Monday 13 December 2010 22:54:39 you wrote:
>> If there's anyway I can get my ppa reactivated it's
>> https://launchpad.net/~halcyonblue/ffmpeg
>
> Go into the Edit PPA page and you can re-enable it.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/392887
>
> Title:
> Cannot delete a PPA
>
> Status in Soyuz - The Launchpad Package Manager:
> Fix Released
>
> Bug description:
> A while back, the ability was added to create new PPAs. This is great, but I have just discovered that there is no method to delete PPAs. Is there any way to get a PPA deleted?
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/soyuz/+bug/392887/+subscribe

Scott McLeod (halcyonblue) wrote :

Looks like once a PPA is in the deleted state the "Change Details" link goes
away. I added /+edit to the end of my PPA's url and was able to re-enable.
 Thanks again!

Scott

On Mon, Dec 13, 2010 at 6:42 PM, Scott McLeod <email address hidden> wrote:

> Thank you!
>
> On Dec 13, 2010, at 6:17 PM, Julian Edwards <email address hidden>
> wrote:
>
> > On Monday 13 December 2010 22:54:39 you wrote:
> >> If there's anyway I can get my ppa reactivated it's
> >> https://launchpad.net/~halcyonblue/ffmpeg
> >
> > Go into the Edit PPA page and you can re-enable it.
> >
> > --
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> > https://bugs.launchpad.net/bugs/392887
> >
> > Title:
> > Cannot delete a PPA
> >
> > Status in Soyuz - The Launchpad Package Manager:
> > Fix Released
> >
> > Bug description:
> > A while back, the ability was added to create new PPAs. This is great,
> but I have just discovered that there is no method to delete PPAs. Is there
> any way to get a PPA deleted?
> >
> > To unsubscribe from this bug, go to:
> > https://bugs.launchpad.net/soyuz/+bug/392887/+subscribe
>

Pali (pali) wrote :

Is there some news or way how to completely delete PPA (or deleted gray PPA)?

No, this is not implemented and is not part of any near-term goals. However, Launchpad is open source and if anyone would like to attempt a fix on this someone will be able to mentor you.

Thomas (t.c) wrote :

I also like to prefer to completely delete PPAs (now I have some i wanna completely delete)
Hope somebody can implement it :-)

Maxim Tikhonov (tikhonov) wrote :

If you use Chrome, you can use this Greesemonkey script I created to hide grey PPAs.

Bernmeister (thebernmeister) wrote :

Is it possible to put in a redirect option?

In my case I have deleted a bunch of PPAs and would be quite happy to have them redirect to another PPA.

For example, I had the PPA https://launchpad.net/~thebernmeister/+archive/indicator-lunar (and others) and have deleted them and consolidated to one PPA, namely https://launchpad.net/~thebernmeister/+archive/ppa.

So either a redirect to another PPA or even a LaunchPad page would do the trick instead of a full delete in the back end.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions