Distributions can't register series (releases)

Bug #211223 reported by Matthew Paul Thomas on 2008-04-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Curtis Hovey
Baltix
Undecided
Unassigned

Bug Description

Maintainers of distributions other than Ubuntu, most notably Baltix, are unable to register series for their distribution. This makes it difficult for them to track bugs using Launchpad.

If this ability was implemented, fixing bug 58250 would become unnecessary.

It may save time to fix bug 80309 at the same time as this bug.

[Originally reported by Mantas Kriaučiūnas in #launchpad.]

Mantas Kriaučiūnas (mantas) wrote :

Now Lauchpad forbids to change (edit) distribution details (description, summary, etc., look at https://edge.launchpad.net/baltix/+edit ), besides an ability to register new release (or milestone) for other distros in launchpad is removed :( Should I report another bug about newly appeared prohibition to change distribution details?

Colin Watson proposes to add the possibility to register a milestone that doesn't have a series yet, and to move milestone to the series once it's registered. Maybe this would be a quick solution for this long standing issue? See bug #201623 for more info.

Btw, shouldn't this bug be assigned to soyuz product ?

Julian Edwards (julian-edwards) wrote :
Changed in launchpad:
status: New → Invalid
Changed in soyuz:
status: New → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

Launchpad developers, please, let other ubuntu-based distributions to register releases (series) for their distribution. Now it's very difficult to track bugs using Launchpad - I can't nominate bugs for fixing, I can't set target milestone, etc., even when I'm the release manager:

" Bug nominations are evaluated by release managers and accepted or declined for fixing in a release.

 The Baltix release manager is Mantas Kriaučiūnas. "

Julian Edwards (julian-edwards) wrote :

This is assigned to the Registry team now.

Changed in soyuz:
status: Confirmed → Invalid
Changed in launchpad-registry:
status: Invalid → Confirmed
Curtis Hovey (sinzui) wrote :

This sounds like a serious problem. I expect to be able to create series as the maintainer of a project. I think this bug is similar to bug 232454. Maybe they can be fixed at the same time?

Curtis Hovey (sinzui) on 2009-01-05
Changed in launchpad-registry:
status: Confirmed → New

On Monday 05 January 2009 17:46:31 Curtis Hovey wrote:
> This sounds like a serious problem. I expect to be able to create series
> as the maintainer of a project. I think this bug is similar to bug
> 232454. Maybe they can be fixed at the same time?

There's a specific requirement to be an LP admin to get the "New series" link
appearing on the +series page. Why, I don't know ...

Celso Providelo (cprov) wrote :

Well, the reason from requiring lp.Admin for creating distribution series is that the publication-side requires a lot of actions to take place before a series can actually be used (see initialise-from-parent.py).

Anyway, the complementary actions are only required for hosted distributions, which atm only Ubuntu is. All other non-hosted distribution may allow series creation for bug-tracking purpose (for instance), since they will never end up being published on disk.

Thinking a little bit further, we might start importing external repositories for non-hosted distribution using 'gina', this way they could also benefit of having a corresponding list of published packages (important for bug-tracking as well). When we start doing it, we have to guarantee that all the distribution.main_archives are skipped from publication (IArchive.publish == False). So, this might be a more permanent and more effective check to perform before allowing series creation for lp.Edit than checking for 'if not ubuntu'; in plain English "Only allow series creation by distribution owners/drivers if the distribution is not going to be published by LP."

Curtis Hovey (sinzui) wrote :

Thank you Celso for the explanation. We can use the Ubuntu celebrity now if we want to provide this feature now. We need a model change to allow distros to publish, maybe official_packages like we use official_bugs?

Celso Providelo (cprov) wrote :

Agreed, go with the Ubuntu celebrity for now, since there is no realistic plan for starting importing packages. I've just mentioned it for providing a big-picture scenario (now I realize it wasn't the brightest idea of the day).

I'm not entirely sure about your suggestion for adjusting the model for representing the existence of packages in a distribution. It seems to me that it's a transparent feature, either it has or hasn't packages, if they exist they will be presented in the UI.

On the other hand, we can represent the fact that a distribution accept or not uploads, if its packages get imported or not (and from where), and finally if we publish its packages or not. Does it make sense ?

Celso Providelo (cprov) wrote :

For the record, those point are way out of the scope of this bug, I will cease the noise ;)

Curtis Hovey (sinzui) on 2009-01-19
Changed in launchpad-registry:
importance: Undecided → Wishlist
status: New → Triaged
Curtis Hovey (sinzui) on 2009-07-20
tags: added: story-release-planning
removed: registry
Curtis Hovey (sinzui) wrote :

This is fixed in development. The feature will be available on edge in a few days.

Changed in launchpad-registry:
assignee: nobody → Curtis Hovey (sinzui)
milestone: none → 2.2.8
status: Triaged → Fix Committed

Fixed released in launchpad-project 2.2.8.

Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers