System wxPython in path causing problems with Pcbnew menu, resize and close button

Bug #1490762 reported by Diogo on 2015-08-31
68
This bug affects 9 people
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
High
Adam Wolf

Bug Description

If you have wxpython installed using homebrew it adds a .pth file thats processed on python start. This causes wxversion.py to pick up on the system wxpython libraries and so there are conflicts between the bundled wxwidgets and the system wxwidgets libraries

This causes

Resize issues in pcbnew
Menu issues in pcbnew
Python Console issues in pcbnew

If you run kicad from the command line there are errors about undefined behaviour due to the conflicts of the system wxwidgets libraries and the bundle wxwidgets libraries

Tags: osx Edit Tag help
Diogo (diogocondeco) wrote :
Diogo (diogocondeco) wrote :

It might be important to mention that I am running kicad on a regular macbook air... No retina display

Diogo (diogocondeco) wrote :

This problem is caused by the presence of wxmac and/or wxpython packages from homebrew... After an update these packages prevent kicad from running correctly... Just need to make sure they are no present on the system and the problem won't be present.
This is independent of the version used to compile kicad, and affects the official nightly builds.

Jesper Krog Poulsen (6-jesper) wrote :

Affects me too, but only Pcbnew and footprint editor, not eeschema or library editor.

OS X version is 10.11 (The copy version function seems to report this incorrectly)

Version info from pcbnew:

Application: pcbnew
Version: (2015-10-02 BZR 6241)-product release build
wxWidgets: Version 3.0.2 (debug,UTF-8,compiler with C++ ABI 1002,GCC 4.2.1,STL containers,compatible with 2.8)
Platform: Mac OS X (Darwin 15.0.0 x86_64), 64 bit, Little endian, wxMac
Boost version: 1.54.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=ON
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Jesper Krog Poulsen (6-jesper) wrote :

Removing wxwidgets or wxmac from homebrew solves the problem, but then I get a "pcbnewInitPythonScripting() failed." message. The details says: "Error importing the wxPython API!"

Diogo (diogocondeco) wrote :

Further testing on this issue let me to believe that there is still some data in the system which results in that error message. I was able to remove it by doing the following: removing completely homebrew (/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/uninstall)" -> may suggest to remove some other dirs in the end, also did that) and/or macports(https://guide.macports.org/chunked/installing.macports.uninstalling.html) and removing kicad completely. (kicad Application and kicad Application support folders).

Unfortunately, I did this in a single step and I am not able to be more precise on the step that really solved the issue. Now there is no error message.

I have some doubts thought on a correct behaviour of the application... When I open the footprint editor (without a pcbnew window being opened first) I get a blank pcbnew window and the footprint editor. But, nickoe confirmed this same behaviour on a windows machine... so it should be all fine with this work around.

Not sure if this ^^^^^ can be addressed like a bug... I have attached a screenshot...

If anyone could first try to remove completely remove kicad folders and preferences, to test this solution and post the results would be much appreciated...

Diogo

2015-10-18 0:29 GMT+02:00 Diogo <email address hidden>:
> Further testing on this issue let me to believe that there is still some
> data in the system which results in that error message. I was able to
> remove it by doing the following: removing completely homebrew
> (/usr/bin/ruby -e "$(curl -fsSL
> https://raw.githubusercontent.com/Homebrew/install/master/uninstall)" ->
> may suggest to remove some other dirs in the end, also did that) and/or
> macports(https://guide.macports.org/chunked/installing.macports.uninstalling.html)
> and removing kicad completely. (kicad Application and kicad Application
> support folders).
>
> Unfortunately, I did this in a single step and I am not able to be more
> precise on the step that really solved the issue. Now there is no error
> message.
>
> I have some doubts thought on a correct behaviour of the application...
> When I open the footprint editor (without a pcbnew window being opened
> first) I get a blank pcbnew window and the footprint editor. But, nickoe
> confirmed this same behaviour on a windows machine...

ehh, no. This was on linux with 6271. I am not sure how Diogo's
response or this test is related to this. But what I tested was what
happened when one clicked the footprint editor icon on the kicad app.
I stated at the time that it opened a blank pcbnew windows, I was
wrong. It opens the footprint editor as expected.

> so it should be
> all fine with this work around.
>
> Not sure if this ^^^^^ can be addressed like a bug... I have attached a
> screenshot...
>
> If anyone could first try to remove completely remove kicad folders and
> preferences, to test this solution and post the results would be much
> appreciated...
>
> Diogo
>
> ** Attachment added: "Screen Shot 2015-10-17 at 23.23.22.png"
> https://bugs.launchpad.net/kicad/+bug/1490762/+attachment/4498366/+files/Screen%20Shot%202015-10-17%20at%2023.23.22.png
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1490762
>
> Title:
> Pcbnew MAC OS X interface won't resize correctly
>
> Status in KiCad:
> New
>
> Bug description:
> Resizing kicad windows (eeschema, pcbnew, library editor and footprint
> editor) won't resize correctly. The windows stay with the same aspect.
> Meaning when enlarging the window gray spaces appear (screenshot
> attached), and decreasing the window size will hide the right bar and
> the bottom information bar and also hide the screen area depending on
> the resize made.
>
>
> Reproduce:
> Open kicad;
> Open on of the following applications: eeschema, pcbnew, library editor and footprint editor (gerbview, pcb calculator, etc are working correctly);
> Resize the window.
>
> Software information:
> MAC OS X 10.10.5
> BZR 6132 (also present in other recent builds)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions

Is this occuring any longer? also is it happening with Adams nightlies/stable (from the kicad website) or only from homebuilt

Changed in kicad:
status: New → Incomplete
Peter Horvath (ejcspii) wrote :

Yes, I can confirm that having wxmac/wxpython installed via homebrew breaks the menu bar on the current nightly. metacollin's homebrew recipe works correctly in this respect (has other issues though)

Unfortunately, having wxmac/wxpython through homebrew is important, for instance gnuradio requires them.

xzcvczx (xzcvczx) on 2015-12-20
Changed in kicad:
status: Incomplete → Confirmed
xzcvczx (xzcvczx) wrote :

I have managed to reproduce this by having wxpython installed from homebrew, On my primary machine which i only use nightlies on i have only wxwidgets (wxmac) installed through homebrew which does not cause the issue as far as i have seen

If anyone can reproduce this issue with only wxwidgets installed from homebrew please comment on the ticket

xzcvczx (xzcvczx) wrote :

To work around this issue, you can

mv /Applications/kicad.app/Contents/Frameworks/python/site-packages/wx-3.0-osx_cocoa /Applications/kicad.app/Contents/Frameworks/python/site-packages/wx-3.0-osx_cocoa.old

and it should resolve the issues. This is not ideal by any means, but i am currently trying to fix the problem

xzcvczx (xzcvczx) wrote :

I have got a patch made for testing, am currently waiting for the build to be available to test

summary: - Pcbnew MAC OS X interface won't resize correctly
+ System wxPython in path causing problems
description: updated
Andres (vandresv) on 2016-01-25
summary: - System wxPython in path causing problems
+ System wxPython in path causing problems with Pcbnew menu, resize and
+ close button
metacollin (metacollin) wrote :

Peter Horvath, if you could shoot me an email (<email address hidden>) or open an issue on the homebrew tap with some of the other issues that occur with my tap, I would very much appreciate it. I am trying to make the tap as reliable as possible.

Also, relevant to this bug: I found that I had to explicitly set essentially every python related path in cmake. Cmake would pick up on the homebrew python interpreter, link to the system python (instead of the same interpreter and same library), and find wxpython elsewhere on the system. Basically, cmake should not be trusted to handle anything python related, at least on OS X. But simply passing all of these paths explicitly seemed to fix the problem.

metacollin (metacollin) wrote :

A good way to check the setup is to configure with cmake, then run ccmake ../ (just like cmake). It will bring up a curses interface with every configuration option available, and its value (if any). Be sure to hit 't' for advanced mode.

There are a few more paths than you probably realize that need to be explicitly curated. Of particular interest that seems to often pick up the homebrew path instead is a value weirdly called '_filename'. It's the location of the wx/version.h file, and often finds the wrong one.

xzcvczx (xzcvczx) wrote :

@metacollin is there any particular reason you avoid the system python installation preferring a homebrew install of it?

xzcvczx (xzcvczx) wrote :

Attached is a patch that fixes this issue if you have wxpython brewed and you are using a kicad that has wxpython bundled with it. Its an early patch at the moment and works here. If someone finds any issues with it let me know

Russ Garrett (russ-garrett) wrote :

The workaround doesn't seem to work for me any more with KiCad 4.0.5 on OS X. Removing the wx module from kicad's site-packages fixes it for Eeschema but not for PCBNew.

Russ Garrett (russ-garrett) wrote :

Update: I think I have managed to work around this by installing HEAD using homebrew using this tap (https://github.com/metacollin/homebrew-kicad) and disabling scripting using this build command:

brew install kicad --HEAD --without-python

Brendan Simon (brendan-simon) wrote :

See my bug report (which is probably a duplicate of this bug)

    https://bugs.launchpad.net/kicad/+bug/1729259

I do NOT have `wxpython` or `wxmac` installed via brew. I do have official wxPython packages installed via the installer for Python 2.5, 2.6 and 2.7. I also have wxPhoenix (wxPython 4.0) wheel installed for Python 3.6 via pip.

I can not close `pcbnew` or open the python scripting console.

If if I rename `/usr/local/bin` and `/usr/local/lib`, then things start to work. i.e. I can close the `pcbnew` window and the python scripting console appears.

    sudo mv /usr/local/bin /usr/local/bin.ORIG
    sudo mv /usr/local/lib /usr/local/lib.ORIG

Interestingly, v4.0.7 python console has some issues with some keys. e.g. I can't press the `o` or `x` keys as they are interpreted as accelerators and the menu flashes. This does not happen in recent snapshots.

import sys
print sys.path
['/private/var/folders/1h/df5214x933ndx_mpl0h71l_r0000gn/T/AppTranslocation/89F1319C-EF15-4533-943D-13121F48F49B/d/kicad.app/Contents/Frameworks/python/site-packages/wx-3.0-osx_cocoa', '/private/var/folders/1h/df5214x933ndx_mpl0h71l_r0000gn/T/AppTranslocation/89F1319C-EF15-4533-943D-13121F48F49B/d/kicad.app/Contents/Frameworks/python/site-packages/wx-3.0-osx_cocoa', '/private/var/folders/1h/df5214x933ndx_mpl0h71l_r0000gn/T/AppTranslocation/89F1319C-EF15-4533-943D-13121F48F49B/d/kicad.app/Contents/SharedSupport/scripting', '/private/var/folders/1h/df5214x933ndx_mpl0h71l_r0000gn/T/AppTranslocation/89F1319C-EF15-4533-943D-13121F48F49B/d/kicad.app/Contents/Frameworks/python/site-packages', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload', '/Users/brendan/Library/Python/2.7/lib/python/site-packages', '/usr/local/lib/python2.7/site-packages', '/Library/Python/2.7/site-packages', '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python', '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC', '/usr/local/lib/wxPython-3.0.2.0/lib/python2.7', '.', '/private/var/folders/1h/df5214x933ndx_mpl0h71l_r0000gn/T/AppTranslocation/89F1319C-EF15-4533-943D-13121F48F49B/d/kicad.app/Contents/SharedSupport/scripting', '/private/var/folders/1h/df5214x933ndx_mpl0h71l_r0000gn/T/AppTranslocation/89F1319C-EF15-4533-943D-13121F48F49B/d/kicad.app/Contents/SharedSupport/scripting/plugins']

Brendan Simon (brendan-simon) wrote :

My workaround/solution is to put a script to set the path and start the application.

    $ cat ~/bin/kicad.sh

    #!/bin/sh

    export PATH=/usr/bin:/bin:/usr/sbin:/sbin

    open /Applications/Kicad-v4.0.7/kicad.app

It works great.

Could you not have similar scripts in the Application bundle root (for each of the apps/symlinks) so that the paths is set to something minimal for the apps to work?

Not sure if you need to use `open` or not, and make the app path relative to the script location.

That should solve the issue and not have to uninstall python/wxpython installs via brew or what not.

Brendan Simon (brendan-simon) wrote :

Oops. Spoke too soon. I forgot to undo the moving of `/usr/local/bin` and `/usr/local/lib`.

My script does not solve the problem :( Sorry for the noise ... sigh ...

Would you want to test a build in a week or two? I could send one over
then to see if the change fixes your issue.

Adam Wolf

On Nov 20, 2017 5:16 PM, "Brendan Simon" <email address hidden> wrote:

> Oops. Spoke too soon. I forgot to undo the moving of `/usr/local/bin`
> and `/usr/local/lib`.
>
> My script does not solve the problem :( Sorry for the noise ... sigh
> ...
>
> --
> You received this bug notification because you are subscribed to KiCad.
> Matching subscriptions: OS X KiCad bugs
> https://bugs.launchpad.net/bugs/1490762
>
> Title:
> System wxPython in path causing problems with Pcbnew menu, resize and
> close button
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions
>

Brendan Simon (brendan-simon) wrote :

Yes please. More than happy to test. I've been trying the nightly builds every day to see if things have improved.

Brendan Simon (brendan-simon) wrote :

Ideally a bundled python and wxPython 4 (aka wxPhoenix) would be a good way to go. wxPhoenix can be installed standalone (unlike wxPython 3 with it's path hacks). Could even bundle Python 3.6 ;-)

I'm assuming wxPython is actually used by Kicad. If not, just bundling python itself would probably solve the issue.

Adam Wolf (adamwolf) wrote :

It is not possible right now to bundle WxPython 4 with KiCad. We are
minutes-days away from the V5 feature freeze, and all of my KiCad time
is spent on that--but bundling Python is already in work I'm doing.

If someone wants to start the WxPython4 work, that isn't something I
can start on until after V5 is out and I am not sure it will be at the
top of my list at that point.

On Mon, Nov 20, 2017 at 6:20 PM, Brendan Simon
<email address hidden> wrote:
> Ideally a bundled python and wxPython 4 (aka wxPhoenix) would be a good
> way to go. wxPhoenix can be installed standalone (unlike wxPython 3
> with it's path hacks). Could even bundle Python 3.6 ;-)
>
> I'm assuming wxPython is actually used by Kicad. If not, just bundling
> python itself would probably solve the issue.
>
> --
> You received this bug notification because you are subscribed to KiCad.
> Matching subscriptions: OS X KiCad bugs
> https://bugs.launchpad.net/bugs/1490762
>
> Title:
> System wxPython in path causing problems with Pcbnew menu, resize and
> close button
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions

I did bring up phoenix in the channel and was advised that as phoenix has apparently moved away from swig it might be harder than one thinks

> On 21/11/2017, at 1:40 PM, Adam Wolf <email address hidden> wrote:
>
> It is not possible right now to bundle WxPython 4 with KiCad. We are
> minutes-days away from the V5 feature freeze, and all of my KiCad time
> is spent on that--but bundling Python is already in work I'm doing.
>
> If someone wants to start the WxPython4 work, that isn't something I
> can start on until after V5 is out and I am not sure it will be at the
> top of my list at that point.
>
> On Mon, Nov 20, 2017 at 6:20 PM, Brendan Simon
> <email address hidden> wrote:
>> Ideally a bundled python and wxPython 4 (aka wxPhoenix) would be a good
>> way to go. wxPhoenix can be installed standalone (unlike wxPython 3
>> with it's path hacks). Could even bundle Python 3.6 ;-)
>>
>> I'm assuming wxPython is actually used by Kicad. If not, just bundling
>> python itself would probably solve the issue.
>>
>> --
>> You received this bug notification because you are subscribed to KiCad.
>> Matching subscriptions: OS X KiCad bugs
>> https://bugs.launchpad.net/bugs/1490762
>>
>> Title:
>> System wxPython in path causing problems with Pcbnew menu, resize and
>> close button
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1729259).
> https://bugs.launchpad.net/bugs/1490762
>
> Title:
> System wxPython in path causing problems with Pcbnew menu, resize and
> close button
>
> Status in KiCad:
> Confirmed
>
> Bug description:
> If you have wxpython installed using homebrew it adds a .pth file
> thats processed on python start. This causes wxversion.py to pick up
> on the system wxpython libraries and so there are conflicts between
> the bundled wxwidgets and the system wxwidgets libraries
>
> This causes
>
> Resize issues in pcbnew
> Menu issues in pcbnew
> Python Console issues in pcbnew
>
> If you run kicad from the command line there are errors about
> undefined behaviour due to the conflicts of the system wxwidgets
> libraries and the bundle wxwidgets libraries
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions

Brendan Simon (brendan-simon) wrote :

In #1729259, @xzcvczx states there is working going on the bundle python and/or removing wxversion to help resolve these issues.

Where is this work happening? I've been monitoring the git repo and snapshot builds daily, but nothing related to python bundling or wxversion is being committed (that I can see).

This is packaging work, and doesn't really happen in the main repo.
After the V5 packaging work is ready, I'll post in here and link to
the repo, which will have a branch for the python bundling changes.
The V5 work is at least a few weeks out.

On Mon, Dec 4, 2017 at 5:20 AM, Brendan Simon
<email address hidden> wrote:
> In #1729259, @xzcvczx states there is working going on the bundle python
> and/or removing wxversion to help resolve these issues.
>
> Where is this work happening? I've been monitoring the git repo and
> snapshot builds daily, but nothing related to python bundling or
> wxversion is being committed (that I can see).
>
> --
> You received this bug notification because you are subscribed to KiCad.
> Matching subscriptions: OS X KiCad bugs
> https://bugs.launchpad.net/bugs/1490762
>
> Title:
> System wxPython in path causing problems with Pcbnew menu, resize and
> close button
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions

Brendan Simon (brendan-simon) wrote :

Thanks Adam. I'm really looking forward to a nice Christmas present ... being able to use KiCad on my Mac :)

Changed in kicad:
assignee: nobody → Adam Wolf (adamwolf)
Jeff Young (jeyjey) on 2018-02-17
Changed in kicad:
importance: Undecided → High
milestone: none → 5.0.0-rc1
Adam Wolf (adamwolf) wrote :

Hi folks! If anyone here is still interested, I think I have fixed this wxmac/wxpython coexistence issue. There may be other issues with the builds, as there are dramatic changes in the build process, but you can test it out and confirm using any of the builds from https://bugs.launchpad.net/kicad/+bug/1490762 from April 26 2018 or newer. If you do try it, and it is working for you or not, please let me know here. Thanks!

Andres (vandresv) wrote :

Hi, I would like to test it out, but where binary builds actually are? The link you gave https://bugs.launchpad.net/kicad/+bug/1490762 redirects back here.

Adam Wolf (adamwolf) wrote :

Doesn't look like I can edit my comment, so sorry about that copypasta.

http://downloads.kicad-pcb.org/osx/testing/

Andres (vandresv) wrote :

I deleted old kicad from Applications and from Application Support. Then I just dragged new directories to correct places. README file is empty so I assumed that dragging is everything that was necessary.

I did a new project and tried to place something to schematic and got bunch of errors tellimg me that lib files from Application Support cannot be read. So I should probably fix permissions manually.

Andres (vandresv) wrote :

Actually I think they are correct:
drwxr-xr-x@ 8 andres admin 272 Apr 26 10:59 kicad

Adam Wolf (adamwolf) wrote :

Hmm. That's very possible. I would not recommend using these packages to
actually make schematics or pcbs--it is very alpha-- but if you can test
that the things that used to be broken when you had wxpython/wmxmac
installed, that's the main thing I'm interested in.

On Thu, Apr 26, 2018 at 2:18 PM, Andres <email address hidden> wrote:
> I deleted old kicad from Applications and from Application Support. Then
> I just dragged new directories to correct places. README file is empty
> so I assumed that dragging is everything that was necessary.
>
> I did a new project and tried to place something to schematic and got
> bunch of errors tellimg me that lib files from Application Support
> cannot be read. So I should probably fix permissions manually.
>
> ** Attachment added: "error while placing symbol"
>
https://bugs.launchpad.net/kicad/+bug/1490762/+attachment/5127818/+files/kicad5.jpg
>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: OS X KiCad bugs
> https://bugs.launchpad.net/bugs/1490762
>
> Title:
> System wxPython in path causing problems with Pcbnew menu, resize and
> close button
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions

Andres (vandresv) wrote :

My library errors were coming from a fact that indeed those legacy library files were not actually available. So it was not a permission problem.

I have wxpython and wmxmac installed using brew and it seems that other aspects are working fine now. I just have to figure out how to get rid of old libraries.

Andres (vandresv) wrote :

I removed old fp-lib-table and sym-lib-table files from /Users/user/Library/Preferences/kicad and restarted kicad. After that it asked about rebuilding new library and now I do not have missing symbols errors anymore. However I always get a "Error importing wxPython API!" error when I try to place a symbol to a schematic. I can just click OK on the error window to make it disappear and after that everything works fine.

Adam Wolf (adamwolf) wrote :

Interesting.

I would recommend removing this test version and going back to 4.0.7
or whichever kicad you were on earlier, or at least switching to the
non-testing nightlies.

Thanks for testing!

On Fri, Apr 27, 2018 at 1:53 AM, Andres <email address hidden> wrote:
> I removed old fp-lib-table and sym-lib-table files from
> /Users/user/Library/Preferences/kicad and restarted kicad. After that it
> asked about rebuilding new library and now I do not have missing symbols
> errors anymore. However I always get a "Error importing wxPython API!"
> error when I try to place a symbol to a schematic. I can just click OK
> on the error window to make it disappear and after that everything works
> fine.
>
> ** Attachment added: "wxPythonError.jpg"
> https://bugs.launchpad.net/kicad/+bug/1490762/+attachment/5128163/+files/wxPythonError.jpg
>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: OS X KiCad bugs
> https://bugs.launchpad.net/bugs/1490762
>
> Title:
> System wxPython in path causing problems with Pcbnew menu, resize and
> close button
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions

Adam Wolf (adamwolf) wrote :

This is fixed in kicad-mac-packaging, and is confirmed fixed in the nightly testing builds from 20180519.

I cannot recommend using those packages until more issues are fixed, but please rest assured that this will be released as soon as kicad-mac-packaging is ready.

This was a long journey, folks, and I'm super excited to be able to close this out soon!

Changed in kicad:
status: Confirmed → Fix Committed
Jeff Young (jeyjey) wrote :

Well done, Adam!

Adam Wolf (adamwolf) wrote :

Thanks! I am literally going to make a cake with the KiCad logo on it
and eat it once this bug is fixed in the normal releases.

On Sun, May 20, 2018 at 2:04 PM, Jeff Young <email address hidden> wrote:
> Well done, Adam!
>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: OS X KiCad bugs
> https://bugs.launchpad.net/bugs/1490762
>
> Title:
> System wxPython in path causing problems with Pcbnew menu, resize and
> close button
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1490762/+subscriptions

Jeff Young (jeyjey) wrote :

We expect a picture posted to this bug report....

Wayne Stambaugh (stambaughw) wrote :

I second that! @Adam, enjoy that cake, you deserve it!

On 05/20/2018 06:45 PM, Jeff Young wrote:
> We expect a picture posted to this bug report....
>

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers