Text cannot be edited on Windows 7 (value is not shown in the entry box)

Bug #999422 reported by John Smith on 2012-05-15
124
This bug affects 16 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Critical
Inkscape
Medium
Unassigned
Inkscape Devlibs
Medium
Unassigned

Bug Description

Affects Windows 7, does not affect Ubuntu or OS X.

1. Select some text
2. Open the Text and Font dialog
3. Click the Text tab
4. Should see the text and it is editable
5. Click the Font tab
6. Click the Text tab again
7. Now the text is not editable/ and probably not visible

This apppears to be a GTK issue on Windows, that also affects the XML Editor(bug #942475).
When a GtkTextView or GtkEntry is hidden then shown again, the control is not sensitive, and/or content not visible.

John Smith (john-smithi) on 2012-05-15
description: updated
su_v (suv-lp) on 2012-05-15
tags: added: win32
jazzynico (jazzynico) wrote :

Not reproduced on Windows XP, Inkscape trunk revision 11497.

jazzynico (jazzynico) wrote :

Upstream GTK+ bug:
- 668239 - texts disappear when notebook switch page at zh_CN locate!
  <https://bugzilla.gnome.org/show_bug.cgi?id=668239>

summary: - Text and Font dialog : Text cannot be edited on Windows 7
+ Text cannot be edited on Windows 7 (value is not shown in the entry box)
Changed in inkscape:
status: New → Triaged
importance: Undecided → Medium
Changed in inkscape-devlibs:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → JazzyNico (jazzynico)
Changed in gtk:
importance: Unknown → Critical
status: Unknown → Fix Released
iwfer (iwfer) on 2013-08-14
information type: Public → Public Security
V字龍(Vdragon) (vdragon) wrote :

@iwfer
Please don't change information type if the issue is not security related

information type: Public Security → Public
Krzysztof Kosinski (tweenk) wrote :

Fixing this requires downloading an updated release of GTK 2.x from OpenSUSE or rebuilding from source, since the official GTK+ page does not have Windows builds of a fixed version.

jazzynico (jazzynico) on 2014-04-10
Changed in inkscape-devlibs:
assignee: jazzynico (jazzynico) → nobody

When could this be fixed? This is very very annoying and renders inkscape unusable

Hachmann (marenhachmann) wrote :

Here is a question from the answers section where the user has a similar problem with Inkscape 0.91 on a Chinese locale system (with English as language used for Inkscape):
https://answers.launchpad.net/inkscape/+question/295548

(in the duplicate report, there was the locale mentioned to have to do something with the problem)

The user works around it by using a software that fakes the locale for a specific program (in this case, Inkscape).

Is this the same bug or would you like another report?

Hachmann (marenhachmann) wrote :

Additional info: the user now tested with the development version ("inkscape-14990-win32"), and the problem still exists there.

jazzynico (jazzynico) wrote :

Confirmed. The win32 devlibs still use gtk-2.24.10, and the bug is fixed in gtk-2.24.14.
The win64 devlibs are very recent and are not affected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.