Inkscape: A Vector Drawing Tool

when Interpolate objects msg popup Inkscape encountered internal error

Reported by Kaatil on 2012-04-07
This bug report is a duplicate of:  Bug #643272: [win32] 0.48; extensions do not work. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

While interpolating two objects it shows that it has found an internal problem and shuts the program.

Many times I tries to work with interpolate but as when I am using Extensions > Generate from path > Interpolate
It show error that Inkscape en-countered internal problem.

Please sp;ve this problem and tell me whether I have to re-install or not as I have already re-installed the same but no progress happened.

Regards
KAATIL

---
Information which had been added in closed duplicate report bug #975916:
> The same problem also happens when I am using any help files.

System Info:
Windows XP, Inkscape version 0.48.2

Alvin Penner (apenner) wrote :

not reproduced on Windows 7, Inkscape 0.48.3.1, attached is a simple example of interpolation.
could you provide details of which OS, and Inkscape version, and attach the file with the two objects you are using?

Alvin Penner (apenner) wrote :

do you also encounter the same problem if you use a related extension like generate from Path->Extrude

~suv (suv-lp) on 2012-04-07
Changed in inkscape:
status: New → Incomplete
description: updated
~suv (suv-lp) wrote :

Based on the additional line of information in the duplicate report:
> The same problem also happens when I am using any help files.

possibly the same issue as
 Bug #649050 "Inkscape: All functions in Extention menu fail plus most in Help menu"
which itself is a duplicate of
 Bug #643272 "[win32] 0.48; extensions do not work"

tags: added: extensions-plugins

Yeah Alvin I also received an error when I use any related extensions from generate from path, please guide to solve this issue.

Regards

> Date: Sat, 7 Apr 2012 14:15:55 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 975914] Re: when Interpolate objects msg popup Inkscape encountered internal error
>
> do you also encounter the same problem if you use a related extension
> like generate from Path->Extrude
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/975914
>
> Title:
> when Interpolate objects msg popup Inkscape encountered internal error
>
> Status in Inkscape: A Vector Drawing Tool:
> New
>
> Bug description:
> While interpolating two objects it shows that it has found an internal
> problem and shuts the program.
>
> Many times I tries to work with interpolate but as when I am using Extensions > Generate from path > Interpolate
> It show error that Inkscape en-countered internal problem.
>
> Please sp;ve this problem and tell me whether I have to re-install or
> not as I have already re-installed the same but no progress happened.
>
> Regards
> KAATIL
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/975914/+subscriptions

Kaatil (kaatil) wrote :

Hello

Well I am using Windows XP and Inkscape version 0.48

Please solve the issue

> Date: Sat, 7 Apr 2012 14:10:21 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 975914] Re: when Interpolate objects msg popup Inkscape encountered internal error
>
> not reproduced on Windows 7, Inkscape 0.48.3.1, attached is a simple example of interpolation.
> could you provide details of which OS, and Inkscape version, and attach the file with the two objects you are using?
>
>
> ** Attachment added: "interpolate.svg"
> https://bugs.launchpad.net/inkscape/+bug/975914/+attachment/3022811/+files/interpolate.svg
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/975914
>
> Title:
> when Interpolate objects msg popup Inkscape encountered internal error
>
> Status in Inkscape: A Vector Drawing Tool:
> New
>
> Bug description:
> While interpolating two objects it shows that it has found an internal
> problem and shuts the program.
>
> Many times I tries to work with interpolate but as when I am using Extensions > Generate from path > Interpolate
> It show error that Inkscape en-countered internal problem.
>
> Please sp;ve this problem and tell me whether I have to re-install or
> not as I have already re-installed the same but no progress happened.
>
> Regards
> KAATIL
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/975914/+subscriptions

~suv (suv-lp) wrote :

> Well I am using Windows XP and Inkscape version 0.48

Please provide the detailed version information for Inkscape as displayed in Inkscape menu 'Help > About Inkscape'
Reason: There have been several bug fix releases of Inkscape 0.48, and the latest one is pending to be released.

Kaatil (kaatil) wrote :

well i am using version 0.48.2 - Also please provide me latest version of Inkscape

> Date: Sun, 8 Apr 2012 19:22:26 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 975914] Re: when Interpolate objects msg popup Inkscape encountered internal error
>
> > Well I am using Windows XP and Inkscape version 0.48
>
> Please provide the detailed version information for Inkscape as displayed in Inkscape menu 'Help > About Inkscape'
> Reason: There have been several bug fix releases of Inkscape 0.48, and the latest one is pending to be released.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/975914
>
> Title:
> when Interpolate objects msg popup Inkscape encountered internal error
>
> Status in Inkscape: A Vector Drawing Tool:
> Incomplete
>
> Bug description:
> While interpolating two objects it shows that it has found an internal
> problem and shuts the program.
>
> Many times I tries to work with interpolate but as when I am using Extensions > Generate from path > Interpolate
> It show error that Inkscape en-countered internal problem.
>
> Please sp;ve this problem and tell me whether I have to re-install or
> not as I have already re-installed the same but no progress happened.
>
> Regards
> KAATIL
>
>
> Information which had been added in closed duplicate report bug #975916:
> > The same problem also happens when I am using any help files.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/975914/+subscriptions

~suv (suv-lp) on 2012-04-08
Changed in inkscape:
status: Incomplete → New
description: updated
Alvin Penner (apenner) wrote :

the most recent release, Inkscape-0.48.3.1-1.exe, is available at

http://sourceforge.net/projects/inkscape/files/inkscape/0.48.3.1/

Kaatil (kaatil) wrote :

Dear

This is humble request to please give me the installation latest version of inkscape to this email.
I went to the below SITE which was referred by you for downloading the latest version of Inkscape but every time it says
Quote: Your Inkscape download will start Automatically...
Problems with the download? Check your browser's security bar, or try a direct link, or try another mirror.
UnQuote
And hence no files downloaded I tried to download six times but all the times it says same but nothing happened.

This is request to please attach latest installation version of Inkscape the copy you have to this email.

Best Regards (Inconvinience Cause is regretted)
Kaatil

> Date: Sun, 8 Apr 2012 22:00:43 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 975914] Re: when Interpolate objects msg popup Inkscape encountered internal error
>
> the most recent release, Inkscape-0.48.3.1-1.exe, is available at
>
> http://sourceforge.net/projects/inkscape/files/inkscape/0.48.3.1/
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/975914
>
> Title:
> when Interpolate objects msg popup Inkscape encountered internal error
>
> Status in Inkscape: A Vector Drawing Tool:
> New
>
> Bug description:
> While interpolating two objects it shows that it has found an internal
> problem and shuts the program.
>
> Many times I tries to work with interpolate but as when I am using Extensions > Generate from path > Interpolate
> It show error that Inkscape en-countered internal problem.
>
> Please sp;ve this problem and tell me whether I have to re-install or
> not as I have already re-installed the same but no progress happened.
>
> Regards
> KAATIL
>
> ---
> Information which had been added in closed duplicate report bug #975916:
> > The same problem also happens when I am using any help files.
>
> System Info:
> Windows XP, Inkscape version 0.48.2
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/975914/+subscriptions

Alvin Penner (apenner) wrote :

have you tried doing a right mouse button click on the "Direct Link" link?

Kaatil (kaatil) wrote :

Dear Alvin Penner

Sorry for the long email conversations. I tried the direct link as you mentioned but it downloaded the Damaged file total file size downloaded was 474KB and popuup msg "NSIS Error"

 Please tell me...

Regards
Kaatil

> Date: Sun, 8 Apr 2012 22:00:43 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 975914] Re: when Interpolate objects msg popup Inkscape encountered internal error
>
> the most recent release, Inkscape-0.48.3.1-1.exe, is available at
>
> http://sourceforge.net/projects/inkscape/files/inkscape/0.48.3.1/
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/975914
>
> Title:
> when Interpolate objects msg popup Inkscape encountered internal error
>
> Status in Inkscape: A Vector Drawing Tool:
> New
>
> Bug description:
> While interpolating two objects it shows that it has found an internal
> problem and shuts the program.
>
> Many times I tries to work with interpolate but as when I am using Extensions > Generate from path > Interpolate
> It show error that Inkscape en-countered internal problem.
>
> Please sp;ve this problem and tell me whether I have to re-install or
> not as I have already re-installed the same but no progress happened.
>
> Regards
> KAATIL
>
> ---
> Information which had been added in closed duplicate report bug #975916:
> > The same problem also happens when I am using any help files.
>
> System Info:
> Windows XP, Inkscape version 0.48.2
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/975914/+subscriptions

diqrtvpe (ccollett) wrote :
Download full text (3.6 KiB)

I also just ran across this bug. I'm using Inkscape 0.48.3.1 on Ubuntu 12.04, and it so far only happens with one file, which I have attached. On the right of the image there are two lines, a dark grey and a light grey, and attempting to interpolate between the two, exponent 0.0, 50 steps, method 2, duplicating endpaths and style, always crashes. This is a reasonably recent development, as the last time I tried to do this interpolation, a month or two ago, it worked without issue.

Here is the backtrace:

(gdb) bt
#0 0x00000000007cecd7 in Inkscape::Extension::Implementation::Script::effect(Inkscape::Extension::Effect*, Inkscape::UI::View::View*, Inkscape::Extension::Implementation::ImplementationDocumentCache*) ()
#1 0x0000000000b555ad in Inkscape::Extension::ExecutionEnv::run() ()
#2 0x00000000007ca00c in Inkscape::Extension::Effect::effect(Inkscape::UI::View::View*) ()
#3 0x0000000000b55c88 in Inkscape::Extension::PrefDialog::on_response(int) ()
#4 0x00007ffff7a1cf31 in Gtk::Dialog_Class::response_callback(_GtkDialog*, int) () from /usr/lib/x86_64-linux-gnu/libgtkmm-2.4.so.1
#5 0x00007ffff4737057 in g_cclosure_marshal_VOID(int0_t, void) ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#6 0x00007ffff4734eca in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#7 0x00007ffff474d741 in g_signal_emit_valist ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#8 0x00007ffff474e242 in g_signal_emit ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#9 0x00007ffff4734eca in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#10 0x00007ffff474d741 in g_signal_emit_valist ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007ffff474e242 in g_signal_emit ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#12 0x00007ffff5ce3845 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#13 0x00007ffff4734eca in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#14 0x00007ffff474d741 in g_signal_emit_valist ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#15 0x00007ffff474e242 in g_signal_emit ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#16 0x00007ffff5ce266d in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#17 0x00007ffff5d8bdd8 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#18 0x00007ffff4734ca2 in g_closure_invoke ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#19 0x00007ffff4746339 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#20 0x00007ffff474dd7e in g_signal_emit_valist ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#21 0x00007ffff474e242 in g_signal_emit ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#22 0x00007ffff5ea6191 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#23 0x00007ffff5d89f63 in gtk_propagate_event ()
   from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#24 0x00007ffff5d8a2c3 in gtk_main_do_event ()
   from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#25 0x00007ffff59fecac in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0
#26 0x00007ffff4477c9a in g_main_context_di...

Read more...

~suv (suv-lp) wrote :

diqrtvpe wrote:
> I'm using Inkscape 0.48.3.1 on Ubuntu 12.04 (…). This is a reasonably
> recent development, as the last time I tried to do this interpolation,
> a month or two ago, it worked without issue.
(…)
> (gdb) bt
> #0 0x00000000007cecd7 in Inkscape::Extension::Implementation::Script::effect(Inkscape::Extension::Effect*, Inkscape::UI::View::View*, Inkscape::Extension::Implementation::ImplementationDocumentCache*) ()

@diqrtvpe - the regression you report for Inkscape 0.48.3.1 is tracked in
Bug #944077 “inkscape crashed with SIGSEGV in Inkscape::Extension::Implementation::Script::effect()”
<https://bugs.launchpad.net/inkscape/+bug/944077>

(The fix is already committed and will be available in the next planned bug-fix release 0.48.4).

~suv (suv-lp) wrote :

@Kaatil - did you manage to install the newer version of Inkscape, and if so, does the newer version also crash whenever trying to run an extension, or opening a item from the 'Help' menu?

tags: added: win32
Changed in inkscape:
status: New → Incomplete
jazzynico (jazzynico) wrote :

Marking duplicate of Bug #643272 "[win32] 0.48; extensions do not work".
Don't hesitate to comment if you think it's a different issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers