"save a copy as" doesn't open the current folder

Bug #791098 reported by Autiwa on 2011-06-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Johan Engelen

Bug Description

Here is an example of use that doesn't behave as I expect :
I edit an .svg file. In order to reuse it, I do "save a copy as" to save a .pdf (to include in my LaTeX file).

BUT

Each time I do this, it opens me the previous folder were I saved a .pdf the last time I used "save a copy as". I would like to see inkscape opening me the current folder, were the .svg I am editing is, but whether I choose the "'save as...' use the current folder" option or not in the saving properties of inkscape, it doesn't change anything.

I think it's a bug, but maybe I'm wrong and everyone else think it's the way inkscape should behave.

Autiwa (autiwa) on 2011-06-01
description: updated
su_v (suv-lp) on 2011-06-01
tags: added: saving
removed: as copy current folder inkscape save
Changed in inkscape:
importance: Undecided → Wishlist
su_v (suv-lp) wrote :

Related feature request asking to implement the opposite (current state, 0.48):
Bug #241135 “Save a copy... doesn't remember last directory”

su_v (suv-lp) wrote :

-> a solution would be to add an additional preference setting (with default to current state), which allows to optionally use the current directory for 'Save a Copy as…'.

Changed in inkscape:
status: New → Triaged
Autiwa (autiwa) wrote :

Thank you for your quick response. Earlier today, I did not found the feature request you linked here. It's exactly what I'm saying. Don't know why I searched without success. I don't know if it's done, but maybe mark my "bug" as a duplicate of the other one.

su_v (suv-lp) wrote :

In my understanding the other report requests the opposite feature (remember the last used path for 'Save a Copy as…') and your request is not a duplicate.

After bug #241135 had been filed - in Inkscape 0.47 - saving was refactored and and the path no longer stored on the level of individual files, but as global preference, persistent across sessions. An additional preference setting had been added for 'Save as…' to allow the same workflow as in older versions at the time, but this preference only affects 'Save as…' and not 'Save a copy as…' (which acts more like an export function than normal saving).

If I understand you correctly, you are asking to allow the same workflow for 'Save a Copy as…', which would mean to either extend the current setting to also affect 'Save a Copy as…' (at the moment the setting only affects 'Save as…') or add an additional setting so that the current workflow as well as your requested one are possible.

Related discussion:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/30951>
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/30951/focus=30970>

LucaDC (dicappello) wrote :

The current "Save a Copy..." behaviour is annoying for me too.
I feel it's more logical to assume that one wants the copy saved in the current directory rather than in some other, maybe used ages before when she last saved a copy. At least you start from a known place.

"Save as..." already behaves as expected. I'd like having the useful "Save a Copy..." do the same: start from the current directory then remember the new one until Inkscape is closed.

Autiwa (autiwa) wrote :

@suv : I think you're right. At first I didn't realized the other "bug" was complaining about the opposite.

Johan Engelen (johanengelen) wrote :

This seems very easy to change (since Save as... already does want it wished for; and I originally copied the save as.. code for my first patch that added Save a Copy... ;).
Just let me know if it is desired that way...
:)

Autiwa (autiwa) wrote :

That's exactly what I would like indeed. It's great if you can add this feature. Thank you

Johan Engelen (johanengelen) wrote :

Save a copy dialog now opens in current directory if this option is set for save as... dialog.
There is also the possibility to manually change the preferences file to change this option independently from the setting for the save as... dialog: open the preferences xml file, and add
   use_current_dir=\"1\"
to the 'save_copy' group.

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.49
status: Triaged → Fix Committed
Autiwa (autiwa) wrote :

Thank you very much :)

su_v (suv-lp) wrote :

Change was committed to trunk in revision 10263.

Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers