Inkscape: A Vector Drawing Tool

Cursor position markers are not cleared from rulers

Reported by Vladimir Savic on 2010-08-30
This bug affects 200 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski
Nominated for 0.48.x by Gary Frankenbery
inkscape (Arch Linux)
Fix Released
Undecided
Unassigned
inkscape (Fedora)
Unknown
Unknown
inkscape (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: inkscape

Since upgrade to Maverick, rulers sometimes forget to refresh. It happens only on plain pointer move over canvas area. Middle mouse button panning triggers proper ruler repainting, for example. Image is attached to illustrate the problem.

Probably not inkscape's fault directly, this bug, but so far, I've only experienced problems there. Please reassign at will.

Regards,
Vlada

== Ubuntu stable release update (SRU) notes ==
* IMPACT/JUSTIFICATION: This bug makes the on-screen rulers in Inkscape effectively unusable for every Maverick user. Please see the large number of "affects me"/duplicate bugs. This is a major issue for a graphics package, in which precise measurements may be required. Backporting the fix would make a log of people happy!

* DETAILS OF FIX: The bug is fixed in the latest upstream version of Inkscape (0.48.1), which is a bug-fix only release. This version has been released in Natty as inkscape_0.48.1-0ubuntu1. The upstream fix was applied in bzr in r9725 of lp:inkscape/0.48.x

* PATCH DETAILS: The upstream patch has been attached to this report (see 9725_9724.diff). This patch fixes the single issue described in this report, and introduces no additional changes.

* TEST CASE: Start Inkscape; move mouse across canvas. Black triangular cursor marks are splattered across both rulers. [Expected result: A single cursor moves smoothly across each ruler to match the position of the mouse pointer]

* REGRESSION POTENTIAL: As far as I know, no new bugs have been reported concerning the rulers in Inkscape 0.48.1 since this patch was applied.

-- Alex Valavanis

~suv (suv-lp) on 2010-09-02
tags: added: ui
~suv (suv-lp) wrote :

Does it happen with different themes too?

There is an old report about a similar issue with the rulers: Bug #165711 “Ruller bar messed up (Industrial theme)” seems to have been related to some GTK+ themes and solved by updating the theme engine(s).

Changed in inkscape:
status: New → Incomplete
Changed in inkscape (Ubuntu):
status: New → Incomplete

Happens with every theme I can test here. By "here" I mean - in Ubuntu Maverick. Clearlooks, Dust, High contrast theme and Ambience all behave the same.

~suv (suv-lp) on 2010-09-12
Changed in inkscape:
status: Incomplete → New
Changed in inkscape (Ubuntu):
status: Incomplete → New
PeterPall (peterpall) wrote :

The same here with the Nodoka theme. Since this kind of issue loads of times is caused by the X server: lspci for my video card gives me the following line:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

Killing compiz or setting the desktop effects to "none" doesn't make the triangles inside the ruler indicating the pointer's position to be removed before being moved to a new place, though. Refreshing the window or minimizing it won't help, either.

~suv (suv-lp) on 2010-09-12
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: New → Confirmed
Anton Klyukin (antonklyukin) wrote :

Same bug on my system Ubuntu 10.10 (black coordination triangles on rulers). My videocard is Nvidia 7900GTS. I changed driver from Noveau to proprietary - there is a same problem.

Confirmed in Ubuntu 10.10 beta. Inkscape 0.48 from repositories.
However, the problem doesn't show up in Ubuntu 10.04 (I'm using a build from Nightly Builders PPA)

Saul (creative-balm) on 2010-09-26
visibility: public → private
~suv (suv-lp) wrote :

@Saul - sorry my ignorance, but I don't understand why this report was marked as private?

~suv (suv-lp) wrote :

Changing visibility back to 'public' since no reason was given for making it private, and duplicate reports get filed for the same issue.

visibility: private → public
Mahendra Tallur (mahen) wrote :

It's probably not related at all, but I encounter another "refresh" issue in Maverick, with the stars (rating) column in Rhythmbox.

Alex Valavanis (valavanisalex) wrote :

I'm not sure if it's related or not. In any case, I also experience problems with rythmbox on Maverick. For reference, this was reported as bug #649738

Brett Alton (brett-alton) wrote :

I can confirm this on my Asus K72JR, running 64-bit Ubuntu 10.10 (up-to-date). I run the proprietary ATI video driver, but disabled it and this ruler problem still appears.

jr@brett-laptop:~$ apt-cache policy inkscape
inkscape:
  Installed: 0.48.0-1ubuntu1
  Candidate: 0.48.0-1ubuntu1
  Version table:
 *** 0.48.0-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages
        100 /var/lib/dpkg/status

jr@brett-laptop:~$ lspci
{snip}
01:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]
{snip}

jr@brett-laptop:~$ uname -a
Linux brett-laptop 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux

Changed in inkscape (Ubuntu):
importance: Undecided → Low
Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
David Guest (david-guest) wrote :

Affects me too on two very different hardware setups (nVidia, ATi). Currently running an up-to-date Maverick 10.10 RC

Tom (1981neo) wrote :

Unfortunately, this bug is affecting me too! It's very annoying! In fact, I'm using Linux to do a lot of graphics work in my company.. and I can't update my pcs before this bug has been fixed. It's not showing up on Lucid though...

propan0 (propan0) wrote :

Seeing it here also, after a successful upgrade from lucid to a freshly released maverick just now.

Hello,

I installed the new version of Ubuntu (10.10 - 32 bits, Maverick Meerkat). Also, I installed the Inkscape.

Something wrong with the rulers with inkscape. Appear little black triangles along the horizontal and vertical rulers, not one for a ruler... many and more. This little triangle show the pointer position in the space area (See the attachment file).

I installed the Inkscape from the ubuntu center software.

Version of Inkscape: Inkscape 0.48.0 r9654

Thanks regards.

Alex
;-)

jezdonline (jezdonline) wrote :

Hello,
I have installed Maverick Meerkat with mac4lin theme. Mobile Intel Graphic Media (X3100) 1280*800

I see triangles in ruler, and tollbars are out of size.

I experience this exact issue with a custom build of Inkscape 0.48.

Platform : Solaris 10 and OpenSolaris x86
GTK+-2.22.0 with gdk-pixbuf-2.22.0
glib 2.26.0

Since it was ok before I assume it's an issue created or uncovered by GTK or related library.

StevenD (daytonmeister) wrote :

I am also seeing the little black triangles fill in along the horizontal and vertical rulers. I just installed Ubuntu 10.10 last night for the first time and am running it in Virtual Box on a Dell laptop. I don't see this same behavior happening when I run Inkscape in Windows 7 on the same laptop.

I upgraded to Maverick from Lucid and I'm having this problem. I'm using 32-bit Ubuntu Desktop with a beta Nvidia graphics driver (I guess that's good to know since Brett's is ATI - maybe it's not related to graphics drivers, then?).

Glad it's been reported and is known about, means I'm not just special :D

I doubt it's Inkscape's fault though if it's happening in Rhythmbox too.

Sorry for the double post! :)

Zooming in/out gets rid of the leftover arrows.

A.K.Karthikeyan (mindaslab) wrote :

Ya this bug afftects me to after upgrading to 10.10

summary: - Ghosts of pointer's past (ruler refreshing problem)
+ Cursor position markers are not cleared from rulers

I also experience this bug in 10.10. I'm using a nvidia GeForce 8600 GT graphics card.

@Alex
What graphics card you use shouldn't matter here since inkscape doesn't take use of the GPU yet (although they plan to).

azer-french (azer-french) wrote :

ATI radeon HD 5650

Vincent Tschanz (fogia) wrote :

this bug also afftects me to after upgrading to 10.10

Nvidia 8500GT, Nvidia 260.19.06, Maverick up to date.

Thierry CHAVEROT (tj-chaverot) wrote :

Coming to increase the herd.
I get the same issue with a new installation of Maverick (not an update from Lucid to Maverick).
Inkscape 0.48 works fine with windows XP on the same computer.

hellslinger (jhemsing) wrote :

This didn't affect me on 0.48 on Ubuntu 10.04, but after clean install on the same system to Ubuntu 10.10.

Ubuntu 10.04 NVidia driver: 256.44 (no problem)
Ubuntu 10.10 NVidia driver: 260.19.06 beta (problem exists)

Mahendra Tallur (mahen) wrote :

It's probably completely unrelated to video drivers -- it even happens with the "nouveau" nvidia driver, for instance.

same problem here also... i am using

  Installed: 0.48.0-1ubuntu1
  Candidate: 0.48.0-1ubuntu1
  Version table:
 *** 0.48.0-1ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

 2.6.35-22-generic-pae #35-Ubuntu SMP Sat Oct 16 22:16:51 UTC 2010 i686 GNU/Linux

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

GTK+-2.22.0 with gdk-pixbuf-2.22.0
glib 2.26.0

corrado (gioiacorrado) wrote :

I have the same problem
i am using

ubuntu 10.10
Inkscape 0.48
Kernel 2.6.35-22-generic

wombat (jewett-ai) wrote :

I also noticed this problem after upgrading to ubuntu 10.10.
I have an ATI Mobility Radeon HD 5870.

Phil Stone (philstone) wrote :

I also found this bug.

Ubuntu 10.10, Inkscape 0.48.

Various display adapters.

Worked OK on 10.04.

azer-french (azer-french) wrote :

I installed the new driver Ati Catalyst 10.10 ( ubuntu 10.10)

But I always found this bug !

I can not draw some objects (circle, rectangle, star)

Worked OK on 10.04.

azer-french (azer-french) wrote :

It Worked with Wine ( Windows version ) on 10.10 !!!!!!!!

azer-french (azer-french) wrote :

I am sorry : It Works with Wine ( Windows version ) on 10.10 !

If you include my Intel Mobile 915GM/GMS/910GML, we're looking at a good range of video hardware this appears on, ATI, NVidia and Intel, so I don't think a video driver issue.

azer-french (azer-french) wrote :

@ Will : yes

ScislaC (scislac) wrote :

This is not a video driver issue, it is a library related issue.

boukeas (boukeas) wrote :

Also affected by this bug after upgrading to 10.10.

jimmylc (jimmy-lc) wrote :

This problem is NOT Ubuntu specific, I've recently upgraded inkscape from package 0.48.0-1 to 0.48.0-3 (Now 0.48.0-4) and there where also some libraries in the upgrade, since then this bug appears, tried to return to 0.48.0-1 but I can't because of some library incompatibility

So no... It is NOT a video driver issue, it is definitively a bug somewhere else

jimmylc (jimmy-lc) wrote :

Oh... Forgot to mention that my distro is Archlinux

vietnam (vietnam-ro2005) wrote :

Ubuntu 10.10 . I confirm it to. This is shitty and annoying

YAFU (yafu) wrote :

It happens in Kubuntu too.

Kubuntu 10.10. Inkscape 0.48.0-1ubuntu1 package.
ATI x1250, radeon free drivers.

Esther Melander (melanes) wrote :

I can confirm on Xubuntu 10.10 Acer Aspire 3000 laptop.

Rulers refresh when using the scrollbars.

Lars (larsmednosen) wrote :

Same here, ubuntu 10.10, worked fine in 10.04...

Lars (larsmednosen) wrote :

So this might be a Inkscape 0.48 problem or is anyone using 0.46-47 getting the same problem in ubuntu 10.10 or 10.04?

Thierry CHAVEROT (tj-chaverot) wrote :

Update of my previous post : I get this issue with my desktop, but Inkscape 0.48 works perfectly with Ubuntu 10.10 (on an external USB disk drive) on my laptop (Toshiba Qosmio F60 10J).

Thierry CHAVEROT (tj-chaverot) wrote :

Oops... Forgot that my laptop was with Lucid Lynx. Sorry.

Goucher (goucherg) wrote :

This one affects me too.
Running Kubuntu 10.10 on an Acer Aspire 3620 laptap.
I've run Inkscape with an upgraded Maverick install as well as a fresh install and same problemnin both.

mathew (meta23) wrote :

Same problem here. Kubuntu 10.10, upgraded from 10.04. nVidia graphics.

Have it too after upgrade.
But there is not ruler issue in Gimp. They seemed to use standard Gtk2 rulers.

Ubuntu 10.10
Linux qualle 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux
NVIDIA Corporation GeForce 9500 GT/PCI/SSE2 3.3.0 NVIDIA 260.19.06

description: updated
description: updated

Interestingly enough, a similar problem now occurs in Xara that did not before 10.10. If you scroll in any direction, outlines of the shapes remain in place and do not refresh until you scroll back again. Perhaps there is a relationship. Someone mentioned that Rhythmbox has a similar issue. OpenOffice Drawing does not.

Hodi K (khodi-aka-hodi) wrote :

After installing a fresh copy of 64 bit version of Ubuntu 10.10 now I've got this problem with rulers in Inkscape too.
My graphics card is ATI HD 3450 on Dell Optiplex 755

Krzysztof Kosinski (tweenk) wrote :

upping importance since this is really distracting.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
importance: Low → Medium
milestone: none → 0.48.1
Changed in inkscape:
status: Triaged → Fix Committed
description: updated
~suv (suv-lp) wrote :

inkscape trunk: r9905
inkscape 0.48.x: r9725

YAFU (yafu) wrote :

Until Ubuntu upgrade the packages, you can experiment 0.49-pre-bzr9906 version from this repository:

https://launchpad.net/~towolf/+archive/ppa

I've stopped having the problem using it.

Trekkele (trekkele) wrote :

Inkscape 0.48.0 r9654 on Archlinux is affected by this bug too

LeoGnu (leogiurdanella-gmail) wrote :

YAFU thanks!!!

Adding this ppa and update Inkscape this bug disappear.

Thanks again!!!

Paolo Rotolo (paolorotolo) wrote :

Inkscape 0.48 on Ubuntu 10.10 is affected by this bug...

krash (cesar-alvarez) wrote :
Changed in inkscape:
assignee: Krzysztof Kosinski (tweenk) → krash (cesar-alvarez)
status: Fix Committed → Fix Released
~suv (suv-lp) wrote :

@krash - this bug does not only affect Ubuntu but other platforms as well. Also, Inkscape has not yet released a official fixed version.

Changed in inkscape:
assignee: krash (cesar-alvarez) → Krzysztof Kosinski (tweenk)
status: Fix Released → Confirmed
status: Confirmed → Fix Committed
jimmylc (jimmy-lc) on 2010-12-08
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape:
status: Fix Released → Fix Committed
~suv (suv-lp) wrote :

@jimmylc - if Arch Linux has released an update of Inkscape 0.48.0 which includes the diff from revision 9725 of the 0.48.x inkscape branch, please set the bug status of the bug task you added, but do not change the bug status for the Inkscape project itself (as previously mentioned, Inkscape has not released a version yet which includes this fix).

pleabargain (dennisgdaniels) wrote :

Here's a vid of bug in .48 on Fedora 14
http://www.youtube.com/watch?v=wDQ6Wd1gXAc

I have the same problem using Inkscape in Ubuntu 10.10. I didn't have this problem with Ubuntu 10.04.

Same problem using Kubuntu 10.10.

NoOp (glgxg) wrote :

While the:
<quote>
** IMPORTANT: Please do not add any more "Me too" comments to this
   report. They are unnecessary and they make the report very
   difficult to read. The bug will be fixed in Inkscape 0.48.1.
   If you experience this bug, please just use the "Does this bug
   affect you?" link above.
</quote>
seems appropriate in most cases, I think it might be worthwhile to report if Tobais' ppa version (https://launchpad.net/~towolf/+archive/ppa) resolves the issue. In my case it does.

Ubuntu 10.10, 64bit & 32bit, 2.6.35-24-generic (GNOME).

~$ apt-cache policy inkscape
inkscape:
  Installed: 0.49-pre-bzr9906-0ubuntu0ppa1
  Candidate: 0.49-pre-bzr9906-0ubuntu0ppa1
  Version table:
 *** 0.49-pre-bzr9906-0ubuntu0ppa1 0
        500 http://ppa.launchpad.net/towolf/ppa/ubuntu/ maverick/main amd64 Packages
        100 /var/lib/dpkg/status
     0.48.0-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

and

$ apt-cache policy inkscape
inkscape:
  Installed: 0.49-pre-bzr9906-0ubuntu0ppa1
  Candidate: 0.49-pre-bzr9906-0ubuntu0ppa1
  Version table:
 *** 0.49-pre-bzr9906-0ubuntu0ppa1 0
        500 http://ppa.launchpad.net/towolf/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
     0.48.0-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

Without the ppa, inkscape is not usable on Ubuntu 10.10 & it will be appreciated if the importance be marked as 'high' rather than low, et al. Just asking if 'others' had similar problems on the inkscape users list brought immediate responses of 'me to', so IMHO this fix is critical to the usability of Inkscape in Ubuntu 10.10. Note: as others report, I do not experience the problem in Inkscape 10.04 Ubuntu 10.04 (Installed: 0.48.0-1ubuntu1~lucid1).

As others in this bug report have noted; the bug does not appear to be graphics driver related.

The 64bit machine above uses:
       *-display:0
             description: VGA compatible controller
             product: Mobile 4 Series Chipset Integrated Graphics Controller
             vendor: Intel Corporation
and the 32bit machine uses:
          *-display
                description: VGA compatible controller
                product: NV25GL [Quadro4 900 XGL]
                vendor: nVidia Corporation

These are vastly different graphics controllers/drivers and machines.

Please upgrade the importance & if at all possible integrate Tobais' modifications. Thanks.

Alex Valavanis (valavanisalex) wrote :

The importance field refers to Ubuntu as a whole, not just to the Inkscape package. Please see https://wiki.ubuntu.com/Bugs/Importance for details of what each importance means. Accordingly, I'll bump it up to "Medium" with the rationale that it is "A bug that has a severe impact on a non-core application." I don't think the importance can reasonably be set higher because this bug doesn't affect a core Ubuntu application.

There's not much point in patching the existing Ubuntu package right now. Inkscape 0.48.1 is due to be released very shortly, and this will fix numerous bugs. As soon as it is released, we can package it for Ubuntu.

Changed in inkscape (Ubuntu):
importance: Low → Medium
Andrew Cowie (afcowie) wrote :

> "There's not much point in patching the existing Ubuntu package right now. Inkscape 0.48.1 is due to be released very shortly"

Do you think we're going to be able to get a Stable Release Update granted for 0.48.1?

AfC

Krzysztof Kosinski (tweenk) wrote :

Andrew: I think it should be possible. 0.48.1 is exclusively a bugfix / regression fix release.

Alessandro Losavio (alo21) wrote :

I have this problem in Ubuntu 10.10 amd 64.
For more information see attachment

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.1-0ubuntu1

---------------
inkscape (0.48.1-0ubuntu1) natty; urgency=low

  * New upstream version (LP: #710619). Fixes several Ubuntu bugs:
    - Node editing causes segmentation fault (LP: #544599)
    - Cursor position markers are not cleared from rulers (LP: #627134)
    - Crashes when opening document properties (LP: #658055)
    - Export to XCF error with default template (LP: #485032)
    - Editing a connector in a transformed group returns it to original
      position (LP: #533897)
    - Ungrouping objects changes position of arrow lines (LP: #552289)
    - Will not save XCF file (LP: #642417)
    - XCF export fails when exporting from unsaved document (LP: #650890)
  * Drop all patches: Applied upstream
  * debian/rules: Disable chmod on debian/patches/* in clean rule (no patches used)
 -- Alexander Valavanis <email address hidden> Tue, 01 Feb 2011 12:53:34 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
NoOp (glgxg) wrote :

inkscape (0.48.1-0ubuntu1) natty
Still not fixed in Maverick or Lucid LTS.
https://launchpad.net/ubuntu/+source/inkscape

Natty (11.04) is still Alpha:
https://wiki.ubuntu.com/NattyReleaseSchedule

Please fix/resolve for Ubuntu Maverick (10.10) & Lucid (10.04).

Alex Valavanis (valavanisalex) wrote :

Upstream diff attached for testing in Ubuntu

Alex Valavanis (valavanisalex) wrote :

@NoOp - Now that the bug has been fixed in Natty, we can look at applying a stable release update in Maverick/Lucid as described at https://wiki.ubuntu.com/StableReleaseUpdates

Alex Valavanis (valavanisalex) wrote :

@NoOp - It just dawned on me... this bug does not affect the Lucid (inkscape_0.47.0-2ubuntu2)! If you want to use an unofficial release from a PPA, then unfortunately we can't support it in this tracker.

As for Maverick (inkscape_0.48.0-1ubuntu1), the issue does exist, and we can look at an SRU. I will try building a patched version of the package.

description: updated
description: updated
description: updated
description: updated
description: updated

...
> As for Maverick (inkscape_0.48.0-1ubuntu1), the issue does exist, and we
> can look at an SRU. I will try building a patched version of the
> package.
>

Thanks Alex. Appreciate that & will keep watch of
https://launchpad.net/ubuntu/+source/inkscape/0.48.1-0ubuntu1

Alex Valavanis (valavanisalex) wrote :

Debdiff attached for maverick-proposed SRU

description: updated
description: updated
Alex Valavanis (valavanisalex) wrote :

(Running a test build in a local Maverick pbuilder chroot)

Alex Valavanis (valavanisalex) wrote :

Oops - forgot to add the patch to 00list!

Corrected debdiff attached.

Local test build in progress

Alex Valavanis (valavanisalex) wrote :

Successful local pbuilder build for amd64. I'm subscribing sponsors to check it out.

Alex Valavanis (valavanisalex) wrote :

I have now tested the amd64 deb. It fixes the bug for me.

NoOp (glgxg) wrote :

Alex is there someplace where I can download the .deb? I'll be happy to test on both 32/64bit in Maverick.

Alex Valavanis (valavanisalex) wrote :

Hi NoOp,

If a sponsor agrees to upload my updated package, it will appear in the maverick-proposed repository, so it can be tested by users. In the meantime, you can try the (unofficial and unsupported!) version in ppa:valavanisalex/inkscape :
https://launchpad.net/~valavanisalex/+archive/inkscape?field.series_filter=maverick

The binary packages are still currently being built in the PPA, so you will probably have a short wait before you can download them.

jimmylc (jimmy-lc) on 2011-02-08
Changed in inkscape (Arch Linux):
status: New → Fix Released
NoOp (glgxg) wrote :

Alex:
$ apt-cache policy inkscape
inkscape:
  Installed: 0.48.0-1ubuntu1.1~ppa1
  Candidate: 0.48.0-1ubuntu1.1~ppa1
  Version table:
 *** 0.48.0-1ubuntu1.1~ppa1 0
        100 /var/lib/dpkg/status
     0.48.0-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

works for me. Thanks!

Downloading
inkscape_0.48.0-1ubuntu1.1~ppa1_amd64.deb
now.

NoOp (glgxg) wrote :

And inkscape_0.48.0-1ubuntu1.1~ppa1_amd64.deb:
$ apt-cache policy inkscape
inkscape:
  Installed: 0.48.0-1ubuntu1.1~ppa1
  Candidate: 0.48.0-1ubuntu1.1~ppa1
  Version table:
 *** 0.48.0-1ubuntu1.1~ppa1 0
        100 /var/lib/dpkg/status
     0.48.0-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

is working for me as well. Thanks Alex!

Changed in inkscape (Ubuntu Maverick):
importance: Undecided → Medium
status: New → Triaged
milestone: none → maverick-updates
Benjamin Drung (bdrung) wrote :

I uploaded inkscape 0.48.0-1ubuntu1.1 with an improved changelog entry (attached) to maverick-proposed.

Alex Valavanis (valavanisalex) wrote :

Great - thanks for your help!

Accepted inkscape into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in inkscape (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed

A quick test showed that the bug is fixed. No obvious regressions were visible, but I only tested it briefly.

Martin Pitt (pitti) on 2011-02-15
tags: added: verification-done
removed: verification-needed
NoOp (glgxg) wrote :

Works for me. Tested on 64bit and 32bit machines (3 machines tested). As in comment #67:

The 64bit machine uses:
       *-display:0
             description: VGA compatible controller
             product: Mobile 4 Series Chipset Integrated Graphics Controller
             vendor: Intel Corporation
$ apt-cache policy inkscape
inkscape:
  Installed: 0.48.0-1ubuntu1.1
  Candidate: 0.48.0-1ubuntu1.1
  Version table:
 *** 0.48.0-1ubuntu1.1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.48.0-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

and the 32bit machines use:
          *-display
                description: VGA compatible controller
                product: NV25GL [Quadro4 900 XGL]
                vendor: nVidia Corporation
$ apt-cache policy inkscape
inkscape:
  Installed: 0.48.0-1ubuntu1.1
  Candidate: 0.48.0-1ubuntu1.1
  Version table:
 *** 0.48.0-1ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     0.48.0-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

Tested by opening & modifying several complex svg.

Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.0-1ubuntu1.1

---------------
inkscape (0.48.0-1ubuntu1.1) maverick-proposed; urgency=low

  * Backport upstream patch 02-fix-cursor-redraw.dpatch to fix cursor
    redraw in rulers (LP: #627134)
 -- Alex Valavanis <email address hidden> Tue, 15 Feb 2011 00:16:43 +0100

Changed in inkscape (Ubuntu Maverick):
status: Fix Committed → Fix Released
propan0 (propan0) wrote :

Just upgraded it the standard way, bug is GONE.

Thank you thank you thank you!!!

description: updated
description: updated
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.