Unexpected displacement of clipped/masked objects due to layer transforms

Bug #569281 reported by Jeff Fortin Tam on 2010-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Mc

Bug Description

Short version/executive summary:
1. create two layers, one with a shape that will be used for a mask, and another below for the rectangle filled with a color or gradient
2. change the document properties (canvas size) in a significant way (Ex: 30% more height)
3. inkscape silently adds transformation attributes to the layers instead of moving the objects
4. result: when you create a new layer or object later on, and try to apply it to the mask created in step #1, it messes up

See the attached video for a demonstration.

Jeff Fortin Tam (kiddo) wrote :
su_v (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9366 on OS X 10.5.8

same unexpected 'translate' of the clipped or masked object if clipping/masking path and clipped/masked object are in differently transformed layers (happens when adding a layer after resizing the page or changing the page format/orientation).

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
tags: added: clipping layers
su_v (suv-lp) wrote :

possibly same issue as earlier reported in bug #489760 “Creating Clip with objects located on different layers makes the objects disapear.”

su_v (suv-lp) on 2011-01-05
summary: - layer translation attributes on canvas resize mess things up later on
+ Unexpected displacement of clipped/masked objects due to layer
+ transforms
su_v (suv-lp) wrote :

Fixed in r14130.

Changed in inkscape:
assignee: nobody → Mc (mc...)
milestone: none → 0.92
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers