Wrong Colors When Importing PDF's to Inkscape

Bug #491694 reported by timstring on 2009-12-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

Attached is a pdf file. When viewed with Acrobat, the color is silver as it should be. When imported into Inkscape, the color is olive drab. Every pdf I have tried to import has been green.

I'm using Inkscape 0.46 on a Mac running 10.4.11.

tim

timstring (timstring) wrote :
su_v (suv-lp) on 2009-12-03
tags: added: color importing pdf
su_v (suv-lp) wrote :

not reproduced with Inkscape 0.46 and Inkscape 0.47 on OS X 10.5.8

The file imported into Inkscape looks similar to the PDF, there is a slight difference when comparing the SVG files in viewers like Batik: the bitmap with the shaded text in the one saved with Inkscape 0.46 is slightly darker.

su_v (suv-lp) wrote :

… and imported & saved as SVG with Inkcape 0.47

su_v (suv-lp) wrote :

Screenshot of 'Have Tools' imported in Inkscape 0.46 on OS X 10.5.8, compared to the PDF rendered in Preview.app.

su_v (suv-lp) wrote :

… and 'Have Tools' imported in Inkscape 0.47 on OS X 10.5.8, compared to the PDF rendered in Preview.app.

su_v (suv-lp) on 2009-12-03
tags: added: osx
su_v (suv-lp) wrote :

Could it be that your X11 uses different settings for displaying colors than native OS X applications (e.g. for the color-depth of its display)?

Maybe there is a relation to your earlier reported bug #461625 “Program will not install” (<https://bugs.launchpad.net/inkscape/+bug/461625>), where it turned out that you still had Panther's X11 version installed after upgrading to Tiger, which prevented Inkscape from launching. Is it possible the your X11 uses settings that were originally set for X11 v1.0.0 on Panther?

timstring (timstring) wrote :

Well, after much heartache and grief, I managed to get X11 1.1.3-Xfree86 4.4.0 to install. I just now deleted com.apple.x11.plist and relaunched Inkscape. When I imported the "Have Tools.pdf" file again, it still is olive drab. I went to the application that generated the pdf and saved a new file; when I imported it, the color was still olive drab. However, I opened a couple of pdf's that were created with Illustrator CS4, and they worked. So, I would guess that the bug may be with my system. I did a Sherlock search for "X11" and came up with 23 different files in several folders. Where should I start looking for an offender?

I must say that I generally like what Inkscape does. I have tried a dozen programs to replace my elderly Canvas X, and in general, Inkscape works just as well as Canvas.

su_v (suv-lp) wrote :

I have asked another user with Inkscape 0.46 on Tiger to open your sample PDF file, and the screenshot he provided <http://uploads.inkscape-forum.de/2009/12/HaveTools.png> indicates in my understanding that this must indeed be an issue with you local settings of either Inkscape, Canvas, Mac OS X 10.4.11 Quartz PDFContext or X11/XFree86.

1) testing Inkscape's settings:
a) Did you open the above attached SVG files created with Inkscape 0.46/0.47 on Leopard? Do they too expose the same color issues showing 'olive drap' instead of 'metallic shading in greys' on your system?
b) Can you test the SVG file attached to this comment where I have un-grouped the PDF content so it could maybe be pin-pointed to the one bitmap for the metallic shading?
c) What happens if you open the original PDF in Inkscape and export it as bitmap (or another file format you can view on your system)? Do the exported files have the same color tint or is it limited to the rendering on-canvas in Inkscape?
d) You could repeat above tests after resetting Inkscape's Preferences to default values (in case some Color Management setting is responsible for the 'olive drab'): easiest way is to rename the preferences file stored as '~/.inkscape/preferences.xml' and restart Inkscape. It will recreate the file with default values for all settings. (Use the Finder to open the hidden dot-folder with menu 'Go > Go to Folder…' and enter '~/.inkscape' without quotes). You can undo this later by deleting the new prefs file and renaming the previous one back if it doesn't have any effect.

2) Canvas: I never used this software, but saw that there's still an active forum for older versions at their website. Maybe other users have experienced similar issues?

3) Mac OS X 10.4.11 Quartz PDFContext:
The OS X component that is used in the print dialog to save as PDF. I can only refer to Apple user forums of any kind - I have no further knowledge how this could be involved in creating PDFs with 'special' color settings (or included ICC/ICM color profiles)

4) X11/XFree86:
Again no further knowledge or experience I could offer. Starting point for my search would be:
a) the X11-users mailing list maintained by apple (unfortunately their archive search is broken)
   <http://lists.apple.com/mailman/listinfo/x11-users>
b) the old X11 FAQ for Tiger
   <http://forums.macosxhints.com/showthread.php?t=39069>

su_v (suv-lp) wrote :

If you are interested in testing Inkscape 0.47 for Tiger PPC:
<http://article.gmane.org/gmane.comp.graphics.inkscape.devel/32417>

Note: this is not yet an official build - so far we are still looking for testers to confirm its stability on different systems. If you feel up to testing it - feedback would be welcome, either here or on the mailing lists (inkscape-user or inkscape-devel). And it could be helpful to report bugs related to running Inkscape 0.47 on your platform (MacOS X Tiger PPC) in the bug tracker.

<http://wiki.inkscape.org/wiki/index.php/Release_notes/0.47>

timstring (timstring) wrote :

The files associated with messages 2 & 3 have white text with black outlines--no fill at all. The others are fine, i think.

0.47 for Tiger is functional. I've not had any trouble with it, except that the pdf files are still wrong.

timstring (timstring) wrote :

I finally bit the bullet and upgraded to Leopard--10.5.8 and am running Inkscape 0.47 inside XQuartz 2.4.0. The pdf's are still the wrong color.

Wolf (drechsel) wrote :

I can confirm, that the problem exists in inkscape 0.47, Mac OS X 10.4.11. I have it on both: X11 and aqua, which may help to track it down. I do attach a screenshot of the OP's pdf, displayed in both: preview.app and inkscape-aqua.app

It does not affect jpg files

Yours, Wolf

su_v (suv-lp) on 2010-02-18
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Wolf (drechsel) wrote :

I attached screenshots of a color table, combined into one file: The upper half is the original, the lower half is the screenshot from the import to Inkscape 0.47 quartz. - Doesnt look too bad - exept the blue component which seems to be missing.

su_v (suv-lp) wrote :

Possibly related to architecture (PPC vs i386) - afaik both timstring and Wolf tested on PPC Macs (Tiger, Leopard), whereas the screenshot from the user of inkscape-forum.de (comment #8, Tiger) as well as those done by me (comment #4-5, Leopard) have been done on an Intel-based Mac

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers