Crash on PDF import with poppler >= 0.12.2 and Inkscape compiled with poppler <= 0.12.1 (ABI mismatch)

Bug #258504 reported by Yuri on 2008-08-16
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
openSUSE
Won't Fix
High
inkscape (ALT Linux)
Unknown
Unknown
inkscape (Arch Linux)
New
Undecided
Unassigned
inkscape (Fedora)
Fix Released
Medium

Bug Description

This pdf document:
http://www.3treasurescenter.com/forms/3%20Treasures%20-%20patient%20information.pdf
when it's loaded into inkscape-0.46 looks different than original.

Check-boxes after "Marital Status" collide with the corresponding letters in inkscape. While they are separate in the original pdf.

Description of problem:

Trying to import a PDF results into:

inkscape: symbol lookup error: inkscape: undefined symbol: _ZN13GfxColorSpace5parseEP6Object

Looking into http://bugs.archlinux.org/task/17524, it seems that this is related to Poppler and rebuilding inkscape against current Poppler in F12 should solve this (but I didn't try a scratch build).

Version-Release number of selected component (if applicable):

inkscape-0.47-1.fc12.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Open an AI/PDF to import

Yes, I see exactly the same thing. Package versions:

$ rpm -qa | grep poppler
poppler-debuginfo-0.12.2-1.fc12.x86_64
poppler-utils-0.12.2-1.fc12.x86_64
poppler-0.12.2-1.fc12.x86_64
poppler-glib-0.12.2-1.fc12.x86_64

# rpm -qa | grep inkscape
inkscape-0.47-1.fc12.x86_64

Any chance of rebuilding and pushing if this indeed fixes it?

Download full text (8.9 KiB)

Actually, doing a local mock build of the current F-12 package wihout changes fails with the message below when building pdf-parser.cpp. I think there must be a missing buildrequires, but am not sure what...

g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi/CORE -I/usr/include/python2.6 -I/usr/inclu
de/freetype2 -pthread -DORBIT2=1 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/gconf/2 -I/
usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/in
clude -fopenmp -I/usr/include/ImageMagick -I/usr/include/libwpg-0.1 -I/usr/include/libwpd-0.8 -I/usr/include/popple
r -DPOTRACE=\"potrace\" -pthread -I/usr/include/gdkmm-2.4 -I/usr/lib64/gdkmm-2.4/include -I/usr/include/giomm-2.4 -I/usr/
lib64/giomm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib64/pangomm-1.4/include -I/usr/include/gtk-2.0 -I/usr/include/gl
ibmm-2.4 -I/usr/lib64/glibmm-2.4/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/sigc++-2.0 -I/
usr/lib64/sigc++-2.0/include -I/usr/include/cairomm-1.0 -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/pixman-
1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/gtkmm-
2.4 -I/usr/lib64/gtkmm-2.4/include -I/usr/include/gtk-unix-print-2.0 -I/usr/include/atkmm-1.6 -I/usr/include/libxml2 -I/usr/
include/gtkspell-2.0 -I../cxxtest -I./bind/javainc -I./bind/javainc/linux -Werror=format-security -Wall -Wformat -Wform
at-security -W -D_FORTIFY_SOURCE=2 -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch -Wno-unused-p
arameter -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=gen
eric -fopenmp -c -o extension/internal/pdfinput/pdf-parser.o extension/internal/pdfinput/pdf-parser.cpp
extension/internal/pdfinput/pdf-parser.cpp: In member function 'void PdfParser::opSetExtGState(Object*, int)':
extension/internal/pdfinput/pdf-parser.cpp:812: error: no matching function for call to 'GfxColorSpace::parse(Object*)'
/usr/include/poppler/GfxState.h:182: note: candidates are: static GfxColorSpace* GfxColorSpace::parse(Object*, Gfx*)
extension/internal/pdfinput/pdf-parser.cpp: In member function 'void PdfParser::opSetFillColorSpace(Object*, int)':
extension/internal/pdfinput/pdf-parser.cpp:1012: error: no matching function for call to 'GfxColorSpace::parse(Object*)'
/usr/include/poppler/GfxState.h:182: note: candidates are: static GfxColorSpace* GfxColorSpace::parse(Object*, Gfx*)
extension/internal/pdfinput/pdf-parser.cpp:1014: error: no matching function for call to 'GfxColorSpace::parse(Object*)'
/usr/include/poppler/GfxState.h:182: note: candidates are: static GfxColorSpace* GfxColorSpace::parse(Object*, Gfx*)
extension/internal/pdfinput/pdf-parser.cpp: In member function 'void PdfParser::opSetStrokeColorSpace(Object*, int)':
extension/internal/pdfinput/pdf-parser.cpp:1035: error: no matching function for call to 'GfxColorSpace::parse(Object*)'
/usr/include/poppler/GfxState.h:182: note: candidates are: static GfxColorSpace* ...

Read more...

Adding poppler maintainer to cc list.

Rex - an api change in poppler 0.12.2 would seem to have broken inkscape

OK, I rebuilt the current rawhide package on F-12 (inside mock) - I see this includes a patch for poppler. I can confirm that this build has functional PDF import again.

So please, as a matter of urgency, push new package builds of inkscape for F-12 including the poppler patch. Thanks in advance.

boo, the poppler abi breakage is certainly uncool, tracking in bug #555820.

Please hold on anything hasty here, while I
1. poke upstream.
2. test poppler-0.12.3 in updates-testing

(we may be able to fix this in the pending poppler update).

confirmed poppler-0.12.3-1 (in updates-testing) also affected.

OK, poppler's change was intentional, and makes now guarantees using these low-level apis.

Patching inkscape appropriately appears to be the way forward here (and long-term, lobby upstream to use poppler's supported -glib or -qt api instead)

Ping Milos? Any chance you can bump and rebuild the F-12 package to fix this.

Apologies - wrong person, Comment #8 was meant for Lubomir, not Milos, of course.

Hm...I can do that as well -- Lubomir?

Created attachment 389676
Patch inkscape for poppler API changes

Patch tested with latest inkscape trunk. Applies cleanly to Fedora package source.

Based on the patch from https://bugs.launchpad.net/inkscape/+bug/487038

(In reply to comment #11)
> Created an attachment (id=389676) [details]
> Patch inkscape for poppler API changes
>
> Patch tested with latest inkscape trunk. Applies cleanly to Fedora package
> source.
>
> Based on the patch from https://bugs.launchpad.net/inkscape/+bug/487038

Actually there's already a patch in the Fedora development (rawhide/F13) branch that fixes the bug and has been tested.

Milos - please do go ahead and build the current rawhide package for F-12, it seems Luomir is MIA.

inkscape-0.47-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/inkscape-0.47-2.fc12

(In reply to comment #12)

> Milos - please do go ahead and build the current rawhide package for F-12, it
> seems Luomir is MIA.

He isn't, I just pinged him via IRC, he was just overwhelmed by abrt bugzilla mails and these got lost -- he immediately fixed that then, thank you Lubomir.

OK, excellent, thanks Lubomir, apologies for thinking you were MIA.

inkscape-0.47-2.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update inkscape'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1743

su_v (suv-lp) on 2010-02-18
tags: added: importing pdf
su_v (suv-lp) wrote :

Closing this report because the PDF file in question is not available ('Server not found'). If you do still have a copy of the file please revert the bug status to 'New' and attach the PDF document so that we can try to reproduce the error with the current release version (Inkscape 0.47).

Changed in inkscape:
status: New → Invalid
Yuri (yuri-tsoft) wrote :

That's because you waited for a bit too long.

I am attaching the same pdf document.
Now my inkscape-0.47 (on FreeBSD) SEGVs while importing this pdf.

Changed in inkscape:
status: Invalid → New
su_v (suv-lp) wrote :

> That's because you waited for a bit too long.
sorry for the delay - I know this can be frustrating.

> Now my inkscape-0.47 (on FreeBSD) SEGVs while importing this pdf.
not reproduced with Inkscape 0.47 on OS X 10.5.8: all 4 pages of the original PDF can be opened in Inkscape without crash and are rendered identically to the PDF as it is displayed in the default PDF viewer (Apple's Preview).

Yuri (yuri-tsoft) wrote :

Here is what gdb says:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 37801140 (LWP 100794)]
0x35f158a7 in PopplerCache::lookup () from /usr/local/lib/libpoppler.so.5

(gdb) bt
#0 0x35f158a7 in PopplerCache::lookup () from /usr/local/lib/libpoppler.so.5
#1 0x35eefa9a in GfxICCBasedColorSpace::parse () from /usr/local/lib/libpoppler.so.5
#2 0x35eeaa43 in GfxColorSpace::parse () from /usr/local/lib/libpoppler.so.5
#3 0x085ded89 in Gtk::manage<Gtk::HSeparator> ()
#4 0x085db20a in Gtk::manage<Gtk::HSeparator> ()
#5 0x085df563 in Gtk::manage<Gtk::HSeparator> ()
#6 0x0824037a in std::operator+<char, std::char_traits<char>, std::allocator<char> > ()
#7 0x08220585 in Gtk::manage<Gtk::SpinButton> ()
#8 0x0821e32f in Gtk::manage<Gtk::SpinButton> ()
#9 0x0809c021 in std::list<sigc::slot_base, std::allocator<sigc::slot_base> >::erase ()
#10 0x0808f0b6 in ?? ()
#11 0x08178e31 in sigc::visit_each<sigc::internal::limit_derived_target<sigc::trackable*, sigc::internal::slot_do_unbind>, sigc::trackable> ()
#12 0x0808cae4 in ?? ()
#13 0x0808bd97 in ?? ()
#14 0x00000002 in ?? ()
#15 0xbfbfe39c in ?? ()
#16 0xbfbfe3a8 in ?? ()
#17 0xbfbfe380 in ?? ()
#18 0xbfbfe398 in ?? ()
#19 0x00000000 in ?? ()
#20 0xbfbfe394 in ?? ()
#21 0x0808bd05 in ?? ()
#22 0x344a6f40 in dlclose () from /libexec/ld-elf.so.1
Previous frame inner to this frame (corrupt stack?)

Poppler libs installed:
poppler-0.12.3_1 A PDF rendering library
poppler-data-0.4.0 Poppler encoding data
poppler-gtk-0.12.3_1 Gtk bindings to poppler
poppler-qt-0.12.3_1 Qt bindings to poppler
poppler-qt4-0.12.3_1 Qt4 bindings to poppler

su_v (suv-lp) wrote :

not reproduced with Inkscape 0.47+devel r9096 on OS X 10.5.8 with poppler 0.12.1

Did you build Inkscape yourself? If so - which patch did you use to compile it with poppler 0.12.3?
This is possibly related to bug #487038 “0.47 build error with poppler 0.12.2 on Linux”:
<https://bugs.launchpad.net/inkscape/+bug/487038>

Yuri (yuri-tsoft) wrote :

It's built on my machine by the FreeBSD ports upgrade process using patches from ports.
All patches applied are here: http://www.freebsd.org/cgi/cvsweb.cgi/ports/graphics/inkscape/files/

su_v (suv-lp) wrote :

Can you open other PDF files without Inkscape crashing?

Yuri (yuri-tsoft) wrote :

I tried many other PDFs.
One out of them also causes a crash, and others (majority) open without a problem.

su_v (suv-lp) on 2010-02-19
tags: added: crash
Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) wrote :

Could you attach the other PDF file that crashes Inkscape as well?

At what point does Inkscape crash? i.e. do you get to the PDF import options dialog with its own preview/thumbnail of the page to be imported or does Inkscape crash before that?

Another thing you could test: there are other PDF renderers/viewers that are based on poppler (e.g. evince, afaik. I'm not sure what GIMP uses to render imported PDFs). Could you test if the PDF file that crashes Inkscape causes issues with those applications as well?

Yuri (yuri-tsoft) wrote :
Yuri (yuri-tsoft) wrote :
Yuri (yuri-tsoft) wrote :

PDF crashes after I press "OK" on "PDF Import Settings" screen.

AFAIK okular in KDE and GIMP both use poppler and all failing in inkscape pdfs are rendered ok in okular and gimp.

su_v (suv-lp) wrote :

all three PDFs open without issues in Inkscape 0.47 and 0.47+devel r9096 on OS X 10.5.8

AFAICT the files have nothing in common: varying PDF versions, different creators, different content (bitmap, text only, vector data, clip-paths)
(output from pdfinfo attached)

Yuri (yuri-tsoft) wrote :

Here are some additional details that I got from debugger. Field 'keys' in the object of class PopplerCache representing ccColorSpaceCache object is bad. Stack is the same in all 3 previous PDF cases:

....
->Gtk::manage<Gtk::HSeparator>
-> GfxColorSpace::parse
    "ICCBased" case in if
-> GfxICCBasedColorSpace::parse
    line: gfx->getIccColorSpaceCache()->put(k, item);
-> PopplerCache::put
    SEGV on line keys[0] = key; with keys=0xf0ffffff
    Error accessing memory address 0xf0ffffff: Bad address.

Yuri (yuri-tsoft) wrote :

This one has a bit different stack on crash.

BTW poppler-0.12.3 is used on my system. Is it the same on OSX? If not, could you try 0.12.3?

Yuri (yuri-tsoft) wrote :

Another observation: all non-crashing PDFs never go through parsing of element with type "ICCBased".

So maybe presence of "ICCBased" elements in the property that all of the problematic PDFs have in common.

ScislaC (scislac) wrote :

Crashes confirmed on Ubuntu Lucid w/ libpoppler 0.12.3 on r9100

Changed in inkscape:
status: New → Won't Fix
status: Won't Fix → Confirmed
ScislaC (scislac) wrote :
Download full text (4.5 KiB)

Backtrace:

Program received signal SIGSEGV, Segmentation fault.
0xb68a4e29 in PopplerCache::lookup(PopplerCacheKey const&) ()
   from /usr/lib/libpoppler.so.5
(gdb) bt
#0 0xb68a4e29 in PopplerCache::lookup(PopplerCacheKey const&) ()
   from /usr/lib/libpoppler.so.5
#1 0xb687a99e in GfxICCBasedColorSpace::parse(Array*, Gfx*) ()
   from /usr/lib/libpoppler.so.5
#2 0xb687a6c3 in GfxColorSpace::parse(Object*, Gfx*) ()
   from /usr/lib/libpoppler.so.5
#3 0x085bde39 in PdfParser::opSetFillColorSpace (this=0x97a4dc0,
    args=0xbfffde58, numArgs=1)
    at extension/internal/pdfinput/pdf-parser.cpp:1014
#4 0x085b98c7 in PdfParser::go (this=0x97a4dc0, topLevel=1)
    at extension/internal/pdfinput/pdf-parser.cpp:409
#5 0x085bd02d in PdfParser::parse (this=0x97a4dc0, obj=0xbfffe0b4, topLevel=1)
    at extension/internal/pdfinput/pdf-parser.cpp:381
#6 0x08222d19 in Inkscape::Extension::Internal::PdfInput::open (
    this=0x8a8e530, uri=0xbcd941c "/home/scislac/dl/studyguidelawrence.pdf")
    at extension/internal/pdfinput/pdf-input.cpp:728
#7 0x08205db7 in Inkscape::Extension::Input::open (this=0x8b55810,
    uri=0xbcd941c "/home/scislac/dl/studyguidelawrence.pdf")
    at extension/input.cpp:153
#8 0x08203f4f in Inkscape::Extension::open (key=0x0,
    filename=0xbcd941c "/home/scislac/dl/studyguidelawrence.pdf")
    at extension/system.cpp:97
#9 0x0809925e in sp_file_open (uri=..., key=0x0, add_to_recent=true,
    replace_empty=true) at file.cpp:222
#10 0x0809bcaa in sp_file_open_dialog (parentWindow=...) at file.cpp:540
#11 0x082484cd in sp_action_perform (action=0x8f3dea8, data=0x0)
    at helper/action.cpp:181
#12 0xb71d80ec in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#13 0xb71c9e52 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0xb71dfc6d in ?? () from /usr/lib/libgobject-2.0.so.0
#15 0xb71e1204 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#16 0xb71e16a6 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0xb7578e85 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#18 0xb757b0ed in gtk_action_activate () from /usr/lib/libgtk-x11-2.0.so.0
#19 0xb7758c0f in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#20 0xb71d80ec in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#21 0xb71c9e52 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#22 0xb71dfc6d in ?? () from /usr/lib/libgobject-2.0.so.0
#23 0xb71e1204 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#24 0xb71e16a6 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#25 0xb759613a in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#26 0xb7597c88 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#27 0xb71d80ec in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#28 0xb71c84d9 in ?? () from /usr/lib/libgobject-2.0.so.0
#29 0xb71c9e52 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#30 0xb71df5ea in ?? () from /usr/lib/libgobject-2.0.so.0
#31 0xb71e1204 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#32 0xb71e16a6 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#33 0xb75961da in gtk_button_r...

Read more...

Yuri (yuri-tsoft) wrote :

I asked the maintainer of poppler Albert Astals Cid about these crashes. Here is what he replied:

> We changed how the ICC cache is handled in poppler 0.12.2 in an ABI
> incompatible change, so if your user is using distributed binaries compiled
> with a different version that he is using that could be the problem. Otherwise
> i would say it is your code problem if okular/evince render the files
> correctly.
>
> Albert

But I've rebuilt inkscape and all dependent packages from sources and still getting SEGVs, so it's not the issue of ABI incompatible change.

Obviously ICC cache was changed and there is some problem in inkscape related to this.

su_v (suv-lp) on 2010-02-22
summary: - Some paths in imported pdf document shifted compared to the original pdf
+ PDF import: crash in PopplerCache::lookup() with poppler >= 0.12.2

Link to inkscape feedback is incorrect. Feedback for inkscape-0.47-2.fc12 can be left at https://admin.fedoraproject.org/updates/inkscape-0.47-2.fc12

@JazzyNico, Alvin - could you test the PDF files on win32 and/or on linux with poppler < 0.12.2?

jazzynico (jazzynico) wrote :

Not reproduced on Ubuntu 9.10, Inkscape 0.47, libpoppler 0.12.0-0ubuntu2.1.

inkscape-0.47-2.fc12 has been pushed to the Fedora 12 stable repository. If problems still persist, please make note of it in this bug report.

Krzysztof Kosinski (tweenk) wrote :

Not reproduced on Lucid (poppler 0.12.4) when I build with the patch from bug 487038.

This is not a bug in the patch there - it is an ABI mismatch. In other words Inkscape was compiled with a different version of Poppler than the one on the user's system. I don't think we can do anything about it - maybe warn when starting Inkscape and disable PDF import?

Krzysztof Kosinski (tweenk) wrote :

I think this is Poppler's fault - it appears they made an ABI break without bumping the soname on libpoppler. x_x

Krzysztof Kosinski (tweenk) wrote :

==IMPORTANT - PLEASE READ==

These crashes happen when you use Inkscape compiled with Poppler <= 0.12.1 on a system that has Poppler >= 0.12.2. These Poppler releases are not ABI-compatible, yet they share the same library name (soname). The direct cause of the crashes is an ABI mismatch.

This issue cannot be satisfactorily fixed in Inkscape. You need to contact your distribution maintainers, who should either:
a) ship a development version of Inkscape recompiled with the new Poppler libraries, or
b) bump the libpoppler soname between 0.12.1 and 0.12.2

You can also recompile Inkscape yourself. You need to use the development version (bzr checkout lp:inkscape) until 0.48 is released. Instructions are available at:
http://wiki.inkscape.org/wiki/index.php/Compiling_Inkscape

summary: - PDF import: crash in PopplerCache::lookup() with poppler >= 0.12.2
+ Crash on PDF import with poppler >= 0.12.2 and Inkscape compiled with
+ poppler <= 0.12.1 (ABI mismatch)
Yuri (yuri-tsoft) wrote :

I just recompiled inkscape and I only have poppler-0.12.3 installed.
I still observe SEGVs on those particular pdfs,

So most certainly it's not related to ABI mismatch.

su_v (suv-lp) wrote :

After upgrading to poppler 0.12.4 (from 0.12.1) on OS X 10.5.8 I could open all 4 attached PDF files attached to bug #258504 without Inkscape crashing.

Could this bug (#258504) - as reported by Yuri - be specific to poppler 0.12.3 and not a general ABI mismatch? It has been reproduced twice with inkscape built against poppler 0.12.3, but not reproduced twice inkscape built against poppler 0.12.4.

Steve Wilson (steve-wilson) wrote :

From my original Bug #548746......(openSUSE 11.2, Inkscape 0.47)

Have downgraded poppler 0.12.3 to 0.12.0 and pdf docs load OK.

su_v (suv-lp) wrote :

@Krzysztof - I still think bug #258504 is not the same issue as the ABI mismatch reported in bug #548746. IMHO the duplicate status (and the summary) of bug #548746 should be reverted and the "==IMPORTANT - PLEASE READ==" comment about ABI mismatch <https://bugs.launchpad.net/inkscape/+bug/258504/comments/24> should be moved (i.e. added) to bug #548746.

Bug #258504 is different:
1) the crashes have been reproduced on two different systems with inkscape locally built against poppler 0.12.3
2) #258504 reports SIGSEGV with certain PDFs only (in 'PopplerCache::lookup()') and not - as again confirmed by Steve in bug #548746 comment #6 - with ALL PDF files ('inkscape: undefined symbol: _ZN13GfxColorSpace5parseEP6Object').

Steve Wilson (steve-wilson) wrote :

Sorry to be the bringer of bad news, but I frequently use Inkscape to import company quotations generated as pdf docs, which I then modify. As I confirmed early, THESE I can now import (since downgrading to poppler 0.12.0). However, I have checked and many other pdf docs still don't load. Even a simple text file created in Open Office, then saved as a pdf, fails to load.

su_v (suv-lp) wrote :

> However, I have checked and many other pdf docs still don't load.

with the same console messages as you reported in bug #548746? If it is a different error - as you downgraded to poppler 0.12.0 it is not likely to be related to that poppler version conflict (ABI mismatch) anymore - these failures should be reported separately IMHO. Please do search the bug database beforehand - there are several other open bugs about issues when opening/importing PDF files. If you file a new report please attach any console messages or available backtraces as well as sample files that fail to load so that we can try to reproduce it on other systems.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.9) Gecko/20100824 SUSE/3.6.9-1.2 Firefox/3.6.9

inkscape exits when trying to import an PDF

Reproducible: Always

Steps to Reproduce:
1. open inkscape
2. Menu/File/Import
3. select a PDF, confirm popup
Actual Results:
inkscape: symbol lookup error: inkscape: undefined symbol: _ZN13GfxColorSpace5parseEP6Object

Expected Results:
inkscape should offer PDF editing

happens with both regular inkscape-0.46 and with inkscape-0.48 from GNOME project

I have found two more interesting things:

a) bug does not happen with all pdfs. e.g. black&white /usr/share/doc/packages/iproute2/rtstat.pdf works.
Bug does happen (among others) with
 http://www.zq1.de/~bernhard/temp/inkscapebug1.pdf created from simple
 http://www.zq1.de/~bernhard/temp/inkscapebug1.odp

b) bug does not happen with a fresh install of 11.2, but after a zypper in libpoppler5 without any extra repos, so there was some update to libpoppler5 causing this bug.

Bin Li: this is possibly caused by the update to 0.12.3 that was pushed as a maintenance update. Could you take a look?

Okay, take care of it.

Cause it's a long time bug, could you try in the latest one, set it wontfix, feel free to contact me if any issue. Thanks!

bug is no more reproducible with 12.1 versions
inkscape-0.48.2-2.1.2.x86_64
libpoppler7-0.14.4-6.1.x86_64
libpoppler13-0.16.5-6.6.x86_64
libpoppler17-0.17.4-1.1.x86_64
libpoppler18-0.18.0-2.1.3.x86_64

Changed in opensuse:
importance: Unknown → High
status: Unknown → Won't Fix
ScislaC (scislac) wrote :

Closing as won't fix since there are no stable distros currently using that old version of poppler any longer. If you feel this was closed in error, please feel free to reopen it and explain why.

Changed in inkscape:
status: Confirmed → Won't Fix
Changed in inkscape (Fedora):
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.