Undo on external extensions deletes all clipped objects

Bug #248920 reported by EarlyBlake on 2008-07-16
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Effect to created black, grey, and white paths around a shape and blur and
clip them for a 3d effect.

I see a few similar problems to this one in other bug reports, but I did not find this exact one when I searched. Sorry if it's a repeat.

I was using the blur and object>>clip to create a 3D embossed effect manually, when I saw the Edge 3D in the Effects menu.

I tried the Edge 3D, and it looked terrible, so I did a control-z. Inkscape 0.46 deleted my all clipped objects on all layers, as well as the Black and White Effects>>Modify Path>>Edge 3D generate item. I was able to recover the lost items with control-y, then delete the 3D effect item manually.

EarlyBlake (pam4water) wrote :

I should probably add that I'm running inkscape 0.46 on Windows Vista Home Premium. Windows should be up to date.

EarlyBlake (pam4water) on 2008-07-16
description: updated
EarlyBlake (pam4water) on 2008-07-17
description: updated

It seems to happen with every effect, not just edge 3D.
I've experienced the same with color effects.

Changed in inkscape:
importance: Undecided → High
milestone: none → 0.47
status: New → Confirmed
ScislaC (scislac) on 2009-11-24
Changed in inkscape:
milestone: 0.47 → none
su_v (suv-lp) on 2010-07-26
tags: added: extensions-plugins
jazzynico (jazzynico) wrote :

Reproduced on Vista, Inkscape trunk revision 9983.

The clipped objects are not deleted (they are still on the XML tree, see XML editor), but not rendered on the canvas. Saving the document after undoing and reloading it make the disappeared object show again.

This bug seems to affect all external extensions (even if the object is not modified or not selected), but not the internal ones (Render>Grids or Filters>Shadows and Glows>Drop Shadow).

summary: - Edge 3d Undo Deletes All Clipped Objects
+ Undo on external extensions deletes all clipped objects
jazzynico (jazzynico) on 2010-12-28
tags: added: clipping
su_v (suv-lp) wrote :

Possibly related:
Bug #274038 “add nodes deletes imported pdf”
<https://bugs.launchpad.net/inkscape/+bug/274038>

jazzynico (jazzynico) wrote :

@~suv - Confirmed. The PDF relies on an heavy use of clippath, and the symptoms are exactly the same.

su_v (suv-lp) wrote :

Also reproduced when toggling 'Live Preview' on and off again.
(see also: <http://www.inkscapeforum.com/viewtopic.php?f=5&t=9076>)

The clipped objects still exist -> they are rendered as expected when opening a duplicate window of the current document.

Changed in inkscape:
status: Confirmed → Triaged
Rena Kunisaki (i-am-inuyasha) wrote :

They'll also reappear if releasing their clip/mask and then undoing that, but I had a crash when doing that too.

Magnes (magnesus2) wrote :

I also had crashes when undoing effect operation on some complex files (can't reproduce it now though) as reported here: https://bugs.launchpad.net/inkscape/+bug/1246015

What scares me a little is why is this bug not fixed since 2011... Or is it wrong place to submit bugs?

su_v (suv-lp) wrote :

Based on tests with archived builds (on OS X 10.7.5):
- reproduced with Inkscape 0.91 r13725,
- reproduced with lp:inkscape rev <= 14244,
- not reproduced with lp:inkscape rev >= 14245,
- not reproduced with lp:inkscape/0.92.x r15074;
it seems that the changes in revision 14245 also addressed this issue:
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14245

AFAICT the report can be closed as 'Fix Committed' for milestone 0.92 if 'no longer reproduces' can be confirmed on other platforms as well (e.g. with a recent build of the stable release branch).

jazzynico (jazzynico) wrote :

Reproduced on Xubuntu 16.04, Inkscape 0.91.
Not reproduced with lp:inkscape/0.92.x rev. 15074.

To be confirmed on Windows 7 later.

jazzynico (jazzynico) wrote :

Fix confirmed on Windows 7, lp:inkscape/0.92.x rev. 15074.

Changed in inkscape:
milestone: none → 0.92
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2017-01-09
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers