Most shortcuts don't work

Bug #1730246 reported by Sergey Tochilov on 2017-11-05
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Patrick Storz

Bug Description

Inkscape version: 0.92.2 (5c3e80d, 2017-08-06) x64
Windows version: 10 Pro x64 RUS 1703 15063.674

In the latest stable Inkscape version most of keyboard shortcuts don't work, specifically those with letters (single or with Ctlr-, Shift- and Alt- prefixes and their combinations). Most other shortcuts (functional keys, +, -, !, 1-9 etc) work. Ctrl- non-letter path shortcuts work. Ctrl-(Shift)-Tab window change work. Non-letter layer shortcuts work. # and | doesn't work. Next and Prev Zoom (Shift)-` doesn't work. This list may be incomlete.

I did some troubleshooting. Reassigning shortcuts in preferences doesn't help. Tried x64, x32 and portable versions with the identical shortcuts misbehavior. Found out that commands selected from menu either by mouse or Alt-letter.. works fine, but this is of little help and I was forced to downgrade back to Inkscape 0.48.5 r10040 where all shortcuts work fine.

Sergey Tochilov (buran21) wrote :

P.S. The shortcut tests were performed with ENG windows keyboard layout.

Patrick Storz (ede123) wrote :

Hi Sergey,

Inkscape attempts to make shortcuts continue to work even when you switch your keyboard layout. For this the shortcut is "converted" to the character your primary keyboard layout would've produced (the primary layout is the first one defined in your regional settings).

For this to work properly you should try to set the English layout (or at least a latin layout) as the first keyboard layout.

This requirement should be removed in current nightly builds of master (the first latin layout is determined automatically). You could try a recent nightly build (e.g. [1]) to see if this fixes the issue for you.

[1] https://ci.appveyor.com/api/buildjobs/attrl9gxonu30fxu/artifacts/build%2Finkscape-0.92%2Bdevel_2017-11-05_2b1d0d5-x64.7z

Hachmann (marenhachmann) wrote :

Would a backport be feasible, @Eduard? (if confirmed to work, I mean)

I think this user has the same issue:
http://www.inkscapeforum.com/viewtopic.php?f=22&t=33141

Patrick Storz (ede123) wrote :

Yes, if we determine the cause of the issue and can find a working fix this could be considered.

It has a regression risk (which is why I tried to keep the changes to shortcuts in 0.92.x minimal) but if it helps enough people it might be worth it. (We'd need testers, though... So far I've not heard any feedback either way).

Sergey Tochilov (buran21) wrote :

Eduard, I tried the nightly build you suggested. Shortcuts work fine independently of what the current layout RUS or ENG is. Also I tried to change the layout order within the Language settings at the Windows regional settings and this seems to not have any effect on the shortcut functionality, both at the stable and the nightly.

Patrick Storz (ede123) wrote :

Hm, OK...

Unfortunately changing the layout order *should* have the same effect as the fix in master I had in mind for back-porting. There have been some additional changes in master but they are a higher regression risk, so I feel a bit uncomfortable with back-porting. Last but not least shortcuts are handled by GTK+ and we switched from gtk2 to gtk3, so it might even be a difference in the toolkit itself.

Just to be sure:
- [1] is the dialog I have in mind
- You have to put a latin layout (e.g. English)
  as the first layout.
- You have to restart you PC once (this is important!)
After that shortcuts should work in 0.92.2 as they do in the nightly build.

If this does not help we'd have to dig deeper...

[1] https://www.msoutlook.info/pictures/regional-keyboardsettings.png

Sergey Tochilov (buran21) wrote :

Eduard, finally I had an opportunity to reboot my home media server where the Ikscapes reside. As expected 0.92.2 shortcuts now work fine as they do in the nightly build. My Win10 has a slightly different language settings dialog, which is attached.

Patrick Storz (ede123) wrote :

OK, great... So it seems to fix at least your issue (a user in the very similar bug #1731394 seems less successful).
I just backported the fix from master to a personal branch; testing builds will be available at [1]. Could you check if this version works for you? (i.e. no regressions and without the need to reorder keyboard layouts?)

> My Win10 has a slightly different language settings dialog.

You're right, I was at work where I still use Windows 7 and didn't notice the difference. The important thing is not to use the strange new Windows 10 dialog accessible from the toolbar (which does not even offer a possibility to re-order).

Sergey Tochilov (buran21) wrote :

Could you please explain what "no regressions" means? I thought "regression" is about risk of introducing errors in a tested code. But from the last mail it's become confusing, should I check some settings of my os besides reordering keyboard layouts?

Patrick Storz (ede123) wrote :

No, just test what you did before... if it works and also works with the initially non-working order of keyboard layouts it's fine.

If any shortcuts *don't* work anymore that used to work before, that would be an issue, but should also be easily noticeable.

Sergey Tochilov (buran21) wrote :

Succeeded, inkscape-0.92+devel_2017-11-05_2b1d0d5-x64 shortcuts work independently of the layout order. Tested some popular shortcuts - all worked.

Patrick Storz (ede123) wrote :

Hm, did you test the same master build again?

https://ci.appveyor.com/project/Ede123/inkscape/build/0.92.x_shortcuts-429
is the 0.92.x build that has the backported fix...

Sergey Tochilov (buran21) wrote :

Sorry, mixed the versions. Just tested inkscape-0.92.2_2017-11-15_1b946ed-x64 with the same positive result - shortcuts work independently of the layout order.

Patrick Storz (ede123) wrote :

OK, great, thanks for testing!

If nobody reports any issues I'll push the fix to the 0.92.x branch eventually.

Patrick Storz (ede123) on 2017-11-24
tags: added: shortcuts
Patrick Storz (ede123) wrote :
Changed in inkscape:
milestone: none → 0.92.3
assignee: nobody → Eduard Braun (eduard-braun2)
status: New → Fix Committed
Bryce Harrington (bryce) on 2018-05-12
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers