Selectable units for steps

Bug #170293 reported by Aleksandar Urošević on 2004-06-20
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned
Nominated for 0.91.x by Lenge

Bug Description

1) Enable to user chose unit in Step preferences tab of Inkscape
Preferences dialog for:
- Arrow keys move by
- > and < scale by
- Inset/Outset by

2) Add spinbox for "Arrow keys move by" to Main toolbar, behind positioning
and dimension properties of selected object, and use globaly set unit on
toolbar for determinign unit for movement step

3) Add Node align dialog, or three new buttons on Node editing toolbar
for:
- align selected nodes vertically
- align selected nodes horizontally
- align selected nodes vetically and horisontally (center)

Eventualy, as in Align and Distribute for selected objects, to add options
align by:
- Last selected
- First selected
- Center of selected nodes

Bug Importer (bug-importer) wrote :

As far as aligning nodes go, I'd like to see the align and distribute
dialog work with those as well, with any invalid items (Biggest Item,
Smallest Item, etc.) greyed out.

Node alignment is in CVS.

Rockstar1707 (rockstar1707) wrote :

Originator: NO

I would just like to ask if there's something going on in this direction.
So far (14th of January 2007) you still can't choose units for STEP. I
think this is really useful feature.

su_v (suv-lp) on 2010-09-01
Changed in inkscape:
importance: Undecided → Wishlist
status: Invalid → Confirmed
tags: added: preferences
su_v (suv-lp) wrote :

a) Selectable units for steps:

Initial commit in revision 10177.

b) Add spinbox for "Arrow keys move by" to Main toolbar:

The option stays in the preferences dialog for now, but with selectable units like other 'Steps' options (part of r10177)

c) Align nodes

Already part of the 'Align & Distribute' dialog when the node tool is active. For further feature requests, see bug #171287 (“Align dialog should have "Relative to" for nodes, too”) and its duplicates.

@Johan - would it be ok to assign the report to you?

Changed in inkscape:
status: Confirmed → In Progress
Pablo Trabajos (pajarico) wrote :

Could you please update the release notes? I don't see any reference to this.

Pablo Trabajos (pajarico) wrote :

Sorry, I was talking about "a) Selectable units for steps" only.

su_v (suv-lp) wrote :

> Could you please update the release notes? I don't see any
> reference to this.

@Pablo - this was just committed less than 24 h ago to inkscape trunk and hasn't seen much testing and user experience yet - why such a hurry to add it to the release notes for 0.49 (which is not scheduled to be released this year anyway)? Or do you propose to backport some selected new features to the 0.48.x branch for 0.48.2 (intended for bug fix releases, not new features)?

Pablo Trabajos (pajarico) wrote :

Ok, sorry, nevermind ;) It was just a reminder.

> Or do you propose to backport some selected new features to the 0.48.x branch for 0.48.2
No, I'm indifferent.
I was afraid that it didn't make to the releases notes since it has happened before (I think) that the person in charge of a part of the code didn't update them. But I'm not in a hurry, so excuse me, forget it;)

On 18-4-2011 17:04, Pablo Trabajos wrote:
> I was afraid that it didn't make to the releases notes since it has happened before (I think) that the person in charge of a part of the code didn't update them. But I'm not in a hurry, so excuse me, forget it;)

I was about to add it, but couldn't find a good spot where to add it and
forgot about it. Please go ahead and add it to the Release Notes. I am
very sure all coders will appreciate it very much if other people helped
them with this kind of stuff. It can be a bit of a pain to get
everything right after implementing something. :-)
Thanks!

su_v (suv-lp) wrote :

@Johan - we have a problem when upgrading to the new feature with old preferences: all commands which take a value from the steps preferences (move with cursor, path inset/outset, scale with keyboard) initially fail with Inkscape trunk (there's no unit in the preferences file). As soon as the preferences dialog has been opened once (without changing anything), the preferences are updated and have the necessary units added: the commands now work as expected.

For users upgrading to a newer version, this is unexpected and the "fix" is not obvious.

Steps to reproduce:
1) quit all instances of Inkscape
2) rename current preferences file
3) launch&quit Inkscape 0.48.1 (to recreate a default preferences file)
4) launch Inkscape trunk, draw a shape and try to move it with the cursor keys -> failure
5) open and close the preferences dialog
5) try again to move the shape -> success

su_v (suv-lp) wrote :

Follow-up report:
Bug #799848 “Commands using 'Steps' values initially fail in trunk with preferences file from stable”

su_v (suv-lp) wrote :

Changing status to 'Fix Committed' (updating prefs file has been filed separately in bug #799848).

Still needs documenting in the release notes 0.49
<http://wiki.inkscape.org/wiki/index.php/Release_notes/0.49>

Changed in inkscape:
status: In Progress → Fix Committed
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions