Can't select multiple files in file open/import native dialogs

Bug #166530 reported by Mati-pl on 2005-05-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

I'd like to open (and work on/compare) some documents,
which all are in the same directory. I can't just
select them using control/shift-clicking, but it's
necessary to open files singly.

ScislaC (scislac) wrote :

confirmed on win32 as well (originally submitted under Linux)

Gnumuthu (gnumuthu) wrote :

I have a patch, that makes it work on the CVS head.
It modifies src/file.cpp & src/dialog/filedialog.[h|cpp].

There are 3 patch files, one for each, Im wondering what to do.
Theres no option to upload this on the website...;-|
Thinking.

Muthu

fixed in cvs thanks to gnumuthu's patch

This appears to affect Windows users too even though the Win32 build now uses native dialogs. Does the fix affect those builds?

Pablo Trabajos (pajarico) wrote :

Yes, it does (on windows at least). Both open and import dialogs. I'm reopening this.

Changed in inkscape:
status: Fix Released → Confirmed
summary: - Can't select multiple files in file open dialog
+ Can't select multiple files in file open/import dialogs
su_v (suv-lp) wrote :

AFAICT fixed for 'File > Open' since Inkscape 0.47, see
- Bug #220000 “Open dialog multiple select not working”
  <https://bugs.launchpad.net/inkscape/+bug/220000>

For 'File > Import' (fixed in current trunk), see
- Bug #203070 “Import Dialog doesn't handle multiple files”
  <https://bugs.launchpad.net/inkscape/+bug/203070>

@JazzyNico, Kris: can we consider this fixed for the Windows native file dialogs, too? (open multiple files since 0.47, import multiple files in current trunk)

Changed in inkscape:
status: Confirmed → Incomplete
Kris (kris-degussem) wrote :

If the windows native dialogs are used File > open nor File > Import allow the selection of multiple files.
So I would say the fix committed status of #203070 is only correct for GTK dialogs. There is no reference to what type of dialog is considered in bug #203070 , so I would refer to this bug (bug #166350 ) as specific to windows and to the windows native dialogs.

su_v (suv-lp) on 2013-03-03
tags: added: win32
removed: all-platforms
Changed in inkscape:
status: Incomplete → Triaged
jazzynico (jazzynico) on 2015-03-21
summary: - Can't select multiple files in file open/import dialogs
+ Can't select multiple files in file open/import native dialogs
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.