Pen/Pencil: new handles with hard-coded sizes ignore global handle size setting

Bug #1562197 reported by su_v on 2016-03-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Martin Owens

Bug Description

In rev 14721, the path drawing tools got refactored to increase the handle of the start/end node on hover (in addition to the existing highlighting with red fill). [1]

The current implementation of this new feature relies on two hardcoded handle sizes [2] and thus introduces a UX regression for users who prefer to work with smaller or larger handle sizes [3]: the global preferences setting for handle size is now overridden/reset for the start- and end nodes in the pen/pencil tool context.

Possible solutions to improve the UX for all users, not just those working with the default handle size:

A) Reimplement the new feature with a relative size increase for the on-hover effect, thus respecting the user's preferred handle size as defined in the preferences.

B) Reimplement the new feature as optional (enabled by default) to allow users who value consistent overall handle sizes more to disable the new feature.

References:
[1] Related discussion on inkscape-devel ML:
* Subject: Re: SpinachCon Results
http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/47721/focus=47732

[2] Hard-coded handle size (7.0/10.0):
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/view/head:/src/ui/draw-anchor.cpp#L29

[3] Earlier reports tracking configurable handle sizes:
* Bug #172059 (sf1749840) “handle configuration”
  https://bugs.launchpad.net/inkscape/+bug/172059
* Bug #1331967 “Nodes and handles in hidpi screens are too small”
  https://bugs.launchpad.net/inkscape/+bug/1331967

Martin Owens (doctormo) on 2016-04-02
Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: New → Confirmed
Martin Owens (doctormo) wrote :

Should now be fixed, the sizeChanger was refactored into a ctrlResize variable which can be changes by any signal or event and it adds (or removed) size from the calculated table. Fewer checks on selected sizeChanger because we can automatically add ctrlResize integer inline.

see r14761

Changed in inkscape:
status: Confirmed → Fix Released
su_v (suv-lp) wrote :

Follow-up report:
Bug #1568644 “Node tool: handle size of selected nodes too big and sticky (rev >= 14761)”
https://bugs.launchpad.net/inkscape/+bug/1568644

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers