[Win 10] copy-paste between documents is rasterized

Bug #1480686 reported by Tristan on 2015-08-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

I am using Inkscape 0.91 r13725 on the recently-released Windows 10 64-bit. I had installed Inkscape on Windows 8.1, before I upgraded. When I copy vector objects of any type from one document to another one in a separate window, the data is rasterized, sometimes incorrectly. Within the same document, copy-paste works as expected.

I am unsure if this bug applies on other versions of Windows, but I don't recall it happening before I upgraded. I managed to work around this by deleting the rest of the document, saving the objects I wanted to copy over, and importing the file, although obviously this is rather clunky.

It appears that there is/was a similar bug (https://bugs.launchpad.net/inkscape/+bug/307005) in OS X, although it appears that that particular bug affected intra-document pasting as well.

EDIT: It appears that this bug is somewhat inconsistent, as later on today I copied and pasted between documents just fine.

Tristan (tristanbomb) on 2015-08-02
tags: added: clipboard
description: updated
description: updated
description: updated
description: updated
su_v (suv-lp) on 2015-08-02
tags: added: win64
Tristan (tristanbomb) on 2015-08-03
description: updated
Brynn (brynn4inks) wrote :

I'm having this problem with Windows 7 Pro, 64-bit. However the computer is relatively new, and of the Windows 10 era. (I hated Windows 10 so much, I bought a new computer with Windows 7.) (Dell Latitude 15")

Let me know if I can help with troubleshooting, or if you need any other info.

Oh here, let me test with some older versions of Inkscape. Currently 0.92.2, 64-bit, 7z package.

Actually no, I don't have the same experience with 0.91. Although my 0.91 is the 32-bit, exe installer (iirc).

Shall I try 0.92.2 for 32-bit? Or 0.91 for 64-bit?

Alvin Penner (apenner) wrote :

problem not reproduced on Windows 10, Inkscape 0.92.2 (5c3e80d, 2017-08-06) (32 bit build)

attached is the vector source I used

Alvin Penner (apenner) wrote :

here is the result after copying and pasting to a new Inkscape window.

could you attach a sample source and destination file for testing purposes?

Brynn (brynn4inks) wrote :

Sorry for the delay. I'm unable to reproduce this now. At the time it happened I tried at least 6 times with 3 different kind of objects, and it happened every time. And when I tried with 0.91 (32-bit) it did not happen.

But now, even using the same objects from the same files, it doesn't happen. I don't know if this indicates some local situation is setting the stage?

All I can do is watch for it to happen again. If it does, I'll be sure to attach sample files.

Beuf (spamdebeuf) wrote :

FYI ran in to same issue. Inkscape 0.91 r13725, Windows 7, 64-bit.

Tried single object, group of objects and selection of objects all resulted in bitmap.

Can not paste anything in notepad but can paste in paint.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers