Color wheel: can't rotate while on black

Bug #1462907 reported by LucaDC on 2015-06-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Martin Owens

Bug Description

When the color wheel is set on black or gray (the dot is on the left vertical side of the triangle) it's not possible to pick the red on the external ring and rotate it to select a different base color. Or better: you can drag and rotate it but as soon as you release it it's reset aligned to red.

I'm on Windows XP and I've found this problem already present when I restarted using the current trunk after sticking with r13640 for a while (where there wasn't this issue but it's a bit too old to be useful, I think).

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91+devel r14194 on OS X 10.7.5.

Based on tests with archived builds, this seems to be a variation of
* Bug #1249618 “Color wheel changes hue when picking brightness and saturation”
  https://bugs.launchpad.net/inkscape/+bug/1249618
introduced with the merge of the fill-n-stroke-cppify branch in r14160:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14160

tags: added: color regression ui
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) on 2015-10-15
Changed in inkscape:
milestone: none → 0.92
Martin Owens (doctormo) wrote :

fixed in r14747

Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: Confirmed → Fix Committed

Awesome! Thanks for fix it!

El mar, 29-03-2016 a las 00:52 +0000, Martin Owens escribió:
> fixed in r14747
>
> ** Changed in: inkscape
>      Assignee: (unassigned) => Martin Owens (doctormo)
>
> ** Changed in: inkscape
>        Status: Confirmed => Fix Committed
>

insaner (insaner) wrote :

Fix might have caused regression:
https://bugs.launchpad.net/inkscape/+bug/1564597
 (cannot edit swatches)

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers