Color wheel changes hue when picking brightness and saturation

Bug #1249618 reported by Alicia Boya on 2013-11-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Martin Owens

Bug Description

As it is right now it's very cumbersome to pick bright colors in Inkscape with the color wheel.

Try to pick a light blue you like. Click the color wheel, select hue for blue and then click and drag within the triangle to select how bright you want it.

You'll notice if you reach the 0-saturation border (white to black) -- which is not really a hard thing to do -- you'll lose your blue: hue has been reset to red (default).

In other situations your hue may be changed to cyan.

Also as you drag the cursor within the triangle it "trembles" (rotates), changing the hue too and making even harder to pick the right color.

This is wrong, the triangle should keep stable all the time, like it does in Gimp. At least while the color picker dialog is open.

Alicia Boya (ntrrgc) wrote :

I attach a small video showing the problem.

jazzynico (jazzynico) wrote :

Reproduced on Crunchbang Waldorf (Debian stable), Inkscape 0.48.3.1 and trunk revision 12795.

tags: added: color ui
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
jazzynico (jazzynico) wrote :

Also reproduced on Windows XP, Inkscape trunk revision 12845.

Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with Inkscape 0.47
- reproduced with 0.48 (initial release), 0.48.4 and current trunk (r13290)

su_v (suv-lp) wrote :

Similar effect in the HSL tab (Inkscape >= 0.48):
1) draw a rect with solid blue fill
2) open 'Fill and Stroke'
3) switch to the HSL tab
4) drag saturation slider 'S' to '0'

Expected result: only 'S' changes, 'H' is unchanged (blue).
Actual result: 'H' is reset to '0' (red), too.

su_v (suv-lp) wrote :

Likely related regression in latest trunk:
* Bug #1462907 “Color wheel: can't rotate while on black”
  https://bugs.launchpad.net/inkscape/+bug/1462907

insaner (insaner) wrote :

Confirmed. fc17 linux 32bit.

Here are some notes from what I posted on IRC about reproducing this:

In the color chooser from the "Fill and Stroke" dialog, if Luminance (L) in the HSL chooser is set to 0 or 255, the Hue and Saturation choosers cannot be set by clicking, as they just jump back to 0, using the spinner makes them move, but clicking again makes them jump back. Setting the Luminance to any other value allows the S or L values to be changed now.

Note, this behavior is destructive, as noted, since if you mistakenly set the L to any extreme value it will kill the values you had for S or H.

I agree with suv, its likely related to Bug #1462907 as well.

Martin Owens (doctormo) wrote :

Introduced by r13341.6.35 without any reason or note.

Fixed in r14747, remove re-referencing signal and hardening colour wheel from self signalling.

Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: Triaged → Fix Committed
jazzynico (jazzynico) on 2016-03-29
Changed in inkscape:
milestone: none → 0.92
su_v (suv-lp) wrote :

Proposing to reopen - the issue as tracked in this report (not a recent regression but already present in earlier stable releases) still reproduces with r14747.

Martin Owens (doctormo) wrote :

su_v: Tested again here, not reproduced. Can you re-iterate your steps for me su_v, I'd like to make sure I catch all of these issues with the wheel so I don't mind adding further fixes.

su_v (suv-lp) wrote :

@Martin - the hue reset to 'red' reproduces as described in the bug description and also as demo'd in the video (comment #1):

1) launch inkscape trunk with default (new) prefs, default new doc
2) draw a rectangle
3) open Fill and Stroke
4) switch to the 'Wheel' color selector
5) grab the round handle inside the triangle and start dragging it around:

As soon as the round handle is dragged 'over' the one triangle edge which connects black and white (lightness), the hue resets to red.

Martin Owens (doctormo) wrote :

There were some other signals going on, the wheel was certainly much better and would mostly not flip to red except when a refresh was kicked off by the selection code. This signal thread was really hard to follow, so in r14748 I put some hue protection into the gimp colour wheel directly and this should prevent any redness.

It also means that the last used hue will sort of stick around when selecting different white objects, but that's ok as far as design goes.

su_v (suv-lp) wrote :

Symptom described in comment #5 filed as separate report:
Bug #1565261 “HSL color selector: saturation '0' resets Hue to '0' (>= 0.48)”
https://bugs.launchpad.net/inkscape/+bug/1565261

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments