Filter editor: effect description not entirely readable

Bug #1436180 reported by Bart Van Audenhove on 2015-03-25
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
insaner

Bug Description

In the Custom Filter Editor, the description of the effect is too big for the space it's in, which is not resizable (vertical resize doesn't help). See attached screenshot.
Inkscape 0.91 on Ubuntu 14.04 LTS.
May be somehow related to bug #462748 (https://bugs.launchpad.net/inkscape/+bug/462748)?

jazzynico (jazzynico) on 2015-03-25
tags: added: filters-svg ui
jazzynico (jazzynico) wrote :

Reproduced on Crunchbang Waldorf, Inkscape trunk rev. 14032.
Not reproduced with 0.48.3.1.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
milestone: none → 0.92
tags: added: regression
su_v (suv-lp) wrote :

Based on tests with archived builds on OS X 10.7.5:
- not reproduced with 0.48+devel r12228,
- reproduced with 0.48+devel rev >= 12232;
the fixed height for the infobox displaying the descriptions with varying lengths was likely introduced in r12229:

Relevant change log:
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/12232

Revision 12229: ability to scroll inside the filter dock -- gain some screen real estate!
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12229

Changed in inkscape:
status: Confirmed → Triaged
insaner (insaner) wrote :

Gtk is pretty annoying to deal with, this is the best I can do right now. Let me know if it's an acceptable fix.

Changed in inkscape:
assignee: nobody → insaner (insaner)
insaner (insaner) wrote :

This is one is an even better approach. However, making the GTK label automatically fit the contents after a resize apparently needs some sort of hack, since it doesn't just work.
 http://stackoverflow.com/questions/1893748/pygtk-dynamic-label-wrapping
So I think I will just leave it as is. Let me know if there are any problems, otherwise I will push the changes on Wednesday.

insaner (insaner) wrote :

Committed to r14846

Changed in inkscape:
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers