Clock does not respect regional settings

Bug #1001595 reported by Ben Aceler on 2012-05-19
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
In Progress
Low
Unassigned
indicator-datetime (Ubuntu)
Low
Unassigned

Bug Description

The clock unity applet (or indicator) have an option to show a date. Regional settings are set to show the date as "19 may", but the clock shows "may 19" instead. After clicking on a clock, in a calendar, it shows properly — 19 may 2012.

Related branches

Ben Aceler (aceler) on 2012-05-19
description: updated
Changed in unity:
status: New → Invalid
Changed in indicator-datetime:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Nekhelesh Ramananthan (nik90) wrote :

Shouldn't this be marked low priority rather than Wishlist since it is a bug rather than a feature request since it shows the correct format after clicking the clock?

Charles Kerr (charlesk) on 2014-03-15
Changed in indicator-datetime:
importance: Wishlist → Low
Changed in indicator-datetime (Ubuntu):
importance: Wishlist → Low
Ivan Larionov (xeron-oskom) wrote :

Same on 14.04 with russian locale (марта is march):

Panels shows:
марта 19 01:12 (wrong order)

Should be:
19 марта 01:12 (right)

After clicking:

Среда, 19 Март 2014 (wrong declension actually — should be Среда, 19 Марта 2014)

Really annoying.

Ivan Larionov (xeron-oskom) wrote :

~$ locale
LANG=ru_RU.UTF-8
LANGUAGE=ru:en
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY=ru_RU.UTF-8
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8
LC_ALL=

~$ env | grep LANG
LANG=ru_RU.UTF-8
GDM_LANG=ru
LANGUAGE=ru:en

Charles Kerr (charlesk) wrote :

The current month/date ordering follows the spec <https://wiki.ubuntu.com/TimeAndDate#Title>.

Assigning to mpt for design feedback. See also <https://launchpadlibrarian.net/83463663/screen.png> for a visual example of this.

Matthew Paul Thomas (mpt) wrote :

Oh, I didn't mean that we should disregard regional settings! I just mentioned the Time & Date settings because they determine which elements are present in the title in the first place. Specification updated. <https://wiki.ubuntu.com/TimeAndDate?action=diff&rev2=94&rev1=92>

no longer affects: unity
Changed in indicator-datetime:
status: Confirmed → Triaged
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Triaged
Charles Kerr (charlesk) wrote :

So, after looking into this, I didn't have to get into too many languages before realizing there isn't a one-size-fits-all solution that can be addressed in the source code.

For example, I the code /could/ check nl_langinfo(D_FMT) to see whether the month or day goes first, and that would solve the MM DD YYYY <--> DD MM YYYY complaints that are part of this ticket.

However there are all kinds of other issues and combinations, for example en zh_CN the weekday should go after the date, rather than before, and always prefers year-month-day rather than day-month-year or month-day-year. And there are several other issues.

In the end, I think this has got to be fixed on a locale-by-locale basis by the translators. However, indicator-datetime's code /can/ make this a lot less painful / more likely to actually happen. I've added copious translator comments to lp:~charlesk/indicator-datetime/lp-1001595 to help make this happen.

Changed in indicator-datetime:
status: Triaged → In Progress
Changed in indicator-datetime (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+14.04.20140328-0ubuntu1

---------------
indicator-datetime (13.10.0+14.04.20140328-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * Short-term workaround for the GIO GAppInfo wakeup bug discussed in
    bug 1296233 (LP: #1296233)
  * Improved translator comments for better time/date localization. (LP:
    #1001595)
 -- Ubuntu daily release <email address hidden> Fri, 28 Mar 2014 16:11:23 +0000

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Ivan Larionov (xeron-oskom) wrote :

That's weird. I really hate seeing "июня 5" (analogue in english is "of june 5" — weird, isn't it?) instead of "5 июня" (5th of june).

Also after click it's "Четверг, 5 Июнь 2014" instead of "Четверг, 5 Июня 2014".

I'm attaching screenshot from OS X where developers know how it should be in russian:

Ivan Larionov (xeron-oskom) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers