remove i2c-i801 from blacklist

Bug #1786574 reported by AaronMa on 2018-08-11
68
This bug affects 16 people
Affects Status Importance Assigned to Milestone
HWE Next
Critical
Unassigned
OEM Priority Project
High
Unassigned
kmod (Ubuntu)
High
Unassigned
Xenial
Undecided
Canonical Foundations Team
Bionic
Undecided
Michael Hudson-Doyle
Cosmic
High
Unassigned

Bug Description

SRU justification
============

[Impact]
Many modern notebooks need i2c-i801 kernel module to function, but it is blacklisted by /etc/modprobe/blacklist.conf, which gives a very poor user experience.

[Test case]
1. Install Ubuntu
2. Check touchpad works or not
3. Install the fixed kmod package
4. Confirm touchpad works

[Regression Potential]
i2c-i801 was blacklisted due to bug 16602. The user complains an HP Compaq nc6000 notebook cannot suspend without blacklisting i2c-i801. While this is a way to workaround the suspend issue, the proper fix should be in linux kernel. Since nc6000 was a machine sold in 2004, it is too difficult to find someone to verify if it will regress due to this SRU. The rationale to blacklist it is: https://bugs.launchpad.net/ubuntu/+source/hotplug/+bug/16602/comments/5, however it is no longer valid nowadays on modern computers.

Besides, there look like to be a quirk in linux kernel that fixes it:
https://github.com/torvalds/linux/blame/master/drivers/pci/quirks.c#L1434

[Other Info]
rationale of i2c_i801 driver blacklist: https://answers.launchpad.net/ubuntu/+source/kmod/+question/269329

-----------------------------------------------------------------------------------------------
Original bug report:

We have a Lenovo Thinkpad machine that requires i2c-i801 kernel module to work, but it is listed in /etc/modprobe/blacklist.conf in Ubuntu. To use the touchpad, users have to remove the i2c-i801 line manually.

i2c-i801 in blacklist.conf is a very old workaround to fix HP compaq nc6000
(Bug #16602), this module should be removed from blacklist.

There is also another bug (Bug #1475945) that needs this module for Acer trackpad to work.

Related branches

AaronMa (mapengyu) on 2018-08-11
affects: ubuntu → kmod (Ubuntu)
AaronMa (mapengyu) on 2018-08-11
no longer affects: linux (Ubuntu)
AaronMa (mapengyu) on 2018-08-11
Changed in hwe-next:
importance: Undecided → Critical
Changed in kmod (Ubuntu):
importance: Undecided → Critical
Shengyao Xue (xueshengyao) wrote :

The real bug should not be bug #10306, but is bug #16602.

also there is a similar bug:
https://bugs.launchpad.net/ubuntu/+source/kmod/+bug/1475945

description: updated
description: updated
tags: added: 1786573 sutton
Changed in kmod (Ubuntu Cosmic):
importance: Critical → High
Anthony Wong (anthonywong) wrote :

Is there anything I should do to move this bug forward? Thanks.

Changed in oem-priority:
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kmod (Ubuntu Bionic):
status: New → Confirmed
Changed in kmod (Ubuntu Xenial):
status: New → Confirmed
Changed in kmod (Ubuntu):
status: New → Confirmed
Joshua Powers (powersj) wrote :

@Anthony - should someone on the kernel team review your proposed merge/change rather than the server team?

Anthony Wong (anthonywong) wrote :

Yes, probably, I actually have pinged apw about this bug, so shouldn't hurt to add him as reviewer. I may also try to find someone to upload a package later.

Kai-Heng Feng (kaihengfeng) wrote :

LP: #1722478 should be the earliest report about this issue.

Stefan Bader (smb) wrote :

I did prepare some slightly modified proposal for this and will try to get things progressing tomorrow.

Hi,
first of all this package seems to have quite some issues in the merges that are done - it doesn't list all remaining changes and the i2c blacklist is one of them.
It comes from like back in 2005 and I agree, it might or is safe to be removed.

Thanks to Stefan Bader for cleaning this up, as the MP linked here has e.g. on changelog entries.
I'd ack to his branch at [1] for Cosmic, is it would be an MP to ack on.

But for the actual sponsoring, as I never really touched kmod before I'd be happy if you'd ask one of the foundations Team that is here this week that touched it recently as they might have extra considerations. OTOH the change really looks right for cosmic IMHO, so if no one responds get back to me.

SRUs of this are quite a different topic for the following reasons:
- if the issues still exists, it might regress somebody due to the SRU then.
- If you can prove that the old issue really does no more exist with e.g. the oldest kernel in Bionic, then it might be done. But you'd have to outline that in detail when completing the SRU template for this bug [2]
Without the prove I'd be concerned and as a SRU member would reject it, so really make sure you
get this documented right.

What makes an SRU even more likely (if there is a regression risk) is that the fix for those affected would be a simple config change, so no one "relies" on this being SRUed to get out of it.

[1]: https://git.launchpad.net/~smb/ubuntu/+source/kmod/log/?h=ubuntu/cosmic-proposed
[2]: https://wiki.ubuntu.com/StableReleaseUpdates

AaronMa (mapengyu) wrote :

Resume issue should be fixed by kernel driver or other WA than blacklist a kernel module.

If the nc6000 issue is still happened on current kernel, please use the following systemd script to fix it.

/lib/systemd/system-sleep/i2c-i801-reload.sh
#!/bin/sh
case $1 in
  pre)
    modprobe -r i2c-i801
    ;;
  post)
    modprobe i2c-i801
    ;;
esac

%sudo chmod a+x /lib/systemd/system-sleep/i2c-i801-reload.sh

On Wed, 19 Sep 2018 at 22:01,  Christian Ehrhardt  <
<email address hidden>> wrote:

> Hi,
> first of all this package seems to have quite some issues in the merges
> that are done - it doesn't list all remaining changes and the i2c blacklist
> is one of them.
> It comes from like back in 2005 and I agree, it might or is safe to be
> removed.
>
> Thanks to Stefan Bader for cleaning this up, as the MP linked here has
> e.g. on changelog entries.
> I'd ack to his branch at [1] for Cosmic, is it would be an MP to ack on.
>

Thanks!

>
> But for the actual sponsoring, as I never really touched kmod before I'd
> be happy if you'd ask one of the foundations Team that is here this week
> that touched it recently as they might have extra considerations. OTOH
> the change really looks right for cosmic IMHO, so if no one responds get
> back to me.
>
> SRUs of this are quite a different topic for the following reasons:
> - if the issues still exists, it might regress somebody due to the SRU
> then.
> - If you can prove that the old issue really does no more exist with e.g.
> the oldest kernel in Bionic, then it might be done. But you'd have to
> outline that in detail when completing the SRU template for this bug [2]
> Without the prove I'd be concerned and as a SRU member would reject it, so
> really make sure you
> get this documented right.
>

I have added the SRU justification, hope that helps.

description: updated
Steve Langasek (vorlon) on 2018-10-23
Changed in kmod (Ubuntu Xenial):
assignee: nobody → Canonical Foundations Team (canonical-foundations)

Oh somehow I failed to notice the merge proposal on here, sorry about that. It's all fairly trivial though...

Changed in kmod (Ubuntu Bionic):
status: Confirmed → In Progress
Changed in kmod (Ubuntu Xenial):
status: Confirmed → In Progress
Changed in kmod (Ubuntu Cosmic):
status: Confirmed → In Progress
Changed in kmod (Ubuntu Bionic):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
tags: added: id-5bcf361f46e3d43769c9cfcb

Hello AaronMa, or anyone else affected,

Accepted kmod into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kmod/25-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in kmod (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in kmod (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Andy Whitcroft (apw) wrote :

Hello AaronMa, or anyone else affected,

Accepted kmod into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kmod/24-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in kmod (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Andy Whitcroft (apw) wrote :

Hello AaronMa, or anyone else affected,

Accepted kmod into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kmod/22-1ubuntu5.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

AaronMa (mapengyu) on 2018-10-30
tags: added: verification-done-xenial
removed: verification-needed-xenial
AaronMa (mapengyu) on 2018-10-30
tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done-cosmic
removed: verification-needed-cosmic
AaronMa (mapengyu) on 2018-10-30
tags: added: verification-done
removed: verification-needed
Changed in hwe-next:
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

@AaronMa - Could you please add some verification details to the bug report?

tags: added: verification-needed-bionic verification-needed-cosmic verification-needed-xenial
removed: verification-done-bionic verification-done-cosmic verification-done-xenial
AaronMa (mapengyu) wrote :

After update to new kmod in proposed and reboot:

$ lsmod |grep i2c
i2c_algo_bit 16384 1 i915
i2c_i801 28672 0

$ dmesg |grep rmi
[ 0.168549] Secure boot could not be determined
[ 3.244024] rmi4_smbus 0-002c: registering SMbus-connected sensor
[ 3.330955] rmi4_f34 rmi4-00.fn34: rmi_f34v7_probe: Unrecognized bootloader version
[ 3.331002] rmi4_f34: probe of rmi4-00.fn34 failed with error -22
[ 3.357589] rmi4_f01 rmi4-00.fn01: found RMI device, manufacturer: Synaptics, product: TM3288-010, fw id: 2685418
[ 3.582251] input: Synaptics TM3288-010 as /devices/rmi4-00/input/input7
[ 3.634203] serio: RMI4 PS/2 pass-through port at rmi4-00.fn03
[ 3.860074] input: TPPS/2 Elan TrackPoint as /devices/rmi4-00/rmi4-00.fn03/serio2/input/input9

On Xenial/Bionic/Cosmic, touchpad works fine.

tags: added: verification-done-bionic verification-done-cosmic verification-done-xenial
removed: verification-needed-bionic verification-needed-cosmic verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 25-1ubuntu1.1

---------------
kmod (25-1ubuntu1.1) cosmic; urgency=medium

  * Remove i2c_i801 from d/modprobe.d/blacklist.conf. (LP: #1786574)

 -- Michael Hudson-Doyle <email address hidden> Wed, 24 Oct 2018 12:20:23 +1300

Changed in kmod (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for kmod has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 24-1ubuntu3.1

---------------
kmod (24-1ubuntu3.1) bionic; urgency=medium

  * Remove i2c_i801 from d/modprobe.d/blacklist.conf. (LP: #1786574)

 -- Michael Hudson-Doyle <email address hidden> Wed, 24 Oct 2018 12:20:23 +1300

Changed in kmod (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 22-1ubuntu5.1

---------------
kmod (22-1ubuntu5.1) xenial; urgency=medium

  * Remove i2c_i801 from d/modprobe.d/blacklist.conf. (LP: #1786574)

 -- Michael Hudson-Doyle <email address hidden> Wed, 24 Oct 2018 12:20:23 +1300

Changed in kmod (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in hwe-next:
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

This seems to have caused a regression see bug 1802135.

Adam Jacobs (bllfr0g) wrote :

Another regression: bug 1802689

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 25-1ubuntu2

---------------
kmod (25-1ubuntu2) disco; urgency=medium

  * Add i2c_i801 back to d/modprobe.d/blacklist.conf again due to regressions.
    (LP: #1802689, #1802135)

 -- Michael Hudson-Doyle <email address hidden> Tue, 13 Nov 2018 10:50:02 +1300

Changed in kmod (Ubuntu):
status: Fix Committed → Fix Released
AaronMa (mapengyu) on 2019-02-20
Changed in kmod (Ubuntu):
status: Fix Released → In Progress
Changed in kmod (Ubuntu Xenial):
status: Fix Released → In Progress
Changed in kmod (Ubuntu Bionic):
status: Fix Released → In Progress
Changed in kmod (Ubuntu Cosmic):
status: Fix Released → In Progress
AaronMa (mapengyu) wrote :

#1802135 is fixed in kernel patch:
https://lists.ubuntu.com/archives/kernel-team/2018-November/096852.html

#1802689 is not reproduced and no feedback from bug reporter.
If reporter still find issue with i2c_i801, we can try fix in kernel.

More touchpads need smbus/i2c support, i2c_i801 should be remove from blacklist.

midnightflash (midnightflash) wrote :

I'm also affected on two machines. (X11e and X250)

AaronMa (mapengyu) wrote :

@midnightflash

What is your issue?

And upload dmesg.

Anthony Wong (anthonywong) wrote :

@midnightflash
Please provide more details on the issues you see so that we can help you. As Aaron said, please upload the dmesg from both your X11e and X250.

Changed in hwe-next:
status: Fix Released → In Progress
Anthony Wong (anthonywong) wrote :

Confirmed with three users who had regressions (bug 1802689 and bug 1802135) through email, and confirmed that our latest kernels no longer manifest the regressions even after i2c_i801 has been removed from blacklist.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 25-1ubuntu3

---------------
kmod (25-1ubuntu3) disco; urgency=medium

  * Drop i2c_i801 from the blacklist again, things work fine with
    current kernels. (LP: #1786574)

 -- Timo Aaltonen <email address hidden> Thu, 04 Apr 2019 11:30:14 +0300

Changed in kmod (Ubuntu):
status: In Progress → Fix Released
AaronMa (mapengyu) wrote :

verification-done-disco

Verified on the latest update on disco.
i2c_i801 is removed and works fine on several laptops.

@aaronMa,

i2c_i801 doesn't in blacklist, but touchpad still not working after suspend. My laptop model is Thinkpad X240 .. previously works okay in disco-alpha

here is my dmesg : http://paste.ubuntu.com/p/kVrkSqxhYn/

Anthony Wong (anthonywong) wrote :

@fenris
Adding back i2c_i801 to blacklist can make the touchpad work again? Is this what you mean?

Nope, I need to re-modprobe the psmouse again to make my touchpad work again

On Apr 16 2019, at 12:39 pm, Anthony Wong <email address hidden> wrote:
> @fenris
> Adding back i2c_i801 to blacklist can make the touchpad work again? Is this what you mean?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1786574
>
> Title:
> remove i2c-i801 from blacklist
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1786574/+subscriptions
>

AaronMa (mapengyu) wrote :

@Khairul

Please try passing "psmouse.synaptics_intertouch=0" in kernel parameter.

If it works, I will send a patch to mainline kernel.

Thanks,
Aaron

@AaronMa,
after recent updates and new kernel 5.0.0-13-generic , I can't reproduce the issue again.

On Apr 17 2019, at 12:25 pm, AaronMa <email address hidden> wrote:
> @Khairul
>
> Please try passing "psmouse.synaptics_intertouch=0" in kernel parameter.
> If it works, I will send a patch to mainline kernel.
> Thanks,
> Aaron
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1786574
>
> Title:
> remove i2c-i801 from blacklist
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1786574/+subscriptions
>

tags: added: hwe oem-priority

Im still having this issue when booting from hibernate :(

On Thu, May 9, 2019, 16:56 Yuan-Chen Cheng <email address hidden> wrote:

> ** Tags added: hwe oem-priority
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1786574
>
> Title:
> remove i2c-i801 from blacklist
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1786574/+subscriptions
>

AaronMa (mapengyu) wrote :

Hi Khairul:

Have you tried passing "psmouse.synaptics_intertouch=0" in kernel parameter?

AaronMa (mapengyu) wrote :

Hi, Khairul,
Could you try the attached patch?

you can apply this patch in latest kernel.
And give it a try? no kernel parameter needed.

If it works, I will upstream it.

Thanks in advance.

Hi Aaron,
Thanks for your prompt replied.

I can't find the file synaptics.c to patch , mind to advise me how to patch ?
On May 9 2019, at 10:21 pm, AaronMa <email address hidden> wrote:
> Hi, Khairul,
> Could you try the attached patch?
>
> you can apply this patch in latest kernel.
> And give it a try? no kernel parameter needed.
>
> If it works, I will upstream it.
> Thanks in advance.
> ** Patch added: "0002-Input-synaptics-remove-X240-from-the-topbuttonpad-li.patch"
> https://bugs.launchpad.net/hwe-next/+bug/1786574/+attachment/5262688/+files/0002-Input-synaptics-remove-X240-from-the-topbuttonpad-li.patch
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1786574
>
> Title:
> remove i2c-i801 from blacklist
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1786574/+subscriptions
>

AaronMa (mapengyu) wrote :

Hi Khairul,
Could you install attached dkms deb?

Then reboot and try touchpad?

Kai-Heng Feng (kaihengfeng) wrote :

Khairul,

Does the touchpad work after boot, and after suspend?

Hi @Aaron & @Kai-Heng,
I've installed the package and reboot + tried suspend 1 time.

So far so good. Will let you know if this problem still occur in the future.
Thanks !
On May 10 2019, at 11:35 pm, Kai-Heng Feng <email address hidden> wrote:
> Khairul,
>
> Does the touchpad work after boot, and after suspend?
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1786574
>
> Title:
> remove i2c-i801 from blacklist
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1786574/+subscriptions
>

Changed in oem-priority:
status: New → In Progress
Changed in oem-priority:
importance: Critical → High

This bug is present in Ubuntu 19.10

Anthony Wong (anthonywong) wrote :

Julian, what exactly is the problem you see in 19.10?

i'm having the issue again, i run the evtest and the output as attached

AaronMa (mapengyu) wrote :

Hi Khairul and Julian:

I have sent the patch to lkml:
https://patchwork.kernel.org/patch/10949569/

But we think Lenovo mixed up the touchpads PnP IDs in X240 series.

Please passing "psmouse.synaptics_intertouch=0" in kernel parameter.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers