HP Officejet Pro K550 fails to print in Ubuntu

Bug #981473 reported by Ricardo Martínez on 2012-04-14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)

Bug Description

I am having an issue with an Officejet Pro K550:

1) Issue started under Ubuntu 11.04
2) Under Ubuntu 10.10 on same laptop printer work's fine
3) Currently running latest hplip updates under 12.04
4) And I have HP Device Manager installed and working.

When attempting to print or run a test print - job starts and always gets an inch or two down the page and then stops. Error code in HP Device Manager is always 5012 - Device Communication Error.

I upgrade to hplip 3.12.4 and same things still happend.

I have never logged a bug under Launchpad before but I can follow technical instructions if laid out clearly.

Looking forward to a response.

Also happens in 12.10 and 13.04

SRU Justification:
Please see bug 1311697.

goutam kodu (goutam-hplip) wrote :

Hi Ricardo,

Can you please post us the output of "hp-check -t" command.

Please try the below steps and check if the bug reproduces:

1. Try power-off the printer and power-on it.
2. Go to "system-config-printer" delete the print queues created for this.
3. Run command "hp-setup -g" and check if the device get detected properly and configured correctly. Post us the "hp-setup -g" output.
4.Launch "hp-toolbox -g" and check the status of the printer in the status tab. It should be "Idle". If you see, 5012 device communication error then post us the "hp-toolbox -g" output.
5. Print a testpage "hp-testpage" and check if the printer printed the test page correctly.

Let us know on the same.

G Kodu

Ricardo Martínez (rm-baraosa) wrote :

Hi Goutam

I have follow your instructions and when I print the test page same communication error.
Printer is configurated properly.

Ricardo Martínez (rm-baraosa) wrote :
Ricardo Martínez (rm-baraosa) wrote :
Ricardo Martínez (rm-baraosa) wrote :
goutam kodu (goutam-hplip) wrote :

Thank you Ricardo for the logs. We will look into the issue.
To debug this issue we would request you to provide us some more logs on this. To provide us the same, please follow the below steps;

(Guessing that you have installed the HPLIP from hplip-3.12.4.run . There gets created a source folder hplip-3.12.4)
1. Open file hplip-3.12.4/io/hpmud/hpmudi.h and uncomment the line.
    //#define HPMUD_DEBUG
   Save the file and do make && sudo make install.

2. Open file /etc/cups/cupsd.conf in write mode and replace the line
LogLevel warn with
LogLevel debug
hpLogLevel 15

3. Clear the syslog and error_log files.
    sudo cat /dev/null > /var/log/syslog
    sudo cat /dev/null > /var/log/cups/error_log

4. Print a test page from "hp-testpage"

5.Capture the log files
   sudo cat /var/log/syslog > ~/Desktop/syslog.txt
   sudo cat /var/log/cups/error_log > ~/Desktop/error_log.txt

Attach us the syslog.txt & error_log.txt files

6. In /tmp folder you will find files with name starting with hpcups like, hpcupsfilterc_1.bmp, hpcupsfilterk_1. bmp, hpcups_jobX.out. Please attach us these files too.

Let us know if you are facing any difficulty in capturing the logs.

Thanks & Regards,
Goutam Kodu

Ricardo Martínez (rm-baraosa) wrote :

Hi, Goutam

This are the files you are requesting me

Ricardo Martínez (rm-baraosa) wrote :
Ricardo Martínez (rm-baraosa) wrote :
Ricardo Martínez (rm-baraosa) wrote :
Ricardo Martínez (rm-baraosa) wrote :

There is too a file named hpcupsfilterc_1.bmp but this file has 80mb, so it is very big for upload. I was looking it and it is a normal print test page included in hplip.

Can you please delete all the print queues by running in teminal 'system-config-printer. Exit hp-systray if running. Run 'hp-setup -g' again in terminal. Once setup is done, run 'hp-toolbox' and check the queue status should be active. Once everything is fine, you should be able to print.

goutam kodu (goutam-hplip) wrote :

Hi Ricardo,

Thank you very much for the logs. We are able to see that there is something wrong going in the claim of the USB interface . Our USB expertise is looking into the issue. Will get back to you soon on this.

For the meantime you can try configuring the device over the network and check if you are able to print.


Ricardo Martínez (rm-baraosa) wrote :

Hi, Goutam

Today, I was printing with this printer in win7. I conected my laptop and I tried to print over the network, but printer gives me same error. It starts to print and suddenly stops. It is well configured over the network and ubuntu searched the drivers without problem.

Thanks a lot for your time.

Best regards,

Ricardo Martínez (rm-baraosa) wrote :

In past days I was trying diferent Linux distributions, like Debian 6.0.4, Linux Mint 12 and OpenSuse, and I have been the same error with this printer. Tomorrow I will try to upgrade hplip in Ubuntu 10.10 to know if the problem is caused for new hplip versions or for something wrong in the new distibutions.

ursaminor (ursa-juvenis) wrote :

Try the following:

1. Go to Terminal > type "system-config-editor" and open.

2. Right-click on printer icon > go to Properties > Make and Model > Change....

3. Click "Select printer from database", HP (recommended) selected.

4. Choose hpijs 3.12.2 > select "Use the new PPd (...) as is". Finish installation.

5. Test print. Use Firefox or other program.

Ricardo Martínez (rm-baraosa) wrote :

Hi, Ursaminor
Thanks a lot. With your instructions I have solved printer problems.
In my case this status bug can be changed to solved.

ursaminor (ursa-juvenis) on 2012-06-25
summary: - HP Officejet Pro K550 fails to print in Ubuntu 12.04
+ HP Officejet Pro K550 fails to print in Ubuntu 12.04 - Resolved

At least the recommended driver should be changed from hpcups to hpijs if the bug in hpcups cannot be fixed. Otherwise, it seems every update resets the driver to hpcups.

Changed in hplip:
status: New → Confirmed
summary: - HP Officejet Pro K550 fails to print in Ubuntu 12.04 - Resolved
+ HP Officejet Pro K550 fails to print in Ubuntu 12.04
summary: - HP Officejet Pro K550 fails to print in Ubuntu 12.04
+ HP Officejet Pro K550 fails to print in Ubuntu
description: updated
Ralph Janke (txwikinger) on 2013-04-03
Changed in hplip (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Ivo Anjo (knuckles) wrote :

Ok so recently I got surprised by this issue. Unfortunately it is not fixed in 13.10 and I don't believe it will be in 14.04 either. The "changing driver" workaround did work for me.

The strange thing was, I installed the latest HP drivers on windows xp and I got the exact same behavior! And also none of HP's troubleshooting tools were able to help. Only by a lot of googling did I have the luck of stumbling onto this bug report.

So I'm guessing that since this printer is old it's not really tested anymore, and the technical documentation that is used by both the windows and hplip teams is wrong.

I have a normal K550 and a K550dtn and would like to see this fixed. I can setup a machine with remote access to both, and am willing to try debug builds of hplip, so if you're interested please say so.

Finally, this Bug #879667 seems to be a dupe of this one.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.14.3-0ubuntu4

hplip (3.14.3-0ubuntu4) utopic; urgency=low

  * debian/rules: Remove hpcups support for the HP Officejet Pro K550 as it is
    known to not work. This way hpijs (which works) will be used (LP: #981473,
    LP: #1311697).
 -- Till Kamppeter <email address hidden> Tue, 29 Apr 2014 12:06:00 +0200

Changed in hplip (Ubuntu):
status: Confirmed → Fix Released

Hello Ricardo, or anyone else affected,

Accepted hplip into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/hplip/3.14.3-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in hplip (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Robert Schilt (rschilt) wrote :

Sorry guys.... I was the one that originally logged this ticket but have since disposed of the K550 so am therefore not able to perform any testing on this fix.

Sebastien Bacher (seb128) wrote :

Could anybody else test the fix to validate the SRU? If not, could we at least confirm that there is no regression, which might be enough to get the SRU copied to -updates

Mathew Hodson (mathew-hodson) wrote :

This is a duplicate of #1311697. The correct fix has been verified in that bug.

Also according to comment 8 in that bug, the package hplip 3.14.3-0ubuntu3.1 linked here is broken and shouldn't be used. It has since been superseded in -proposed.

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers