hpcups in 3.11.7 and 3.11.10 doesn't respect top margin

Bug #890684 reported by Jiri Popelka on 2011-11-15
68
This bug affects 15 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Sanjay Kumar
hplip (Fedora)
Fix Released
Medium
hplip (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Hello,

Some Fedora users report [1] that hpcups driver from hplip-3.11.7 and hplip-3.11.10 doesn't respect top margins and that 3.11.5 is ok.
Affected printers: LaserJet P2055dn, LaserJet p4014dn, LaserJet P4015, LaserJet m1522nf MFP, LaserJet 1150, LaserJet 2035n, LaserJet 3030, LaserJet 4350dtn

Diff of hpcups in 3.11.5 and 3.11.7 has shown that only HPCupsFilter::isBlankRaster() function was changed.
I also found this note in changelog [2] to 3.11.7
- Condition to check the blankraster for k plane is added for top and bottom clipping issue with HP LaserJet Professional m1212nf MFP

Some users confirmed [1] that reverting (see attached patch) that change fixes the problem.
Can you please look at this problem ?
Thank you.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=738089
[2] http://hplipopensource.com/hplip-web/release_notes.html

Description of problem:
When I try to print any document, using any program, the top margins are not respected. For example, a document that is supposed to have the top margin start at about 68 pixels actually prints at about 17 pixels.

Version-Release number of selected component (if applicable):
hplip-3.11.7-2.fc14.x86_64
hplip-libs-3.11.7-2.fc14.x86_64
hplip-common-3.11.7-2.fc14.x86_64
hplip-gui-3.11.7-2.fc14.x86_64

How reproducible:
All attempted print jobs print incorrectly.

Steps to Reproduce:
1. Print a document.
2.
3.

Actual results:
A 68 pixel margin magically becomes a 17 pixel margin

Expected results:
I should be able to print any document that I choose and have the margins be where they were when I created the document.

Additional info: If I downgrade to the following, printing always works exactly as it should:
hplip-3.10.6-3.fc14.x86_64
hplip-libs-3.10.6-3.fc14.x86_64
hplip-common-3.10.6-3.fc14.x86_64
hplip-gui-3.10.6-3.fc14.x86_64

Also, the output of "diff -ur etc-cups-ppd-working /etc/cups/ppd/HP-LaserJet-P2055dn.ppd" reads as follows:

steve@localhost ~$ diff -ur etc-cups-ppd-working /etc/cups/ppd/HP-LaserJet-P2055dn.ppd
--- etc-cups-ppd-working 2011-09-12 15:07:19.935878232 -0500
+++ /etc/cups/ppd/HP-LaserJet-P2055dn.ppd 2011-09-13 15:47:44.889982117 -0500
@@ -1,6 +1,6 @@
 *PPD-Adobe: "4.3"
 *%%%% PPD file for HP LaserJet p2055dn with CUPS.
-*%%%% Created by the CUPS PPD Compiler CUPS v1.4.8.
+*%%%% Created by the CUPS PPD Compiler CUPS v1.4.4.
 *% (c) 2008 Copyright Hewlett-Packard Development Company, LP
 *FormatVersion: "4.3"
 *FileVersion: "hpcups 3.11.7"

So, margins always print as expected with hplip-3.10.6-3.fc14.x86_64 but always print incorrectly with hplip-3.11.7-2.fc14.x86_64

It would be interesting to find out how the various versions of hplip built between those two updates behave:

3.11.7-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=255361
3.11.5-4 * http://koji.fedoraproject.org/koji/buildinfo?buildID=250673
3.11.5-3 http://koji.fedoraproject.org/koji/buildinfo?buildID=247166
3.11.5-1 http://koji.fedoraproject.org/koji/buildinfo?buildID=243702
3.11.3a-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=236950
3.11.3-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=234520
3.11.1-3 * http://koji.fedoraproject.org/koji/buildinfo?buildID=231559
3.11.1-2 http://koji.fedoraproject.org/koji/buildinfo?buildID=216983
3.11.1-1 http://koji.fedoraproject.org/koji/buildinfo?buildID=215370
3.10.9-14 * http://koji.fedoraproject.org/koji/buildinfo?buildID=214486
3.10.9-13 http://koji.fedoraproject.org/koji/buildinfo?buildID=213831
3.10.9-11 http://koji.fedoraproject.org/koji/buildinfo?buildID=213796
3.10.9-9 http://koji.fedoraproject.org/koji/buildinfo?buildID=209472
3.10.9-8 http://koji.fedoraproject.org/koji/buildinfo?buildID=207573
3.10.9-6 http://koji.fedoraproject.org/koji/buildinfo?buildID=204755
3.10.9-5 http://koji.fedoraproject.org/koji/buildinfo?buildID=204591
3.10.9-4 http://koji.fedoraproject.org/koji/buildinfo?buildID=202467
3.10.9-3 http://koji.fedoraproject.org/koji/buildinfo?buildID=200939
3.10.9-2 http://koji.fedoraproject.org/koji/buildinfo?buildID=200460
3.10.9-1 http://koji.fedoraproject.org/koji/buildinfo?buildID=198781
3.10.6-7 * http://koji.fedoraproject.org/koji/buildinfo?buildID=198181
3.10.6-5 http://koji.fedoraproject.org/koji/buildinfo?buildID=196054

That's 22 builds, of 7 different versions. Could you please try each of the builds that I've marked with '*' above? I'm trying to narrow down which version broke this for you.

To try one of the builds, download the relevant packages for your architecture, and run 'yum downgrade FILES...' replacing FILES... with the full list of the filenames you've downloaded. ("Relevant packages" because you only need the ones you've already got installed... if you don't have libsane-hpaio installed, don't download that package for example.)

Let me know how you get on.

The following builds produce "404 Not Found" errors when I attempt to download the appropriate files:
3.10.6-7 * http://koji.fedoraproject.org/koji/buildinfo?buildID=198181
3.11.1-3 * http://koji.fedoraproject.org/koji/buildinfo?buildID=231559
3.11.3-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=234520
3.11.3a-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=236950

The other three builds I have already downloaded the RPMS. I will get started right away.

As requested:

> 3.11.7-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=255361
Results: Does not print the top margin correctly.

> 3.11.5-4 * http://koji.fedoraproject.org/koji/buildinfo?buildID=250673
Results: Prints top margin correctly.

> 3.11.3a-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=236950
> 3.11.3-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=234520
> 3.11.1-3 * http://koji.fedoraproject.org/koji/buildinfo?buildID=231559
Attempts to download these three builds resulted in "404 Not Found" errors.

> 3.10.9-14 * http://koji.fedoraproject.org/koji/buildinfo?buildID=214486
Results: Prints top margin correctly.

> 3.10.6-7 * http://koji.fedoraproject.org/koji/buildinfo?buildID=198181
Attempts to download this build resulted in "404 Not Found" error.

So, it looks like 3.11.7-1 and 3.11.7-2 (the current update) are the only ones that cause this problem.

If there are any more builds that you want me to try, let me know.

Just another data point:

Same problem in F15 - same printer HP-LaserJet-p2055dn

Sep 13 15:08:13 Updated: hplip-common-3.11.7-2.fc15.x86_64
Sep 13 15:08:13 Updated: hplip-libs-3.11.7-2.fc15.x86_64
Sep 13 15:08:17 Updated: 1:hpijs-3.11.7-2.fc15.x86_64
Sep 13 15:08:52 Updated: hplip-3.11.7-2.fc15.x86_64
Sep 13 15:08:52 Updated: libsane-hpaio-3.11.7-2.fc15.x86_64
Killed the top margin, text now being cut off

Downgraded the packages
Sep 16 08:04:53 Installed: hplip-common-3.11.3a-1.fc15.x86_64
Sep 16 08:04:54 Installed: hplip-libs-3.11.3a-1.fc15.x86_64
Sep 16 08:04:55 Installed: 1:hpijs-3.11.3a-1.fc15.x86_64
Sep 16 08:04:57 Installed: hplip-3.11.3a-1.fc15.x86_64
Sep 16 08:04:57 Installed: libsane-hpaio-3.11.3a-1.fc15.x86_64
Files print correctly

Redownloaded/updated to previous released update:
Sep 16 08:46:17 Updated: hplip-common-3.11.5-3.fc15.x86_64
Sep 16 08:46:17 Updated: hplip-libs-3.11.5-3.fc15.x86_64
Sep 16 08:46:20 Updated: 1:hpijs-3.11.5-3.fc15.x86_64
Sep 16 08:46:21 Updated: hplip-3.11.5-3.fc15.x86_64
Sep 16 08:46:22 Updated: libsane-hpaio-3.11.5-3.fc15.x86_64
Files print correctly

I had the same problem with a HP LaserJet 4350dtn on Fedora 15, downgrading to hplip-3.11.5-4.fc15 (and related rpms) fixes the problem.

Same problem here with a LaserJet m1522nf MFP via network, using hplip-3.11.7-2.fc15.x86_64.

I had the same problems with an HP LaserJet 1150 in a F15 i686 and a F14 i686.

For F15:
hplip-3.11.7-2.fc15.i686

For F14:
hplip-3.11.7-2.fc14.i686

If you try adding blank lines at the beginning of the document, they are wiped out too.

If I print from the F14 to a printer connected to an F13 box using hplip-3.11.5-1.fc13.i686 through the network, it prints well.

ditto with hp laserjet 2035n + hplip-3.11.7-2.fc14.i686

I'm experiencing this problem (or something similar) with an HP LaserJet P4015.

Same problem with a HP LaserJet 3030.

We see same problem with HP LaserJet p4014dn.
Changing driver from default hpcups to hpijs cures it.

(In reply to comment #11)
> We see same problem with HP LaserJet p4014dn.
> Changing driver from default hpcups to hpijs cures it.

It works for me too.
I changed to hpijs and my hp LaserJet 1150 respects the top margin again.
Thank you.

Still the same with hplip-3.11.10-1.fc15.x86_64 from koji.

After 3 weeks without any new developments, I decided to change my driver from hpcups to hpijs. The margin problem seems to be fixed.

I went for the foomatic driver, problem solved.

Just did a fresh install of Fedora 16. The bug that necessitated me filing this bug report has followed me (and I assume all the others that have commented on this bug) to Fedora 16. I will apply a workaround to get my printer working correctly, but hplip is still broken.

Please advise about any different versions of hplip I can try until this bug gets fixed. The build that worked for me on Fedora 14 has had the Fedora 16 RPM's deleted.

Last comment was a little premature. If I downgrade to 3.11.5-5, the top margin prints correctly again.

For anyone else that has this problem, but wants to use the hplip driver, the 3.11.5-5 build of hplip can be found here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=252270

So, at least I can use my printer until an update for hplip is released.

I have the same (or at least a very similar problem) with 3.11.10 and an Office Jet Pro 8000. 3.11.7-? worked fine for me with Fedora 14 and 3.11.7-5 for Fedora 16 also seems to be working.

So far we know that downgrade 3.11.7 -> 3.11.5 or change hpcups->hpijs fixes (except for comment #19) the problem. That means that the problem was introduced in hpcups driver between 3.11.5 and 3.11.7. Diff has shown that there was only one change in hpcups driver. So I've done a F16 scratch-build [1] with this change reverted and it would be great if some of you could test it to confirm/disprove that this change has been causing the problem.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3512348

(In reply to comment #22)
> So far we know that downgrade 3.11.7 -> 3.11.5 or change hpcups->hpijs fixes
> (except for comment #19) the problem. That means that the problem was
> introduced in hpcups driver between 3.11.5 and 3.11.7. Diff has shown that
> there was only one change in hpcups driver. So I've done a F16 scratch-build
> [1] with this change reverted and it would be great if some of you could test
> it to confirm/disprove that this change has been causing the problem.
>
> [1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3512348

This revert fixes the problem for me on a HP LaserJet 4350dtn with hpcups drivers!

(In reply to comment #22)
> So far we know that downgrade 3.11.7 -> 3.11.5 or change hpcups->hpijs fixes
> (except for comment #19) the problem. That means that the problem was
> introduced in hpcups driver between 3.11.5 and 3.11.7. Diff has shown that
> there was only one change in hpcups driver. So I've done a F16 scratch-build
> [1] with this change reverted and it would be great if some of you could test
> it to confirm/disprove that this change has been causing the problem.
>
> [1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3512348

That fixes the problem for me too.

Thanks!
Could you actually also try the hplip-3.11.10-7.fc16 from stable repository to make sure the problem is still there. The "yum downgrade 'hplip*' hpijs" should do the trick when you are already using my hplip-3.11.10-8.fc16 build.

(In reply to comment #25)
> Thanks!
> Could you actually also try the hplip-3.11.10-7.fc16 from stable repository to
> make sure the problem is still there. The "yum downgrade 'hplip*' hpijs" should
> do the trick when you are already using my hplip-3.11.10-8.fc16 build.

Yes, after downgrading to hplip-3.11.10-7.fc16 the problem with hpcups comes back.

(In reply to comment #22)
> So far we know that downgrade 3.11.7 -> 3.11.5 or change hpcups->hpijs fixes
> (except for comment #19) the problem. That means that the problem was
> introduced in hpcups driver between 3.11.5 and 3.11.7. Diff has shown that
> there was only one change in hpcups driver. So I've done a F16 scratch-build
> [1] with this change reverted and it would be great if some of you could test
> it to confirm/disprove that this change has been causing the problem.
>
> [1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3512348

This build fixes the problem for me :)

And I'll add my thumbs up as well.

goutam kodu (goutam-hplip) wrote :

Hi Jiri,

Thanks for reporting this bug here. Will look into it and get back to you on the same.
Can you please let us know in which version of Fedora you are able to see this bug. Post us the "hp-check -t" output

Also i would request you to provide some debug information.

Please follow the below steps to provide the same

1.Open the file /etc/cups/cupsd.conf in write permissions.
$su -c "vim /etc/cups/cupsd.conf"
 Change LogLevel warn to LogLevel debug and below that line add hpLogLevel 15.

2. Restart the cups
$su -c "/etc/init.d/cups restart"

3. Empty the cups error_log file and syslog file

su -c "cat /dev/null > /var/log/messages"
su -c "cat /dev/null > /var/log/cups/error_log"

4. Print a test page.

5.Attach us the /var/log/messages and /var/log/cups/error_log file.

6. In /tmp folder you will find files with name starting with hpcups like, hpcupsfilterc_1.bmp, hpcupsfilterk_1. bmp, hpcups_jobX.out.

Can you please attach those files too.

Let me know if you have any trouble in getting the logs.

Thanks & Regards,
Goutam Kodu

All: If you are interested in helping HP narrow down the issue you can provide some requested information in the upstream bug https://bugs.launchpad.net/ubuntu/+bug/890684

Steven P. Ulrick (meow8282) wrote :

> 1.Open the file /etc/cups/cupsd.conf in write permissions.
> $su -c "vim /etc/cups/cupsd.conf"
> Change LogLevel warn to LogLevel debug and below that line add hpLogLevel 15.

Done.

> 2. Restart the cups
> $su -c "/etc/init.d/cups restart"

Done.

> 3. Empty the cups error_log file and syslog file
>
> su -c "cat /dev/null > /var/log/messages"
> su -c "cat /dev/null > /var/log/cups/error_log"

Done.

> 4. Print a test page.

Done.

> 5.Attach us the /var/log/messages and /var/log/cups/error_log file.

Done.

> 6. In /tmp folder you will find files with name starting with hpcups like, hpcupsfilterc_1.bmp, hpcupsfilterk_1. bmp,
> hpcups_jobX.out.
>
> Can you please attach those files too.

Done.

Steven P. Ulrick (meow8282) wrote :
Steven P. Ulrick (meow8282) wrote :
Steven P. Ulrick (meow8282) wrote :
Steven P. Ulrick (meow8282) wrote :
Steven P. Ulrick (meow8282) wrote :
Steven P. Ulrick (meow8282) wrote :

When I attempted to print the default CUPS test page, it printed the front side correctly (which was very unexpected) but it printed the back side with no top margin (I have duplex printing installed. So, I used a different file as a test page, and both front and back printed with absolutely no top margin.

goutam kodu (goutam-hplip) wrote :

Hi,

Thanks for the logs. The bmp images looks clear. Can you post us the original file so that we can have a reproduce of the same here.

What result do you get when you print a hplip test page ? Run command "hp-testpage" and attach us the bmp images generated for this in /tmp folder.

Also please post us the "hp-check -t" command output.

Thanks,
Goutam Kodu

(In reply to comment #31)
> hplip-3.11.10 builds with the work-around applied:
> [F14] http://koji.fedoraproject.org/koji/buildinfo?buildID=274394
> [F15] http://koji.fedoraproject.org/koji/buildinfo?buildID=274391
> [F16] http://koji.fedoraproject.org/koji/buildinfo?buildID=270875
> [F17] http://koji.fedoraproject.org/koji/buildinfo?buildID=274387

I can confirm that also this build for F16 works correctly for me.

Changed in hplip:
status: New → In Progress
assignee: nobody → goutamkk (goutam-hplip)
Dan Ciarniello (b6-danny) wrote :
Dan Ciarniello (b6-danny) wrote :
Dan Ciarniello (b6-danny) wrote :
Dan Ciarniello (b6-danny) wrote :
Dan Ciarniello (b6-danny) wrote :
Dan Ciarniello (b6-danny) wrote :
Dan Ciarniello (b6-danny) wrote :
Dan Ciarniello (b6-danny) wrote :
Dan Ciarniello (b6-danny) wrote :

I was not able to get hp-testpage to print (it complained about not being able to find a printer and it would not accept the URI that hp-probe determined) so I was not able to provide any related files.

It is possible that this problem is related to duplex printing. When I print the cups test page with duplex printing turned off, the test page prints fine. When I turn duplex printing on, the test page is printed on both sides of the page with one side having the top margin cut off and the other having the bottom margin cut off.

goutam kodu (goutam-hplip) wrote :

Hi Dan,

Can you check the same using the Postscript PPD file for this printer. To do the same follow the below steps.

1. Delete the existing print queue for this printer in "system-config-printer"
2. Run hp-setup command from terminal and by default it will choose the hpcups PPD . You need to browse to the path and choose this PPD file /usr/share/ppd/HP/hp-laserjet_p2055dn-ps.ppd.gz while configuring the device.
3. After configuring your printer perform the duplex job.

Let us know if this works.

Thanks,
Goutam Kodu

The attached patch works when applied to the HPLIP package in Ubuntu Oneiric. I will issue a Stable Release Update for Oneiric with this patch and apply it to the Precise package for the time being until a better fix gets issued by upstream.

Changed in hplip (Ubuntu):
status: New → Triaged
importance: Undecided → High
tags: added: patch patch-forwarded-upstream
Changed in hplip (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
milestone: none → oneiric-updates
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.11.10-1ubuntu1

---------------
hplip (3.11.10-1ubuntu1) precise; urgency=low

  * debian/patches/hpcups-top-margins-not-respected.dpatch: Reverted upstream
    change which caused a regression in handling the upper margin by monochrome
    laser printers in hpcups (LP: #890684, Red Hat bug #738089).
 -- Till Kamppeter <email address hidden> Thu, 1 Dec 2011 12:26:00 +0100

Changed in hplip (Ubuntu):
status: Triaged → Fix Released

I have uploaded a fixed HPLIP package to oneiric-proposed now. As soon as the upload gets approved it will be available for testing. We post another comment here then with instructions. Please test and tell us your results then.

A debdiff of the changes is attached.

Changed in hplip (Ubuntu Oneiric):
status: Triaged → Fix Committed
Antanas (br-justinas) on 2011-12-02
Changed in hplip (Ubuntu Oneiric):
status: Fix Committed → Fix Released

Antanas, please do not change the bug status without giving any reason to do so. The Oneiric task is for the SRU and an SRU is going through a defined testing procedure. There will be posted a comment when the testing period is started and then everyone suffering the problem is invited to test the fixed package. After one week the testing period ends and if we get reports that the package solves the problem and no reports that it introduces regressions, we move the package into the official updates. Then and only then the Oneiric task is considered fixed.

Changed in hplip (Ubuntu Oneiric):
status: Fix Released → Fix Committed

Hello Jiri, or anyone else affected,

Accepted hplip into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Matthias, Antanas, Davide, and everyone elese affected, can you test the proposed package as described in the previous comment and report back here? Thanks.

Matthias Rosenkranz (rose) wrote :

Sorry, I don't have access to the affected printer anymore so I cannot test it at the moment.

DottorBartolo (dottorbartolo) wrote :

Yep, I'm looking into the repository now...
What is the name of the proposed package? cups-ppdc perhaps?
Thanks,
Davide

DottorBartolo, the best way to check it is to add the oneiric-proposed repository to your software sources as described on https://wiki.ubuntu.com/Testing/EnableProposed and then do a full system update. If you want to avoid a full system update due to a slow connection or to not install other proposed packages, the actual fix is in the hplip-cups binary package, but probably you will have to replace also hplip, hplip-data, hplip-doc, and libhpmud0 due to dependencies. (will be done automatically if you update hplip-cups with the software center or with the command "sudo apt-get install hplip-cups").

Antanas (br-justinas) wrote :

Dear Till,
Yes, it works ! (LaserJet 1150)
Thank you !

Antanas, thanks for testing. So I will mark this bug as verified.

tags: added: verification-done
removed: verification-needed
DottorBartolo (dottorbartolo) wrote :

It works!
Thanks Till (and all the team)!
D

DottorBartolo, thank you very much for testing.

Alex Kulesza (kulesza) wrote :

I had the same problem with an HP LaserJet P4015n; any whitespace at the top of the page was removed, and the page content shifted up. The fix in oneiric-proposed worked for me. Thanks!

Davide (dspinell) wrote :

The fix in oneiric-proposed worked in my system.

Thanks

hplip-3.11.10-11.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/hplip-3.11.10-11.fc16

Package hplip-3.11.10-11.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.11.10-11.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16911/hplip-3.11.10-11.fc16
then log in and leave karma (feedback).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.11.7-1ubuntu3.1

---------------
hplip (3.11.7-1ubuntu3.1) oneiric-proposed; urgency=low

  * debian/patches/hpcups-top-margins-not-respected.dpatch: Reverted upstream
    change which caused a regression in handling the upper margin by monochrome
    laser printers in hpcups (LP: #890684, Red Hat bug #738089).
 -- Till Kamppeter <email address hidden> Thu, 1 Dec 2011 12:26:00 +0100

Changed in hplip (Ubuntu Oneiric):
status: Fix Committed → Fix Released

hplip-3.11.12-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/hplip-3.11.12-1.fc15

Package hplip-3.11.12-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.11.12-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16911/hplip-3.11.12-1.fc16
then log in and leave karma (feedback).

All: There's hplip-3.11.12 in updates-testing which includes upstream fix for this problem.

hplip-3.11.12-1.fc16 has been pushed to the Fedora 16 stable repository. If problems still persist, please make note of it in this bug report.

hplip-3.11.12-1.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

It seems like this didn't help with my Samsung CLP-310N. I'm using the Samsung Unified Printer Driver, since the foo2qpdl driver gives unusable results as printouts.
The cutoff of the top margin affects monochrome as well as colour prints.

I'm running Ubuntu 11.10 and the installed hplip package version is 3.11.7-1ubuntu3.1...

Please let me know if I can provide any additional information that helps solving this issue. If I just missed the right patch, please give me a little hint :)

Sanjay Kumar (sanjay-kumar14) wrote :

Fix is now available for this issue in HPLIP-3.12.2 and HPLIP-3.12.4.

Changed in hplip:
status: In Progress → Fix Released
assignee: goutam kodu (goutam-hplip) → Sanjay Kumar (sanjay-kumar14)
Changed in hplip (Fedora):
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.