HPLIP is not compatible with modern GNOME (No system tray detected on this system. Unable to start, exiting.)

Bug #1714659 reported by Norbert on 2017-09-02
146
This bug affects 28 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install Ubuntu 17.10
2. Install hplip-gui
3. Launch GNOME session.
4. Get error message window with header "HPLIP Status Service"
and text
"No system tray detected on this system.
Unable to start, exiting."

Expected results:
hp-systray is compatible with modern GNOME

Actual results:
hp-systray is not compatible with modern GNOME

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: hplip-gui 3.17.7+repack0-3
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic i686
ApportVersion: 2.20.7-0ubuntu1
Architecture: i386
CupsErrorLog: W [01/Sep/2017:17:24:48 +0300] Notifier for subscription 112 (dbus://) went away, retrying!
CurrentDesktop: GNOME
Date: Sat Sep 2 14:10:19 2017
InstallationDate: Installed on 2017-08-26 (6 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha i386 (20170826)
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: ASUSTeK COMPUTER INC. UX32A
PackageArchitecture: all
Papersize: a4
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.12.0-11-generic root=UUID=c2d4f47c-f1c6-4731-b8d0-dc268c6bf996 ro quiet splash vt.handoff=7
SourcePackage: hplip
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/12/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX32A.216
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX32A
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX32A.216:bd02/12/2014:svnASUSTeKCOMPUTERINC.:pnUX32A:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32A:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: UX
dmi.product.name: UX32A
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Norbert (nrbrtx) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hplip (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2017-09-02
tags: added: xenial
Norbert (nrbrtx) wrote :

Ubuntu 17.10 with all updates. Bug is fixed.

Changed in hplip:
status: New → Invalid
Changed in hplip (Ubuntu):
status: Confirmed → Invalid
description: updated
Norbert (nrbrtx) on 2017-10-21
tags: removed: artful
Kyle Raglin (ktraglin) wrote :

Ubuntu 17.10 with all updates, however, this problem persists for me. I would not describe it as "fixed".

RickB (rick-777) wrote :

Sorry but this bug was not fully fixed back in September. It's still affecting me in December.

Till Kamppeter (till-kamppeter) wrote :

To the HPLIP developers at HP: Can you provide a patch which we can apply to the HPLIP 3.17.7 which comes with Ubuntu 17.10, especially if you have fixed this already in a later version (like 3.17.11)? Thanks.

Xavier Guillot (valeryan-24) wrote :

I also have this bug with HPLIP 3.17.11 on Ubuntu 18.04 - I know this is an alpha, but just to inform.

Version 3.17.11 resolved problem of scanner non identified, but I get the "no system tray detected" at startup...

Norbert (nrbrtx) on 2018-01-29
tags: added: artful bionic
Changed in hplip (Ubuntu):
status: Invalid → Confirmed
Changed in hplip:
status: Invalid → Confirmed
Ra (raffamaiden) wrote :

I also have this problem.
Every time at startup the "No system tray detected" erro message shows up.
I use Ubuntu 17.10 and HPLIP 3.17.11 (last version at the time of writing).

Ping-Wu (wliauh) wrote :

Experiencing the same problem with bionic. Reproducible.

qwelegen (kipingor) wrote :

Same Issue, and I just run an update, I still get
No system tray detected on this system.
Unable to start, exiting.
on Startup

Russell Keating (rqkeating) wrote :

Just purchased and installed an HP printer with software from HP web page, device. I have this same bug. Ubuntu 18.04, HPLIP 3.18.4, device manager 15.0 (Qt4)

Same issue in Ubuntu 18.04 LTS, HPLIP 3.18.4.
Every time at startup a popup error display the message "No system tray detected".
Please solve the problem.
Thanks.

Same issue here with official 18.04 LTS release. I have installed HPLIP 3.18.4, but I get the error message, No System Tray Detected on this system: Unable to start, exiting. What's worse is that the HP Officejet printer will not print anything. It just keeps sending all print jobs to "pause".

jean-marc mainguet (jmeme) wrote :

Just purchased and installed an HP printer with software from HP web page, device. I have this same bug. Ubuntu 18.04, HPLIP 3.18.4, device manager 15.0 (Qt4)
tanks

Albert Boucher (alby-074) wrote :

Same issue with HPLIP 3.18.4 on 18.04 LTS fresh install. No system tray detected unable to start, but I can print with no problems but no access to scanner functions or faxing.

Same issue with HPLIP 3.18.5 on 18.04 LTS, only show on startup. But when I open printer (HP Laserjet p1006), it can print normally.

I try this method from 'Edson Jose dos Santos' from this link.

https://bugs.launchpad.net/hplip/+bug/1770027

'To display the icon on the tray, I installed this extension "Alternate Menu for Hplip" and it worked ok, but the error message (No system tray detected on this system, unable to start, exiting) continued to appear.

Then I removed the startup "hp-systray -x" and the error continued.

What happened after restarting the PC?

At startup, the HP icon came in alone and appeared at the startup of the "SETUP" tool and the message disappeared. OK . See attachment.

Now the error message (No system tray detected on this system. Unable to start, exiting) only appears when we click on the HP icon and open the printer.'

It can help me and now no annoying message at startup.

Dimitri Clicque (shinobix9x) wrote :

same issue Ubuntu 18.04 hplip-3.18.6 at evey boot i get this error when i log in to my account.
Woulud be nice to have this solved.

edelans (edelans) wrote :

I had this error on every boot on a fresh and up to date ubuntu 18.04 Bionic Beaver after installing the latest drivers for my HP printer.

I just deleted the file

/etc/xdg/autostart/hplip-systray.desktop

to get rid of the problem. But it would be nice to have it fixed =)

Nagy Gergő (daf182) wrote :

I have the very same error, on 18.04 and HPLIP-3.17.10.
Is there any workaround within /etc/xdg/autostart/hplip-systray.desktop to turn this off? - instead of removing the file. completely.

Lefol Laurent (lololapile) wrote :

I have the very same error, on 18.04.1 and HPLIP-3.18.6

This issue creates problems with every Ubuntu update specifically with python.
I would appreciate a solution.

lololapile

Mark Preston (emarkpreston) wrote :

I think that is error is now causing very high CPU usage. Typically my CPU load averages are under 1. They usually range like thus: .5 to .8 for all time frames (1 min, 5 min, 15 min). Currently my avgs. are 3.00 to 4.00. These high loads started after HPLIP's "No systray" on daily power up.

Mark Preston (emarkpreston) wrote :

In the above post, I was in error about hplip causing the high CPU usage. I have changed my Desktop management from Gnome to Unity. The hp systray icon is back on the panel. I apologize for the CPU usage mistake.

Eduardo Reyes (eddie55) wrote :

Ubuntu 18.04.2 fresh install on System 76 Laptop
Downloaded the latest Version of HPLIP 3.19.3
from https://developers.hp.com/hp-linux-imaging-and-printing/gethplip

I am getting this bug

I wonder if i use the hplip that comes with ubunut or is in the repo is i would still get this bug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers