Unable to install plugin for network printer Laserjet 2600n

Bug #1195221 reported by manolo on 2013-06-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

Hi to all.

It is ages since I got the same problem when trying to install the network printer HP Color Laser Jet 2600n.
I've been changing several distributions (Ubuntu, Kubuntu, Mint) and per each I've been changing several versions together with hundred kerlen updates: the same problem persist and this is the kind of error message I always get:

The printer you are trying to setup requires a binary driver plug-in and it failed to install.
Please check your internet connection and try again.
Visit http://hplipopensource.com for more infomation

What I do is the following:
1) open HPLIP tray icon
2) click on the "+" icon to "setup a new device"
3) select the "Network/Ethernet/Wireless network (direct connection or JetDirect)" option
4) the only network printer detected is already selected and corresponds to my network printer. So I just click on "Next": I'm asked for the administrator password and then the "Driver Plug-in Installation" windows asks me to chose the installation method
5) I choose the following option: "Download and install the plug-in from an HP authorized server (recommended)" and then click on the "Next" button.
6) after few seconds, the error message appears: "Plug-in install failed." then I get the above error message reported at the beginning of this bug report, talking about some binary driver (see the above error message)

As a consequence, the printer is not always manageble by the hplip tool.
Of course, the printer works perfectly if the drivers are installed by my Linux distros.

How to solve this problem affecting thousands users as reported into several forums and bug reports?
Thanks.
Regards.

Hi Manolo,

Please provide following information to analyse further.

1) Is /tmp directory mounted to tmpfs? run following command.

$ df -h

2) Provide us output of hp-plugin command
$ su -c 'hp-plugin -g'

or

$ sudo hp-plugin -g

3) provide us hp-check command output

$ hp-check

Thanks & Regards,
Amarnath

manolo (mac-man2005) wrote :

Hi Amarnath,
thanks for your reply.

Please note the following:

df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 46G 5,8G 38G 14% /
udev 1,5G 4,0K 1,5G 1% /dev
tmpfs 1,5G 318M 1,2G 22% /tmp
tmpfs 589M 1,1M 588M 1% /run
none 5,0M 0 5,0M 0% /run/lock
none 1,5G 704K 1,5G 1% /run/shm
none 100M 16K 100M 1% /run/user
/dev/sda3 409G 148G 241G 39% /home

Please see the result of "hp-plugin -g" command in attachment. The result for hp-setup command is included inside the next post.
Thanks.

manolo (mac-man2005) wrote :
manolo (mac-man2005) wrote :

Sorry, when I wrote "hp-setup" in my previous post I actually ment "hp-check".
As for hp-check I attached both the automatically generated .log (please see the above message including the hp-check.log file) and the output shown on screen as well (included in the hp-check.txt file)

Hi Manolo,

Failing to install as /tmp mounted to tmpfs (RAM), OS won't allow to run commands from this directory.
Please refer this http://ubuntuforums.org/showthread.php?t=1901876

Please try following
1) download hplip-3.13.6-plugin.run,hplip-3.13.6-plugin.run.asc files to other directory (~/Downloads or ~/Desktop) from http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/ URL.

2) run hp-lugin
$ su -c 'hp-plugin -g'
--> select 2nd option( local copy advanced option) and browse hplip-3.13.6-plugin.run file.

Thanks & Regards,
Amarnath

manolo (mac-man2005) wrote :

Dear Amarnath,
thank you again for your time. Unfortunately, it did not work. I run your instructions in step 1) and step 2) but the result is the same. I did not try to solve the /tmp problem since I'm afraid I may risk to damage other applications expecting the /tmp folder to be mounted just in the default way. So I run those two steps directly, but no luck.
Please see the attached screenshot.

Any other suggestion, please?
Thanks.

Hi Manolo,

Can you try following as above comment #5 is still trying to extract in /tmp directory.

--> go to the downloaded directory and run this command.
$ su -c "sh hplip-3.13.6-plugin.run --keep"

--> Once plugin installs, you can remove temporary file (optional).
$ su -c "rm -r ./plugin_tmp"

Thanks & Regards,
Amarnath

Changed in hplip:
status: New → In Progress
manolo (mac-man2005) wrote :

Dear Amarnath,
thanks for your reply and sorry for the delay.

Actually I'm not sure I understood your comment #7.
So, I tried to understand what you meant and I executed the following:
1) downloaded the .run and the .asc again, in the "Desktop" folder (actually is the "Scrivania" folder since I'm using Linux Mint in Italian language)

2) run the first command of your comment #7, but I got the following errors on terminal and then the window closed unexpectedly after accepting the licence and clicking on "Next" button:

su -c "sh hplip-3.13.6-plugin.run --keep"
Password:
Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.13.6 Plugin Self Extracting Archive.............................

HP Linux Imaging and Printing System (ver. 3.13.6)
Plugin Installer ver. 3.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.13.6
Installed HPLIP version: 3.13.6
Number of files to install: 24

(process:10325): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(process:10325): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(process:10325): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
QGtkStyle was unable to detect the current GTK+ theme.
Qt: Session management error: None of the authentication protocols specified are supported

Done.

3) Of course, I did not run the second command on your comment #7. Then I run hp-plugin again, but still errors (do you need me to post the related errors?)

What should I do now?
Thank you again so much.
Regards.

Hi Manolo,

-->Reason for below steps:-
---------> hplip-3.13.6-plugin.run tries to extract by default in /tmp directory and /tmp doesn't have execution permission.
---------> if "--keep" option is passed, Creates temporary plugin_tmp folder current directory
--> so run needs to pass --keep.

1) download hplip-3.13.6-plugin.run file to other directory (~/Downloads or ~/Desktop) from http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/ URL.

$ su
$ sh hplip-3.13.6-plugin.run --keep

--> As gui error is coming in above post, run in interactive mode
$ cd plugin_tmp
$ python ./plugin_install.py -i
$ cd ..

--> Once plugin installs, you can remove temporary file (optional).
$ rm -r ./plugin_tmp"

Thanks & Regards,
Amarnath

manolo (mac-man2005) wrote :

Unfortunately, I'm still experiencing (the same?) problems also when executing your new instructions.
Actually, since at the time of executing "sh hplip-3.13.6-plugin.run --keep" when writing "sh hplip[TAB]" it did not completed the file name with the rest of the .run file, I thought there where execution permiss missing. So, before executing the .run I "did chmod 777 hplip-3.13.6-plugin.run" which changed the permission to the file but still it did not completed the file name when pressing TAB key. Maybe that helps.

Well, getting back to your istructions, I followed them and again I'm unable to complete the procedure:
sh hplip-3.13.6-plugin.run --keep
Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.13.6 Plugin Self Extracting Archive.............................

HP Linux Imaging and Printing System (ver. 3.13.6)
Plugin Installer ver. 3.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.13.6
Installed HPLIP version: 3.13.6
Number of files to install: 24

(process:10897): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(process:10897): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(process:10897): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
QGtkStyle was unable to detect the current GTK+ theme.
Qt: Session management error: None of the authentication protocols specified are supported

Done.

What should I do?
Thanks.
Regards.

Hi Manolo,

Ignore this GTK error and run following commands in root mode.

$ cd plugin_tmp
$ python ./plugin_install.py -i

Thanks & Regards,
Amarnath

manolo (mac-man2005) wrote :
Download full text (6.0 KiB)

I executed your instructions, but again I don't think it did the job.

In fact, what I just get is almost similar to before. The only difference is that now there's no GUI, just something on terminal.
In detail, again as you can see, there's nothing more after accepting the licence. What else should I do?

Thanks,
regards.

# su
# cd plugin_tmp/
# python ./plugin_install.py -i

HP Linux Imaging and Printing System (ver. 3.13.6)
Plugin Installer ver. 3.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.13.6
Installed HPLIP version: 3.13.6
Number of files to install: 0

You must agree to the license terms before installing the plug-in:

LICENSE TERMS FOR HP Linux Imaging and Printing (HPLIP) Driver Plug-in

These License Terms govern your Use of the HPLIP Driver Plug-in Software (the
"Software"). USE OF THE SOFTWARE INCLUDING, WITHOUT LIMITATION, ANY
DOCUMENTATION, IS SUBJECT TO THESE LICENSE TERMS AND THE APPLICABLE AS-IS
WARRANTY STATEMENT. BY DOWNLOADING AND INSTALLING THE SOFTWARE, YOU ARE AGREEING
TO BE BOUND BY THESE TERMS. IF YOU DO NOT AGREE TO ALL OF THESE TERMS, DO NOT
DOWNLOAD AND INSTALL THE SOFTWARE ON YOUR SYSTEM.

1. License Grant. HP grants you a license to Use one copy of the Software with
HP printing products only. "Use" includes using, storing, loading, installing,
executing, and displaying the Software. You may not modify the Software or
disable any licensing or control features of the Software.

2. Ownership. The Software is owned and copyrighted by HP or its third party
suppliers. Your license confers no title to, or ownership in, the Software and
is not a sale of any rights in the Software. HP's third party suppliers may
protect their rights in the Software in the event of any violation of these
license terms.

3. Copies and Adaptations. You may only make copies or adaptations of the
Software for archival purposes or when copying or adaptation is an essential
step in the authorized Use of the Software. You must reproduce all copyright
notices in the original Software on all copies or adaptations. You may not copy
the Software onto any public network.

4. No Disassembly. You may not Disassemble the Software unless HP's prior
written consent is obtained. "Disassemble" includes disassembling, decompiling,
decrypting, and reverse engineering. In some jurisdictions, HP's consent may not
be required for limited Disassembly. Upon request, you will provide HP with
reasonably detailed information regarding any Disassembly.

5. No Transfer. You may not assign, sublicense or otherwise transfer all or any
part of these License Terms or the Software.

6. Termination. HP may terminate your license, upon notice, for failur...

Read more...

Hi Manolo,

From above log, plugin is installed successfully.

Let me know what issue you are facing..

Thanks & Regards,
Amarnath

manolo (mac-man2005) wrote :

Dear Amarnath,
thank you so much for your support. Well, actually the problem was that I expected a more tiem consuming procedure or at least something more explicit like "congratulation, you successfully installed the plug-in!". So, I thought nothing changed.

Then, after your reply, I added the printer through hplip tool and it actually did not ask me to install the plugin: just asked me to confirm whether the location for the ppd file was right.

So, I could say that the main problem has been solved. Thank you very much.
I just hope now the problem could be definitively solved letting users install the plugin easily without doing all that mess.
Thank you again.
Regards.

Hi Manolo,

Fixed this /tmp mounted to tmpfs issue and it will be released in next HPLIP release!!

Thanks & Regards,
Amarnath

Changed in hplip:
status: In Progress → Fix Committed
Changed in hplip:
status: Fix Committed → Fix Released
manolo (mac-man2005) wrote :

The "Upgrade" button is a nice idea.
However, it does not work.

It asks me to close the hptool program manually and then it stops the upgrading process.
It all happens while no hp program was running, except the Hp Device Manager that I run just to perform the upgrade.
In other words, the application though which I call the upgrade function opens a terminal through which I'm asked to close the upgrade-calling application.
I think this issue should be fixed.

As a workaround, I tried to force closing the HP Device manager after it opening the terminal. As a good news, the upgrading process goes on with some steps but then it stops due to the following error after downloading the plugin:

/tmp//hplip-3.13.7.run: 1: eval: ./hplip-install: Permission denied
Upgrade Failed or Skipped.

Please close this terminal manually.

What sohuld I do now?
Thanks.
Regards.

Hi Manolo,

Please try following command.

$ hp-upgrade -g -d ~/Downloads

Thanks & Regards,
Amarnath

manolo (mac-man2005) wrote :
Download full text (95.9 KiB)

Hi Amarnath,
thanks again so much for your support.

 hp-upgrade -g -d ~/Downloads

HP Linux Imaging and Printing System (ver. 3.13.6)
HPLIP upgrade latest version ver. 1.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

hp-upgrade[5392]: debug: Locking: /home/superman/.hplip/hp-upgrade-upgrade.lock
hp-upgrade[5392]: debug: Upgrade log saved in: /var/log/hp/hp-upgrade.log
hp-upgrade[5392]: debug:
hp-upgrade[5392]: debug: ['unknown', 'mepis', 'debian', 'suse', 'mandriva', 'fedora', 'redhat', 'rhel', 'slackware', 'gentoo', 'redflag', 'ubuntu', 'xandros', 'freebsd', 'linspire', 'ark', 'pclinuxos', 'centos', 'igos', 'linuxmint', 'linpus', 'gos', 'boss', 'lfs']
hp-upgrade[5392]: debug: /usr/bin/wget --cache=off --tries=3 --timeout=60 --output-document=- http://www.hp.com
hp-upgrade[5392]: debug: --2013-07-26 21:06:57-- http://www.hp.com/
Resolving www.hp.com (www.hp.com)... 15.217.49.141, 15.192.45.28
Connecting to www.hp.com (www.hp.com)|15.217.49.141|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `STDOUT'

    [<=> ] 0 --.-K/s <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html dir="ltr" lang="en-us">
<head>
<meta content="IE=edge" http-equiv="X-UA-Compatible" />
<title xmlns="http://www.w3.org/1999/xhtml">HP - United States | Laptop Computers, Desktops , Printers, Servers and more</title>
<!-- BEGIN METADATA -->
<meta content="text/html; charset=utf-8" http-equiv="Content-Type" />
<meta content="text/javascript" http-equiv="content-script-type" />
<meta content="text/css" http-equiv="content-style-type" />
<meta content="hpweb.1.4" name="hp_design_version" />
<meta content="us" name="target_country" />
<meta content="R163" name="web_section_id" />
<meta content="company_info" name="page_content" />
<meta content="Segment Neutral" name="segment" />
<meta content="any" name="user_type" />
<meta content="follow, index" name="robots" />
<meta content="no" name="allow-search" />
<meta content="Research or buy HP printers, desktops, laptops, servers, storage, enterprise solutions and more at the Official Hewlett-Packard Website" name="description" />
<meta content="Official Hewlett-Packard Website, printers, desktops, laptops, servers, storage, enterprise solutions" name="keywords" />
<meta content="79A25BB4603B17F3E8A0A53F6289AF1B" name="msvalidate.01" />
<meta content="9d94bba7e488b72b" name="y_key" />
<meta content="HiFJ064ICG5RpKCPcftjRtJRmALa-icmkpt3W1ueL8Y" name="google-site-verification" />
<meta content="gateway" name="lifecycle" />
<meta content="CORP" name="bu" />
<meta content="welcome-home" name="analytics_template_name" />
<meta content="gw" name="analytics_section" />
<!-- END METADATA --><!-- BEGIN HEAD HTML RESOURCES -->
<link href="http://welcome.hp-ww.com/country/us/en/cs/images/i/favicon.ico" rel="shortcut icon" />
<link href="http://www.www8-hp.com/us/en/...

manolo (mac-man2005) wrote :

Any update, please?
Thanks so much.
B/R

Hi Manolo,

you can install the latest HPLIP as mentioned in http://hplipopensource.com/hplip-web/install/install/index.html site.

I am not able to reproduce with following settings so would like to know the your system environment to reproduce this.
   1) Mounted /tmp directory to tmpfs and gave noexec permission (using /etc/fstab)
   2) ran 'hp-upgrade -g -d ~/Downloads' command.
   --> Successfully upgraded to latest HPLIP.

Thanks & Regards,
Amarnath

manolo (mac-man2005) wrote :
Download full text (9.7 KiB)

Hi Amarnath,
I'm not sure I perfectly understood your last comment. However, after reading it I've been doing downloading and installing the latest HPLIP just following the instructions on screen (same instructiosn as reported in your link of the above comment).
Also, I've been asked whether to install the plug-in and the installation seemed to be successful.

However, I found an error at the end of the installation process so I'm not sure whether the installation crashed or did not complete properly anyway. See at the bottom of this comment all the lines that I copied/pasted from the screen.

Last but not the least, I have one question: should I reconfigure my printers/scanners each time I install the HPLIP/plugin updates?
Thank you so much.
Regards.

sh hplip-3.13.7.run
Creating directory hplip-3.13.7
Verifying archive integrity... All good.
Uncompressing HPLIP 3.13.7 Self Extracting Archive.........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers