Gwibber is not completely translatable

Bug #520462 reported by Jochen Skulj on 2010-02-11
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
Ubuntu Translations
High
Unassigned
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

Although you can translate gwibber via Launchpad (https://translations.launchpad.net/gwibber/trunk/+pots/gwibber/de/+translate), it seems to me that not all strings in Gwibber are translatable yet. For example, I haven't found out how to translate the Edit menu or the Preferences dialog.

Please make all strings that are visible to users translatable so that you can provide a completely localized UI. Thanks!

Related branches

Ryan Paul (segphault) on 2010-02-13
Changed in gwibber:
milestone: none → 2.30.0
Milo Casagrande (milo) wrote :

There's also one file missing from the POTFILES.in in the po/ directory (at least looking at the trunk code). The missing file is "util.py".

David Planella (dpm) wrote :

I've created a branch fixing some of the issues, but I still haven't figured out why none of the strings from the /ui/*.ui files are extracted.

David Planella (dpm) wrote :

Ok, the branch in its current status should now fix the bug. Submitted merge proposal.

Milo Casagrande (milo) wrote :

@David: one note on the "actions.py" file. I was looking at it yesterday night, and the last string of actions.py, the one of the Tomboy sync, is not really a good translatable string.
Is it possible for you to modify the code of your branch, to make that string like this:
  _("%(protocol_name)s message from %(sender)s at %(time)s\n\n%(message)s\n\nSource: %(url)s") % \
       {"protocol_name": client.model.services[msg["protocol"]]["name"], \
        "sender": msg["sender"]["name"], \
        "time": msg["time"], \
        "message": msg["text"], \
        "url": msg["url"]
       }

Other notes I was pondering yesterday:
_Search for a query (from the actions.py file)
Personally, I don't think it is that clear as a message. I can't find it while running the program so I don't exactly what it does, but I find it strange.

View reply t_hread
What about a simpler "View discussion"?

And this one:
print _("Searching for group"), query
There is no space between "group" and the query string that will be added, is it OK to be like that?

Milo Casagrande (milo) wrote :

Forget the "Searching for group" thing, Python automatically adds a white space with the print function.

Milo Casagrande (milo) wrote :

Hmmm... pressed Enter to fast. It automatically adds a white space, but the string could be made a little bit better:
print "Searching for group %(query)" % {"query": query}

El dg 28 de 02 de 2010 a les 09:51 +0000, en/na Milo Casagrande va
escriure:
> @David: one note on the "actions.py" file. I was looking at it
> yesterday night, and the last string of actions.py, the one of the
> Tomboy sync, is not really a good translatable string.
> Is it possible for you to modify the code of your branch, to make that string like this:
> _("%(protocol_name)s message from %(sender)s at %(time)s\n\n%(message)s\n\nSource: %(url)s") % \
> {"protocol_name": client.model.services[msg["protocol"]]["name"], \
> "sender": msg["sender"]["name"], \
> "time": msg["time"], \
> "message": msg["text"], \
> "url": msg["url"]
> }
>

Sure, done. Thanks!

> Other notes I was pondering yesterday:
> _Search for a query (from the actions.py file)
> Personally, I don't think it is that clear as a message. I can't find
> it while running the program so I don't exactly what it does, but I
> find it strange.
>

I think it is only for debugging purposes, as it should only print to
stdout, so I did not mark it as translatable or made it use a
%(variable)s. I'm always in favour of having everything translatable,
but for debugging messages, I think it is easier for developers to have
it in English, and for translators to concentrate only on really visible
strings.

> View reply t_hread
> What about a simpler "View discussion"?
>

I haven't changed that one, since it's not related to the translation
fixes, and it's probably something that should be discussed with the
developers, but basically, yes, I prefer your suggestion as well. I
think this one could be sorted out just by having a quick chat at
irc://irc.arstechnica.com/gwibber.

> And this one:
> print _("Searching for group"), query
> There is no space between "group" and the query string that will be added, is it OK to be like that?
>

The same comment as the other one. I haven't changed it for now, as I
think it is only a debug message.

David Planella (dpm) on 2010-03-01
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.29.91-0ubuntu1

---------------
gwibber (2.29.91-0ubuntu1) lucid; urgency=low

  * new upstream release 2.29.91
    - fixed a bug that prevented mentions/replies to get added to the
      messaging indicator
    - added more debug level logging
    - Fixed raising the client via dbus, missed a variable rename
    - Added signatures to the URLShorten dbus methods, fixes (LP: #517723)
    - URL shortening should be async (LP: #521974)
    - don't fail if desktopcouch is slow to start
    - Make "Name" more descriptive, it is displayed on UNE and in
      GNOME Shell (LP: #522180)
    - Fixed calls to print_exc that failed
    - Gwibber stops working after suspending (LP: #518550)
    - Fixed notifications for mentions only (LP: #528270)
    - Set the autostart gconf key if it wasn't set at all before
    - Internationalization fixed from David Planella (LP: #520462)
    - use human readable time string in save to tomboy (LP: #532730)
    - imported translations from LP
    - Moved the init_design_doc method call to MessageMonitor, this fixes a
      bug loading the design document before it is created
    - fixed a problem with configuring accounts spawning two services
    - check to see if gwibber-service is already running before starting
  * debian/gwibber.desktop
    - Make gwibber-service autostart with a delay of 60s if accounts are
      configured
 -- Ken VanDine <email address hidden> Fri, 19 Feb 2010 16:42:07 -0500

Changed in gwibber (Ubuntu):
status: New → Fix Released
Omer Akram (om26er) on 2010-03-08
Changed in gwibber:
status: New → Fix Released
Gabor Kelemen (kelemeng) wrote :
Gabor Kelemen (kelemeng) wrote :
Gabor Kelemen (kelemeng) wrote :

I found some more strings that are not translated :).

Changed in gwibber (Ubuntu):
status: Fix Released → Confirmed
Changed in gwibber:
status: Fix Released → Confirmed
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
David Planella (dpm) wrote :

Gabor, do you think you could create a branch integrating all your patches? It would make the work of merging the fixes a lot easier, and you'd also be properly credited in the source :)

It's just a matter of e.g.:

* bzr branch lp:gwibber
* (commit the patches locally)
* bzr push lp:~kelemeng/gwibber/bug-520462
* Press the "Link a related branch" link on this bug (there might be a way of doing this automatically with bzr or e-mail, but I haven't looked at it yet)
* Click on your branch and then on "Propose for merging"
* Start pestering devs after a few days if it's not been reviewed or committed ;)

tags: added: patch
etali (etali) on 2010-03-23
tags: added: patch-needswork
David Planella (dpm) on 2010-03-24
tags: added: gwibber-18n
David Planella (dpm) on 2010-03-24
tags: added: gwibber-i18n
removed: gwibber-18n
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.29.93-0ubuntu1

---------------
gwibber (2.29.93-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Use MAX_MESSAGE_LENGTH for max length instead of hard coding 140
    - Changed the views to not emit the entire doc as a value
    - Set default focus to the text input widget (LP: #528302)
    - Made a string translatable, requested by the translations
      team (LP: #534667)
    - Patch from Gabor Kelemen setting translation domain for .ui
      files (LP: #538846)
    - Mark strings translatable, thanks Kelemen Gábor (LP: #520462)
    - Added X-GNOME-Gettext-Domain to allow translations of the desktop
      files to be loaded at runtime (LP: #538851
    - Use the desktopcouch API for excluding the DB and handle
      errors (LP: #539583)
    - Set window icons properly so they scale nicely
    - Set account IDs in desktopcouch to force merging on sync instead of
      creating dupes (LP: #535263)
  * debian/patches/lp_report_to_ubuntu.patch
    - File bugs against the package (LP: #551132)
 -- Ken VanDine <email address hidden> Wed, 17 Mar 2010 13:20:24 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Omer Akram (om26er) on 2010-03-30
Changed in gwibber:
status: Confirmed → Fix Released
David Planella (dpm) wrote :

Although the title is generic, the particular issues reported in this bug have been fixed. For the remaining ones, see https://bugs.launchpad.net/ubuntu-translations/+bugs?field.tag=gwibber-i18n

Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers