The Gnome Thumbnail Image Viewer

scrollwheel should scroll not browse

Reported by Lesmana Zimmer on 2009-09-23
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gThumb
Invalid
Medium
gthumb (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gthumb

in gthumb, viewing an image, scrolling the scrollwheel should scroll the image instead of browsing to the next/previous image. that way it would be more consistent with other apps and also conforming to gnomes own human interface guideline.

http://library.gnome.org/devel/hig-book/stable/input-mouse.html.en

using ubuntu jaunty

related: https://bugs.launchpad.net/ubuntu/+source/eog/+bug/435488 (scrollwheel should scroll not zoom)
a bit related: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/92607 (using "ctrl + mouse scroll wheel" for zooming is inconsistent in different application)

Endolith (endolith) wrote :

This is really infuriating, when you try to scroll down an image and it fast forwards through dozens of image and loses your place. Is there a way to disable this?

Changed in gthumb (Ubuntu):
status: New → Confirmed
Changed in gthumb:
importance: Unknown → Medium
status: Unknown → New

From the changelog of 2.9.1 and the corresponding bugreport (131416) it seems that the idea was to navigate through the images only in fit mode.

Perhaps a modifier key such as Alt. for either scrolling or navigating would be nice?

In the meantime, does anyone know a (fast) image viewer that allows one to scroll with the scroll wheel? (I reinstalled gthumb because I knew it had this feature...)

http://gthumb.sourceforge.net/news.html
https://bugzilla.gnome.org/show_bug.cgi?id=131416

Changed in gthumb:
status: New → Fix Released
Jani Uusitalo (uusijani) wrote :

This has been fixed upstream ages ago, how come the fix never made it to Ubuntu? I'm using up-to-date Precise and this is still an issue: scrollwheel still browses between pictures instead of panning the current picture.

Current upstream gthumb uses the mousewheel for prev/next navigation, not for scrolling within an image.

Jani Uusitalo (uusijani) wrote :

More accurate upstream target; previous was fixed but didn't fix the issue reported here.

Changed in gthumb:
importance: Medium → Unknown
status: Fix Released → Unknown
Changed in gthumb:
importance: Unknown → Medium
status: Unknown → Invalid
kenjiru (kenjiru) wrote :

Any news about this issue? The default behaviour is really annoying, since in all other applications the mouse wheel is used for zooming. It should be configurable somehow.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.