Various themes for the GNOME 2 desktop

Darklooks gtkrc is broken [hardy-intrepid]

Reported by Nanley Chery on 2008-04-11
52
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-themes-extras
Fix Released
Medium
gnome-themes-extras (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Nanley Chery
Nominated for Intrepid by Nanley Chery
Nominated for Jaunty by Nanley Chery

Bug Description

Binary package hint: gnome-themes-extras

Apps loose their gtk theming when the darklooks theme is enabled. This is a regression from the gutsy package.
Command line output:

nanley@nanley-laptop:~$ firefox
/usr/share/themes/Darklooks/gtk-2.0/gtkrc:181: Invalid symbolic color 'tooltip_bg_color'
/usr/share/themes/Darklooks/gtk-2.0/gtkrc:181: error: invalid identifier `tooltip_bg_color', expected valid identifier

Nanley Chery (nanoman) wrote :

I am unable to reproduce this and have been using DarkLooks in Hardy for 3-4 months now.

I think your errors might be right about the gtkrc though - the top of that file defines tooltips_bg_color, not tooltip_bg_color

Chris Jones (cmsj) wrote :

Do you have a $HOME/.gtkrc or similar?

Nanley Chery (nanoman) wrote :

I don't see it. I've attached the file from my /usr/share... folder.
I should mention that I did a fresh install of Hardy using a dailylive cd yesterday. I think you haven't been able to reproduce the error because you've kept the same Hardy for so long.

Kristian (kristian-soderholm) wrote :

You can fix it by changing the two tooltip lines...

from:
...
181: bg[NORMAL] = @tooltip_bg_color
182: fg[NORMAL] = @tooltip_fg_color
...

to:
...
181: bg[NORMAL] = @tooltips_bg_color
182: fg[NORMAL] = @tooltips_fg_color
...

Nanley Chery (nanoman) wrote :

Sorry for changing this bug to confirmed myself, but the problem has been found...

Changed in gnome-themes-extras:
assignee: nobody → dholbach
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Somebody should forward the bug upstream and see if the suggested fix is OK.

Changed in gnome-themes-extras:
assignee: dholbach → nobody
roderikk (roderikk) wrote :

Hi,

I have the same problem. When opening some (not all) apps they go back to gtk1 (I think) widgets. Giving the following errors:

~$ bluetooth-properties
/usr/share/themes/Darklooks/gtk-2.0/gtkrc:181: Invalid symbolic color 'tooltip_bg_color'
/usr/share/themes/Darklooks/gtk-2.0/gtkrc:181: error: invalid identifier `tooltip_bg_color', expected valid identifier

roderikk (roderikk) wrote :

I can also confirm that changing the fix proposed by Kristian works.

Thiago Arrais (thiago-arrais) wrote :

I had the same problem and Kristian's fix worked for me.

Nanley Chery (nanoman) wrote :

If I have time, I'll try file a bug on the bugzilla tomorrow ( http://bugzilla.gnome.org/simple-bug-guide.cgi?product=gnome-themes-extras ).
I'd appreciate it if anyone w/ a gnome account would file the bug for me ;-).

Side Note:
For time's sake I suggest we edit the package to -> ubuntu2 and send the proposed fix to upstream afterwards. Just a thought.

Chris Jones (cmsj) wrote :

filed upstream after confirming 2.22's gtkrc has the same spelling difference

Changed in gnome-themes-extras:
importance: Undecided → Unknown
status: New → Unknown
Nanley Chery (nanoman) wrote :

Thank you Chris. =]
I hope this will get fixed before the release...

Changed in gnome-themes-extras:
status: Unknown → Fix Released
Dycedarg (cloud0e) wrote :

Sorry but i new in this how i can modified the tooltip line where is this. someonehelp me plz how i can do this??

You can fix it by changing the two tooltip lines...

from:
...
181: bg[NORMAL] = @tooltip_bg_color
182: fg[NORMAL] = @tooltip_fg_color
...

to:
...
181: bg[NORMAL] = @tooltips_bg_color
182: fg[NORMAL] = @tooltips_fg_color
...

Thanks for answer

Thiago Arrais (thiago-arrais) wrote :

Dycedarg, the file you have to modify is named on Nanley's original bug report: /usr/share/themes/Darklooks/gtk-2.0/gtkrc

Dycedarg (cloud0e) wrote :

Thanks a lot thiago arrais and the solution of Kristian it's work Thanks for the help!!

Lealcy B. Junior (lealcy) wrote :

Kristian patch works fine for me. Thank you.

Changed in gnome-themes-extras:
status: Confirmed → Fix Committed
Todd Ross (brainsick) wrote :

I was experiencing different symptoms but the fix detailed here resolved my problem as well.

I selected Darklooks using gnome-appearance-properties and everything looked good until I'd reboot. When the GNOME came back up, the theme clearly wasn't Darklooks although the Appearance panel showed that it was still selected. Selecting a different theme and then reselecting Darklooks would cause the theme to be applied again.

The status of this bug is VERY misleading. It's great that its fixed upstream and all, but IT'S STILL BROKEN IN HARDY.

svk (serg-kr) wrote :

I can confirm I have the same issue as Todd Ross. Upon reboot, the GTK elements of the theme are broken (including scroll bars, gnome panel menu items, dialogs, buttons, etc) -- they revert to a simplistic, gray, and squarish style.

Things like reselecting the theme or logging out and back in fix the theme. The issue only recurs on reboot.

Dave Chiluk (chiluk) wrote :

Can someone tell me why hasn't this been released as a Hardy package yet?

Todd Ross (brainsick) wrote :

This isn't fixed in Intrepid either.

Lars Pohlmann (lars-pohlmann) wrote :

Which is kind of strange. It's such an easy fix...

Bob Hazard (junkbit) wrote :

This bug is still present in Intrepid. About 50% of apps (including Firefox) revert to a basic GTK1 theme as a fallback because of errors in the gtkrc file for the Darklooks theme.

After comparing the Darklooks theme with the original Clearlooks theme on which it is based, the error is in the first line that defines the colour variables:

gtk_color_scheme = "fg_color:#E6E6E6\nbg_color:#555753\nbase_color:#2E3436\ntext_color:#D3D7CF\nselected_bg_color:#3F403D\nselected_fg_color:#7AA3CC\ntooltips_bg_color:#EDDE5C\ntooltips_fg_color:#000000"

There are TWO spelling errors in this line compared to the original Clearlooks which uses the singular tooltip_bg_color and tooltip_fg_color.

Removing the two Ss from tips fixes the problem, and given that Clearlooks is the reference design for Darklooks I suggest changing the top line to remain consistent across the family

Nanley Chery (nanoman) wrote :

I think we should mark the debian bug as fix committed. There is a fix in SVN, but a new release has not been made since. And why has this bug been "fix committed" for so long?

Nanley Chery (nanoman) wrote :

See comment above.
Gnome Bug Tracker: http://bugzilla.gnome.org/show_bug.cgi?id=528322

Changed in gnome-themes-extras:
importance: Unknown → Undecided
status: Fix Released → New
status: New → Fix Committed

why would this be fixed in the next major release, thats stupid! a small bug like this is instantly fixed with a patch! someone complain about this.

i experience this bug in intrepid.

Kristian, if you could, attach a patch to this bug report so that it can be rolled out to everyone. if not, ill have to figure out how to do that myself.

Scott Peterson (lunchtimemama) wrote :

Just googled my way here b/c I hit this problem. Why in god's name is this TWO LINE FIX not taken care of? Someone! Do something!

Kenneth Wimer (kwwii) wrote :

Because this is an upstream problem not an ubuntu specific problem. Being rude won't help either.

I was'nt rude was I?
On Fri, 23 Jan 2009 12:06:50 -0000, "Kenneth Wimer" <email address hidden>
said:
> Because this is an upstream problem not an ubuntu specific problem.
> Being rude won't help either.
>
> --
> Darklooks gtkrc is broken [hardy-intrepid]
> https://bugs.launchpad.net/bugs/215472
> You received this bug notification because you are a member of Ubuntu
> Artwork Team, which is a subscriber of a duplicate bug.
--
  martin smith
  <email address hidden>

--
http://www.fastmail.fm - Does exactly what it says on the tin

I'm attaching a debdiff that fixes it the same way it fixed upstream. Perhaps it should be done as a dpatch instead. Or even better package an svn snapshot and gain the various translation work done as well. I'm not sure why there are no upstream releases being done.

Amr Hassan (amr-hassan) wrote :

huh. this is still screwed up in jaunty.

James Westby (james-w) on 2009-04-18
Changed in gnome-themes-extras:
importance: Undecided → Unknown
status: Fix Committed → Unknown
James Westby (james-w) wrote :

Fix confirmed, thanks. Release team, ok to upload this?

Thanks,

James

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-themes-extras - 2.22.0-0ubuntu2

---------------
gnome-themes-extras (2.22.0-0ubuntu2) jaunty; urgency=low

  * Unplural tooltips_bg_color and tooltips_fg_color. (LP: #215472)

 -- Thomas E Jenkins <email address hidden> Sat, 14 Feb 2009 16:05:24 -0500

Changed in gnome-themes-extras (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-themes-extras:
status: Unknown → Fix Released
Changed in gnome-themes-extras:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.