Artful (17.10) Session logout after screen turned off

Bug #1721428 reported by Shu Hung (Koala) on 2017-10-05
246
This bug affects 53 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Unknown
Unknown
Nouveau Xorg driver
New
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

Whenever I turn off my screen, the computer (a desktop PC) logs me out of my session.

Here is a discussion thread with users of similar issue:
https://ubuntuforums.org/showthread.php?t=2372388&p=13694312&posted=1#post13694312

tags: added: artful
summary: - Session logout after screen turned off
+ Artful (17.10) Session logout after screen turned off
no longer affects: ubuntu-settings (Ubuntu)
Jib (jib2-form) wrote :

Same problem here.
My setting : screen turned off after 5 minutes.
When I wake the screen, I get the GDM login screen and a new session opens.
The previous session is lost.
Same behaviour with wayland and xorg.

Logs xorg session: https://pastebin.com/pb7XEbXZ

Logs wayland session: https://pastebin.com/Y002JiEv

Shu Hung (Koala) (koalay) wrote :

My video card is sort of new (Geforce 1050 Ti). And I think Nouveau might have been involved. I configured GRUB to boot with "nomodeset" option. The symptom is now gone (while, obviously, left me with crap graphics).

bhoult (bhoult) wrote :

I tried nomodeset with a geforce 770 using both the Nouveau and Nvidia drivers, but it still logs me out whenever I turn off the screen.

Shu Hung (Koala) (koalay) wrote :

I've just tried to installed graphic card ppa (sudo apt-add-repository ppa:graphics-drivers/ppa) and the nvidia-387 driver in it. After reboot, the same old problem is here again. So not a driver specific issue.

My monitor is connected to the video card with HDMI. I guess it detects that I turn off the screen and enter some sort of power saving mode and thus trigger the issue. Any guess which piece of software is responsible?

Shu Hung (Koala) (koalay) wrote :

One more discovery. If I go to console terminal (e.g. "Ctrl-Alt-F3") first before turning off the screen, I can get my session back then by turning on the screen then back to GUI (i.e. "Ctrl-Alt-F1").

Georg (gnarf) wrote :

Same here with video driver = "Intel Ivybridge Desktop". HDMI screen sent to sleep by Gnome's power saving settings, turning off via screen's power button or switching to other PC on the KVM will end the GUI session.

no longer affects: ubuntu
Changed in gnome-shell:
assignee: nobody → Anatoli Yakimovich (akelav)
assignee: Anatoli Yakimovich (akelav) → nobody
Zachary (zacbaker) wrote :

This is effecting me as well, all the latest updates applied, AMD RX480 graphics card. Once my screen goes to sleep I have to log back in and it is a fresh session, all my programs are closed. Also if I've made any changes to the UI like adding favorites and I haven't logged out/in properly these are lost.

spencer davies (bogwelsh) wrote :

Same here. I'm running an Asrock Deskmini with i5-7500 and onboard Intel graphics. It has a HP Z27n 2560x1440 monitor attached via displayport. Everything was working as expected under 17.04 but after upgrading to 17.10 it has the symptoms noted by others above. If monitor sleeps or it is turned off and back on again then i'm logged out of the current session. Not expert enough to offer much more in the way of diagnostics but this is definitely a new behavior introduced by the 17.10 upgrade.

bhoult (bhoult) wrote :

So along with getting logged out whenever I turn off the screen, the left panel disappeared yesterday and has yet to come back after updates.

I decided to switch to kde until they get this sorted out. From ubuntu you can install kde with "apt-ket install kubuntu-desktop" and then you can change to kde using the gear icon when you login.

So far everything is working... I can turn off the screen and am still logged in when I turn it back on.

Shu Hung (Koala) (koalay) wrote :

Since changing to KDE seems to have fix the issue, I now copy the issue to Gnome's bugzilla:

https://bugzilla.gnome.org/show_bug.cgi?id=789166

Jason Nicholls (permietech) wrote :

Same problem for me using "Ubuntu on Xorg". I have upgraded to 17.10 vs clean install. My system has an Nvidia card (GTX 1060) and using the proprietary nvidia drivers.

cul ugne (herp-derp) wrote :

Hi, all ok (for now) if I use gnome or mate. ubuntu and ubuntu on xorg only bad things.

Seems to be fixed with the latest update for me.

On Sun, Oct 22, 2017 at 4:31 AM, cul ugne <email address hidden>
wrote:

> Hi, all ok (for now) if I use gnome or mate. ubuntu and ubuntu on xorg
> only bad things.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721428
>
> Title:
> Artful (17.10) Session logout after screen turned off
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-shell/+bug/1721428/+subscriptions
>

--
~toroman

ols iron (olsiron) wrote :

Still occurring with gnome-shell 3.26.1-0ubuntu4

ols iron (olsiron) wrote :

From stacktrace I posted to Gnome peeps:

https://bugzilla.gnome.org/show_bug.cgi?id=789166#c6

<quote>
Some code is trying to access a non-existent GSettings key, which is a fatal error:
> message=message@entry=0x563b7a0d4ac0 "Settings schema 'org.gnome.shell.overrides' does not contain a key named 'button-layout'", data=data@entry=0x0)

There isn't any code that tries to read any 'button-layout' key in all of gnome-shell, so this is either a bug in an extension or in a downstream patch.
</quote>

This only gets triggered when monitor goes into standby...

Srecko Toroman (sreckotoroman) wrote :

Try with latest graphics drivers from
http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu artful (if you are
using nVidia).

On Sun, Oct 22, 2017 at 5:37 PM, ols iron <email address hidden>
wrote:

> Still occurring with gnome-shell 3.26.1-0ubuntu4
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721428
>
> Title:
> Artful (17.10) Session logout after screen turned off
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-shell/+bug/1721428/+subscriptions
>

--
~toroman

ols iron (olsiron) wrote :

Intel i915...

sudo lshw -numeric -C display
  *-display
       description: VGA compatible controller
       product: Iris Graphics 6100 [8086:162B]
       vendor: Intel Corporation [8086]
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:51 memory:c0000000-c0ffffff memory:b0000000-bfffffff ioport:3000(size=64) memory:c0000-dffff

ols iron (olsiron) wrote :

I've added a new user with no gnome-shell extensions and the issue does not occur.

original user has the following extensions installed:
AlternateTab
Applications Menu
Caffeine
Dash to Panel
Default Minimize and Maximise
Ubuntu AppIndicators (disabled)
Ubuntu Dock (disabled)
Workspace Grid

I'll starting working through them to see which one is the culprit.

ols iron (olsiron) wrote :

"Default Minimize and Maximize" extension looks to be the culprit. Disabling this extension and bug not reproducible.

Shu Hung (Koala) (koalay) wrote :

Seems "Dash to Dock" can cause the issue on my machine. Disabling it can fix the problem while re-enabling it would introduce it back to the system.

Jason Nicholls (permietech) wrote :

My user only had "System-monitor" (via ubuntu package), and "Turn off display" enabled over the default ubuntu extensions. I've disabled both and still experience the problem. Interestingly disabling "Turn off display" seems to fix the Ubuntu appindicators since they were not showing up until I disabled it...

I can confirm as for Shu Hung that first switching to a text tty before turning off the monitor will allow me to then switch back to my session without losing it.

@Srecko I'm already on the latest nvidia drivers - and since this is affecting people using Nouveau and intel then I doesn't seem like that is the issue.

A 'me too'. When the screen blanks, the session is logged out. And i'm running an Intel Skylake GT2 display driver.
My laptop running a 'Haswell Mobile' display doesn't seem to be affected, it works fine.

Both were in place upgraded from 17.04

Ehlers-jens (ehlers-jens) wrote :

The affects me to. I am using a desktop computer with external monitor. Whenever I power of the screen, I am logged out.

Ubuntu 17.10.

Patrick Moore (tricheboars) wrote :

I am effected by this bug as well. It is on my HTPC setup. 17.10. Gnome.

Jason Nicholls (permietech) wrote :

FYI seems to be fixed for me now. I haven't been trying for about a week (using switch-to-text tty first) but giving it a go now and it's all good again. Anyone else?

Jason Nicholls (permietech) wrote :

oh should have mentioned up-to-date on packages, currently:

* gnome-shell 3.26.1-0ubuntu5
* gdm3 3.26.1-3ubuntu3

Shu Hung (Koala) (koalay) wrote :

It is still happening on my machine. Whenever I enable "Dash to Dock", my desktop session will got logout on me turning off the screen. I believe it is a problem of GNOME handling error that caused by extensions.

Same here. Integrated graphics using the i915 driver.

Upgrade from 17.04 to 17.10 64 bit. Not fixed after the latest updates to gnome-shell (3.26.1-0ubuntu5) and gdm3 (3.26.1-3ubuntu3).

luwen (ningluwen-gmail) wrote :

Seems randomly log out the gnome session, really annoying, not sure what happened.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
James Lewis (james-fsck) wrote :

Confirmed still occurring fully patched as of 05/11/17

Leszek Zalewski (zalesz) wrote :

Same here, it gets a bit annoying to use external screen. The only thing that works for sure (at least for me) is to unplug everything from laptop before locking the screen

Same problem here on "Intel NUC NUC7i7BNH (Ubuntu 17.10 ; 4.13.0-16-generic)".
I use some extensions ( Blyr, Removable Drive Menu, Sound Input & Output Device Chooser, TeaTime ).
When i create a new account without extensions, problem is same, when screen is lock or monitor goes to standby mode Ubuntu go to "Login screen" and all Apps is gone. I tested Wayland and Xorg.

Max Mraz (maxmraz) wrote :

 I turned off extensions using the Tweaks app for Gnome but the problem still occurs, whether I turn off the monitor or let it enter standby. It does not occur, however, if I connect the monitor through HDMI (I normally use 2 monitors--one through DisplayPort and one through Thunderbolt 3 to DisplayPort, both of which cause the problem).
Intel HD Graphics 630 (Kaby Lake GT2)
driver=i915 according to lshw -c display

skipper (attila-egri-nagy) wrote :

I also have it with Intel integrated graphics on both of my desktops, connecting through DisplayPort. I hope this will help to find the problem. But if its the display cable type, how come that there are only few occurrences of the bug?

spencer davies (bogwelsh) wrote :

Confirming what maxmraz says... session logout problem occurs with DisplayPort but not with HDMI.

Jason Nicholls (permietech) wrote :

My screen is DP too.

I am affected by this bug as well. (Coffee Lake, connecting through displayport)
Driver is i915 with alpha support.

marc (mxe) wrote :

To me this is happening on HDMI connection.

MeneM (mark-maas-martin) wrote :

In my case, turning off the "User themes" extension fixed it for me.

@MeneM I don't think that I even have this extension installed.

I disabled all gnome-shell extensions and my session gets killed if I turn my screens off.
I have to turn them off, as I disabled the screen savem do to being logged out when the screen blanked.

The only workaround is to disable the screen saver, which means when I leave my desk, my session is open for any one to fiddle with.
If I lock the screen, the screen saver re-activates turns off the screen and my session gets killed.

This not very convenient at all.

skipper (attila-egri-nagy) wrote :

I tried Budgie and standard Gnome Shell sessions. They don't have this problem. Only the Ubuntu session (both xorg and wayland).

jrstravino (jrstravino) wrote :

Same here. Integrated graphics using the i915 driver/ Display Port.

jrstravino (jrstravino) on 2017-12-03
Changed in ubuntu:
status: Confirmed → Fix Released
Changed in gnome-shell:
status: New → Confirmed
jrstravino (jrstravino) on 2017-12-03
Changed in gnome-shell:
status: Confirmed → New

This seems to have been raised in Gnome bugzilla as https://bugzilla.gnome.org/show_bug.cgi?id=772413 which was then marked as a duplicate of https://bugzilla.gnome.org/show_bug.cgi?id=771646

The latter bug is marked as "resolved fixed" on the 12th October. Does anyone have any idea how long this will take to trickle through to 17.10?

Leperous (scabin) on 2017-12-04
information type: Public → Public Security
Shu Hung (Koala) (koalay) wrote :

No. Fix is not "released".

1. I have just updated my Ubuntu 17.10 with all latest update. Then I enabled "Dash to Dock" extension. Same symptom. Fix is not available yet.

2. I am using GNOME session with Xorg and GDM. Wayland session is somehow not available for my installation.

Changed in ubuntu:
status: Fix Released → Confirmed
jrstravino (jrstravino) wrote :

Sorry, I accidentally clicked fix release on wanting, and could not get back.

Yesterday I performed a clean install of Ubuntu 17.10 and confirm that it has the same problem.

information type: Public Security → Public
jrstravino (jrstravino) wrote :
Changed in mutter:
importance: Unknown → Undecided
status: Unknown → New

According to last -x command my session terminates only when turning the screen back on.

I also confirm that the session is not only logged out but every process created and all files in /run/shm/ are also killed.

It seemed like installing caffeine (disabling auto suspend and screensaver) had solved it, but after turning the screen on in the morning the session crashed at that moment.
In /var/crash there are files timestamped just after I turned the screen back on of: caffeine, Xwayland and gnome-shell.

This was a fresh install of 17.10 on desktop with AMD cpu and AMD gfx card connected to HDMI monitor. Everything was updated before the latest crash occurred again.

apt-cache policy
 gnome-shell 3.26.2-0ubuntu0.1
 gdm3 3.26.1-3ubuntu3

Changed in gnome-shell:
importance: Undecided → Unknown
status: New → Unknown
affects: ubuntu → gnome-shell (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
affects: mutter → mutter (Ubuntu)
Changed in mutter (Ubuntu):
status: New → Confirmed

I'm having the same issue on Intel NUC7 (NUC7i3BHN) with Ubuntu 17.10 and Intel i915 proprietary driver.

The NUC is set up as a Kodi HTPC and connected to a Samsung TV. When the TV is turned off and then turned on the session gets terminated and all applications are instantly killed.

When the TV is just turned off everything works in the background (eg. when I'm streaming music using Kore remote instead of TV) but crashes the moment the TV is turned on. Also random crashes occur with the TV turned off and long music playback.

This confirms that this bug is driver unrelated as it occurs on Nvidia, AMD and Intel.

Daniel van Vugt (vanvugt) wrote :

Hi all,

There are a number of bugs in gnome-shell that would exhibit symptoms like this bug describes. So I'm going to ask:

@koalay only: Please run 'apport-collect 1721428' on the affected machine to help us gather more information.

Everyone: Look in /var/crash for some .crash files. If you find any then please use the command:
  ubuntu-bug /var/crash/YOURFILE.crash
to create a new bug. And then mention your new bug ID here. Careful not to attach crash files to existing bugs. Each crash file should create a new bug.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Incomplete
Changed in mutter (Ubuntu):
status: Confirmed → Incomplete

OK, I cleared the /var/crash folder and then replicated the bug. I got the crash file and submitted it however I don't know how to get bug ID to link it. When I click Continue in the crash report window it disappears.

The bug title was "gnome-shell crashed with SIGSEGV in meta_window_get_monitor()

Seeing similar issue here on Intel NUC6i5SYH on Dell U3415Wb monitor on DP connector. Problem happens when manually switching monitor input from NUC Ubuntu 17.10 on DP connector to Mac laptop on HDMI connector on same monitor.

Also cleared my /var/crash folder and submitted two reports using ubuntu-bug after replicating problem (per @vanvugt instructions), one with filename _usr_bin_gnome-shell.1000.crash and another _usr_bin_Xwayland.1000.crash (also don't know where to use bug id)

Daniel van Vugt (vanvugt) wrote :

Yes, sorry, that seems to be a missing feature (or bug?) of apport. It tells you a crash happened but not where to follow it up on the web.

Here's how to find out where your crash(es) went. In a terminal run the below command. It will ask you for your password because for some (security) reason the machine's unique ID is considered private. Enter you password when asked and it should then open a web page with all the crashes listed from your machine:

  xdg-open "https://errors.ubuntu.com/user/"`sudo cat /var/lib/whoopsie/whoopsie-id`

or as two separate lines ending in a backtick:

  xdg-open "https://errors.ubuntu.com/user/"`
  sudo cat /var/lib/whoopsie/whoopsie-id`

The page will initially say "No data to display" but wait a second or two and it will then be populated.

Clicking on a crash's link in the Received column will open details about that particular instance. Then to follow it up scroll to the bottom of the page and click on the "Problem" link. That will take you to the bucket on errors.ubuntu.com where your crash has been grouped with other people experiencing the same problem. You can also get to the launchpad bug from there, if one exists, or tell it to open a new bug.

That worked but I had to ask for access to bug tracking since I'm new to this.

Just hope there's no confirmation link etc. email from Canonical since I lost access to mail account I used to create U1 acount way back then.

Daniel van Vugt (vanvugt) wrote :

OK, I am assuming "That worked" means you found the bug ID(s) your machine is experiencing, and they were not this one :)

Per comment #52, if the original reporter does not reply by early February then this bug will be closed due to lack of response. That doesn't mean this bug doesn't exist, just that we need (other) more detailed bug reports with crash information do be able to do anything with them. And those we have many of already. It's just a matter of finding the right crash report(s).

Before closing, could you please let us know which issues(s) to track to be informed of progress?

Daniel van Vugt (vanvugt) wrote :

If the bug does get closed due to lack of response from the reporter then that actually doesn't stop us commenting here.

Everyone please report your own separate bugs for crashes so that we may diagnose and group them more accurately. If you like, please mention the ID of your new bug(s) here.

jrstravino (jrstravino) wrote :

Even when enabled, apport will not upload crash reports to Launchpad for a stable release (see bug #994921). Instead, crash reports are uploaded to http://errors.ubuntu.com. To file a report on Launchpad anyway, one may open the following file via a command line:

gksudo gedit /etc/apport/crashdb.conf
and change:

'problem_types': ['Bug', 'Package'],
to:

# 'problem_types': ['Bug', 'Package'],
Save, close, and try to file the crash report again via:

ubuntu-bug /var/crash/_my_crash_report.crash

jrstravino (jrstravino) wrote :

@Andrzej Wojtaszewski
@Daniel van Vugt (vanvugt)

ubuntu-bug /var/crash/_usr_bin_gnome-shell.1000.crash
Bug #1742540
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1742540

ubuntu-bug /var/crash/_usr_bin_gnome-shell.121.crash
Bug #1742542
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1742542

ubuntu-bug /var/crash/_usr_bin_Xwayland.1000.crash
Bug #1742544
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1742544

ubuntu-bug /var/crash/_usr_bin_Xwayland.121.crash
Bug #1742545
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1742545

I can confirm this as well when using Ubuntu 17.10.

I'm on a desktop (Shuttle XPC DH110SE) with Skylake processor and Intel graphics with latest updates.

Didn't have any problems on 17.04, don't have problems when using Gnome on logon.

What I can add: I have no extension enabled - at least none of the ones displayed in Gnome Tweaks' "Extensions" tab.

And it seemed to force log-off when a HDMI cable was plugged into my PC, but was not connected to a display. The actual connection to the display is done via DisplayPort. So the dead-end HDMI cable could cause trouble?

Miroslav Zaťko (mirec-z) wrote :

Actually logout can occur without any cable manipulation or turning on/off external monitor. Few times it already happened to me with just lock screen activated. No standby, no hibernate. After I came back, I expected a screen to enter password for unlock, but login screen appear... Means session was logged out and all work lost... No restart was made concerning uptime result...
My config:
Lenovo P50, noveau driver for nvidia, Ubuntu17.10, everything updated to most recent versions

Daniel van Vugt (vanvugt) wrote :

Everyone please log your own separate bugs for this issue. Because it's not really one issue - it is multiple different gnome-shell crashes. Logging your own bug will help us to figure out exactly which crash you are experiencing and which fix you need.

spencer davies (bogwelsh) wrote :

Logged separate bug for this issue per <email address hidden>

https://bugs.launchpad.net/bugs/1744029

leder (gerrit-leder) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.