Artful (17.10) Session logout after screen turned off

Bug #1721428 reported by Shu Hung (Koala) on 2017-10-05
338
This bug affects 75 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Unknown
Unknown
gnome-shell (Ubuntu)
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

Whenever I turn off my screen, the computer (a desktop PC) logs me out of my session.

Here is a discussion thread with users of similar issue:
https://ubuntuforums.org/showthread.php?t=2372388&p=13694312&posted=1#post13694312

tags: added: artful
summary: - Session logout after screen turned off
+ Artful (17.10) Session logout after screen turned off
no longer affects: ubuntu-settings (Ubuntu)
Jib (jib2-form) wrote :

Same problem here.
My setting : screen turned off after 5 minutes.
When I wake the screen, I get the GDM login screen and a new session opens.
The previous session is lost.
Same behaviour with wayland and xorg.

Logs xorg session: https://pastebin.com/pb7XEbXZ

Logs wayland session: https://pastebin.com/Y002JiEv

Shu Hung (Koala) (koalay) wrote :

My video card is sort of new (Geforce 1050 Ti). And I think Nouveau might have been involved. I configured GRUB to boot with "nomodeset" option. The symptom is now gone (while, obviously, left me with crap graphics).

bhoult (bhoult) wrote :

I tried nomodeset with a geforce 770 using both the Nouveau and Nvidia drivers, but it still logs me out whenever I turn off the screen.

Shu Hung (Koala) (koalay) wrote :

I've just tried to installed graphic card ppa (sudo apt-add-repository ppa:graphics-drivers/ppa) and the nvidia-387 driver in it. After reboot, the same old problem is here again. So not a driver specific issue.

My monitor is connected to the video card with HDMI. I guess it detects that I turn off the screen and enter some sort of power saving mode and thus trigger the issue. Any guess which piece of software is responsible?

Shu Hung (Koala) (koalay) wrote :

One more discovery. If I go to console terminal (e.g. "Ctrl-Alt-F3") first before turning off the screen, I can get my session back then by turning on the screen then back to GUI (i.e. "Ctrl-Alt-F1").

Georg (gnarf) wrote :

Same here with video driver = "Intel Ivybridge Desktop". HDMI screen sent to sleep by Gnome's power saving settings, turning off via screen's power button or switching to other PC on the KVM will end the GUI session.

no longer affects: ubuntu
Changed in gnome-shell:
assignee: nobody → Anatoli Yakimovich (akelav)
assignee: Anatoli Yakimovich (akelav) → nobody
Zachary (zacbaker) wrote :

This is effecting me as well, all the latest updates applied, AMD RX480 graphics card. Once my screen goes to sleep I have to log back in and it is a fresh session, all my programs are closed. Also if I've made any changes to the UI like adding favorites and I haven't logged out/in properly these are lost.

spencer davies (bogwelsh) wrote :

Same here. I'm running an Asrock Deskmini with i5-7500 and onboard Intel graphics. It has a HP Z27n 2560x1440 monitor attached via displayport. Everything was working as expected under 17.04 but after upgrading to 17.10 it has the symptoms noted by others above. If monitor sleeps or it is turned off and back on again then i'm logged out of the current session. Not expert enough to offer much more in the way of diagnostics but this is definitely a new behavior introduced by the 17.10 upgrade.

bhoult (bhoult) wrote :

So along with getting logged out whenever I turn off the screen, the left panel disappeared yesterday and has yet to come back after updates.

I decided to switch to kde until they get this sorted out. From ubuntu you can install kde with "apt-ket install kubuntu-desktop" and then you can change to kde using the gear icon when you login.

So far everything is working... I can turn off the screen and am still logged in when I turn it back on.

Shu Hung (Koala) (koalay) wrote :

Since changing to KDE seems to have fix the issue, I now copy the issue to Gnome's bugzilla:

https://bugzilla.gnome.org/show_bug.cgi?id=789166

Jason Nicholls (permietech) wrote :

Same problem for me using "Ubuntu on Xorg". I have upgraded to 17.10 vs clean install. My system has an Nvidia card (GTX 1060) and using the proprietary nvidia drivers.

cul ugne (herp-derp) wrote :

Hi, all ok (for now) if I use gnome or mate. ubuntu and ubuntu on xorg only bad things.

Seems to be fixed with the latest update for me.

On Sun, Oct 22, 2017 at 4:31 AM, cul ugne <email address hidden>
wrote:

> Hi, all ok (for now) if I use gnome or mate. ubuntu and ubuntu on xorg
> only bad things.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721428
>
> Title:
> Artful (17.10) Session logout after screen turned off
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-shell/+bug/1721428/+subscriptions
>

--
~toroman

ols iron (olsiron) wrote :

Still occurring with gnome-shell 3.26.1-0ubuntu4

ols iron (olsiron) wrote :

From stacktrace I posted to Gnome peeps:

https://bugzilla.gnome.org/show_bug.cgi?id=789166#c6

<quote>
Some code is trying to access a non-existent GSettings key, which is a fatal error:
> message=message@entry=0x563b7a0d4ac0 "Settings schema 'org.gnome.shell.overrides' does not contain a key named 'button-layout'", data=data@entry=0x0)

There isn't any code that tries to read any 'button-layout' key in all of gnome-shell, so this is either a bug in an extension or in a downstream patch.
</quote>

This only gets triggered when monitor goes into standby...

Srecko Toroman (sreckotoroman) wrote :

Try with latest graphics drivers from
http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu artful (if you are
using nVidia).

On Sun, Oct 22, 2017 at 5:37 PM, ols iron <email address hidden>
wrote:

> Still occurring with gnome-shell 3.26.1-0ubuntu4
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721428
>
> Title:
> Artful (17.10) Session logout after screen turned off
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-shell/+bug/1721428/+subscriptions
>

--
~toroman

ols iron (olsiron) wrote :

Intel i915...

sudo lshw -numeric -C display
  *-display
       description: VGA compatible controller
       product: Iris Graphics 6100 [8086:162B]
       vendor: Intel Corporation [8086]
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:51 memory:c0000000-c0ffffff memory:b0000000-bfffffff ioport:3000(size=64) memory:c0000-dffff

ols iron (olsiron) wrote :

I've added a new user with no gnome-shell extensions and the issue does not occur.

original user has the following extensions installed:
AlternateTab
Applications Menu
Caffeine
Dash to Panel
Default Minimize and Maximise
Ubuntu AppIndicators (disabled)
Ubuntu Dock (disabled)
Workspace Grid

I'll starting working through them to see which one is the culprit.

ols iron (olsiron) wrote :

"Default Minimize and Maximize" extension looks to be the culprit. Disabling this extension and bug not reproducible.

Shu Hung (Koala) (koalay) wrote :

Seems "Dash to Dock" can cause the issue on my machine. Disabling it can fix the problem while re-enabling it would introduce it back to the system.

Jason Nicholls (permietech) wrote :

My user only had "System-monitor" (via ubuntu package), and "Turn off display" enabled over the default ubuntu extensions. I've disabled both and still experience the problem. Interestingly disabling "Turn off display" seems to fix the Ubuntu appindicators since they were not showing up until I disabled it...

I can confirm as for Shu Hung that first switching to a text tty before turning off the monitor will allow me to then switch back to my session without losing it.

@Srecko I'm already on the latest nvidia drivers - and since this is affecting people using Nouveau and intel then I doesn't seem like that is the issue.

A 'me too'. When the screen blanks, the session is logged out. And i'm running an Intel Skylake GT2 display driver.
My laptop running a 'Haswell Mobile' display doesn't seem to be affected, it works fine.

Both were in place upgraded from 17.04

Ehlers-jens (ehlers-jens) wrote :

The affects me to. I am using a desktop computer with external monitor. Whenever I power of the screen, I am logged out.

Ubuntu 17.10.

Patrick Moore (tricheboars) wrote :

I am effected by this bug as well. It is on my HTPC setup. 17.10. Gnome.

Jason Nicholls (permietech) wrote :

FYI seems to be fixed for me now. I haven't been trying for about a week (using switch-to-text tty first) but giving it a go now and it's all good again. Anyone else?

Jason Nicholls (permietech) wrote :

oh should have mentioned up-to-date on packages, currently:

* gnome-shell 3.26.1-0ubuntu5
* gdm3 3.26.1-3ubuntu3

Shu Hung (Koala) (koalay) wrote :

It is still happening on my machine. Whenever I enable "Dash to Dock", my desktop session will got logout on me turning off the screen. I believe it is a problem of GNOME handling error that caused by extensions.

Same here. Integrated graphics using the i915 driver.

Upgrade from 17.04 to 17.10 64 bit. Not fixed after the latest updates to gnome-shell (3.26.1-0ubuntu5) and gdm3 (3.26.1-3ubuntu3).

luwen (ningluwen-gmail) wrote :

Seems randomly log out the gnome session, really annoying, not sure what happened.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
James Lewis (james-fsck) wrote :

Confirmed still occurring fully patched as of 05/11/17

Leszek (pb-zalewski-leszek) wrote :

Same here, it gets a bit annoying to use external screen. The only thing that works for sure (at least for me) is to unplug everything from laptop before locking the screen

Same problem here on "Intel NUC NUC7i7BNH (Ubuntu 17.10 ; 4.13.0-16-generic)".
I use some extensions ( Blyr, Removable Drive Menu, Sound Input & Output Device Chooser, TeaTime ).
When i create a new account without extensions, problem is same, when screen is lock or monitor goes to standby mode Ubuntu go to "Login screen" and all Apps is gone. I tested Wayland and Xorg.

Max Mraz (maxmraz) wrote :

 I turned off extensions using the Tweaks app for Gnome but the problem still occurs, whether I turn off the monitor or let it enter standby. It does not occur, however, if I connect the monitor through HDMI (I normally use 2 monitors--one through DisplayPort and one through Thunderbolt 3 to DisplayPort, both of which cause the problem).
Intel HD Graphics 630 (Kaby Lake GT2)
driver=i915 according to lshw -c display

skipper (attila-egri-nagy) wrote :

I also have it with Intel integrated graphics on both of my desktops, connecting through DisplayPort. I hope this will help to find the problem. But if its the display cable type, how come that there are only few occurrences of the bug?

spencer davies (bogwelsh) wrote :

Confirming what maxmraz says... session logout problem occurs with DisplayPort but not with HDMI.

Jason Nicholls (permietech) wrote :

My screen is DP too.

I am affected by this bug as well. (Coffee Lake, connecting through displayport)
Driver is i915 with alpha support.

marc (mxe) wrote :

To me this is happening on HDMI connection.

MeneM (mark-maas-martin) wrote :

In my case, turning off the "User themes" extension fixed it for me.

@MeneM I don't think that I even have this extension installed.

I disabled all gnome-shell extensions and my session gets killed if I turn my screens off.
I have to turn them off, as I disabled the screen savem do to being logged out when the screen blanked.

The only workaround is to disable the screen saver, which means when I leave my desk, my session is open for any one to fiddle with.
If I lock the screen, the screen saver re-activates turns off the screen and my session gets killed.

This not very convenient at all.

skipper (attila-egri-nagy) wrote :

I tried Budgie and standard Gnome Shell sessions. They don't have this problem. Only the Ubuntu session (both xorg and wayland).

jrstravino (jrstravino) wrote :

Same here. Integrated graphics using the i915 driver/ Display Port.

jrstravino (jrstravino) on 2017-12-03
Changed in ubuntu:
status: Confirmed → Fix Released
Changed in gnome-shell:
status: New → Confirmed
jrstravino (jrstravino) on 2017-12-03
Changed in gnome-shell:
status: Confirmed → New

This seems to have been raised in Gnome bugzilla as https://bugzilla.gnome.org/show_bug.cgi?id=772413 which was then marked as a duplicate of https://bugzilla.gnome.org/show_bug.cgi?id=771646

The latter bug is marked as "resolved fixed" on the 12th October. Does anyone have any idea how long this will take to trickle through to 17.10?

Leperous (scabin) on 2017-12-04
information type: Public → Public Security
Shu Hung (Koala) (koalay) wrote :

No. Fix is not "released".

1. I have just updated my Ubuntu 17.10 with all latest update. Then I enabled "Dash to Dock" extension. Same symptom. Fix is not available yet.

2. I am using GNOME session with Xorg and GDM. Wayland session is somehow not available for my installation.

Changed in ubuntu:
status: Fix Released → Confirmed
jrstravino (jrstravino) wrote :

Sorry, I accidentally clicked fix release on wanting, and could not get back.

Yesterday I performed a clean install of Ubuntu 17.10 and confirm that it has the same problem.

information type: Public Security → Public
jrstravino (jrstravino) wrote :
Changed in mutter:
importance: Unknown → Undecided
status: Unknown → New

According to last -x command my session terminates only when turning the screen back on.

I also confirm that the session is not only logged out but every process created and all files in /run/shm/ are also killed.

It seemed like installing caffeine (disabling auto suspend and screensaver) had solved it, but after turning the screen on in the morning the session crashed at that moment.
In /var/crash there are files timestamped just after I turned the screen back on of: caffeine, Xwayland and gnome-shell.

This was a fresh install of 17.10 on desktop with AMD cpu and AMD gfx card connected to HDMI monitor. Everything was updated before the latest crash occurred again.

apt-cache policy
 gnome-shell 3.26.2-0ubuntu0.1
 gdm3 3.26.1-3ubuntu3

Changed in gnome-shell:
importance: Undecided → Unknown
status: New → Unknown
affects: ubuntu → gnome-shell (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
affects: mutter → mutter (Ubuntu)
Changed in mutter (Ubuntu):
status: New → Confirmed

I'm having the same issue on Intel NUC7 (NUC7i3BHN) with Ubuntu 17.10 and Intel i915 proprietary driver.

The NUC is set up as a Kodi HTPC and connected to a Samsung TV. When the TV is turned off and then turned on the session gets terminated and all applications are instantly killed.

When the TV is just turned off everything works in the background (eg. when I'm streaming music using Kore remote instead of TV) but crashes the moment the TV is turned on. Also random crashes occur with the TV turned off and long music playback.

This confirms that this bug is driver unrelated as it occurs on Nvidia, AMD and Intel.

Daniel van Vugt (vanvugt) wrote :

Hi all,

There are a number of bugs in gnome-shell that would exhibit symptoms like this bug describes. So I'm going to ask:

@koalay only: Please run 'apport-collect 1721428' on the affected machine to help us gather more information.

Everyone: Look in /var/crash for some .crash files. If you find any then please use the command:
  ubuntu-bug /var/crash/YOURFILE.crash
to create a new bug. And then mention your new bug ID here. Careful not to attach crash files to existing bugs. Each crash file should create a new bug.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Incomplete
Changed in mutter (Ubuntu):
status: Confirmed → Incomplete

OK, I cleared the /var/crash folder and then replicated the bug. I got the crash file and submitted it however I don't know how to get bug ID to link it. When I click Continue in the crash report window it disappears.

The bug title was "gnome-shell crashed with SIGSEGV in meta_window_get_monitor()

Seeing similar issue here on Intel NUC6i5SYH on Dell U3415Wb monitor on DP connector. Problem happens when manually switching monitor input from NUC Ubuntu 17.10 on DP connector to Mac laptop on HDMI connector on same monitor.

Also cleared my /var/crash folder and submitted two reports using ubuntu-bug after replicating problem (per @vanvugt instructions), one with filename _usr_bin_gnome-shell.1000.crash and another _usr_bin_Xwayland.1000.crash (also don't know where to use bug id)

Daniel van Vugt (vanvugt) wrote :

Yes, sorry, that seems to be a missing feature (or bug?) of apport. It tells you a crash happened but not where to follow it up on the web.

Here's how to find out where your crash(es) went. In a terminal run the below command. It will ask you for your password because for some (security) reason the machine's unique ID is considered private. Enter you password when asked and it should then open a web page with all the crashes listed from your machine:

  xdg-open "https://errors.ubuntu.com/user/"`sudo cat /var/lib/whoopsie/whoopsie-id`

or as two separate lines ending in a backtick:

  xdg-open "https://errors.ubuntu.com/user/"`
  sudo cat /var/lib/whoopsie/whoopsie-id`

The page will initially say "No data to display" but wait a second or two and it will then be populated.

Clicking on a crash's link in the Received column will open details about that particular instance. Then to follow it up scroll to the bottom of the page and click on the "Problem" link. That will take you to the bucket on errors.ubuntu.com where your crash has been grouped with other people experiencing the same problem. You can also get to the launchpad bug from there, if one exists, or tell it to open a new bug.

That worked but I had to ask for access to bug tracking since I'm new to this.

Just hope there's no confirmation link etc. email from Canonical since I lost access to mail account I used to create U1 acount way back then.

Daniel van Vugt (vanvugt) wrote :

OK, I am assuming "That worked" means you found the bug ID(s) your machine is experiencing, and they were not this one :)

Per comment #52, if the original reporter does not reply by early February then this bug will be closed due to lack of response. That doesn't mean this bug doesn't exist, just that we need (other) more detailed bug reports with crash information do be able to do anything with them. And those we have many of already. It's just a matter of finding the right crash report(s).

Before closing, could you please let us know which issues(s) to track to be informed of progress?

Daniel van Vugt (vanvugt) wrote :

If the bug does get closed due to lack of response from the reporter then that actually doesn't stop us commenting here.

Everyone please report your own separate bugs for crashes so that we may diagnose and group them more accurately. If you like, please mention the ID of your new bug(s) here.

jrstravino (jrstravino) wrote :

Even when enabled, apport will not upload crash reports to Launchpad for a stable release (see bug #994921). Instead, crash reports are uploaded to http://errors.ubuntu.com. To file a report on Launchpad anyway, one may open the following file via a command line:

gksudo gedit /etc/apport/crashdb.conf
and change:

'problem_types': ['Bug', 'Package'],
to:

# 'problem_types': ['Bug', 'Package'],
Save, close, and try to file the crash report again via:

ubuntu-bug /var/crash/_my_crash_report.crash

jrstravino (jrstravino) wrote :

@Andrzej Wojtaszewski
@Daniel van Vugt (vanvugt)

ubuntu-bug /var/crash/_usr_bin_gnome-shell.1000.crash
Bug #1742540
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1742540

ubuntu-bug /var/crash/_usr_bin_gnome-shell.121.crash
Bug #1742542
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1742542

ubuntu-bug /var/crash/_usr_bin_Xwayland.1000.crash
Bug #1742544
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1742544

ubuntu-bug /var/crash/_usr_bin_Xwayland.121.crash
Bug #1742545
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1742545

I can confirm this as well when using Ubuntu 17.10.

I'm on a desktop (Shuttle XPC DH110SE) with Skylake processor and Intel graphics with latest updates.

Didn't have any problems on 17.04, don't have problems when using Gnome on logon.

What I can add: I have no extension enabled - at least none of the ones displayed in Gnome Tweaks' "Extensions" tab.

And it seemed to force log-off when a HDMI cable was plugged into my PC, but was not connected to a display. The actual connection to the display is done via DisplayPort. So the dead-end HDMI cable could cause trouble?

Miroslav Zaťko (mirec-z) wrote :

Actually logout can occur without any cable manipulation or turning on/off external monitor. Few times it already happened to me with just lock screen activated. No standby, no hibernate. After I came back, I expected a screen to enter password for unlock, but login screen appear... Means session was logged out and all work lost... No restart was made concerning uptime result...
My config:
Lenovo P50, noveau driver for nvidia, Ubuntu17.10, everything updated to most recent versions

Daniel van Vugt (vanvugt) wrote :

Everyone please log your own separate bugs for this issue. Because it's not really one issue - it is multiple different gnome-shell crashes. Logging your own bug will help us to figure out exactly which crash you are experiencing and which fix you need.

spencer davies (bogwelsh) wrote :

Logged separate bug for this issue per <email address hidden>

https://bugs.launchpad.net/bugs/1744029

leder (gerrit-leder) wrote :
smk (pobox95) wrote :

Switching from Wayland to Xorg in Gnome Session not only solved the session logout problem, but also a more serious one, namely, the computer becoming completely unresponsive after suspend, leaving me with no alternative but to force shut down the computer and restarting. Overall the computer works better on Xorg than on Wayland.
I have Ubuntu 17.10 installed on a new Dell Insipiron 15 5000 series laptop.

Craig Carnell (craig-carnell) wrote :

Are there any updates on this issue? This issue is causing some major problems for me - as soon as I go away from my computer for more than a few minutes and re login to the computer all my windows have closed and I have to re-open everything.

My system is a Dell 9560 with Intel & Nvidia 1050 Graphics - Ubuntu 17.10, Wayland Gnome.

marc (mxe) wrote :

Since 18.04 will not feature Wayland as a default anymore, I too chose to go back to xorg, which made the issue disappear for me as well.

Daleus (daleus) wrote :

Same as #68 - Also running a Dell 9560 (go figure..)

Locking the machine with WIN + L locks no problem and I can unlock without issue if done immediately.

If I lock & walk away the screen will blank after a few minutes and my session is GONE. However worth noting is that my VPN (openvpn provided by network-manager-gnome-openvpn) stays connected.

I run with my laptop display CLOSED (monitor via HDMI).

Daniel van Vugt (vanvugt) wrote :

Everyone please log your own separate bugs for this issue. Because it's not really one issue - it is multiple different gnome-shell crashes. Logging your own bug will help us to figure out exactly which crash you are experiencing and which fix you need.

Craig Carnell (craig-carnell) wrote :

Whenever I try to log an issue with ubuntu-bug /var/crash/_usr_bin_Xwayland.1000.crash for this issue my machine locks up

Daniel van Vugt (vanvugt) wrote :

Craig, in that case please just:

1. Open a bug https://bugs.launchpad.net/ubuntu/+source/xorg-server/+filebug
2. Add tag "xwayland"
3. Change it from Public to Private (top right of the page)
4. Attach your crash file to the bug.

Normally we do not recommend doing it that way as there's no guarantee we'll be able to decode it by hand.

Peter Becich (peterbecich) wrote :

Hello, this seems to happen to me, also.

Debian 9.3
kernel 4.14.0-0.bpo.3-amd64
Nvidia driver from the "testing" repository, 384.111
Nvidia card GeForce 1060

I found only two suspicious things in `nvidia-bug-report.log.gz`, which was freshly generated after the bug:

[32940.892161] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[32940.892198] cache: parent cpu15 should not be sleeping
[32940.892287] microcode: CPU15: patch_level=0x08001129
[32940.892650] CPU15 is up
[32940.894082] ACPI: Waking up from system sleep state S3
...
[32941.030214] nvidia 0000:23:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x000e address=0x0000000000000000 flags=0x0000]
https://pastebin.com/hQhyp8kC

and

[ 32952.583] (II) NVIDIA: Using 24576.00 MB of virtual memory for indirect memory
[ 32952.583] (II) NVIDIA: access.
[ 32952.586] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 32952.586] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 32952.586] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 32952.586] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 32952.586] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 32952.586] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 32952.586] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 32952.586] (II) NVIDIA(0): Config Options in the README.
[ 32952.599] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select,DFP-1:nvidia-auto-select"
[ 32952.702] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 32952.702] (==) NVIDIA(0): Backing store enabled
[ 32952.702] (==) NVIDIA(0): Silken mouse enabled
[ 32952.703] (==) NVIDIA(0): DPMS enabled

Daniel van Vugt (vanvugt) wrote :

Everyone please log your own separate bugs for this issue. Because it's not really one issue - it is multiple different gnome-shell crashes. Logging your own bug will help us to figure out exactly which crash you are experiencing and which fix you need.

I reproduce the same thing with a pretty standard Ubuntu 17.10 (but upgraded from 17.04) in which I did not installed any extension (which mean I only have the system Ubuntu ones: "Ubuntu AppIndicators" and "Ubuntu Dock"). I wanted to try to disable those extension to check but it does not seems to be possible (at least not from https://extensions.gnome.org/local/).

My system is a Nuc Arches Canyon Nuc6cayh.

For some weird reason gnome-tweak-tool is telling me that Ubuntu extensions are not enabled but I guess it's a visual bug since I don't have the problem anymore if I use the top bar button to disable all extensions at once. So it definitely seems to be in one of the Ubuntu extensions but no idea which once since I can't disable them separately.

OK so it's actually a bit random actually. Even with all extensions disabled in gnome-tweak-tool the session sometimes crash and sometimes stay.

I used ubuntu-bug but no idea what issue has been created from it since it's not indicating anything. I just got new .upload and uploaded files added to /var/crash/.

Here are the reported issues (thanks @jrstravino for the apport fix to send them to the right place):
* https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1750570
* https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1750572

Craig Carnell (craig-carnell) wrote :

https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1750773

However, the uploading of attachments appears to be broken.

Daniel van Vugt (vanvugt) wrote :

Bug 1750773 does not seem to exist (!?)

Craig Carnell (craig-carnell) wrote :

It's set to private at request

jrstravino (jrstravino) wrote :

I upgraded to Ubuntu 18.04 beta, and this issue has been resolved.
Everything working perfectly.
Finally!

naisanza (naisanza) wrote :

As @ShuHung mentioned, disabling "Dash to Dock" keeps the session from ending when turning off the monitor

Daniel van Vugt (vanvugt) wrote :

Bug closed, due to no response from the original reporter after over 3 months (see comment #52).

Everyone else, please keep logging your own bugs if you have any issues.

Changed in gnome-shell (Ubuntu):
status: Incomplete → Invalid
Changed in mutter (Ubuntu):
status: Incomplete → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
affects: nouveau → ubuntu
no longer affects: ubuntu
Daniel van Vugt (vanvugt) wrote :

I mean:

Bug closed, due to no response from the original reporter after over 2 months (see comment #52).

Everyone else please keep logging your own bugs if you have any issues.

Matt Mahin (matt.mahin) wrote :
Download full text (4.6 KiB)

Seeing this issue on gnome shell after recent 17.10 upgrade from 16.04 LTS. Anytime the screen turns off, my gnome session crashes.

// seems like everything up to date with these except for xorg
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

$ cat /proc/version
Linux version 4.13.0-37-generic (buildd@lcy01-amd64-026) (gcc version 7.2.0 (Ubuntu 7.2.0-8ubuntu3.2)) #42-Ubuntu SMP Wed Mar 7 14:13:23 UTC 2018

[63316.108041] [drm] Reducing the compressed framebuffer size. This may lead to less power savings than a non-reduced-size. Try to increase stolen memory size if available in BIOS.
[81819.033174] [drm] Reducing the compressed framebuffer size. This may lead to less power savings than a non-reduced-size. Try to increase stolen memory size if available in BIOS.
[81828.179633] [drm:drm_scdc_set_high_tmds_clock_ratio [drm_kms_helper]] *ERROR* Failed to read tmds config, err=-6
[81828.179726] [drm:intel_hdmi_handle_sink_scrambling [i915]] *ERROR* Set TMDS ratio failed
[81828.208165] gnome-shell[2815]: segfault at 38 ip 00007f039c0bac30 sp 00007ffcecb5f918 error 4 in libmutter-1.so.0.0.0[7f039c068000+141000]
[81828.318684] rfkill: input handler enabled
[81828.328347] [drm:drm_scdc_set_high_tmds_clock_ratio [drm_kms_helper]] *ERROR* Failed to read tmds config, err=-6
[81828.328387] [drm:intel_hdmi_handle_sink_scrambling [i915]] *ERROR* Set TMDS ratio failed
[81828.328392] [drm] Reducing the compressed framebuffer size. This may lead to less power savings than a non-reduced-size. Try to increase stolen memory size if available in BIOS.
[81828.382297] [drm:drm_scdc_set_high_tmds_clock_ratio [drm_kms_helper]] *ERROR* Failed to read tmds config, err=-6
[81828.382318] [drm:intel_hdmi_handle_sink_scrambling [i915]] *ERROR* Set TMDS ratio failed
[81831.917503] [drm:drm_add_edid_modes.part.27 [drm]] *ERROR* Unknown HDMI VIC: 0
[81831.984981] [drm] Reducing the compressed framebuffer size. This may lead to less power savings than a non-reduced-size. Try to increase stolen memory size if available in BIOS.
[81879.389515] [drm:drm_add_edid_modes.part.27 [drm]] *ERROR* Unknown HDMI VIC: 0
[81880.918441] rfkill: input handler disabled
------
[82380.490818] [drm:drm_scdc_set_high_tmds_clock_ratio [drm_kms_helper]] *ERROR* Failed to read tmds config, err=-6
[82380.490848] [drm:intel_hdmi_handle_sink_scrambling [i915]] *ERROR* Set TMDS ratio failed
[82380.522584] gnome-shell[26432]: segfault at 18 ip 00007f433fedfd94 sp 00007fffac254b88 error 4 in libmutter-1.so.0.0.0[7f433fe41000+141000]
[82380.633077] rfkill: input handler enabled
[82384.241961] [drm:drm_add_edid_modes.part.27 [drm]] *ERROR* Unknown HDMI VIC: 0
[82384.319360] [drm] Reducing the compressed framebuffer size. This may lead to less power savings than a non-reduced-size. Try to increase stolen memory size if available in BIOS.
[82403.842828] [drm:drm_add_edid_modes.part.27 [drm]] *ERROR* Unknown HDMI VIC: 0
[82406.263963] rfkill: input handler disabled
------
[83520.980283] [drm:drm_scdc_set_high_tmds_clock_ratio [drm_kms_helper]] *ERROR* Failed to read tmds config, err=-6
[83520.980375] [drm:intel_hdmi_handle_sink_scrambling [i915]] *ERROR* Set TMDS ratio failed
[83521.030747...

Read more...

Matt Mahin (matt.mahin) wrote :

Issue is mitigated by enabling Automatic screen lock when screen turns off.

Daniel van Vugt (vanvugt) wrote :

This bug is closed.

Please log new bugs if you have any issues at all.

Stuart (shutch) wrote :

@Daniel

Why was this bug closed? @matt.mahin suggestion doesn't seem to fix this.

Daniel van Vugt (vanvugt) wrote :

See comments #52 and #64.

bluebomber (bluebomber) wrote :

I tried to follow the directions in comment #52, but when I ran the `ubuntu-bug` command, it didn't give me any output. So I followed the instructions in comment #55, but although I do get the the searchable histogram of top issues, I receive the error "Sorry, you are not a member of a group that is allowed to see the data from error reports. Please fill out this form to request access."

When I click that, it's asking me to consent to a legal disclaimer and provide a bunch of personal information, including home address, which seems excessive. I just want to report a bug, and if this isn't the right bug to track, the proper procedure needs to be simplified.

I do have a crash file; can I just create a new ticket, tag the app named in the crash file (apport-gtk), and attach it to the ticket?

Daniel van Vugt (vanvugt) wrote :

If 'ubuntu-bug' fails for you then please try applying the workaround from bug 994921 first.

RevAngel (revangel) wrote :

Woohoo! ;-)

Well, about two weeks before the change back to x-org they fixed wayland and this bug does not affect me anymore. Fantastic!

Craig Carnell (craig-carnell) wrote :

@RevAngel do you have a link to this please?

RevAngel (revangel) wrote :

Well, it was too early to shout a "woohoo"...

Outcome is inconsistent, sometimes it logs my system off, sometimes it just "blacks out" Kodi when running a video.

About the change back to X-Org? Sure: google "ubuntu 18 x-org"

Daniel van Vugt (vanvugt) wrote :

This bug is closed due to no response from the original reporter, so please don't add further comments.

Everyone else should:

1. If using a release older than 18.04 then apply the workaround from bug 994921 first.

2. Run: ubuntu-bug /var/crash/YOURFILE.crash

Elin Yordanov (yordanov) wrote :

It is nonsense to close an issue if it affects 70+ people.

Changed in gnome-shell (Ubuntu):
status: Invalid → Confirmed
Daniel van Vugt (vanvugt) wrote :

This bug is closed due to no response from the original reporter, so please don't add further comments.

Everyone else should:

1. If using a release older than 18.04 then apply the workaround from bug 994921 first.

2. Run: ubuntu-bug /var/crash/YOURFILE.crash

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

BTW, we have fixed many gnome-shell bugs with these symptoms recently in Ubuntu 18.04. So please try 18.04 and log a new bug if you have any problems.

Roland Giesler (lifeboy) wrote :
Download full text (15.3 KiB)

Still happens in 18.04. Switching to Xorg fixed it for me.

$ sudo lshw
roland-zenbook
    description: Convertible
    product: UX461UN
    vendor: ASUSTeK COMPUTER INC.
    version: 1.0
    serial: J1N0CX17A84604B
    width: 64 bits
    capabilities: smbios-3.0 dmi-3.0 smp vsyscall32
    configuration: boot=normal chassis=convertible family=UX uuid=4A314E30-4358-3137-4138-343630344241
  *-core
       description: Motherboard
       product: UX461UN
       vendor: ASUSTeK COMPUTER INC.
       physical id: 0
       version: 1.0
       serial: QCCBKQ0JE80300258
       slot: MIDDLE
     *-firmware
          description: BIOS
          vendor: American Megatrends Inc.
          physical id: 0
          version: UX461UN.305
          date: 12/04/2017
          size: 64KiB
          capacity: 8128KiB
          capabilities: pci upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer acpi usb smartbattery biosbootspecification uefi
     *-memory
          description: System Memory
          physical id: 8
          slot: System board or motherboard
          size: 16GiB
        *-bank:0
             description: Row of chips LPDDR3 Synchronous Unbuffered (Unregistered) 2133 MHz (0.5 ns)
             product: K4EBE304EB-EGCG
             vendor: Samsung
             physical id: 0
             serial: 55000000
             slot: ChannelA-DIMM0
             size: 8GiB
             width: 64 bits
             clock: 2133MHz (0.5ns)
        *-bank:1
             description: Row of chips LPDDR3 Synchronous Unbuffered (Unregistered) 2133 MHz (0.5 ns)
             product: K4EBE304EB-EGCG
             vendor: Samsung
             physical id: 1
             serial: 55000000
             slot: ChannelB-DIMM0
             size: 8GiB
             width: 64 bits
             clock: 2133MHz (0.5ns)
     *-cache:0
          description: L1 cache
          physical id: d
          slot: L1 Cache
          size: 256KiB
          capacity: 256KiB
          capabilities: synchronous internal write-back unified
          configuration: level=1
     *-cache:1
          description: L2 cache
          physical id: e
          slot: L2 Cache
          size: 1MiB
          capacity: 1MiB
          capabilities: synchronous internal write-back unified
          configuration: level=2
     *-cache:2
          description: L3 cache
          physical id: f
          slot: L3 Cache
          size: 8MiB
          capacity: 8MiB
          capabilities: synchronous internal write-back unified
          configuration: level=3
     *-cpu
          description: CPU
          product: Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz
          vendor: Intel Corp.
          physical id: 10
          bus info: cpu@0
          version: Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz
          serial: To Be Filled By O.E.M.
          slot: U3E1
          size: 3544MHz
          capacity: 4005MHz
          width: 64 bits
          clock: 100MHz
          capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr s...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.