[mir] mesa-demos

Reported by Jeremy Bicha on 2012-01-11
252
This bug affects 50 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Invalid
Medium
gnome-control-center (Ubuntu)
Undecided
Unassigned
mesa-demos (Ubuntu)
Wishlist
Unassigned

Bug Description

mesa-utils is required for the GNOME System Settings 'Details' panel (formerly 'System Info') to display info about the computer's graphics card driver. Otherwise a rather unhelpful "Unknown" is displayed. mesa-utils was actually in main already (as part of the mesa source package) until Maverick when it was split off as a separate tarball (mesa-demos) that gets released at the same time and by the same people as the main mesa package.

$ apt-cache show mesa-utils
Package: mesa-utils
Priority: extra
Section: universe/graphics
Installed-Size: 148
Maintainer: Ubuntu X-SWAT <email address hidden>
Architecture: amd64
Source: mesa-demos
Version: 8.0.1+git20110129+d8f7d6b-0ubuntu2
Replaces: xbase-clients (<< 6.8.2-38)
Depends: libc6 (>= 2.4), libgl1-mesa-glx | libgl1, libx11-6
Filename: pool/universe/m/mesa-demos/mesa-utils_8.0.1+git20110129+d8f7d6b-0ubuntu2_amd64.deb
Size: 30286
Description-en: Miscellaneous Mesa GL utilities
 This package provides several basic GL utilities built by Mesa, including
 glxinfo and glxgears.
Homepage: http://mesa3d.sourceforge.net/

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: mesa-utils 8.0.1+git20110129+d8f7d6b-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-8.14-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Wed Jan 11 03:16:40 2012
SourcePackage: mesa-demos
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
Changed in mesa-demos (Ubuntu):
importance: Undecided → Wishlist
summary: - [mir] mesa-utils
+ [mir] mesa-demos
Michael Terry (mterry) on 2012-01-13
Changed in mesa-demos (Ubuntu):
assignee: nobody → Matthias Klose (doko)
Matthias Klose (doko) wrote :

- do we need to ship 20MB sources in main for five binaries?
- the package builds binary packages mesa-utils*; why is the source named mesa-demos?
- mesa-utils-extras should stay in universe

maybe I'm pedantic, given that was already in main ...

Changed in mesa-demos (Ubuntu):
assignee: Matthias Klose (doko) → nobody
status: New → Incomplete
Jeremy Bicha (jbicha) wrote :

I don't handle mesa packaging so I don't know why this name was chosen; it's the same as what Debian is doing though.

I don't need mesa-utils-extras in main, just the mesa-utils binary. And I don't see how the source tarball size matters.

Jeremy Bicha (jbicha) on 2012-02-13
Changed in mesa-demos (Ubuntu):
status: Incomplete → New
Michael Terry (mterry) on 2012-02-14
Changed in mesa-demos (Ubuntu):
assignee: nobody → Matthias Klose (doko)
Bryce Harrington (bryce) wrote :

The split and the naming follows Debian.

You might check if the information the System Info panel needs can't just be queried directly from X. We've dealt with several situations so far where various things were depending on parsing glxinfo which were able to get the info more efficiently just making the appropriate C call. Dunno if that's relevant in your case but might be worth checking first.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa-demos (Ubuntu):
status: New → Confirmed
Austin Dempewolff (adempewolff) wrote :

I would just like to add that I've observed (on Ask Ubuntu, for example see this recent one: http://askubuntu.com/questions/145439/enabling-gtx-570) a number of new users--mostly Windows converts--who see the "Unkown" in System Settings and, assuming that this means the card isn't recognized, break their systems trying to fix this non-problem by uninstalling the working drivers/installing the wrong drivers/etc. Although in theory this is a trivial bug, we might want to consider this side-effect that is occurring in practice when determining the urgency of this bug.

Jan Claeys (janc) wrote :

To confirm Austin's observation, another recent one: http://askubuntu.com/q/85318/935

An easy way for users to get correct & complete system information is also important to help such new users.

It would be nice to get this bug fixed. Relating to what Austin Dempewolff said, I was sent off on some kernel testing spree trying to figure out why my graphics driver (Intel Graphics 4000) wasn't being detected. I was on my way to submitting an upstream kernel bug until I came across this.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/914631

tags: added: package-qa-testing

This bug is still present on Ubuntu 12.10 beta. I had to manually install mesa-utils to get the driver type to be displayed on the details tab. System is fully up-to-date, all available updates have been installed!

tomtomtom (tomtomtom) wrote :

What is the problem to fix this bug? We currently have many users trying to "get a driver" because developers are not able to add a simple depency.

It is really annoying to see this. We support many users at http://ubuntuusers.de and this bug affects a lot of users who doesn't have a launchpad account and don't report this here.

But on the support forums we see this and we have to say the users:

 Please don't break your system. The developers are not able to add a depency because they have to discuss the name of the source-package.

Jeremy Bicha (jbicha) on 2012-12-18
Changed in mesa-demos (Ubuntu):
assignee: Matthias Klose (doko) → nobody
Michael Terry (mterry) on 2012-12-19
Changed in mesa-demos (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) wrote :

Seems fine to me, especially since it used to be in main. As for the naming of the package, it's following Debian, so that's fine.

Maintainership doesn't seem *super* great (not often updated in Debian or Ubuntu), but I guess there's not a lot of activity here anyway. Several crasher bugs, but they seem mostly driver related than anything.

It would be nice if we could sync up with Debian, but it's not too important. Only changes are some package metadata stuff. We do have a rather large delta with Debian in the form of the -extras package. But if this is going into main, it's a delta we'd gladly suffer (rather than moving everything into the one package).

Archive Admins: please only promote mesa-utils, *not* mesa-utils-extra. Thanks!

Changed in mesa-demos (Ubuntu):
assignee: Michael Terry (mterry) → nobody
status: Confirmed → Fix Committed
Jeremy Bicha (jbicha) on 2012-12-19
description: updated
Jeremy Bicha (jbicha) on 2012-12-19
Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Adam Conrad (adconrad) wrote :

(base)adconrad@cthulhu:~$ change-override -c main -t mesa-demos
Override component to main
mesa-demos 8.0.1+git20110129+d8f7d6b-0ubuntu2 in raring: universe/utils -> main
Override [y|N]? y
1 publication overridden.
(base)adconrad@cthulhu:~$ change-override -c main mesa-utils
Override component to main
mesa-utils 8.0.1+git20110129+d8f7d6b-0ubuntu2 in raring amd64: universe/graphics/extra -> main
mesa-utils 8.0.1+git20110129+d8f7d6b-0ubuntu2 in raring armhf: universe/graphics/extra -> main
mesa-utils 8.0.1+git20110129+d8f7d6b-0ubuntu2 in raring i386: universe/graphics/extra -> main
mesa-utils 8.0.1+git20110129+d8f7d6b-0ubuntu2 in raring powerpc: universe/graphics/extra -> main
Override [y|N]? y
4 publications overridden.

Changed in mesa-demos (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu9

---------------
gnome-control-center (1:3.6.3-0ubuntu9) raring; urgency=low

  * debian/control.in:
    - Recommend mesa-utils so that the Details panel shows the
      graphics driver name instead of 'Unknown' (LP: #914631)
 -- Jeremy Bicha <email address hidden> Wed, 19 Dec 2012 14:34:16 -0500

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Changed in gnome-control-center:
status: New → Invalid
Sam_ (and-sam) wrote :

This one possibly a merger or dupe. Bug #865957

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.