Blank preview screen

Bug #664300 reported by Tobias Schultze on 2010-10-21
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
High
Mathieu Bastian

Bug Description

Preview is just a blank / empty screen when I refresh. It shows the loading icon which disapears after a few seconds but the preview stays blank. Changing settings doesn't help. Others have experienced the same problem: http://forum.gephi.org/viewtopic.php?f=4&t=546
Graph size doesn't matter. It alway happens.
But the normal Graph mode works fine.

I tried the Seagragon exporter plugin. But it just generated all blank tiles...
I think that results from the same bug.

Hi,

Please give me more information about your system and if this happens only with your graphs or also with the sample ones?

I would also be interested by the log file, could you post it here? Instructions where to find it here: http://wiki.gephi.org/index.php/HowTo_report_a_bug

The stack trace seems to be:

java.lang.IllegalArgumentException: Width (0) and height (0) cannot be <= 0
 at java.awt.image.DirectColorModel.createCompatibleWritableRaster(DirectColorModel.java:999)
 at java.awt.image.BufferedImage.<init>(BufferedImage.java:324)
 at processing.core.PGraphicsJava2D.allocate(PGraphicsJava2D.java:125)
 at processing.core.PGraphicsJava2D.setSize(PGraphicsJava2D.java:116)
 at processing.core.PApplet.resizeRenderer(PApplet.java:930)
 at processing.core.PApplet.run(PApplet.java:1322)
[catch] at java.lang.Thread.run(Thread.java:680)

The issue is somehow related to the processing library, which tries to resize before it has been inited. I'm not sure why and as I'm not able to reproduce the problem, so I'm requesting some help.

I patched some things on the trunk but I'm not sure if it will fix the problem. Is it possible that you try the latest version on the trunk and let me know if the problem still occurs?

You an find the instructions to build the sources here: http://gephi.org/developers/intro/

Thanks

Actually there is an easier way, we have a testing plugin provider.

Go on Gephi > Plugins > Settings and add a new provider with the following address:

http://gephi.org/updates/testing/updates.xml

That will update the DesktopPreview module with my patch

Peter Krantz (peter-krantz) wrote :

I tried the update via the new plugin provider (which is added via Tools -> Plugins -> Settings tab. My Plugins menu is empty).

Unfortunately the bug is still there.

Peter Krantz (peter-krantz) wrote :

I tried the patch with a new graph file approximately half the number of nodes compared to my previous test. 5500 instead of 10000 and now the preview area works!

Ok,

I tried something else, could you please repeat the operation and update Gephi from the testing provider.

Tell me if it solves the problem

Some news?

Updating from the testing provider seems to solve my problem.
The preview now displays nicely. But I haven't tried the Seadragon exporter yet.

Changed in gephi:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Mathieu Bastian (mathieu.bastian)
Zhigang Wu (epzgwu2010) wrote :

I got the same problem of blank previews. However, when I add the testing provider, there is a new available plugin named DrL, but whenever I want to install it, a message displays saying that "Networking problem in http://gephi.org/updates/testing/org-gephi-layout-plugin-drl.nbm"

@Zhigang Wu This problem is not correlated.

About plug-ins, just reboot Gephi at it should work.

Changed in gephi:
milestone: none → 0.7beta
E.R. Dugundji (e-r-dugundji) wrote :

I believe I am experiencing a similar issue as described here with the blank screen.

I successfully installed all available updates from the Gephi Update Center.
However when I tried to install the new available plugin 'DrL' from the Testing provider as described in the reply to Peter Krantz, I got the same issue as Zhigang Wu: "Networking problem in http://gephi.org/updates/testing/org-gephi-layout-plugin-drl.nbm".
Rebooting Gephi unfortunately did not resolve the networking problem to download DrL.

Is the server down? Or has the DrL plugin been removed from this location?
Or do I need to supply manual proxy settings?
When I tried to open the link in a regular browser window, I got a Error 404 - Not Found.

Attached you will find:
1) my log file when I initially tried to open the LesMiserables.gexf test file from the Tutorial.
2) my log file when I was updating Gephi and attempting to download/install 'DrL' from the Testing provider
3) a series of screenshots showing what happens: the Gephi Graph window is simply displaying the previous screen image.

In gephi_graphic-error.gif, you will see my desktop in the Gephi Graph window, after I minimized and then maximized Gephi.

In gephi_graphic-error_contd.gif, you will see the Plugins menu which had been in fact closed after I tried to install 'DrL'. (The 'Available Plugins (1)' tabs indicates 1 remaining plugin, namely 'DrL' which could not be installed due to the networking error.)

OS: Windows Vista 6.0 x86
Java: version: 19.0-b09, Java HotSpot(TM) Client VM, Sun Microsystems Inc.
OpenGL version: 1.5.0 - Build 7.15.10.1502
Vendor: Intel
Renderer: Intel Cantiga

E.R. Dugundji (e-r-dugundji) wrote :

Addendum to my previous post after experimenting some more:

It seems that the the Graph window does indeed function correctly after clicking on the "Overview" button at the top left in Gephi - even without being able to install the 'DrL' patch.

The preview window still fails, however PDF/SVG export is successful even though the preview window has issues.

I encountered 2 minor additional graphical hiccups while following the Tutorial QuickStart with the LesMiserables data with similar workarounds.

* Tutorial slide 9: The nodes pulldown menu is initially empty. After clicking on the edges tab, the nodes pulldown menu is filled.

* Tutorial slide 32: The PNG screenshot operation causes a graphical error with the Graph window, although the PNG export is successful.
By clicking on the "Preview" button at the top, and then returning to the "Overview" button, the network visualization reappears.
Note however: clicking on the "Preview" tab within the "Overview" layout simply yields the white window.
It seems to be necessary to leave the "Overview" layout and then return to it, in order to get the network visualization back.

For reference, I am attaching an additional series of screenshots showing what happens.

A truly wonderful and amazingly powerful program though! :)
I was so impressed while following the Tutorial.
Many, many thanks for your efforts to make Gephi available to the network community.

E.R. Dugundji (e-r-dugundji) wrote :

Attached is also the messages log while following the Tutorial QuickStart.

Hey,

The procedure described here is not valid anymore. Its quite a while the bugfix that used to be only on testing has been integrated in regulat Gephi uodate, so if you update your gephi, you have it.

We only use testing for big releases or in some special cases, the testing repository is currently out-dated compared to the beta one ans shouldn't be used. The DrL is not related to this issue ans is now known as the OpenOrd plugin http://gephi.org/plugins/openord

Please create separate reports or forum topics for the issues you're experiencing, as this bug is closed :-)

Changed in gephi:
status: Fix Committed → Fix Released
Atheg (hoganaj) wrote :

I have this problem, too.

Same problem. I attached my gephi file. Try open and check. I tried in Linux and Windows XP unsucessfull :-/

Tuxkernel...

I am facing the same bug. I am seeing a blank preview screen even for the default graph input files provided with gephi. Uninstalling and reinstalling, downloading all the available plugins, etc nothing worked for us. Kindly guide us on the fix for it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers