The Evolution Mail & Calendaring Tool

Unable to create gmail account

Reported by Julien Olivier on 2012-09-11
300
This bug affects 68 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Medium
gnome-contacts
Invalid
Undecided
Unassigned
evolution-data-server (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

[IMPACT]

 * This bug at a minimum completely breaks adding Gmail accounts to Evolution either directly or with GNOME Online Accounts (GOA). Yahoo Mail is probably also affected.

 * I think this also broke Google Contacts support in the Contacts app as provided by GOA, and may have caused problems in Thunderbird. Both Thunderbird & Contacts are included in the default Ubuntu image.

[TESTCASE]

 1. Add a Google account, either through Evolution directly or with GNOME Online Accounts (Run gnome-control-center online-accounts)
 2. Without this fix, the Google account will appear to be set up but won't actually show up in Evolution.
 3. After applying the fix, log out and log back in (to ensure that the old evolution services are quit and the new ones started).
 4. The Google account that you already added in step 1 will magically work.

Note that if you tried multiple times to get Gmail in Evolution working earlier, those multiple attempts should now be working. Click Edit>Preferences and delete the extra duplicate Gmail accounts.

[Regression Potential]
Zero. This is only installing missing files to fix a high priority bug.

Original bug report
==================
In quantal, I am unable to create any gmail account in Evolution. When I enter my gmail address in the setup wizard, the summary shows that everything is recognized correctly, but when I validate, no account has been created. I have tried with another IMAP account (@free.fr), and it works perfectly.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: evolution 3.5.91-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
Uname: Linux 3.5.0-14-generic i686
ApportVersion: 2.5.1-0ubuntu7
Architecture: i386
Date: Tue Sep 11 11:52:15 2012
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
ProcEnviron:
 LANGUAGE=fr:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
UpgradeStatus: Upgraded to quantal on 2011-04-01 (529 days ago)

Julien Olivier (julo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
paraiko (paraiko) wrote :

I did an upgrade from 12.04 in stead of a fresh install. In my precise installation there was already a gmail account configured which was not shown anymore after the upgrade. I ran the wizard to add the account as described above with the same result.

my google calendar is present and working, but I do not know if it was retained from 12.04 or added after running the account wizard.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-online-accounts (Ubuntu):
status: New → Confirmed

Hi,
I did an upgrade from 12.04 with an already configured GMail account. It was removed after the upgrade. I am not able to configure a new account in evolution. The account wizard is not able to add it to evolution, too.

Marek Tyburec (marek-tyburec) wrote :

I did a fresh install and experience a same problem.

The account addition will succeed if you uncheck the last two checkboxes on the last screen -- those about adding a calendar and contacts to the Google account.

I'm not sure exactly if it's a bug in Evo or in gnome-online-contacts, but the issue is defined enough that we can move this to "Triaged". Setting priority to Medium. We should definitely try to fix this before release, it's very confusing even if the workaround is pretty simple.

Changed in evolution (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
milestone: none → ubuntu-12.10
Changed in gnome-online-accounts (Ubuntu):
status: Confirmed → Incomplete

Set to High after all ;)

Is there anything showing up in ~/.xsession-errors, messages from evolution that could explain the issue seen here?

Could you please attach the output of:

grep evolution ~/.xsession-errors

to this bug report?

Thanks!

Bazon (bazonbloch) wrote :

$ grep evolution ~/.xsession-errors
(evolution-alarm-notify:2263): libecal-WARNING **: Failed to dispose cal view: Verbindung ist geschlossen
(evolution-alarm-notify:2263): Gdk-WARNING **: evolution-alarm-notify: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.

"Verbindung ist geschlossen" = "connection is closed"
"Die Ressource ist zur Zeit nicht verfügbar" = "the resource is not available right now"
(I wish there still was a language selection in LightDM or GDM... :-( )

Thanks for informing about the possibility to uncheck the two checkboxes. I tried to add the calender manually (I want the calender in the Gnome-Shell top-panel!), evolution is showing that google calendar is opened in the statusbar, but this statusbar-status never changes.
I did $ grep evolution ~/.xsession-errors in that state, after trying to add the calendar manually.

Bazon (bazonbloch) wrote :

It is possible to integrate Google Calendar and Contacts anyway:

For the calendar, add an "on the web" calendar and enter the ical-adress of your Google calendar. If you have dates with e-mail-notification, you get an endless series of warning popups saying evolution calendar doesn't support e-mail notifications for dates, so you have to kill it and the process "evolution-calendar-factory".

Google contacts can be integrated the normal way, so I suppose it's really about Google calendar here.

Julien Olivier (julo) wrote :

@Bazon: for the calendar, I simply used the "google" calendar type in Evolution and it works perfectly.

Julien Olivier (julo) wrote :

Related to this bug is the fact that you need to manually add the Google email, contacts and calendar even though they are already configured in gnome-online-accounts. The expected behaviour is that you add your gmail address in gnome-online-accounts, and - automagically - the IMAP account, the contacts and the calendar(s) are configured in Evolution. This is how it works in Empathy.

Bazon (bazonbloch) wrote :

Julien wrote "@Bazon: for the calendar, I simply used the "google" calendar type in Evolution and it works perfectly."

I tried that with the result described in #9.
works for you, doesn't work for me. whyever.

paraiko (paraiko) wrote :

I've attached the output of grep evolution ~/.xsession-errors after running the account wizard in evolution for the addition of a gmail account. I left the checkboxes checked.

paraiko (paraiko) wrote :

additionally: I managed to add my gmail account to evo by unchecking the contacts/calendar boxes
I also manually added contacts to evolution from the contacts tab and it works. I could now also display my google contacts in the gnome-contacts app while this was previously not possible, both contacts and calendar did not showup after adding my gmail account to gnome-online-accounts.

To me this still feels as if it is not an evo bug, but something related to the (gnome-)online-accounts plumbing in ubuntu, but unfortunately a feeling is not the same as proof ;)

Jeffrey Flaker (jflaker) wrote :

I had this working just recently, but wanted to check to see if the bug was still bugging.....

This was tried only after setting up an email account OTHER THAN GMAIL.

If I create the account with an email address of soemthing OTHER than <email address hidden>, then configure the imap and smtp servers manually it works.......BUT only if I uncheck the create calendar and address books at the end of the set up wizard/dialog.

If left checked, the "wizard" looks like it completes, but the email account doesn't show up.

I was able to add the address book from google without trouble, but I can't seem to get the calendar to work.......which is why I removed the account and retried. However, I needed to remove any remnants of evolution being set up by deleting any evolution folders before re-setting up my email accounts.

Jeffrey Flaker (jflaker) wrote :

Another note: I've noticed the use of googlemail.com as some of the gmail domains. As far as I can remember, google is no longer using that domain name. This may be the issue in the calendar too. On setting up the calendar, Evolution will seemingly freeze with noticable network blips on my router. It is as if trying to resolve a domain name or contact a non-existent server.

I know the mail domain names are as follows with common ports for secure and unsecure
imap.gmail.com for IMAP
smtp.gmail.com for SMTP
pop.gmail.com for POP3

I hope this helps. I love Evolution since it, like Outlook, is a unified app for mail and calendar. PLease fix the ills.

Changed in evolution:
importance: Unknown → Medium
status: Unknown → New
Changed in evolution (Ubuntu):
milestone: ubuntu-12.10 → quantal-updates
Changed in evolution:
status: New → Incomplete
Tim (darkxst) wrote :
Jeremy Bicha (jbicha) on 2012-10-17
description: updated
Changed in evolution-data-server (Ubuntu Quantal):
importance: Undecided → High
status: New → Triaged
Changed in evolution (Ubuntu Quantal):
status: Triaged → Invalid
Changed in gnome-online-accounts (Ubuntu Quantal):
status: Incomplete → Invalid
Jeremy Bicha (jbicha) on 2012-10-17
description: updated
Sebastien Bacher (seb128) wrote :

settings to in progress since the upload is in the queue

Changed in evolution-data-server (Ubuntu Quantal):
status: Triaged → In Progress

Hello Julien, or anyone else affected,

Accepted evolution-data-server into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/evolution-data-server/3.6.0-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in evolution-data-server (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Karma Dorje (taaroa) wrote :

$ apt-cache policy evolution
evolution:
  Installed: 3.6.0-0ubuntu3
  Candidate: 3.6.0-0ubuntu3
  Version table:
 *** 3.6.0-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

verification-done

tags: added: verification-done
removed: verification-needed
Karma Dorje (taaroa) wrote :
Julien Olivier (julo) wrote :

I have tested the latest version and, at first, it didn't work: when starting gnome-shell I saw a persistent authentication dialog. As soon as I entered the right dialog, it re-appeared...

I managed to fix it by removing ~/.config/evolution/sources.

Now, it works perfectly. Thanks!

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 3.6.0-0ubuntu3

---------------
evolution-data-server (3.6.0-0ubuntu3) quantal-proposed; urgency=low

  * debian/evolution-data-server.install
    - add missing registry modules (LP: #1049028)
 -- Tim Lunn <email address hidden> Wed, 17 Oct 2012 10:48:32 +1100

Changed in evolution-data-server (Ubuntu):
status: In Progress → Fix Released
Changed in evolution-data-server (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in evolution:
status: Incomplete → Fix Released
Grzegorz G. (grzesiek1e5) wrote :

Shouldn't this bug be marked as invalid in gnome-contacts?

no longer affects: evolution (Ubuntu)
no longer affects: evolution (Ubuntu Quantal)
no longer affects: gnome-online-accounts (Ubuntu)
no longer affects: gnome-online-accounts (Ubuntu Quantal)
Changed in gnome-contacts:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.