Add MARC bibliographic field 758 to the MARC editor

Bug #1780639 reported by Jane Sandberg on 2018-07-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

This is a new field that should be added to the right-click dropdown menus in the MARC Editor: https://www.loc.gov/marc/bibliographic/bd758.html

This is a pretty interesting field with a lot of implications for a transition to linked data. It probably deserves some further discussion of how it should be handled (should it be indexed, displayed, harvested for additional content, etc.).

Cesar V (cesardv) on 2018-11-16
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Revision history for this message
Cesar V (cesardv) wrote :

Not a cataloguer so I can't add much to the discussion on the implications of this new field, but here's a marcedit-tooltips.xml for this particular field and the resulting sql statements (after running the xml thru Open-ILS/src/extras/marc_tooltips_to_sql perl script) that one would use to insert the new field data to the proper config.* tables in order to enable it on the marceditor.

Note - that one may need to "clear local storage settings" in order to force the new fields to populate on the browser.

Also noting, (JIC it's not out there already), that we probably need a separate LP to address that locDoc2xml.xsl is about 10 years out of date... so we can no longer get a fresh marcedit-tooltips.xml from the latest LoC has to offer.

Revision history for this message
Cesar V (cesardv) wrote :
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Revision history for this message
Cesar V (cesardv) wrote :
tags: added: pullrequest
Beth Willis (willis-a) on 2019-03-07
Changed in evergreen:
assignee: nobody → Beth Willis (willis-a)
Revision history for this message
Beth Willis (willis-a) wrote :

Evergreen v.3.2.4

I was able to add MARC field 758 using the right-click dropdown menus in the MARC Editor when creating a new MARC record and when editing an existing MARC record.

I did need to "clear local storage settings" in order to access the new field on the dropdown menu.

I have tested this code and consent to signing off on it with my name, Beth Willis and my email address, <email address hidden>.

tags: added: signedoff
Changed in evergreen:
assignee: Beth Willis (willis-a) → nobody
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Chris Sharp (chrissharp123) wrote :

Pushed to master. Thanks Cesar and Beth!

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: none → 3.next
Revision history for this message
Michele Morgan (mmorgan) wrote :

If I'm reading things correctly, it looks like this bug fix was released in 3.3.0, but I don't see it marked released here, or see it in release notes.

I see the changes here:

https://git.evergreen-ils.org/?p=Evergreen.git;a=shortlog;h=refs/heads/tags/rel_3_3_0

Changed in evergreen:
milestone: 3.next → 3.3.0
status: Fix Committed → Fix Released
Revision history for this message
Remington Steed (rjs7) wrote :

Good catch, Michele. I fixed the milestone and status, and also on another bug in the same situation (bug 1709698).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments