bib record merges should mark bib inactive

Bug #1771386 reported by Rogan Hamby on 2018-05-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.1
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

When the biblio record entry delete command is issued the bib is both flagged as deleted and inactive. The asset.merge_record_assets function is only marking it deleted but not inactive. Both should be done for consistency.

Changed in evergreen:
assignee: nobody → Rogan Hamby (rogan-hamby)
Garry Collum (gcollum) wrote :

While confirming this bug I found a related issue that may require a separate LP entry.

If you undelete a bib in the xul client, active is set to true, deleted is set to false. If you undelete a bib in the web client, active remains false, deleted is set to false.

Changed in evergreen:
status: New → Confirmed
Rogan Hamby (rogan-hamby) wrote :

Branch for this issue at user/rogan/lp1771386_merged_bib_should_be_inactive, 7df1f00a2466324feee56cf0ca89a4d82023dcbf

Garry, did you file a launchpad bug for the webclient undelete behavior?

tags: added: pullrequest
Kathy Lussier (klussier) on 2018-05-25
Changed in evergreen:
assignee: Rogan Hamby (rogan-hamby) → nobody
tags: added: cataloging
Michele Morgan (mmorgan) wrote :
Changed in evergreen:
milestone: none → 3.3-rc
Changed in evergreen:
milestone: 3.3-rc → 3.3.1
Beth Willis (willis-a) wrote :

 I have tested this code and consent to signing off on it with my name, Beth Willis and my email address, <email address hidden>

tags: added: signedoff
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers