web client: item status list view display issues

Bug #1743801 reported by Elaine Hardy on 2018-01-17
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.0
High
Unassigned

Bug Description

Display issues in scan item/item status list view include:

Circulation library is circulating library
Age protection does not display
Circ?,hold,ref? true/false rather than yes/no
Owning library displays numerical code rather than short policy name
Fine level displays numerical code
Loan duration doesn't display
Remaining renewals doesn't display
Circ as type displays as MARC code

Other display issues have been reported elsewhere:
https://bugs.launchpad.net/evergreen/+bug/1743654
https://bugs.launchpad.net/evergreen/+bug/1732975
https://bugs.launchpad.net/evergreen/+bug/1743793

Kathy Lussier (klussier) wrote :

Adding a note that the following are addressed in the branch at bug 1738249.

- Circulation library is circulating library
- Remaining renewals doesn't display

Joan Kranich (jkranich) wrote :

Release 3.0.3

Items with the Holdable field set to False display as set to True in Item Status Detail View and List View.

Jason Stephenson (jstephenson) wrote :

I'm setting the importance to High because it has been identified to me as critical to fix this.

Changed in evergreen:
importance: Undecided → High
status: New → Confirmed
Andrea Neiman (aneiman) wrote :

Owning library displays numerical code rather than short policy name --
 per comment #6 on bug 1738240, this was addressed as part of bug 1738249 (which has a pullrequest, if anyone would like to review).

a. bellenir (abellenir) wrote :

> Circ?,hold,ref? true/false rather than yes/no

this is not specific to this view. all datatype="bool" fields show "true"/"false" instead of "yes"/"no".

Open-ILS/web/js/ui/default/staff/services/grid.js coerces true/false value to (translated) string in javascript: ''+true

comments say: 'Translates bools to Booleans so the browser can display translated value. (Though we could manaully translate instead..)'

a. bellenir (abellenir) wrote :

pushed branch http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/abellenir/lp1743801-copy-status-columns

it fixes the age protection and displays strings for fine level and loan duration.

tags: added: pullrequest
a. bellenir (abellenir) wrote :

> Circulation library is circulating library
i don't understand. is the label wrong or the contents?

> Remaining renewals doesn't display
works for me. remaining renewals is blank for available items, but showed up for items that were checked out.

> Circ as type displays as MARC code
i can replicate, but haven't figured out a fix yet.

Kathy Lussier (klussier) wrote :

As mentioned in comment #1, the circulation library is circulating library issue and the remaining renewals issues were addressed in another bug. Some other issues may have been addressed there too. It probably would be a good idea to review the original report and see which are still relevant and which are taken care of.

Changed in evergreen:
milestone: none → 3.2-beta
a. bellenir (abellenir) wrote :

attaching an optional patch to display "Yes" or "No" instead of "true" or "false" for datatype=bool fields in grids.

NOTE: this effects all datatype=bool fields in grids.

no longer affects: evergreen/3.1
Changed in evergreen:
milestone: 3.2-beta → 3.1.3
a. bellenir (abellenir) wrote :

updated branch user/abellenir/lp1743801-copy-status-columns (http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/abellenir/lp1743801-copy-status-columns) with fleshed circ_as_type field to display desired value.

fixes are now available for all issues in the original report.

Kathy Lussier (klussier) on 2018-06-08
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

Thank you for the code contribution idjit! It works for me, and I've pushed a signoff to the working repo at:
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1743801-copy-status-columns-signoff

I held off on merging it because I would like a second opinion on the way you handled the loan duration and the fine level. The cause for my hesitation was that future development (or possible configuration?) could expand the number of duration and fine levels, but this assumes that there are three distinct levels.

On the other hand, we're already doing something very similar in current Evergreen in the item status full detail view, so it may be perfectly fine. Does anyone else have thoughts on this?

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
tags: added: signedoff
Jennifer Pringle (jpringle-u) wrote :

I tested the fix in 3.1 and it fixes everything listed (and not already fixed elsewhere) except for the issue of true/false versus yes/no.

Should the true/false versus yes/no issue be split into a separate bug report so the patch can be commented on and a decision made about whether it should be included in upstream?

a. bellenir (abellenir) wrote :

Jennifer,

ideally, yes.

from irc (http://irc.evergreen-ils.org/evergreen/2018-06-08#i_363534):
kmlussier: [...] I was going to suggest a new bug for it if people still thought it was an issue. [...]

true/false vs yes/no is also referenced in bug 1741347.

Changed in evergreen:
milestone: 3.1.3 → 3.1.4
Changed in evergreen:
milestone: 3.1.4 → 3.1.5
Bill Erickson (berick) wrote :

Kathy, I have no concerns about your fine level question. As it stands, the levels are hard-coded in the DB. IF they change later, we'll just have to the change the UI to match. I did not test the code, but I did review it, and +1 to merging.

Elaine Hardy (ehardy) wrote :

After applying this to our test servers, I am still not seeing the same issues with attribute display.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Chris Sharp (chrissharp123) wrote :

I opened bug 1788417 to address the "true"/"false" "Yes"/"No" issue since it affects all boolean fields in the grids.

Jason Stephenson (jstephenson) wrote :

Tested the branch this morning with 3.0 and it works for me. I pushed to master, rel_3_1, and rel_3_0.

Thanks, a. bellenir, Kathy, and everyone else!

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
status: Confirmed → Fix Committed
Dan Wells (dbw2) on 2018-08-30
Changed in evergreen:
milestone: 3.1.5 → 3.1.6
milestone: 3.1.6 → 3.1.5
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers