Web Client: mbts fields missing from Patron Bills screen column picker

Bug #1662535 reported by Michele Morgan on 2017-02-07
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.1
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

Evergreen 2.11

The following fields from money.materialized_billable_xact_summary are useful but missing from the web client Patron Bills screen column picker:

Last Billed
Last Billing Note
Last Payment
Last Payment Note
Last Payment Type

Andrea Neiman (aneiman) wrote :

Confirmed 2.12. Noting that those fields are included in the Bill History tabs "Transactions" and "Payments".

Changed in evergreen:
status: New → Confirmed
Joan Kranich (jkranich) wrote :

Evergreen 3.0.3

In addition to the fields noted above, the Patron Bills screen column picker:

Lists Checkout/Renewal Library twice.
Owning Library is missing. Is the term Location replacing the term Owning Library?

Jennifer Pringle (jpringle-u) wrote :

Evergreen 3.1

In addition to all the other fields notes above the Patron Bills column picker is also missing:

Call Number
Shelving Location (in the xul client this column was called Location)

Michele Morgan (mmorgan) on 2018-05-31
tags: added: webstaffcolumns
Terran McCanna (tmccanna) wrote :

Summarizing Missing Fields:

Call Number
Last Billed
Last Billing Note
Last Payment
Last Payment Note
Last Payment Type
Owning Library
Shelving Location

Other Problems:
Checkout/Renewal Library is listed twice, one of them is unusable
Circulation Library won't always load
Type is available but empty

tags: added: billing
Terran McCanna (tmccanna) wrote :

Here is a patch that addresses all of the above missing columns, plus fixes Type.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=ac6caf92e4a8d30a881a298fc0aec9c3a2692125

It does not address the duplicate Checkout/Renewal column due to the way columns are being loaded in groups. I'll start a new bug report for that one. Nor does it address Circulation Library loading issues, which will likely need a separate ticket with additional detail.

tags: added: pullrequest
Changed in evergreen:
assignee: nobody → John Amundson (jamundson)
John Amundson (jamundson) wrote :

Tested on a 3.2.2 system with this patch and the one for Bug #1743783 installed.

Confirmed the columns Terran list in comment #4 are all present. "Location" has been updated to "Billing Location", and "Billing Location" updated to "Grocery Billing Location". "Last Billed" and "Last Paid" are now "Last Billing Timestamp" and "Last Payment Timestamp". These changes feel appropriate to me.

Type now display correctly, (i.e. circulation/grocery).

The Circulation Library loading issue should already be fixed by Bug #1798170

Thanks for your work on this, Terran.

I have tested this code and consent to signing off on it with my name, John Amundson, and my email address, <email address hidden>

tags: added: signedoff
Changed in evergreen:
assignee: John Amundson (jamundson) → nobody
Changed in evergreen:
milestone: none → 3.3-beta1
Jason Stephenson (jstephenson) wrote :

I have tested this on rel_3_1 and it works there, too.

I signed off and committed to master, rel_3_1, and rel_3_2 along with the branch from bug 1743783. I also added a combined release notes file for both bugs.

Thanks, Terran, John, and everyone else who participated in the discussion on this bug!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
Changed in evergreen:
status: Fix Released → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers