Unable to add questions to new surveys

Bug #1573269 reported by Lynn Floyd on 2016-04-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

When creating a new survey, you are unable to add any questions to any survey.

I was creating the documentation with 2.9 and 2.10, then discovered there is not a way to add any questions to a survey.

I was using Sclends.lib.sc.us (2.9.3) and Sitka Test Server testing-210-1.catalogue.libraries.coop(2.10)

Erica Rohlfs (erohlfs) wrote :

I marked this bug incomplete, because I just successfully created a Q&A on 2.10.1 without error. Lynn, will you please step us through the workflow you used?

Changed in evergreen:
status: New → Incomplete
Lynn Floyd (lfloyd) wrote :

I'm attaching the screen shots of what I see on our test server, this is exactly what I saw with our live server, and Sitka's 2.10 demo server.

Lynn Floyd (lfloyd) wrote :

As for the work flow,

1. Add new survey
2. filled in approiate fields.
3. clicked Save Changes.
4. Expected to be able to add a question on the next screen. No where to add question.

Did test using the Old Survey Wizard, and you can add questions via that method, but not via the Survey Menu.

Kathy Lussier (klussier) wrote :

Hi Lynn,

I didn't look at the screenshots yet, but I could never create a new survey question either until I found out that you need to set the survey date for the future. Did you do that?

See the discussion at http://irc.evergreen-ils.org/evergreen/2015-10-29#i_211220

Erica Rohlfs (erohlfs) wrote :

Hi Lynn,

Based on the screen images, it looks like you are trying to create a survey with a retroactive start date. A survey must be created with a start date in the future.

Based on the images, I think this bug may be a duplicate of https://bugs.launchpad.net/evergreen/+bug/1157932

Erica Rohlfs (erohlfs) wrote :

Perhaps we should start a new bug to describe the un-intuitiveness of the survey interface or lack of warning that the survey cannot be created with a retroactive start date.

I think it would be good to add a warning that you need a future date since
the behavior is intentional. A new bug for that would be good (IMO).

On Tue, Apr 26, 2016 at 8:08 AM, Erica Rohlfs <email address hidden>
wrote:

> Perhaps we should start a new bug to describe the un-intuitiveness of
> the survey interface or lack of warning that the survey cannot be
> created with a retroactive start date.
>
> --
> You received this bug notification because you are subscribed to
> Evergreen.
> Matching subscriptions: evergreenbugs
> https://bugs.launchpad.net/bugs/1573269
>
> Title:
> Unable to add questions to new surveys
>
> Status in Evergreen:
> Incomplete
>
> Bug description:
> When creating a new survey, you are unable to add any questions to any
> survey.
>
> I was creating the documentation with 2.9 and 2.10, then discovered
> there is not a way to add any questions to a survey.
>
> I was using Sclends.lib.sc.us (2.9.3) and Sitka Test Server
> testing-210-1.catalogue.libraries.coop(2.10)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evergreen/+bug/1573269/+subscriptions
>

Kathy Lussier (klussier) wrote :

I agree. I'll add a new bug now.

Erica Rohlfs (erohlfs) on 2016-04-26
Changed in evergreen:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers