Survey interface should inform users that new questions can't be created if the start date is retroactive

Bug #1575177 reported by Kathy Lussier on 2016-04-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

When creating a new survey, questions cannot be added if the survey's start date is retroactive. This is intended behavior to prevent users from adding questions after a survey has been added.

However, it isn't clear to the user why they are unable to add a new question. The user simply sees the Questions & Answers heading with no visible means of adding the new question. It would be more intuitive if there was text below the heading informing the user they can only add new questions if the survey's start date is in the future.

Erica Rohlfs (erohlfs) wrote :

Confirmed

There are two related bugs leading to the creation of this one:

https://bugs.launchpad.net/evergreen/+bug/1573269

https://bugs.launchpad.net/evergreen/+bug/1157932

Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier) on 2016-04-26
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

Today seemed as good of a day as any to try my hand at a Dojo interface. Who knows when I'll get the chance again?

My stab at a fix is available in the working repo at:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1575177-survey-new-question-warning

The screenshot at http://www.screencast.com/t/vXqwQ2ap shows the text that will be displayed when the Start Date is not set in the future.

Since this branch introduces a new string, I'll only target it to 2.next.

I'm happy to load this on a Sandbox if anyone wants to look at it!

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
milestone: none → 2.next
tags: added: pullrequest
Mike Rylander (mrylander) wrote :

Picked into master for 2.11. Thanks, Kathy!

Changed in evergreen:
milestone: 2.next → 2.11-beta
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers