I can't boot into my system after a fresh install for 0.3.1 in UEFI mode

Bug #1492256 reported by 賴家亨 on 2015-09-04
96
This bug affects 22 people
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
High
Cody Garver
Ubuntu
Undecided
Unassigned

Bug Description

There were no such problem in 0.3, why does it become this way??

http://i.imgur.com/EOfgLzV.jpg

So I am forced to give up UEFI mode, and go back to Legacy mode now.....

Please fix this....

Tried boot-repair CD, no luck

I don't have your "no such device" message

/boot/efi fat32 300M
/ btrfs 142G

Tried with / ext4, no luck too

賴家亨 (laichiaheng) wrote :

What do you mean?

I tried an UEFI install with / in btrfs and / in ext4

The two of them won't boot. I'm stuck at the same grub prompt of your screenshot

Tried "boot-repair-cd" but it didn't fixed it too.

賴家亨 (laichiaheng) wrote :

In their blog, it says "This release should also improve support for (U)EFI systems, especially when installing without an internet connection.", and I can't boot into the UEFI mode now........what an improvement.

賴家亨 (laichiaheng) wrote :

So...are you in Legacy mode now, Tommy Bok?

Yes, I had no choice

賴家亨 (laichiaheng) on 2015-09-05
tags: added: uefi
tags: added: grub
賴家亨 (laichiaheng) on 2015-09-07
tags: added: freya
賴家亨 (laichiaheng) wrote :

I see, thanks.

Daniel Fore (danrabbit) on 2015-09-11
Changed in elementaryos:
status: New → In Progress
Daniel Fore (danrabbit) on 2015-09-18
Changed in elementaryos:
milestone: none → loki-beta1
Cody Garver (codygarver) on 2015-09-22
Changed in elementaryos:
importance: Undecided → Medium
Cody Garver (codygarver) on 2015-11-13
Changed in elementaryos:
assignee: nobody → Cody Garver (codygarver)
importance: Medium → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Cody Garver (codygarver) on 2015-12-14
Changed in elementaryos:
milestone: loki-beta1 → none
status: In Progress → Fix Released
StevenX (stvnx7) wrote :

I really like the work that elementary is doing. (I'm a monthly finite). This issue affects me though. I can't get my computer to boot. I end up on a grub rescue prompt. Had to go back to Mint for now, but will come back to elementary when there is a fix.

Since the new Elementary release mentioned EFI fixes, I thought this was
solved by now. Did you use the latest version?
On Dec 19, 2015 07:25, "StevenX" <email address hidden> wrote:

> I really like the work that elementary is doing. (I'm a monthly finite).
> This issue affects me though. I can't get my computer to boot. I end up
> on a grub rescue prompt. Had to go back to Mint for now, but will come
> back to elementary when there is a fix.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1446447).
> https://bugs.launchpad.net/bugs/1492256
>
> Title:
> I can't boot into my system after a fresh install for 0.3.1 in UEFI
> mode
>
> Status in elementary OS:
> Fix Released
> Status in Ubuntu:
> Confirmed
>
> Bug description:
>
> There were no such problem in 0.3, why does it become this way??
>
> http://i.imgur.com/EOfgLzV.jpg
>
> So I am forced to give up UEFI mode, and go back to Legacy mode
> now.....
>
> Please fix this....
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1492256/+subscriptions
>

賴家亨 (laichiaheng) wrote :

Yes, is is solved in 0.3.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers