Unable to boot via UEFI into installed freya system [$500]

Bug #1355698 reported by Eduard Gotwig on 2014-08-12
380
This bug affects 79 people
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
High
Cody Garver

Bug Description

I could boot fine into my usb drive on that is elementary Freya Beta 1 running via UEFI.

However, while the install process I got this message:

grub-efi-amd64-signed package failed to install into /target/

Than the installation stopped. probably this has to do with missing GPG keys for Ubuntu packages.

So what I did, was to go to a terminal, and update everything to the latest version. Afterwards the installation process worked without any issue (I checked the log, everything was ok, even the grub2 efi installation)

But after I booted my final system from my installed harddrive, I ended up on a GRUB command line boot prompt, without any error message or anything.

Joel Almeida (joelalmeidaptg) wrote :

I'm trying to install Elementary OS Freya Beta 1 alongside with my Windows 8.1 system using EFI. This is happening to me but no exacly in the same way. For me the install goes smoothly, I have no such errors. But upon rebooting, I simply end with the dreaded black command line from gub. I tried to use boot-repair but whatever options I use, boot-repair always fails. Here's my last report: http://paste2.org/FIpzxftE

I have to mention that the EFI option in my BIOS to booting into elementary OS is working just fine, as well as the Windows one. If I select Windows in my BIOS, the OS boots just fine. If I select elementary, I get the grub screen. I think the problem might be with the version of grub being used by the OS, but I'm not sure.

Also, if I install Ubuntu 14.04 with the exact same setup everything goes fine, so I think my partition-scheme is not no blame. It must be a problem with the elementary installer.

I'm installing elementary using an USB drive. I believe I read somewhere that if you burned the ISO into a DVD instead, the install would work, but I cannot test this myself since I replaced the DVD player of my laptop with an hard drive. Can someone confirm this?

Eduard Gotwig (gotwig) on 2014-08-12
Changed in elementaryos:
status: New → Confirmed

I can confirm this as well.

Rick Kerkhof (rick-2889) wrote :

Confirmed. Acer Aspire V7 UEFI laptop. Boot-repair won't fix this, a reinstall won't fix this, seems nothing I tried fixes this.

Chris Timberlake (game64) wrote :

Confirmed. Macbook Pro Retina 13" 2013. boot-repair also does not fix. No way to access ESP from inside Linux either due to it not installing via EFI.

Diego Medeiros (xeolhades) wrote :

Same here. Notebook Dell Inspiron I14-3437-A45 with Windows 8 and Ubuntu 14.04. Boot-Repair does not fix anything too.

Lime (cloverdale) wrote :

The same thing on Acer V7-582PG.

Eldin SLopez (tscompany09) wrote :

Confirmed. The same thing on samsung laptop np270e4e

tags: added: efi
tags: added: uefi
removed: efi
tags: added: efi
tags: added: grub
tags: added: freya
Cody Garver (codygarver) on 2014-08-13
Changed in elementaryos:
importance: Undecided → High
milestone: none → freya-beta2
Bill O'Dwyer (bill-odwyer-uk) wrote :

Confirmed on a single boot system. Completely unbootable PC.

Mateusz Maćkowski (m4tx) wrote :

I can confirm it as well (dualboot with Windows). However, I have temporary solution, too:

When you see the GRUB command line, type the following commands:

set root=(hdX,gptY)
set prefix=(hdX,gptY)/boot/grub
insmod normal
normal

You should see the normal GRUB screen now. Of course, replace X and Y in hdX,gptX with number of disk and partition you've installed elementary on, for instance sda5 = hd0,gpt5, sdb2 = hd1,gpt2, etc.

Joel Almeida (joelalmeidaptg) wrote :

I can confirm the code provided by Mateusz is working for me. Anyway we can make it boot without entering those lines? It's really bad having to enter them before booting, specially if your keyboard is in another language.

Eduard Gotwig (gotwig) wrote :

This is a general solution for the grub boot prompt, however it has not much to do with a fix of this bug.

I think its a problem somewhere on the package base, be it the wrong packages, double packages or bad signature..

Mateusz Maćkowski (m4tx) wrote :

> it has not much to do with a fix of this bug.
Of course, that's why I said it's *temporary* solution (workaround is even better word here). I just thought some people may find it useful, who really want to boot elementary, even by the most hacky way.

Andrey Gulitskiy (wyorma) wrote :

Same thing. Lenovo B590 laptop (single boot, Freya was installed instead Windows 8) loads into the GRUB command line. "Windows Boot Manager" record in UEFI menu still showing.

Diego Medeiros (xeolhades) wrote :

The workaround provided by Mateusz worked here. Is there any way to make this solution permanent?

Has anyone tried the Boot Repair from another LiveCD, like Ubuntu for example?

Joel Almeida (joelalmeidaptg) wrote :

I tried with Ubuntu and boot-repair live OS and no good.

Parth Doshi (doshi-parth9) wrote :

How are you guys even booting the USB into uefi mode? I've tried to write the ISO using dd, UNetBootin, and even manually writing it but my laptop just won't detect it unless I put it into legacy mode.

Joel Almeida (joelalmeidaptg) wrote :

Check if your flash drive is formated as FAT32. I had that happening to me once, it was because the USB was formated as FAT. As soon as I changed the file system it started working for EFI

Diego Medeiros (xeolhades) wrote :

I used the Startup Disk Creator with a USB formated as FAT32. Works fine.

Florian Albertz (flo-albertz) wrote :

Apparently, grub has 'prefix' set to (hd0,gpt1)/EFI/ubuntu by default. To make the above fix permanent (for now), you can copy your "/boot/efi/EFI/elementary" folder to "/boot/efi/EFI/ubuntu".

Diego Medeiros (xeolhades) wrote :

Someone already tested this fix?

Jefferson (jeffebido) wrote :

Confirmed. Hp Pavilion g4 2216br laptop dual boot with Windows 8.1, boot repair and grub-install do not work.

Mehdi Benadel (murazaki) wrote :

Ok so had a quite similar bug : https://bugs.launchpad.net/elementaryos/+bug/1355290

What I did :

Installed Elementary again ;

My Elementary partition is in /dev/sda4
My EFI is in /dev/sda1

Chose "Install partition boot to /dev/sda".

I installed with wifi ON, there was NO error.

Then I typed in a terminal (based on this method http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd ) :
sudo mount /dev/sda4 /mnt
sudo mount /dev/sda1 /mnt/boot/efi # (I mounted the efi as grub did it when it was working in Ubuntu)

sudo mount --bind /dev /mnt/dev &&
sudo mount --bind /dev/pts /mnt/dev/pts &&
sudo mount --bind /proc /mnt/proc &&
sudo mount --bind /sys /mnt/sys

sudo chroot /mnt

grub-install --verbose --efi-directory=/mnt/boot/efi --boot-directory=/mnt/boot --no-secure-boot-efi --target=x86_64-efi /dev/sda
grub-install --recheck --verbose --efi-directory=/mnt/boot/efi --boot-directory=/mnt/boot --no-secure-boot-efi --target=x86_64-efi /dev/sda
update-grub

It seems like the "no secure boot" feature was of most importance here.

Mehdi Benadel (murazaki) wrote :

Oh yeah sorry, I didn't mention everything was ok after that (needed an update-grub on elementary startup to find Windows though)

Alex Liebensfeld (liebensfeld) wrote :

I can confirm this on my Lenovo Y40-70, although my installation never halted. I can also confirm that m4tx's workaround works in my case.

Joel Almeida (joelalmeidaptg) wrote :

I can confirm that the workaround by Florian Albertz is working just fine. Moving Elementary files into the Ubuntu folder worked just fine. For those who don't know how to do this, I just installed the Disks tool via Software Center in the live OS, mounted the FAT partition in my disk and then just moved the files using FIles. Remember you need to have secure boot disabled to access this partition. Thank you a lot for the tip :)

Martin Giger (freaktechnik) wrote :

I used boot-repair to first remove any existing grub installation and then ran boot-repair (on the freya live disc) with the SecureBoot option disabled, but EFI enabled and my GRUB was fixed.

Diego Medeiros (xeolhades) wrote :

The workaround by Florian Albertz works fine. As Joel Almeida wrote, i just renamed the elementary folder in /boot/efi to 'ubuntu' (after mounting the partition with gnome-disk-utility).

By the way, in previous attempts of elementaryOS installation, I formatted the partition of UEFI and lost my Windows entry. Does anyone know what steps to recover it?

Mehdi Benadel (murazaki) wrote :

Diego, I've been through that situation, and that's a real mess.

You should try to find a backup on your windows partition. look for bootmgr.efi and BCD.log. there should also be a lot of language folders with it. If you got this folder, copy it to (your efi disk)EFI/Microsoft/Boot.

If you don't find BCD.log or if they don't work, try a rescue boot from Windows disk. They have some commands to generate the files.

Mehdi Benadel (murazaki) wrote :

Sorry it's BCD, not BCD.log.

Glove An (980921305-6) wrote :

This bug is caused by /boot/efi/EFI/elementary/grubx64.efi.
In the file grubx64.efi, the GRUB environment variable "prefix" is hard coded with the path "/EFI/ubuntu", which is a wrong path where the grubx64.efi and the grub.cfg are located. So the config file grub.cfg cannot be found by grubx64.efi, and the system failed to boot.

The solution for me is to use a hex editor to change the hard coded path.
1. Use hex editor and open /boot/efi/EFI/elementary/grubx64.efi with root previlege.
2. Find the string "/EFI/ubuntu", and replace it to "/EFI/elementary".
3. Save file and reboot.

Eduard Gotwig (gotwig) wrote :

Ok, so find out which package provides which grub functions to generate these files. Than patch those packages with an elementary version and offer it in our PPA.

Bill O'Dwyer (bill-odwyer-uk) wrote :

Out of curiosity, when a proper, non-workaround fix is released, will it affect the slightly hacky ways we have attempted to fix this problem?

Rick Kerkhof (rick-2889) wrote :

Using Glove An's fix, I get in a boot loop with Shim UEFI key management.

I have three options,
- Continue boot (which doesn't work and throws me back in either Shim or my laptop's boot loader)
- Enroll key from disk
- Enroll hash from disk

None seem to work. I used GHex to make the edit in the live session, Bless wouldn't allow me to save it.
Going to try murazaki's attempt now.

Note that I kicked Windows from my HDD so elementary is a loner now.

Rick Kerkhof (rick-2889) wrote :

I think I found the bug on my side, insert mode was off in GHex. Trying a reinstall of GRUB now and then trying again.

Çağatay Çöl (cagataycol) wrote :

i can confirm this bug too and i did installed elementary luna to another partition after i installed freya. so, i can boot into freya using luna's grub.

Ananyo Sen (ananyo-sen2) wrote :

same here, had to set prefix on every boot, ditched GRUB, currently using rEFInd with EFI stub booting, no problem so far

Daniel Fore (danrabbit) on 2014-08-22
Changed in elementaryos:
assignee: nobody → Cody Garver (codygarver)
status: Confirmed → In Progress

There is a really hacky way of getting around this.

1. First, make sure that secure boot is disabled.
2. The trick I used is to create ANOTHER EFI partition during the installation. This resolves any conflicts that the boot loader may have when it installs into the EFI partition. Although it is recommended that you don't have more than 1 EFI partition, you are going to have to rely on the UEFI BIOS to detect the different boot loader in the BOOT SELECTION menu.

Lets assume that you already have windows installed. This means that there is already an EFI partition, a MSR partition and then your NTFS partitions followed by some free space.

Then while creating the partitions for the linux install, create (another) EFI partition (~400MB), and proceed to create your EXT4 partitions for your different mount points. When selecting the device to install the bootloader to select the PARTITION (sdXY), NOT THE DISK (sdX).

Once the installation is complete you can select which OS to boot into via UEFI boot menu. This also means that GRUB doesn't detect the Windows installation, and hence can be safely removed without affection the boot method of Windows. It is especially useful if you plan on installing multiple linux distros on the same disk (you can use the newly created EFI partition to install GRUB to - and this works because GRUB plays nice with other linux distros)

Cody Garver (codygarver) wrote :

Can someone affected by this test installing this iso?:

http://downloads.elementaryos.org/isos/elementaryos-grub-test-amd64.20140826.iso

Let me know if it works

Cody Garver (codygarver) on 2014-11-03
Changed in elementaryos:
assignee: Cody Garver (codygarver) → nobody
status: In Progress → Confirmed
harris (harrismrubin) on 2014-11-12
summary: - Unable to boot via UEFI into installed freya system
+ Unable to boot via UEFI into installed freya system [$135]
hoang (hoangksn) on 2014-11-19
Changed in elementaryos:
assignee: nobody → hoang (hoangksn)
ponschy (ponschy) on 2014-11-20
information type: Public → Public Security
information type: Public Security → Public
Daniel Fore (danrabbit) on 2014-11-24
summary: - Unable to boot via UEFI into installed freya system [$135]
+ Unable to boot via UEFI into installed freya system [$500]
tags: added: bounty
Changed in elementaryos:
assignee: hoang (hoangksn) → nobody
Eduard Gotwig (gotwig) on 2014-12-07
Changed in elementaryos:
assignee: nobody → Eduard Gotwig (gotwig)
Daniel Fore (danrabbit) on 2014-12-09
Changed in elementaryos:
assignee: Eduard Gotwig (gotwig) → Cody Garver (codygarver)
status: Confirmed → In Progress
Daniel Fore (danrabbit) on 2014-12-11
Changed in elementaryos:
status: In Progress → Fix Committed
hoang (hoangksn) on 2014-12-11
Changed in elementaryos:
status: Fix Committed → Fix Released
70 comments hidden view all 150 comments
Abhinav (agauniyal) wrote :

Another Install here , No matter what I did , OS didn't installed till I chose Legacy mode in my BIOS.

iso: uefi 7
computer: Lenovo G500s
boot conf: Legacy mode, Single Boot, Fresh Install
Result : Sucess

Another thing I noticed is , my /boot/grub/ now contains i386-pc folder and files along with fonts and other things while my laptop's architecture is x64. During installation , it installed grub2 while showing terminal text as i386. Is that default behaviour?

Abhinav (agauniyal) wrote :

Another way to solve the problem , googled around a bit : http://askubuntu.com/questions/400400/ubuntu-12-04-grub-efi-amd64-signed-failed-to-install-into-target , < found this.
I chose to install updates and installation proceeded flawlessly on UEFI-Secure Boot(off). Maybe upgrading all the packages on the ISO will solve it.

Linus Bobcat (biobunny-exe) wrote :

Given that Hoang had 0 activity whatsoever on Launchpad, and that this bug should not be marked "Fix Released" until Freya Beta 2 is released, or until the fixes land in the daily builds, which to my knowledge it didn't, I'm marking this back into fix committed.

Linus Bobcat (biobunny-exe) wrote :

Never mind, it's not possible on my side. Apologies for the spam.

Daniel Fore (danrabbit) on 2014-12-12
Changed in elementaryos:
status: Fix Released → Fix Committed
Oliver Nagel (rulestormer) wrote :

Running a dualboot Win8.1 and Freya, and I can confirm that uefi7 works.
Many thanks for the effort!

My PC spec, if it's of any help:
Intel Core i5-4670K
ASUS Z87-PRO
AMD R9-280X

Bill O'Dwyer (bill-odwyer-uk) wrote :

Haven't tested the installation yet, but both isos (uefi2 & uefi7) are unbootable if using dd to make a USB.

My laptop is
ASUS N550JK
I7 4700HQ
 Windows 8.1 Update 1
Using above ISO doesn't solve the problem for me.

James Carroll (glitterbrew) wrote :

I've managed to successfully install elementary with UEFI mode turned on with the UEFI 7 ISO above after messing around with it a little, having previously being unable using DD alone. After using DD to copy over the Linux Mint ISO, and then the elementary ISO, I noticed that - at least under gparted's interpretation - the USB stick produced by the elementary ISO didn't have any real/recognised partitioning ( although it worked fine to boot under BIOS compatibility mode), whereas the Linux Mint stick had two partitions, one containing the boot files, and one containing the rest of the system.

With that in mind, I completely zeroed out the USB stick I was using, and using gparted created a GPT partition table and filled up all the remaining space with a single fat32 partition. This is important from what I'm aware of because UEFI looks for the first fat32 partition it can find to find the boot files, so if the partition wasn't fat32 then it wouldn't be bootable at all, it's not essential for there to be a seperate boot partition either so having just one main partition simplifies things. Once a GPT partition table with one partition on it in with a fat32 filesystem has been created, just copy and paste the files from the elementary ISO over to the USB stick and it will work completely fine for the purposes of UEFI. Obviously copying and pasting the files could be done by any program capable of extracting the ISO, local loopback, etc.

After that's been done, I was successfully able to install the elementary uefi 7 ISO above in uefi mode on the computer, and it works perfectly. It won't solve any incompatibilities with Ubuntu/Derivatives mentioned above, but does boot and otherwise work exactly as expected.

I'm not exactly sure how the ISO image is generated in the first place, one potential trick to get more testing on this would be to create the usb stick as I described, use DD to create an image of the USB, and then ship that alongside the main ISO for this specific purpose of getting uefi capable computers to work, but creates unnecessary confusion and isn't ideal when shipping the stable ISO.

Stinger (e-mindahl) wrote :

Re #118
Now we know what the FAT partition is needed for. Recognition of the USB-pen. Thanks for the explanation :) .
I pointed this out in #52

To sum it up:
Freya is now capable to install on most UEFI systems if you use a DVD as install media.

If you use a USB-pen you can't be sure that it'll boot unless you use the workaround in #118
I think it is a matter of how you create your USB-pen. If you use the dd command , you end up with a USB-pen that most likely won't boot on a UEFI-system because of the missing FAT boot partition.

I'm changing the bug status to 'In progress' cause it's not fixed for booting on a USB-pen created via the dd command.
You, the developers, can change it back if you disagree but please explain why, if you do.

Changed in elementaryos:
status: Fix Committed → In Progress
Daniel Fore (danrabbit) wrote :

if you can burn an ubuntu or debian uefi/secureboot iso with dd and it still works but it does not for elementary OS, please file a new bug report.

This report as it was reported has been fixed.

Changed in elementaryos:
status: In Progress → Fix Committed
Stinger (e-mindahl) wrote :

Re #120
Thank you for the explanation.
Will do some tests with dd and USB-stick's and report if necessary.
I hope that anyone else on this bug report , who has the same or a similar issue, will do so to.

Rene Arts (renearts) wrote :

I was able to install the elementary iso via EFI from #99 from a USB made with Unetbootin without any problems whatsoever.

Stinger (e-mindahl) wrote :

Re #122
I can tell you why.
Unetbootin only accepts a USB-pen with a FAT32 partition thereby ensuring that you can boot from a UEFI system.
If you USB-pen hasn't got a FAT32 partition you'll have to create it yourself, or it won't accept you pen.

If you use the dd command ( or gnome-disks for that matter ) you don't have to care about partitions because these tools just dumps the raw disk image on the USB-pen no matter what content was on it before.

But there is something wrong with the iso from elementary , it doesn't automatically create a 2,4MB FAT boot partition like Ubuntu or Mint does when you use dd ( though it seems to be present on the iso ), thats why it's essential that you use a tool like Unetbootin if you have a UEFI system, because a UEFI system requires a FAT32 boot partition to boot from USB.

Phillip Sz (phillip-sz) wrote :

@123 open a new bug then!

Akshay Shekher (voldyman) wrote :

[don't mind me, i am just testing the bot]

http://i.imgur.com/mHWtnqV.gif

Cody (stillcms) wrote :

I just bought a windows laptop with UEFI and I really want to dual boot with Freya when it comes out! Please make it as newbie friendly as possible!

Fred (freddesch62) wrote :

Thank you.
Running a dualboot Win8.1 and Freya, and I can confirm that uefi7 work

My PC spec:
ASUS ZENBOOK UX305FA
Intel Core M 5Y10 (broadwell)
INTEL HD graphics 5300

Abhinav (agauniyal) wrote :

I didn't experienced whatsoever problem with UEFI and FAT partition stuff , probably because I used Universal Usb Installer. But whenever I try to install freya ( either by that sourceforge iso or this UEFI7 Iso provided here) , if I do not opt for installing updates , the installation fails with this message : " grub-efi-amd64-signed package failed to install into /target/ ".
And yet I'm seeing fix committed status here. I have successfully installed freya on three of my systems , but that were with updates being downloaded at installation time. BUT it isn't necessary that I would have an internet access everytime I would install freya. If this could get fixed , it would be of great help.

Abhinav (agauniyal) wrote :

There is similarly unnoticed bug here too : https://bugs.launchpad.net/elementaryos/+bug/1245436 , with a fixed committed status. If you guys have already noticed these two , thanks for doing that :) , just ignore this and the post above ^ .

Linus Bobcat (biobunny-exe) wrote :

@Abhinav, "fix committed" means that a developer submitted the fix to the codebase. "Fix Released" means that a new (and public) version of the software with the fix has been released. There are sometimes exceptions where a "Fix Committed" means "Fix Released," because it's hard for elementary to manage 5000 bugs. Since there are no daily ISO builds of Freya publicly available, the "UEFI7" build being a special case, this bug will only be truly fixed once Freya Beta 2 is released. I'm not sure what the case is with the second bug you mentioned. If your first issue is still an issue after a fresh install of Freya Beta 2, report a new bug.

To others reporting success with the UEFI7 build, I hope you all enjoy elementary OS, but this bug has already been confirmed to be fixed.
Every comment here sends an email to every elementary developer that is associated with this bug, and it'd be nice to not send more "this bug has been fixed" emails to a bug that already has been fixed.

If you did encounter a special case where the fix does *not* work, please report a new bug for that issue.

Doesn't work for me.

Iso: uefi7
Computer: Acer Aspire V5
Windows 8.1 update1

Paulo Molina (polochamps2004) wrote :

The new iso works for me.

Thureos (thureos) wrote :

@Paulo Molina,

What iso did you use?

Paulo Molina (polochamps2004) wrote :

@Thureos

Works most of the time. http://downloads.elementaryos.org/isos/elementaryos-uefi7-amd64.20141209.iso
Source: https://bugs.launchpad.net/elementaryos/+bug/1355698/comments/90

@ALL

When I had problems with my DNS/Internet connection, the installation fails. I don't exactly know if it pulls the UEFI fix from the internet. I reinstalled it for more than 30 times using 3 different internet connections and different DNS servers.

When it works, the installation proceeds with lots of files pulled through from the server. But when it fails, the installation is very quick to finish before the dreaded "grub-efi-amd64-signed" appears.

Secure boot on and off doesn't make a difference.

Can anyone confirm if it pulls some/most of the UEFI fix through the internet?

Thank you

Paulo Molina (polochamps2004) wrote :

One thing to add when the installation fails meaning when this "grub-efi-amd64-signed" appears, it usually creates 5 partitions as opposed to the usual 3 partitions.

Partition#1 - 1MB Free space
Partition#2 - EFI
Partition#3 - EXT4
Partition#4 - Swap
Partition#5 - 1MB Free space

It is always like this when it fails.

Thureos (thureos) wrote :

@Paulo Molina,

Thanks,

Daniel Fore (danrabbit) on 2015-02-09
Changed in elementaryos:
status: Fix Committed → Fix Released
Paulo Molina (polochamps2004) wrote :

Hi Daniel,

Still had the bug like what I described in post #134.

Thank you

Latest Beta 2 release doesn't solve UEFI problem for me.
I am running ASUS N550JK with Windows 8.1.
I tried UltraISO and UnetBootin to burn iso into usb with partition type FAT and FAT32...

Doesn't work for me either. :( I have and Asus laptop as well. When I click install, or try install, the elementary logo comes on for a few seconds and then the screen turns black and it doesn't work.

CodeMan99

> On Feb 10, 2015, at 9:48 AM, Abdur Rehman <email address hidden> wrote:
>
> Latest Beta 2 release doesn't solve UEFI problem for me.
> I am running ASUS N550JK with Windows 8.1.
> I tried UltraISO and UnetBootin to burn iso into usb with partition type FAT and FAT32...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1355698
>
> Title:
> Unable to boot via UEFI into installed freya system [$500]
>
> Status in elementary OS:
> Fix Released
>
> Bug description:
> I could boot fine into my usb drive on that is elementary Freya Beta 1
> running via UEFI.
>
> However, while the install process I got this message:
>
> grub-efi-amd64-signed package failed to install into /target/
>
> Than the installation stopped. probably this has to do with missing
> GPG keys for Ubuntu packages.
>
> So what I did, was to go to a terminal, and update everything to the
> latest version. Afterwards the installation process worked without any
> issue (I checked the log, everything was ok, even the grub2 efi
> installation)
>
> But after I booted my final system from my installed harddrive, I
> ended up on a GRUB command line boot prompt, without any error message
> or anything.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1355698/+subscriptions

Cody (stillcms) wrote :

I tried burning the image with unetbootin, and Rufus. When I click burn it says "D: failure". Does this sound like a It10t error or a bug?

Andrew Malyhin (katoquro) wrote :

I have tried with build 20150208. The problem is still there

Andrew Malyhin (katoquro) wrote :

There is no efi option when I select type of file system in gui step "something else".
I've tried linux mint 17 after that and it has.
Corect me if I am wrong, bouth are based on the same ubuntu version which supports efi

sachintha (c4c5nf3) wrote :

 I first installed ubuntu 14.04, which installed grub in the EFI, and then I removed ubuntu and installed elementary os freya. Laptop was still booting into windows directly. then after googling it found this solution, in windows command prompt tried this and worked :)
bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

Mehdi Benadel (murazaki) wrote :

Hi Sachintha,

You're a little off topic. But just for the advice :

You shouldn't have to ask windows bootloader system to let you access linux, the BIOS should do it. I hope you can still access Windows ?

You should be able to access directly to Grub by modifying the boot option in the BIOS (type F1, F10 or Del when you turn on your computer). In the boot options (or Hard Drive Boot Order), there should be several efi boot options, like Windows, Ubuntu, etc. . The Ubuntu one should bring you to Grub.

FYI: You might have several Ubuntu boot options since you installed ubuntu then elementary, but both should lead to the same grub (if you didn't change your partitions and installed elementary on the old ubuntu disk).

Hi,
I tried to install the elementaryos-freya-amd64.20150411.iso to MacBook Air (1,1) and the message "grub-efi-amd64-signed package failed to install into /target/" appeared after installation was compete.
I was previously installed and booted Fedora 21 without problem.

sachintha (c4c5nf3) wrote :

i solved it,,,( i had this problem with Freya final version (not with beta))

when install create root and swap in normal way,,,
additionaly
i add 500 mb /boot partion
(select boot partion & root before install)

After installed i still get the error msg,,,

then i try to install grub menu manually,,
i booted with ubuntu live usb,,,

then install boot-repair
https://help.ubuntu.com/commun...

first try Rrecommended Repair,,
if its not work
Go to Advanced optioned...
Here i tried with 2,3 time with different setting until it get work,,,

This Important,,,
set In Grub Location Tab--
os to boot by default-- select elemntary os sdaX here,,
seperate/boot/efi partion---select that 500mb sdaX

this will be vary to pc to pc(my pc Asus S550),,,

sorry for my English

Andrew Malyhin (katoquro) wrote :

2 sachintha: Sorry but even it works, I don't think that it's normal way to support UEFI boot in elementary...
2 all: I don't understand why it cannot be done the similar way to Ubuntu distro?

Darrell Swafford (darelster) wrote :

Anyone having problems booting the DVD on a EFI machine? It will not boot where as other EFI distros will such as Manjaro.

Any ideas?

Cant get elementary installed if it wont boot from dvd / flashdrive

Joel Handwell (joelhandwell) wrote :

I tried to install the elementaryos-freya-amd64.20150411.iso in Gateway SX2110G and got following error while installation:
"grub-efi-amd64-signed package failed to install into /target/"

Fabio M. Panico (fbugnon) wrote :

I can confirm this, but also wanted to point that I could work around this but by simply having Internet connected during the install process.

Displaying first 40 and last 40 comments. View all 150 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions