Indicators do not show in Pantheon

Bug #1301699 reported by Daniel Fore on 2014-04-03
78
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Application Indicators
New
Undecided
Unassigned
Indicator Date and Time
New
Undecided
Unassigned
Session Menu
New
Undecided
Unassigned
The Sound Menu
New
Undecided
Unassigned
elementary OS
Fix Released
Medium
elementary OS team
indicator-datetime (Ubuntu)
Undecided
Unassigned
indicator-network (Ubuntu)
Wishlist
Unassigned
indicator-session (Ubuntu)
Trusty
Medium
Unassigned
indicator-sound (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]

It looks like "OnlyShowIn=Unity;GNOME;" has been added to indicator-datetime, indicator-session, and indicator-sound

We should provide a patch to add "Pantheon" to that list.

[Test Case]

(1) install the Pantheon desktop sesssion (eg. Elementary OS) and log in
(2) verify the appropriate indicator (for this case, session indicator) appears
(3) install the Unity 7 desktop session and log in
(4) verify the indicator still appears

[Regression Potential]

A typo in the modified .desktop file could cause the indicator to not appear in a Ubuntu session such as Unity 7 or Gnome Flashback.

Related branches

Cody Garver (codygarver) on 2014-04-03
Changed in elementaryos:
assignee: nobody → Cody Garver (codygarver)
status: Confirmed → In Progress
tags: added: os-patch
removed: patch
Daniel Fore (danrabbit) on 2014-04-03
summary: - Patch Indicators to show in Pantheon
+ Indicators do not show in Pantheon
description: updated

I've submitted merge requests for the indicators you requested, as well as for indicator-application.

Cody Garver (codygarver) on 2014-04-09
Changed in elementaryos:
assignee: Cody Garver (codygarver) → nobody
assignee: nobody → elementary OS team (elementary-os)
description: updated
Justin Zobel (justin-zobel) wrote :

Can someone release this so I can test? :)

Cody Garver (codygarver) wrote :

All the default indicators are patched and working again except bluetooth. Needs further investigation.

"indicator-bluetooth" seems to be a mobile-only package, the one we're interested in is "gnome-bluetooth".

Cody Garver (codygarver) wrote :

Bluetooth indicator present in iso I tested

Changed in elementaryos:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+14.10.20140611-0ubuntu1

---------------
indicator-datetime (13.10.0+14.10.20140611-0ubuntu1) utopic; urgency=low

  [ Charles Kerr ]
  * when src/timezone-file.c reads the contents of a file, skip lines
    that begin with '#' (LP: #1312775)
  * Use the Suru Arpeggio as the default alarm sound. (LP: #1309063)
  * Prefer to use ubuntu-platform-hardware-api for wakeups when possible
    s.t. user-defined alarms/appointments can wake up the phone from
    sleep to give a snap decision. (LP: #1299916)

  [ Sergey "Shnatsel" Davidoff ]
  * Add Pantheon, the desktop environment of elementary Project, to
    OnlyShowIn lists in .desktop files. (LP: #1301699)
 -- Ubuntu daily release <email address hidden> Wed, 11 Jun 2014 12:36:52 +0000

Changed in indicator-datetime (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+14.10.20140611-0ubuntu1

---------------
indicator-sound (12.10.2+14.10.20140611-0ubuntu1) utopic; urgency=low

  [ Ted Gould ]
  * Protect against icon serialization errors (LP: #1305902)

  [ Sergey "Shnatsel" Davidoff ]
  * Add Pantheon, the desktop environment of elementary Project, to
    OnlyShowIn lists in .desktop files. (LP: #1301699)
 -- Ubuntu daily release <email address hidden> Wed, 11 Jun 2014 17:25:52 +0000

Changed in indicator-sound (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) on 2014-11-20
Changed in indicator-session (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Medium
Stephen M. Webb (bregma) on 2014-11-20
description: updated
Antti Kaijanmäki (kaijanmaki) wrote :

i-network requires the indicator-panel-service to implement custom items such as AccessPointItem and ModemInfoItem. Before unity7 or any other DE implements these, i-network is not usable on them.

Changed in indicator-network:
status: New → Triaged
importance: Undecided → Wishlist

Hello Daniel, or anyone else affected,

Accepted indicator-session into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/indicator-session/12.10.5+14.04.20140925-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-session (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Stephen M. Webb (bregma) wrote :

Marked as verification-done after correspondence with Sergey.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for indicator-session has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.5+14.04.20140925-0ubuntu1

---------------
indicator-session (12.10.5+14.04.20140925-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * When logging out, prefer com.canonical.Unity.RequestLogout over
    org.gnome.SessionManager.Logout. (LP: #1296814)
  * Install translations into the correct directories. (LP: #1318980)

  [ Sergey "Shnatsel" Davidoff ]
  * Allow Pantheon as a valid show-in target. (LP: #1301699)
 -- Ubuntu daily release <email address hidden> Thu, 25 Sep 2014 15:07:42 +0000

Changed in indicator-session (Ubuntu Trusty):
status: Fix Committed → Fix Released
Pete Woods (pete-woods) on 2015-03-26
no longer affects: indicator-network
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
Changed in indicator-network (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers