LibreOffice Productivity Suite

After upgrade to KDE 4.7 all tooltips in Libre Office are black on black

Reported by Robert Simmons on 2011-08-03
148
This bug affects 36 people
Affects Status Importance Assigned to Milestone
KDE Base
Unknown
Medium
Kubuntu PPA
Undecided
Unassigned
LibreOffice Productivity Suite
Confirmed
Low

Bug Description

I upgraded to KDE 4.7 from ppa:kubuntu-ppa/backports and after the upgrade all the tooltips in LibreOffice are
suddenly black text on a black background.

Reproducible: Always

Steps to Reproduce:
1) Install Libre Office and KDE 4.7.0
2) Open a LibreOffice document.
3) Hover over anything to make a tooltip appear.

Actual Results:
Black text on black background tooltips.

Expected Results:
Black text on blue background like the rest of the tooltips.

I am using the following versions:
Kubuntu 11.04
Libre Office 3.3.2
KDE 4.7.0

Changed in libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in kde-baseapps:
importance: Unknown → Medium
status: Unknown → New
Kayvee (vkkodali) wrote :

I have the exact same issue. I am using Kubuntu 11.04, KDE 4.7.0 with LibreOffice 3.3.3
Picture of it is attached

Changed in kde-baseapps:
status: New → Unknown
Pak (paolo-tezza) wrote :

After updating to kde 4.7 I got the same behaviour...
kubuntu 11.04
kde 4.7
libreoffice 3.3.3

Torge (tdellert) wrote :

Same here..

Kubuntu 11.04
KDE 4.7
LibreOffice 3.3.3

I made the tooltips readable again by changing the colours manually at

System Settings > Application Appearance > Colors > Colors tab > Tool Tips Background / Tool Tips Text

I would prefer the original tooltip colors, though.

Created attachment 50664
You can see the bug here.

I have installed KDE 4.7 recently, and bound the KDE theme to LibreOffice thanks to a package my distribution (ArchLinux) provides.

Without this package, I see the UI as in Java I suppose... Whatever,

With the KDE style, the UI is perfect, but the tooltips are written in black on a black background.

The only solution I've found at the moment is to change theme...

I am using the Oxygen colorset (default) in KDE (this is the colorset which puts the tooltips in blackOnBlack).

Deactivate/Reactivate tooltips in LibreOffice options does not fix the issue.

I get the same thing on an earlier LO version.

LibreOffice 3.3.3
OOO330m19 (Build:301)
tag libreoffice-3.3.3.1, Ubuntu package 1:3.3.3-1ubuntu2

running on

Linux 2.6.38-10-generic running KDE Development Platform 4.7.00 (4.7.0)

memartin (memartin) wrote :

The same here on Oneiric 11.10 beta 32bit, LO 3.4.2, KDE 4.7.1

memartin (memartin) wrote :

AFAICS LO respects the system's tooltip background color, but forces black as foreground/text color. This makes LO's tooltips unreadable with dark tooltip backgrounds.

Valter Mura (valtermura-gmail) wrote :

I confirm the same result in my system:

Kubuntu 11.04
KDE 4.7.0
LibreOffice 3.3.3

But the problem is nor here in Kubuntu neither in KDE (tooltips in other programs are displayed correctly), it is supposed to be in LibreOffice, as memartin indicates.

*** Bug 40827 has been marked as a duplicate of this bug. ***

I am not going to mess with your bug database, but I surely think this is a duplicate of bug 39784.

*** Bug 39784 has been marked as a duplicate of this bug. ***

*** Bug 39781 has been marked as a duplicate of this bug. ***

Changed in libreoffice:
status: Confirmed → Invalid
Imad (md-imad) wrote :

Can confirm the same after upgrading to Kubuntu 11.10

Peter (peterroots) wrote :

why has this bug been set to invalid - when it is a bug that affects people?
I can confirm it is present on Kubuntu 11.10 (64bit) KDE 4.71 LibreOffice 3.4.3

Removal of the kde integration package solves the problem but you get the horrible LO open/save dialogues and a not so nice toolbar appearance.
If kde integration was giving true integration then the kde colours for both tooltip background and text colour should be respected, which they are not. As previously mentioned (memartin) only the background colour is respected but text colour is ignored. THAT is a bug.

From a suggestion elsewhere, I've put the following in my .bashrc
export OOO_FORCE_DESKTOP=gnome
which solves it for me

This is listed as fixed. Can someone tell me which version it is fixed in?

The next one.

I also have this problem with kubuntu installation.

There is two possible solutions:

1) change default kde tooltip background color to something light (like light yellow)
2) change libreoffice kde ui to use the correct theme background color. My gtk apps (firefox, chrome) use light blue backgound with black font color.

It seems to be a bug in the libreoffice that does not use the correct pallete color for tooltip font color. The default kubuntu kde tooltip color is white over black.

mebuntu (salsa-temps) wrote :

changing tooltip ( system settings > application appearance > colours > colours > common colours > tooltip background ) to light grey background fixes for me.

I removed 'libreoffice-kde' totally from my system, because it caused crashes when pasting rich text. It also solves the tooltip issue, although then of course you also lack the KDE integration..

Accroding to commentary 6 https://bugs.freedesktop.org/show_bug.cgi?id=40461#c6 this bug shoulf be fixed now, but it's still reproduced even with LibreOffice 3.4.5 from LIbreOffice PPA (libreoffice-kde package is updated too).

I am now using 3.4.4 and this is not fixed. My Kubuntu version is now 11.10 and using KDE 4.8.0.

Andrew (andrewgrant31) wrote :

The solution proffered by Torge and mebuntu works wonderfully!
Thanks!

Uqbar (uqbar) wrote :

Andrew, what Torge suggested is a "working workaround", not a solution.
The solution is to fix, i presume, the kde-config-gtk so that any GTK+ application (like Google Chrome) use the colors I specify in the KDE settings.
Anyway, workaround at #12 also works, even if I'm not experiencing any issue but the tool-tip thing.

Hello Uqbar,

Firefox, google-chrome and others use the correct tooltip bgcolor. So, I conclude that it is not kde-config-kde problem. I think that the problem is with libreoffice or libreoffice-kde, which is using the wrong background color.

Hum... now I noticed that the gtk colors are not the same of kde. They just don't use kde colors.

Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed
jude dawson (judedawson) wrote :

Thanks for the workaround. I'm happy.

Still here.

LO 3.4.4
KDE 4.7.4
Kubuntu 11.10

It also affects the formula tooltip, the one with the syntax.

Fixed for me with update to LibreOffice 3.5.

Changed in kubuntu-ppa:
status: New → Invalid
Götz Christ (g-christ) on 2012-03-03
Changed in kubuntu-ppa:
status: Invalid → Fix Released

I saw this happening in version: LibreOffice 3.4.4 OOO340m1 (Build:402) (current in Ubuntu Oneiric).
I found that the tooltip background and foreground colours obey the KDE text colour settings Tooltip Background and View Text, respectively.
(These are the names as listed under System Settings -> Application Appearance -> Colours -> Colours tab -> Colour set: Common Colours. They seem to have different names depending on where you go to edit them.)

I have since upgraded to the current Oneiric version in ppa:libreoffice/ppa (LibreOffice 3.5.0 Build ID: 350m1(Build:13)).
With this build, the colours are taken from Tooltip Text and Tooltip Background colour settings as expected.

So, someone has fixed this bug, and the Tooltip Background/View Text settings provide a workaround for older versions.
Of course, a backport would be nice, if any package maintainers are watching... ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.