Debian GNU/Linux

synaptic crashes immediately on startup with SIGABRT in raise() when run with UTF-8 locale/l10n strings

Reported by Jeremy Bicha on 2011-09-02
414
This bug affects 74 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
synaptic (Debian)
New
Unknown
synaptic (Ubuntu)
Medium
Unassigned

Bug Description

.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: synaptic 0.75.2ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Thu Sep 1 21:45:07 2011
ExecutablePath: /usr/sbin/synaptic
ProcCmdline: /usr/sbin/synaptic
Signal: 6
SourcePackage: synaptic
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 std::terminate() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
Title: synaptic crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Jeremy Bicha (jbicha) wrote :

StacktraceTop:
 __gnu_cxx::__verbose_terminate_handler () at ../../../../src/libstdc++-v3/libsupc++/vterminate.cc:95
 __cxxabiv1::__terminate (handler=<optimized out>) at ../../../../src/libstdc++-v3/libsupc++/eh_terminate.cc:40
 std::terminate () at ../../../../src/libstdc++-v3/libsupc++/eh_terminate.cc:50
 __cxxabiv1::__cxa_throw (obj=0xd58780, tinfo=<optimized out>, dest=<optimized out>) at ../../../../src/libstdc++-v3/libsupc++/eh_throw.cc:83
 std::__throw_out_of_range (__s=0x492033 "vector::_M_range_check") at ../../../../src/libstdc++-v3/src/functexcept.cc:82

Changed in synaptic (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Jeremy Bicha (jbicha) on 2011-09-02
visibility: private → public
Changed in synaptic (Ubuntu):
status: New → Confirmed

This works for me now so I'm going to go ahead and close this bug since I was the guy who reported it. :-)

Changed in synaptic (Ubuntu):
status: Confirmed → Invalid
Extender (msveshnikov) wrote :

It working for clear user profile, but something in my old profile makes it coredump

@Jeremy How did you solve it? I still have this bug, so I don't think this should be marked as Invalid.

Jeremy Bicha (jbicha) wrote :

Reopening since it doesn't work for me now...

Changed in synaptic (Ubuntu):
status: Invalid → Confirmed
Omar Mohsen (omohsen) wrote :

I dont think its invalid, I face the same issue.

Omar Mohsen (omohsen) wrote :

terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check
Aborted (core dumped)

Smeuuh (smeuuh) wrote :

Same here.

tags: added: bugpattern-needed
alrusdi (alrusdi) wrote :

Same as Omar Mohsen
$ sudo synaptic
terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

It doesn't seem to happen if I log in to Lubuntu instead...

summary: - synaptic crashed with SIGABRT in raise()
+ synaptic crashed with SIGABRT in raise() [Unity only?]

For me, it crashes immediately on startup. It happens in Unity, Unity 2D, and "Classic GNOME (no effects)". It doesn't crash in Lubuntu, or from the "rescue console" (xterm only).

It still doesn't crash if I'm running "compiz&", or even "unity&", after logging in with the "recovery console".

summary: - synaptic crashed with SIGABRT in raise() [Unity only?]
+ synaptic crashes immediately on startup with SIGABRT in raise() [GNOME
+ only?]
Alan Jenkins (aj504) wrote :

Renaming ~root/.synaptic to ~root/.syn doesn't resolve it (running "sudo synaptic"). (Nor moving ~/.synaptic to ~/.syn, just in case). So if it's configuration-specific, it doesn't seem to be the _synaptic_ configuration that's the problem.

Alan Jenkins (aj504) wrote :

Hah! I found out why this doesn't happen for everyone.

If I toggle the screen reader on & off again (System Settings->Universal Access->Screen Reader), it stops crashing. If I enable the screenreader again, it starts crashing again.

GNOME _used_ to have a global "enable accessibility" checkbox. It looks like that's been removed & is now handled automatically. If you're not using any individual accessibility option, the global setting is disabled for you. (For efficiency reasons).

But the old value of the global "enable accessibility" setting was preserved from before I upgraded.

The reason it only happens when GNOME is started normally, is because other environments don't set up accessibility.

> #16 0x00007f15a95a6805 in atk_object_real_ref_state_set (accessible=0xce33c0) at atkobject.c:1399 (accessible=0xce33c0) at atkobject.c:1399

(from Stacktrace.txt)

summary: - synaptic crashes immediately on startup with SIGABRT in raise() [GNOME
- only?]
+ synaptic crashes immediately on startup with SIGABRT in raise() [Only
+ when accessibility is enabled, e.g. screen reader]
tags: added: a11y
Thomas Templin (coastgnu) wrote :

What helped here was killing gnome-settings-daemon:

pkill gnome-settings-demon

and Snaptic starts as before.

Thomas Templin (coastgnu) wrote :

Pardon the typo. It should be:

pkill gnome-settings-daemon

Kwok Ho Yin (hykwok1) wrote :

I have tried "pkill gnome-settings-daemon" but it does not work for me.

Denis Konstantinov (linvinus) wrote :

i can confirm
>If I toggle the screen reader on & off again (System Settings->Universal Access->Screen Reader), it stops crashing. If I enable the >screenreader again, it starts crashing again.

this help me too

melchiorre (melchiorre) wrote :

I confirm too, synaptic works again after this trick

>If I toggle the screen reader on & off again (System Settings->Universal Access->Screen Reader), it stops crashing. If I enable the >screenreader again, it starts crashing again.

BavarianPH (bavarianph) wrote :

 the screen-reader on

the on-screen-keyboard on

will crash synaptic

both settings to off

synaptic works as expected.

BavarianPH,
Ubuntu Forever!

Joachim Hansen (sn3ipen) wrote :

The trick do not work for me.

Robert Ward (rob-ward78) wrote :

hey there. this seems to work

gsettings set org.gnome.desktop.interface toolkit-accessibility false

Is there any chance to release as a patch so that the not as savy people and the newbies can also get the benefit?

>> It appears that it's related to accessibility settings. I was able to fix this problem on my system by opening Universal Access, >> enabling then disabling the screen reader, then opening Synaptic again.
>>
>> Try:
>>
>> gsettings set org.gnome.desktop.interface toolkit-accessibility false
>>
>> It worked for me.
>>
>> https://bugs.launchpad.net/synaptic/+bug/607605/comments/6

Rudolf (petzolt) wrote :

Don't work for me

paolo.mgi (paolo-mgi) wrote :

I am using oneiric on a tablet (novatech ntab). Disabling on-screen keyboard is no workaround. Disabling orca alon does not help at all.

I had this problem and none of the advice here fixed it. I had uninstalled onboard, one of the screen keyboard programs. I finally got synaptic working by re-installing onboard and then disabling "Screen Keyboard" in System Settings->Universal Access->Typing->Typing Assistant. Weird.

dandygrow (chetan-bravo) wrote :

thanks worked for me too :D

Pavlo Bohmat (bohm) wrote :

ubuntu ~12.04
synaptic crashed Unity only, in fluxbox ok...

Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

Robert Roth (evfool) wrote :

Could anyone reconfirm this with the latest updates applied on Precise? This seems to be a duplicate of bug #607605, which states that in 0.75.5~exp2 and later this issue is fixed, and the fix has been validated on 10th of February, aka 6 days ago.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in synaptic (Ubuntu):
status: Confirmed → Incomplete
Changed in synaptic (Ubuntu):
status: Incomplete → Confirmed
Robert Roth (evfool) wrote :

@Christopher (soft-kristal) - which Synaptic version did you confirm this? I have tried using the latest with Screen reader enabled, and it did work as expected.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in synaptic (Ubuntu):
status: Confirmed → Incomplete
Phill (phill.l) wrote :

Just for clarity, enabling the on-screen keyboard on it's own is enough to cause this crash.

Robert Roth (evfool) wrote :

@Phill: On Precise, it's not enough to enable the on-screen keyboard, as I can run these two simultaneously without synaptic crashing. See my screenshot.

To find out the version of synaptic you are running, please open a terminal and run the command: apt-cache policy synaptic

Marius B. Kotsbak (mariusko) wrote :

Maybe this is a duplicate of bug #787173? Does running:

"sudo LANG=en_EN.utf8 synaptic"

work for you?

Yes, using the work around others have found works for me too.

On Thu, 2012-03-08 at 11:13 +0000, Marius Kotsbak wrote:

> Maybe this is a duplicate of bug #787173? Does running:
>
> "sudo LANG=en_EN.utf8 synaptic"
>
> work for you?
>

See bug #952392 for a related problem in Precise.

Changed in synaptic (Ubuntu):
status: Incomplete → Confirmed
tags: added: precise
Marius B. Kotsbak (mariusko) wrote :

At startup it outputs: "(synaptic:25142): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()". Backtrace in Precise version:

Program received signal SIGSEGV, Segmentation fault.
0xb7118b8e in vfprintf () from /lib/i386-linux-gnu/libc.so.6
(gdb) backtrace
#0 0xb7118b8e in vfprintf () from /lib/i386-linux-gnu/libc.so.6
#1 0xb71d2841 in __vasprintf_chk () from /lib/i386-linux-gnu/libc.so.6
#2 0xb76fca66 in g_vasprintf () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3 0xb76d9da3 in g_strdup_vprintf () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4 0xb76d9dd3 in g_strdup_printf () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5 0x08079722 in ?? ()
#6 0x0807a5d6 in ?? ()
#7 0x0807b408 in ?? ()
#8 0x08058caa in ?? ()
#9 0xb70ec4d3 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#10 0x0805b7e1 in ?? ()

summary: - synaptic crashes immediately on startup with SIGABRT in raise() [Only
- when accessibility is enabled, e.g. screen reader]
+ synaptic crashes immediately on startup with SIGABRT in raise()
Changed in synaptic (Debian):
status: Unknown → New
tags: added: quantal

Still an issue in Quantal version. I wonder if we track at least two bugs here.

Marius B. Kotsbak (mariusko) wrote :

The accessibility bug is probably bug #607605 which is now fixed.

Marius B. Kotsbak (mariusko) wrote :

I found that this does happen with locale "nb_NO.UTF-8", but not with "nb_NO", so this seems to be a problem with UTF-8 handling of strings in the .po files. The actual string contains Norwegian characters outside of ASCII table:

format=0xb7fd605f "%i pakker, %i installert, %i delagt. %i skal installeres/oppgraderes, %i skal fjernes ; %sB vil bli %s", args=0xbfffee54 "")
    at vasprintf_chk.c:68

The complete stacktrace:

Program received signal SIGSEGV, Segmentation fault.
0xb7129e29 in _IO_vfprintf_internal (s=0xbfffed10, format=<optimized out>, ap=0xbfffee70 "\360\316\062\b\230\343\062\b") at vfprintf.c:1630
1630 vfprintf.c: Ingen slik fil eller filkatalog.
(gdb) bt
#0 0xb7129e29 in _IO_vfprintf_internal (s=0xbfffed10, format=<optimized out>, ap=0xbfffee70 "\360\316\062\b\230\343\062\b") at vfprintf.c:1630
#1 0xb71e8ab1 in __GI___vasprintf_chk (result_ptr=0xbfffee1c, flags=1,
    format=0xb7fd605f "%i pakker, %i installert, %i delagt. %i skal installeres/oppgraderes, %i skal fjernes ; %sB vil bli %s", args=0xbfffee54 "")
    at vasprintf_chk.c:68
#2 0xb7703356 in g_vasprintf () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3 0xb76e09a3 in g_strdup_vprintf () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4 0xb76e09d3 in g_strdup_printf () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5 0x0807826a in ?? ()
#6 0x080791c0 in ?? ()
#7 0x080799e6 in ?? ()
#8 0x0805958e in ?? ()
#9 0xb70fe4d3 in __libc_start_main (main=0x8058f80, argc=1, ubp_av=0xbffff1d4, init=0x80d2380, fini=0x80d23f0, rtld_fini=0xb7fed270 <_dl_fini>, stack_end=0xbffff1cc)
    at libc-start.c:226
#10 0x0805c091 in ?? ()

summary: - synaptic crashes immediately on startup with SIGABRT in raise()
+ synaptic crashes immediately on startup with SIGABRT in raise() when run
+ with UTF-8 locale/l10n strings
Marius B. Kotsbak (mariusko) wrote :

It seems like this can be caused by translations not being updated:

%i packages listed, %i installed, %i broken. %i to install/upgrade, %i to remove; %s will be used

is still translated for Norwegian (nb):

%i pakker, %i installert, %i ødelagt. %i skal installeres/oppgraderes, %i skal fjernes ; %sB vil bli %s

where the last %s is probably "freed/used". There is actually a proposed change for this in Launchpad:

https://translations.launchpad.net/synaptic/main/+pots/synaptic/nb/345/+translate

so maybe that just needs to be accepted and imported into Synaptic package.

Same for this one:

https://translations.launchpad.net/synaptic/main/+pots/synaptic/nb/344/+translate

Marius B. Kotsbak (mariusko) wrote :

Patch to solve this problem for Norwegian translation.

tags: added: patch

The attachment "fix_lp839219_nb.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Robert Roth (evfool) wrote :

I can confirm that Marius Kotsbak's patch fixes the issue, after applying the patch on the nb_NO translations, Synaptic starts with nb_NO locale without crashing.

Mathias Bynke (mabynke) wrote :
Changed in ubuntu-translations:
status: New → Confirmed
status: Confirmed → Fix Committed
Marius B. Kotsbak (mariusko) wrote :

It still crashes in Raring...

tags: added: raring
Joachim Hansen (sn3ipen) wrote :

Still affects me in Raring.

Joachim Hansen (sn3ipen) wrote :

Came to think of it and it have been an issue since 11.10. Thats two and a half year! We know it have to do with the translation and we have done it for a long time. There is a fix around, but it still don't make it to the final.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.