2.6.1-1ubuntu3 makes apps crash with Bus error

Bug #137179 reported by Daniel Elstner
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glibc (Debian)
New
Undecided
Unassigned
glibc (Ubuntu)
High
Unassigned

Bug Description

Since the upgrade to libc6 2.6.1-1ubuntu3 (amd64) several applications crash with "Bus error (core dumped)" right on startup. At least gnome-terminal and evolution are affected, and probably other applications too. Downgrading to libc6 2.6.1-1ubuntu1 fixed the problem for now.

Revision history for this message
Daniel Elstner (daniel-elstner) wrote :

Argh, despite the downgrade the problem only went away with gnome-terminal but is still there with evolution. I have no idea what's going on. A backtrace is attached.

Ian Jackson (ijackson)
Changed in glibc:
assignee: nobody → ijackson
Revision history for this message
Ian Jackson (ijackson) wrote :

Thanks for the report. I'm not sure what's causing it but I would like some information to help investigate:

* What version of the libc6 package did you have installed before 2.6.1-1ubuntu3 ? /var/log/dpkg.log may be helpful if you don't know offhand.

* Could you please strace one of the crashing programs and attach the result to the bug report ?

* Could you run "ldconfig" and see if that helps (or, with libc6 2.6.1-1ubuntu3, "ldconfig.real") ?

* I take it this is only happening on one computer. How new is that computer ? Have you had other crashes on it ?

Thanks.

Revision history for this message
Daniel Elstner (daniel-elstner) wrote :

This is strange. I re-upgraded to 2.6.1-1ubuntu3 and it didn't make any difference -- that is, gnome-terminal still worked but evolution didn't. Then I noticed bug #133786 and completely purged and then reinstalled evolution as suggested there. This did indeed fix the problem with evolution, too (and without downgrading libc6). I'm now pretty sure that it is the same bug, as it is also about a Bus error related to package upgrades and on amd64.

> * What version of the libc6 package did you have installed before 2.6.1-1ubuntu3 ? /var/log/dpkg.log may be helpful if you don't know offhand.
According to dpkg.log, I had libc6 2.6.1-1ubuntu2 installed previously, and libc6 2.6.1-1ubuntu1 shortly before that (I think without even a reboot in between; I upgraded from feisty to gutsy just yesterday).

> * Could you please strace one of the crashing programs and attach the result to the bug report ?
Sorry, too late, since unfortunately I forgot to do the strace before trying to reinstall evolution.

> * Could you run "ldconfig" and see if that helps (or, with libc6 2.6.1-1ubuntu3, "ldconfig.real") ?
I actually tried that (both ldconfig and ldconfig.real) before I downgraded to 2.6.1-1ubuntu1 and afterwards as well. It didn't change anything.

> * I take it this is only happening on one computer. How new is that computer ? Have you had other crashes on it ?
I have only one computer with gutsy around at the moment, which was bought in February 2006. I don't recall any crashes which couldn't be traced to some software error.

Revision history for this message
Daniel Elstner (daniel-elstner) wrote :

Bug #90004 might be related as well.

Revision history for this message
Daniel Elstner (daniel-elstner) wrote :

Got this again yesterday after an upgrade which among other packages included libc6 2.6.1-1ubuntu7. Again, gnome-terminal was affected. However, this time reinstalling gnome-terminal didn't help, but reinstalling libc6 did the trick. Before that I also tried to run ldconfig manually, which didn't help.

I think there's something amiss here, but I still have no idea as to what and where. Sorry for not being very helpful.

Revision history for this message
Luis Medinas (lmedinas) wrote :

I can confirm reinstalling libc6 avoid -terminal crashes. Maybe glibc maintainers should force everyone to reinstall libc6 (revbump !?).

Revision history for this message
Evan Carroll (evancarroll) wrote :

Confirmed to exist in Gutsy. I've had this problem for over a month using x86 version. An `apt-get --reinstall install libc6` fixed it.

Thanks.

Revision history for this message
Evan Carroll (evancarroll) wrote :

Bug affects gnome-terminal, and totem, not xterm, vlc, or gmplayer. Not sure what those two are calling from libc6 that the others aren't but it is quite awkward. No feedback unless run through console.

Changed in glibc:
status: New → Confirmed
Ian Jackson (ijackson)
Changed in glibc:
assignee: ijackson → nobody
Revision history for this message
Richard Ayotte (rich-ayotte) wrote :

Today's libc6 update broke my system. I can't get to a terminal because of bus errors on the ttys. I also got filesystem corruption. I think this bug https://bugs.launchpad.net/ubuntu/+bug/133786 is related.

Revision history for this message
Richard Ayotte (rich-ayotte) wrote :

I can confirm that reinstalling libc6_2.6.1-1ubuntu10_amd64.deb fixed the corrupted libc6 files but I'm not convinced that the corruption is caused by libc6 because corruption of other packages have occurred as well. At first I thought the corruption was caused by incompatible hardware but I installed a new hard drive from a different manufacturer and the problem persists. I then thought that the ADMA feature on nforce4 was broken so I disabled it in /etc/modprobe.d/options-custom with options sata_nv adma=0 but after this morning's break, I can confirm that disabling ADMA does not help either.

What's the next step?

Revision history for this message
Helge Titlestad (helgedt) wrote :

Same as Richard here: Updating libc6 to 2.6.1-1ubuntu10 broke stuff, doing sudo aptitude reinstall libc6 fixed it.

I do have one extra piece of info, though: I used to get memory corruption on my feisty installation before, which I got rid of by removing powernowd and any CPU core frequency changing. Since this bug is only a problem for AMD64, maybe it could be a faulty CPU series or something? Here's the top of my /proc/cpuinfo, if you want to compare:

processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 4
model name : AMD Athlon(tm) 64 Processor 3000+
stepping : 10

Revision history for this message
Daniel Elstner (daniel-elstner) wrote :

I'm running with PowerNow! completely disabled in the BIOS setup. My CPU family is different, too:

vendor_id : AuthenticAMD
cpu family : 15
model : 35
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
stepping : 2
cpu MHz : 2010.324
cache size : 512 KB

So I don't think it's a hardware problem. And I've never seen this before gutsy either.

Revision history for this message
Helge Titlestad (helgedt) wrote :

Darn. Back to scratch, then. (=

Revision history for this message
thatunixchap (john-bird2) wrote :

Hi All,

This hit me on 2.6.1-1ubuntu10.

In answer to Ian Jackson's questions:

1. Previously installed version of libc6 was 2.6.1-1ubuntu9 (which I can confirm was working)
2. Strace of gnome-terminal Bus erroring attached
3. Rerunning ldconfig doesn't fix this problem.
4. The crash happened on a D600 Latitude - so not the newest box out there. :-)

Hope this helps!

Cheers,
John

Revision history for this message
thatunixchap (john-bird2) wrote :

I will hold off reinstalling libc6 in case any additional information are needed or in case you want to test a fix

Revision history for this message
jonathan (new-jonathan) wrote : Re: 2.6.1-1ubuntu10 makes app crash with Bus error

can anyone explain why 2.6.1-1ubuntu10 libc6 is so unstable in gutsy? Everything works until libc6 is updated to 2.6.1-1ubuntu10.
I have to reinstall 2.6.1-1ubuntu10 multiple times so that I can get different applications (gnome-terminal, getlibs, icedtea) to work without core dumping. I'm running x64 ubuntu gutsy on Dell 640m (Core2 Duo T7200, 2GB ram)

Changed in glibc:
importance: Undecided → High
Revision history for this message
Eric M. Smith (esmithbss-gmail) wrote :

I just ran into this issue on my x86_32 box (Gateway M460) when I upgraded to libc6-2.6.1-1ubuntu10 in Gutsy.

I just built the box from scratch yesterday using the Alternate install CD, loaded some additional programs (Java, Azureus, ATI restricted driver, etc...) and did

    sudo apt-get update
    sudo apt-get upgrade

Part way through the upgrade process (199 files left to upgrade) it tried to update e2fslibs to 1.40.2-1ubuntu1.1

Once it finished the "Setting up e2fslibs (1.40.2-1ubuntu1.1) ..." operation and started "Processing triggers for libc6 ..." i received the following lines:

   ldconfig deferred processing now taking place
   Segmentation fault (core dumped)
   dpkg: subprocess post-installation script returned error exit status 139

after 5 or 6 retries and attempts to use "dpkg --configure -a" and dpkg --configure libc6", the only way I could get past the problem was to reboot into a recovery mode (gdm disabled) and reinstall.

This corrected the first issue.

I then rebooted the machine and completed the "apt-get upgrade" process, then for good measure re-ran both the "apt-get update" and "apt-get upgrade" processes again.

After one final reboot, gnome-terminal fails with the "Bus error (core dumped)"

Using "sudo aptitude reinstall libc6" corrected this issue for now.

Revision history for this message
Ubaida Othman (ubaida) wrote :

i'm having bus error failure on loading apache2 ...
reinstalling libc6 / apache2 doesnt do anything.

running gdb on apache2 produce this error:

Program received signal SIGBUS, Bus error.
[Switching to Thread -1217066816 (LWP 20190)]
0xb7efcf8f in ?? () from /lib/ld-linux.so.2

Revision history for this message
Ubaida Othman (ubaida) wrote :

i've upgraded to hardy ... no more bus error.

Revision history for this message
Matthias Klose (doko) wrote :

> i've upgraded to hardy ... no more bus error.

closing the report based on this message.

Changed in glibc:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers