Bus error when running Firefox or Epiphany

Bug #133786 reported by xtknight on 2007-08-21
46
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Using Gutsy amd64 (08/21/07) I have problems running Firefox and Epiphany, among other programs like vmware. I suspect the root of the problems is the same thing.

Firefox: "Bus error (core dumped)" [this is all the output I get]
Epiphany: Begins to start ("Don't Recover" or "Recover" session message appears, and then exits with this after you press one of the buttons: "Bus error (core dumped)")
VMware: ldd: exited with unknown exit code (135)
Segmentation fault (core dumped)

Attached is a crash dump of Firefox.

Konqueror runs fine without issues. This seems to be some kind of GNOME/D-Bus problem.

xtknight (xt-knight) wrote :

Firefox Crash Dump

description: updated
description: updated
xtknight (xt-knight) wrote :

I fixed the VMware problem by reinstalling VMware but the original error persists. How can I help debug this problem?

xtknight (xt-knight) wrote :

sudo dpkg --purge --force-all firefox
sudo apt-get install firefox

seemed to fix this. (or adding /usr/lib/firefox to /etc/ld.so.conf.d/libc.conf but I did this for a problem staring gxine)

For now, I will close this bug. If the problem persists in a new Gutsy install I will reopen it. I will create a new bug for gxine if I continue to experience any issues with that (missing libmozjs.so).

xtknight (xt-knight) wrote :

Reopened because this is happening out-of-the-blue again. It may be because of the last round of updates. Once again, "sudo dpkg --purge --force-all firefox" then "sudo apt-get install firefox" fixed it.

xtknight (xt-knight) wrote :

I used diff to track down the problem.

--- nonworkingcomp 2007-08-30 16:20:53.110438000 -0400
+++ workingcomp 2007-08-30 16:20:24.044781000 -0400
@@ -88,7 +88,7 @@
 166f06c8224f470554bd54fed7694878 libfileview.so
 0d1ab316bb93e9bd0984e17e6c8ccec4 libgfx_gtk.so
 8b336f49e47bbdeab58077f90d25009c libgfxps.so
-89523336097ac2ffdc39419207f6ef38 libgklayout.so
+69ba1a464ad5a60e79b3aac59e5677b6 libgklayout.so
 0106b8a7c60b3a3994bf6801d17af5f3 libgkplugin.so
 432fed5253f7e5f86cb322acaf7553e1 libhtmlpars.so
 6751ffde761c463da3f474ab668b4bf6 libi18n.so
@@ -116,7 +116,7 @@
 25f95f012591646b79023130f917df3c libtoolkitcomps.so
 806cc72920ef83519a689e9b9cc602c6 libtransformiix.so
 597ed0487abef512b7f05a4a764531ba libtxmgr.so
-be9ddf086d9156f3427c07074eb31774 libuconv.so
+3507ade799383f62163460fb39938cf9 libuconv.so
 34f66fd52a1567c67bf0ee51e1c2c11e libucvmath.so
 83138eeada5ffb028ed48b17aa7c1780 libuniversalchardet.so
 b153be167bb80ab3dc0237a79d0ecc32 libwebbrwsr.so

libgklayout.so and libuconv.so both get corrupted somehow causing the Bus Error.

Non-corrupt versions:
-rw-r--r-- 1 root root 8324688 2007-08-30 16:23 /usr/lib/firefox/components/libgklayout.so
-rw-r--r-- 1 root root 868032 2007-08-30 16:23 /usr/lib/firefox/components/libuconv.so

/usr/lib/firefox/components/libgklayout.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), stripped
/usr/lib/firefox/components/libuconv.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), stripped

Corrupt versions:
-rw-r--r-- 1 root root 3506176 2007-08-30 16:22 /home/andy/Desktop/libgklayout.so.corrupt
-rw-r--r-- 1 root root 421888 2007-08-30 16:22 /home/andy/Desktop/libuconv.so.corrupt

libgklayout.so.corrupt: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), stripped
libuconv.so.corrupt: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), stripped

They are quite drastically different in size, and these files seem to become corrupt whenever I do an update (or maybe reboot?)

Any ideas? Gran Paradiso also seems to be affected (Bus Error) but I haven't looked into that one.

Attached is a tar.gz of the corrupt and noncorrupt files (corrupt are *.corrupt).

TJ (tj) wrote :

It is possible all these issues are caused by an underlying system issue.

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:

1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at http://wiki.ubuntu.com/KernelTeamBugPolicies.

Thanks in advance!

xtknight (xt-knight) wrote :

Seems to be a known problem for granparadiso so I assume it's the same problem.

per https://wiki.ubuntu.com/MozillaTeam/Bugs/ here is my backtrace for granparadiso. I will grab the additional info very soon.

xtknight (xt-knight) wrote :

1. Linux andy-desktop 2.6.22-10-generic #1 SMP Wed Aug 22 07:42:05 GMT 2007 x86_64 GNU/Linux

2. Fresh dmesg attached.

xtknight (xt-knight) wrote :

3. lspci-vvnn.log attached

xtknight (xt-knight) wrote :

cat /proc/version_signature

Full kernel ver#: Ubuntu 2.6.22-10.30-generic

Bret Towe (magnade) wrote :

I'm also seeing this it ate part of libc6 on last update on my ppc mac mini
kernel wise I'm running latest mainline
Linux mini 2.6.23-rc5 #16 Sat Sep 1 14:41:11 PDT 2007 ppc GNU/Linux
same kernel for the amd64 box thats having the issue

the 2 i386 boxen I have haven't hit this yet

Richard Ayotte (rich-ayotte) wrote :

I'm having the same problem with Firefox and other apps like gnome-terminal. There could be other apps as well.

Bret Towe (magnade) wrote :

I got both the ppc and the amd64 back up and running with the help of debsums
running 'debsums -s' will list all packages that ether have no md5sums to check
or have a corrupt file
once you find they have a corrupt file its just a matter of reinstalling that package

Richard Ayotte (rich-ayotte) wrote :

Thank you Bret, that was very helpful. I found the following corrupted files on a newly installed Tribe 5. / is XFS and /boot is Reiser3.

debsums: checksum mismatch firefox file /usr/lib/firefox/components/libuconv.so
debsums: checksum mismatch firefox file /usr/lib/firefox/components/libgklayout.so
debsums: checksum mismatch gnome-utils file /usr/share/gnome/help/baobab/fr/figures/baobab_fullscan.png
debsums: checksum mismatch libc6 file /usr/lib/gconv/libCNS.so
debsums: checksum mismatch ttf-dejavu-extra file /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed.ttf

And on another system, all Reiser3 I found:

root@cheetah:~# cat debsums.txt|grep mismatch|cut -d ' ' -f4|uniq|wc -l

140!!!

So I quickly reinstalled with:

debsums -s &> debsums.txt
cat debsums.txt|grep mismatch|cut -d ' ' -f4|uniq|xargs apt-get -y --force-yes --reinstall install

And everything seems to be OK now. Gutsy is very crashy with the desktop effects enabled so it might explain the corruption from all the rebooting. I thought Reiser and XFS were supposed to protect me from that so there might be a bug in the kernel. I have also disabled the write cache on my drives with hdparm -W0 /dev/sda as recommended by the SGI folks to see if it helps .

My /etc/hdparm.conf now contains the following additions.

/dev/sda {
        write_cache = off
}

/dev/sdb {
        write_cache = off
}

Bret Towe (magnade) wrote :

Your welcome Richard

and for further information, filesystems on all my systems are xfs
and I have crashed the system a few times but I don't recall
items breaking around those times

liferea I notice here once in a while keeps dieing on my amd64 box
and its database is corrupt where I have to trash it to get it to reload
wonder if it's related?
to add to that fun /home on both the ppc and amd64 boxen are nfs4
but only corruption of any sort I've seen is liferea

grendelkhan (scottricketts) wrote :

This happened to me with Exchange on a fresh install, right after an upgrade. The dpkg purge operation fixed things, and my filesystem is also XFS.

kervel (frank-dekervel) wrote :

i can confirm this. Running on a laptop R51, i suspend/resume frequently (but i tried rebooting immediately after upgrading and still got corruption), and i also see corruption after dist-upgrade, causing the same bus errors. Also here, it happens frequently (almost always when updating openoffice , firefox).

i also use the XFS filesystem (but i already use it for years without problems).

i tought it was a broken apt (apt-get frequently just hangs also on my machine, and control-Z on apt doesn't work anymore, neither does control-C) but as everybody affected seems to use XFS ...

greetings,
Frank

Teo Ruiz (teo) wrote :

I had the same problem:

$ cat /tmp/debsums.txt | egrep "mismatch|can't" | cut -d " " -f4 | uniq | wc -l
134

After undoing the prelinking on my system (ie. setting "PRELINKING" to "no" at /etc/default/prelink and running the daily prelink cron task) it changed to:

$ cat /tmp/debsums_noprelink.txt | egrep "mismatch|can't" | cut -d " " -f4 | uniq | wc -l
34

I'm also using XFS on the root partition and gutsy. I'm attaching the debsums file after undoing the prelink.

Same problem for me. Output from debsums attached.

Richard Ayotte (rich-ayotte) wrote :

The corruption problems that I initially experienced went away until after this morning's update. I can't even boot into my system because of bus errors on the ttys. Could the libc6 update cause this? I'm not sure how to repair now. Here's the output of xfs_check:

root@cheetah:~# xfs_check /dev/sdb1
agi unlinked bucket 44 is 96428 in ag 7 (inode=939620524)
agi unlinked bucket 50 is 96434 in ag 7 (inode=939620530)
allocated inode 939620524 has 0 link count
allocated inode 939620530 has 0 link count

This bug is definitely beyond Firefox or Epiphany and more likely a libc6, kernel or driver problem. We could probably rule out bad hardware at this point.

kervel (frank-dekervel) wrote :

this is how i repaired my system:

- boot into ubuntu live cd and fetch the libc package
- use alien to convert the libc package into tar.gz format (alien -t i think)
- mount your linux partitions and unpack the tgz on your "/mnt/linux" or so
- now you will probably have a working libc and you can chroot /mnt/linux /bin/sh to fix the rest using apt/dpkg and reboot

you could also try with dpkg --root=/mnt/linux --admindir=/mnt/linux/var/lib/dpkg --instdir=/mnt/linux (but i never tried that, no idea if this works)

Thank-you. Reinstalling libc fixed the problem. Is there a way to have
debsums run automatically after every update?

On 10/25/07, kervel <email address hidden> wrote:
>
> this is how i repaired my system:
>
> - boot into ubuntu live cd and fetch the libc package
> - use alien to convert the libc package into tar.gz format (alien -t i
> think)
> - mount your linux partitions and unpack the tgz on your "/mnt/linux" or
> so
> - now you will probably have a working libc and you can chroot /mnt/linux
> /bin/sh to fix the rest using apt/dpkg and reboot
>
> you could also try with dpkg --root=/mnt/linux
> --admindir=/mnt/linux/var/lib/dpkg --instdir=/mnt/linux (but i never
> tried that, no idea if this works)
>
> --
> Bus error when running Firefox or Epiphany
> https://bugs.launchpad.net/bugs/133786
> You received this bug notification because you are a direct subscriber
> of the bug.
>

kervel (frank-dekervel) wrote :

Hello,

it seems:
- filesystem does not matter (some people have it on xfs, some on ext3)
- hardware does not matter ..
- it always happens with apt (for me at least: i never got the corruption when i didn't apt-get something) .. right ?

and maybe this is related: i'm not sure if this is always the case, but when i have corruption i sometimes see apt hanging (while unpacking) , control-C doesn't work, i have to kill apt from another terminal and restart. could this be related ?

i already had to reinstall (sometimes more than once) glibc, kdelibs, openoffice, firefox. and i always just run apt-get from the command line (no update-manager, synaptic, aptitude , ...)

greetings,
frank

Richard Ayotte (rich-ayotte) wrote :

I can confirm:

   - Filesystem does not matter. I've had corruption on Reiser3 and xfs
   - I've had to reinstall many different packages. The bug is not specific to a single package.
   - Corruption occurs on i386 and AMD64.

I'm not sure about:

   - Hardware. The problem did not appear to be as severe when I disabled ADMA on my nforce4 chipset. We need to find out which other chipsets are affected.
   - I've had corruption on Maxtor (SATA) and Western Digital (SATA2) drives so we can probably rule out drive brand. We need to find out if SCSI and IDE drives are affected too.
   - Corruption occurs at the filesystem level. I'm not sure if a userspace app can do that without a bug in kernel space.

How do we get this bug on the radar. Importance should be set to at least Major and status to Confirmed since so many people have reported it.

Possibly relataded bugs: #146636, #137179, #90004.

I stumbled across the same error. Firefox refused to start and gave "Bus error ..." message. Using debsums I discovered that

 debsums: checksum mismatch libbonobo2-0 file /usr/lib/libbonobo-2.so.0.0.0

so I reinstalled that package. Et voila: everything is running fine again.

I am running Kubuntu Gutsy Gibbon on i386 with XFS as the root file system.

Heikki Lindholm (holindho) wrote :

Happens here, too. A Duron/VIA box. First boot after fresh 7.10 CD install seemed to work fine, but, after dist-upgrade and boot, things went south. Using XFS filesystems only. Firefox, gnome_terminal, others dying with bus error. Corruption shown by debsums and confirmed at the (root disk) filesystem level by xfs_check from gentoo 2007 CD. Another computer made useless until this is fixed.

malraux (scottanderson42) wrote :

I just ran into this as well.

Fresh install on dual Xeon dual-core 64-bit chips. I removed the CD, rebooted, installed the nVidia driver and ran all of the updates, rebooted, and Firefox, Epiphany, and Gnome Terminal all give bus errors on startup now.

uname -a:
Linux my-desktop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

debsums:
/usr/lib/cups/cgi-bin/admin.cgi FAILED
/lib/modules/2.6.22-14-generic/modules.pcimap FAILED
/lib/modules/2.6.22-14-generic/modules.dep FAILED
/lib/modules/2.6.22-14-generic/modules.usbmap FAILED
/lib/modules/2.6.22-14-generic/modules.isapnpmap FAILED
/lib/modules/2.6.22-14-generic/modules.alias FAILED
/lib/modules/2.6.22-14-generic/modules.symbols FAILED
/usr/share/firefox/chrome/toolkit.jar FAILED
/usr/lib/firefox/components/libuconv.so FAILED
/usr/lib/firefox/components/libgklayout.so FAILED
/usr/lib/firefox/components/libpipnss.so FAILED
/usr/lib/gconv/libCNS.so FAILED

This looks similar to what other posters are reporting, so I doubt it's random.

Reinstalling firefox, the kernel, cupsys, and libc6 (all of which were upgraded in the update I performed) fixed things.

This appears to be a problem with at least the update utility, or with whatever it uses on the back-end.

Grizzly (sven-witterstein) wrote :

It also happenened to me right now. Runnung XFS-systems on amd64 - and kernel, openoffice, firefox etc needed a repair.

A simple sudo apt-get update does not help (because the db thinks it's all fine)

I think it has to to with the update order: when you "followed" in a gutsy installation from release day till today, you got the updates in a more or less specific order.

Now, when you install every update at once after a fresh install, you get a different order and run into these problems. So the bug might have been in released gutsy but now ist not there anymore.

A hint might be that firefox suddenly said it had been updated (like in win) - which was not true at that time and afterwards refused to start.

Personally, I think, feisty was more stable. I hope next LTS will be stable, though... almost everything you can imagine, I'm running into...

Michael P. Jung (mpjung) wrote :

I debootstrapped an Ubuntu 7.10 system a few weeks ago and didn't have that problems.

Yesterday I replaced the debootstrapped system with an Ubuntu 7.10 installed from the alternative install CD and just ran into the same problems as described in here. Bus errors upon running several applications. esp. Firefox, Thunderbird, etc.

Kernel: 2.6.22-14-generic
Architecture: x86_64
/root filesystem: XFS
/boot filesystem: ext2

Reinstalling the packages fixed the problems. That never happened to me on any Debian or Ubuntu box before. I'd guess the package manager and/or some other post-install script is messing up the installed libraries?

Heikki Lindholm (holindho) wrote :

Reinstalling the packages that were reported by debsums to be corrupted fixed the situation so, that debsums doesn't find any corruption anymore. However, after a *clean* reboot to gentoo install cd, and running xfs_check from there for the root filesystem, yet again shows corruption similar to what Richard Ayotte reports above. Before updating anything, the filesystem was xfs_repair'ed and xfs_checked before boot into ubuntu, so, it definitely was ok.

Grizzly (sven-witterstein) wrote :

Update: After playing around with some boxes and a restart later, especially: after installing current ati driver because the one included does not support x1650 card, I noticed things started to behave strangely.

First of all, on this particular board (M2R32-MVP with AMD-crossfire chipset) I can either run one new "sda" type disk (raid not yet invested in :-) or the old IDE UDMA5 disk WinXP is on (natively in MBR).

When both drives (IDE and SATA) are physically supplied with power, the windows boot hangs after MUP.SYS (widely discussed in Forums, real reason: the IDE drivers are loaded afterwards and die before they can report it, thus everybody reports harmless MUP.SYS which is only the last driver that is being loaded before UDMA (?) driver(s) crash)

Initially, I thought it was the problem having 2 IDE disks on the leftover legacy IDE controller (probably poorly tested...), that is only there to support simple CDR/DVD-Drives

I used the opportunity to exchange one IDE for a SATA-drive, calculating that it would be harmless to have only one IDE-Master and one SATA drive.

BUT: Grub in MBR on sda fails to chainload the windows MBR on the IDE Master with IDE and SATA drive connected.
BUT: With IDE _and_ SATA drives connected, ubuntu boot from sda crashes when trying to initialize IDE with the 0xEC command error, that is specified as "identify drive command", that some people in webspace referred to as "used to query an IDE CD-ROM drive" and thus unsuitable for probing IDE Harddisks. It does not matter whether my ATAPI-CDROM is powered, connected and Master-slave is also irrelevant.

So there is a bug in the bios and or kernel (or they just don't harmonize?) which makes the kernel think, any other drive then the boot drive could realistically be only CD-Rom, something like that.

Now XFS and broken apt comes into play: exactly the _kernel_ and the two .debs (russian and ukrainian language support) on my XFS root got corrupted when the boot crash occured. However, the _next_ packet I installed (I think it was samba) got _not_ corrupted when I did a clean reboot without the second (now old IDE) harddisk connected to power.

The new (UDMA-6) IDE drive now in the other box lives happily with its root still on reiserfs and boots the other box just fine without noticable problems, with or without compiz. But this box is an nvidia system and nForce chipset, now also xfs-ed.

I think there is a bios bug and a kernel bug (or no workaround yet, better to say so) wich breaks something for xfs. I do not suspect apt any more (because this works fine on more stable systems.

Maybe somebody has a similar hardware and can investigate / confirm.

Heikki Lindholm (holindho) wrote :

I solved the problem by installing a custom kernel.org 2.6.23.8 kernel. Configured with ubuntu .22 default config as basis but disabled all suspicious new stuff, such as virtualization and tickless. No more XFS filesystem corruption and no more debsums corruption even after apt updates and new installs. I'd say there's a bug in ubuntu's kernel, either in the xfs fs or in something related to cache flushes.

Michael Lueck (mlueck) wrote :

I just had quite a fight with a clean install of 7.10 Gutsy Gibbon and applying the updates makes Firefox no longer start.

Turned out the solution was to mark the Firefox related packages to be reinstalled. Complete details in this thread.

http://ubuntuforums.org/showthread.php?t=641027#td_post_4031964

I sure hope someone gets this bug fixed. Sounds like, per this thread ( https://bugs.launchpad.net/ubuntu/+bug/133786/comments/29 ), that it might be due to applying all available updates to a clean install of 7.10... which is bound to happen. (Ja think!?)

Michael Lueck (mlueck) wrote :

Oh and yes, I have all partitions as xfs other than /boot which is ext3.

Ditto for on one of my clean re-installations Gnome Terminal would not start as well. This most recent reload, however, that trouble has not popped up.

Roderik van der Veer (roderik) wrote :
Download full text (3.8 KiB)

I've run into the same problem today, but only with some configurations:

1 x dual core intel - one big reiserfs disk - no problems
1 x dual core amd - one big reiserfs disk (/) and two xfs disk for storage - no problems

Kervel (https://bugs.launchpad.net/ubuntu/+bug/133786/comments/24) who also works here:

1 x thinkpad laptop - ext3 /boot, the rest xfs partitions - corruption
1 x macbook pro - ext3 /boot, the rest xfs partitions - corruption

And this morning a new server:

1 x two cpu, dual core intel, ext3 boot, the rest xfs on a software raid 1 - corruption

All systems are completely updated and fresh installs.

debsums: checksum mismatch git-core file /usr/bin/git-mktree
debsums: checksum mismatch gsfonts file /usr/share/fonts/type1/gsfonts/n019023l.pfb
debsums: checksum mismatch libc6-dev file /usr/lib/libc.a
debsums: checksum mismatch libc6-dev file /usr/lib/xen/libpthread.a
debsums: checksum mismatch libsnmp10 file /usr/lib/libnetsnmphelpers.so.10.0.1
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/kernel/drivers/isdn/hisax/hisax.ko
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/kernel/drivers/net/wireless/ipw2100.ko
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/kernel/drivers/scsi/aic7xxx/aic7xxx.ko
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/kernel/drivers/scsi/ipr.ko
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/kernel/fs/gfs2/gfs2.ko
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/modules.pcimap
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/modules.dep
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/modules.usbmap
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/modules.isapnpmap
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/modules.alias
debsums: checksum mismatch linux-image-2.6.22-14-server file /lib/modules/2.6.22-14-server/modules.symbols
debsums: checksum mismatch mc file /usr/share/locale/tr/LC_MESSAGES/mc.mo
debsums: checksum mismatch mysql-client-5.0 file /usr/bin/mysql_client_test_embedded
debsums: checksum mismatch mysql-server-5.0 file /usr/bin/ndb_delete_all
debsums: checksum mismatch mysql-server-5.0 file /usr/bin/ndb_drop_table
debsums: checksum mismatch mysql-server-5.0 file /usr/bin/ndb_select_all
debsums: checksum mismatch mysql-server-5.0 file /usr/share/mysql/mysql-test/suite/funcs_1/r/myisam_views.result
debsums: checksum mismatch python-egenix-mxdatetime file /usr/share/doc/python-egenix-mxdatetime/mxDateTime.pdf.gz
debsums: checksum mismatch sun-java6-bin file /usr/lib/jvm/java-6-sun-1.6.0.03/jre/lib/rt.jar
debsums: checksum mismatch ttf-dejavu-extra file /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-BoldOblique.ttf
debsums: checksum mismatch xfonts-base file /usr/share/fonts/X11/misc/18x18ja.pcf.gz

Other lines were for examele

debsums: no md5sums for at
deb...

Read more...

Michael Lueck (mlueck) wrote :

I ended up reloading to Ubuntu 7.04 - OUTSTANDING RESULTS!!! The systems run noticeably faster. Able to have xfs filesystem (other than /boot which is ext3). I found a project for Ubuntu downloading the latest binaries of Firefox and Thunderbird direct from Mozilla. Vista Business in a Parallels VM session is actually quite tolerable, whereas before it was "click......... did I actually click a few minutes ago?!"

With such good news, I did not want to keep it to myself. "Jump into 7.04, the water is great!"

Sigurd Høgsbro (sigurd) wrote :

I have also been subjected to this bug, with bus-errors/segfaults appearing on a multitude of applications. GnomeTerm was the first, soon followed by others. I never saw this in 7.04; but have been suffering with it in 7.10 for months, re-installing the O/S each time. It seems to be specific to 64-bit version; I have 2 totally stable servers that are older CPUs running the 32-bit version. Our cluster of 16 Core2Duo servers (ext3 /boot, multiple XFS filesystems for root etc) have problems repeatedly.

I concur that the problem occurs as soon as you run the update. I have tried countless virgin installs on my Dell M1330 Core2duo laptop several times, and as soon as I run apt-get update & upgrade I get these problems again.

It is a crying shame it's so difficult to pinpoint this problem. Until I found this thread I was on verge of finding an alternative distro.

Michael Lueck (mlueck) wrote :

Sigurd Hogsbro: It is not specific to the AM64 version. A friend of mind is running 7.10 AM64 and is having NO troubles at all. For me the x86 version of 7.10 was a nightmare.

I tried installing 7.10 on all ext3 partitions, better but not perfect. Performance got much better when I dropped back to 7.04 for example w/ normal partitioning scheme (ext3 for /boot, all others xfs).

I did some initial testing with Hardy (8.04) and my normal partitioning scheme was stable as in 7.04. Since it is going to be an LTS release, I certainly hope it is more solid than 7.10!

Andrew Gaylard (ag-computer) wrote :

My experience with this bug has been severe and painful. On certain boxes, both Intel and AMD, I can make it happen every time, using this process:

1. install 7.10
2. upgrade 7.10
3. change /etc/apt/sources.list to point to hardy, not gutsy
4. apt-get update
5. apt-get dist-upgrade

At this point these boxes will appear to run fine, but certain processes will experience bus errors. A reboot will often fail to boot completely (/bin/sh get bus errors). The problem appears to be that glibc was corrupted during the upgrade process, so everything which depends on it will get bus errors. I managed to rescue a box in this state by booting off the 7.10 CD, copying libc from the CD over the one on the disk, which was enough to get debusums and apt-get to work. Then I could use debsums and apt-get to reinstall any packages which were damaged. I now use debsums between steps 4 and 5 whenever I upgrade a box. Mostly it is fine, but sometimes packages (various ones, but usually the list includes libc) fail the debsums test; an "aptitude reinstall " before booting sorts them out.

All the machines where this problem occurred were installed with a small /boot as ext3 and / as xfs. I dunno if that's a factor. Some machines never showed this problem. It's becoming less of an issue now that 8.04's out, and the wave of upgrading 7.10 boxes has passed.

Craig Maloney (craig-decafbad) wrote :

Have you had the same experience with Hardy Heron? (8.04?)

Richard Ayotte (rich-ayotte) wrote :

No problem in Hardy (8.04) for me.

Michael Lueck (mlueck) wrote :

Absolutely Not!!! "May it never be!"

Where 7.10 was to be avoided like the plague that it was, 8.04 is again a rock solid release as 7.04 its predecessor.

xfs is rock solid stable, latest updates the same, UbuntuZilla does a great job installing the Mozilla Official FF/TB.

I happen to prefer to purge packages compiz*, but that is a personal preference.

8.04 rocks!

ro9u3b46 (ro9u3b46) wrote :

Hello

I have just installed 8.04.1 Kubuntu on my wife's machine.

Everything worked well with Firefox 3.0.1 at the beginning.

I installed Aisleriot for her and I saw about 30 - 60 gnome programs added.

Since this install Firefox has not worked.

I downloaded Firefos 3.0.2 and ran in terminal - got "Bus error"

Anything else . . .

coCoKNIght (cocoknight) wrote :

Because of an other bug I got a 50% chance for a kernel panic when I unplug the ethernet cable. This happened the other night while I was running Firefox. Since then, when I open Firefox it crashes just before it fully loads the first webpage, returning "bus error" when started from terminal. Same happens with epiphany.
I'm running 9.04 on an ext4 filesystem

Tobin Davis (gruemaster) wrote :

Remove Ubuntu-moblin-remix from bug.

affects: ubuntu-moblin-remix → sbb
Tobin Davis (gruemaster) on 2009-09-26
Changed in sbb:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

[Expired for Ubuntu because there has been no activity for 60 days.]

Changed in ubuntu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers