Adding/Removing an external monitor causes open windows to move to another workspace

Bug #763148 reported by grigori on 2011-04-16
304
This bug affects 59 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Steve Langasek
0.9.9
Medium
Unassigned
Compiz Core
Medium
Christopher Townsend
compiz (Ubuntu)
Medium
Steve Langasek
Precise
Undecided
Bartosz Kosiorek

Bug Description

[Impact]
Many users will put different windows in different workspaces for better work flow. If a user connects and/or disconnects an external monitor or projector, all of these windows will be put in the first workspace. Having to go back and move all of the windows back to their workspaces is very frustrating and time consuming.

[Test Case]
#. Open some applications in different workspaces.
#. Plug in an external monitor.

[Regression Potential]
Very low possibility that a window still ends up in the wrong workspace.

--------------------------------------------

Original description:
well, i plug in my external screen.

expected behaviour would be, if all of my windows would stay in the workspaces i aligned them to, and if they'd be on the same screen i had them in the first place.

unfortunatly in unity, if i plug-in (or plug-off) my external screen the windows are all around, but not where i'd expect them to be (namely in the same place they were before). so i always have to toggle expo-mode and re-align all of my windows.

Related branches

lp:~vorlon/compiz/lp.763148
Merged into lp:compiz/0.9.10 at revision 3646
PS Jenkins bot: Approve (continuous-integration) on 2013-04-07
MC Return: Abstain on 2013-04-07
Sam Spilsbury: Approve on 2013-04-07
lp:~vorlon/compiz/lp.763148-0.9.9
Merged into lp:compiz/0.9.9 at revision 3646
PS Jenkins bot: Approve (continuous-integration) on 2013-04-08
Didier Roche: Approve on 2013-04-08
lp:~townsend/compiz-core/fix-763148
Merged into lp:compiz-core at revision 3136
Brandon Schaefer: Approve on 2013-04-22
Alex Launi (alexlauni) wrote :

The issue you're describing doesn't sound related to Unity. Could you log into a classic gnome session and see if this issue persists?

Changed in unity:
importance: Undecided → Low
status: New → Incomplete
Changed in compiz (Ubuntu):
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in compiz (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low

you're absolutely right. i just tested it in classic-session. the problem was the same. so it seems to be a problem with compiz!?

btw. the windows are not "all around", as i said in the initial report; they rather seem to be aligned the way they were before i plugged in the secondary monitor, but without considering the 1080 pixels that are 'new' to the configuration. so a window that was on my second workspace in a one-monitor-layout, will appear on my first workspace in a two-monitor-layout, because it keeps the same distance to x=0/y=0 (which is the upper left corner) as before.

my way to "work around" this problem is to press "super+s" and drag the windows to the workspaces i have assigned them to before. doing this every time i change my monitor-layout is quite annoying.

Braiam Peguero (braiampe) wrote :

Can you disable compiz at all, using Gnome Classic (No effects), so we can confim as a compiz bug.

Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid

just tested it: the bug does not occur after "metacity --replace" in gnome classic.

Changed in compiz (Ubuntu):
status: Incomplete → New
Changed in compiz (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Reproduced problem on precise.

The new multi-monitor spec covers this case and describes what the proper behavior should be.

http://design.canonical.com/the-toolkit/unity-multi-monitor-interactions/

Changed in compiz (Ubuntu):
status: Confirmed → Triaged
importance: Low → Medium
Bryce Harrington (bryce) wrote :

Bumping priority up since current behavior is incorrect with respect to the specification.

tags: added: precise
summary: - multi-monitor setup breaks window/workspace alignment
+ Adding/Removing an external monitor causes open windows to move to
+ another workspace
affects: unity → compiz
Changed in compiz:
importance: Low → Medium
status: Invalid → Confirmed
milestone: none → 0.9.8.0
no longer affects: unity (Ubuntu)
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
assignee: nobody → Ted Gould (ted)
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Changed in compiz:
assignee: Ted Gould (ted) → nobody
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Andy Freeland (rouge8) wrote :

Is there any information/logs needed to help resolve this bug? I can reproduce it every time.

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Ian Hutchinson (hutch) wrote :

Thanks fo Daniel van Vugt for recurrent attention to this bug. But I presume his repeated changes to "milestone" mean that no one is paying the slightest attention to actually fixing it. Is there a realistic expectation that it will ever be fixed?

Ian Hutchinson: I'm not part of the team but I can say that there is an extremely small handful of people working on the compiz codebase - some of these people are also pulling double-duty on Mir. Unless a hero pulls off a set of patches to help the stack I'm afraid we're going to have to trust that they will prioritize the long bug list well enough to deal with the issues at the best time they can.

Hope that helps, and were I better at C++ I'd dive in myself.

Steve Langasek (vorlon) on 2013-04-07
Changed in compiz (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Steve Langasek (vorlon)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision 3646, scheduled for release in compiz, milestone 0.9.10.0

Changed in compiz:
status: Confirmed → Fix Committed
Changed in compiz:
assignee: nobody → Steve Langasek (vorlon)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/0.9.9 at revision None, scheduled for release in compiz, milestone 0.9.9.2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.04.10-0ubuntu1

---------------
compiz (1:0.9.9~daily13.04.10-0ubuntu1) raring; urgency=low

  [ Steve Langasek ]
  * Adding/Removing an external monitor causes open windows to move to
    another workspace (LP: #763148)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3646
 -- Ubuntu daily release <email address hidden> Wed, 10 Apr 2013 04:03:14 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz-core:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Christopher Townsend (townsend)

I'm going to work on backporting this fix to 12.04.

Changed in compiz-core:
status: Confirmed → In Progress
Daniel Farina (drfarina) wrote :

I filed #1166673 (a dupe) and can confirm that this update fixed my raring laptop. Yay.

Eduards Bezverhijs (mjasnik) wrote :

Terricif news! Thanks!
Now I'm looking into getting that on Precise...

Update:
I have a merge proposal in for lp:compiz-core which is the branch that is used for Precise. I'll work with the necessary folks to get this pushed through and get it out as an SRU.

Eduards Bezverhijs (mjasnik) wrote :

Hi!

I have tested this on precise, I've applied patch to current version of compiz, rebuilt packages and installed the following deb files:
sudo dpkg -i compiz_0.9.7.12-0ubuntu1_all.deb compiz-core_0.9.7.12-0ubuntu1_amd64.deb compiz-gnome_0.9.7.12-0ubuntu1_amd64.deb compiz-plugins_0.9.7.12-0ubuntu1_amd64.deb compiz-plugins-default_0.9.7.12-0ubuntu1_amd64.deb

I still see slightly incorrect behavior in case app is fullscreen on external display. So, when I maximize the app on external display, then remove the cable, space shrinks, window stays on the same workspace on primary screen maximized, that is expected and fine, but when I unmaximize it, it moves to the workspace on right, maybe it still thinks there is the space which was available when external display was connected. Maybe smht to do with original window position.

P.S. Really big thanks for the solution, now it at least do not mess up the whole WS when I connect projector or monitor.
P.P.S. As this is my "production" machine, I'll be testing this even more and will post the results.

Hi Eduards,

Thank you for trying out the patch for 12.04. I was wondering if you see the same slightly incorrect behavior in 13.04? I want to make sure my branch does not have some regression that is not present in 13.04.

Thanks!

Steve Langasek (vorlon) wrote :

Chris, yes, the behavior of full-screen windows is still wrong in 13.04.

Hi Steve,

Ok, thanks. I assume that should be a separate bug from this. Do you agree?

Steve Langasek (vorlon) wrote :

yeah, please treat that as a separate bug.

Eduards Bezverhijs (mjasnik) wrote :

Hi Christopher,

If you make another bug, please mention it here or please add me to the subscribers list.
Are You planning to fix it Yourself?
I'm asking because usually WS bugs are not going to be fixed anytime soon due to WS concept is thought as advanced feature for advanced users and therefore do not fall into the "for masses" category which means not a priority.

thanks
Eduards

Hi Eduards,

There are not any plans at this time to fix the WS issue you are seeing. However, since you are more familiar with the issue than I, could you please enter a new bug for this?

Thanks,
Chris

Eduards Bezverhijs (mjasnik) wrote :

Hi Chris,

Bug created https://bugs.launchpad.net/compiz/+bug/1171878
Added more details how to reproduce.

Thanks,
Eduards

Changed in compiz-core:
status: In Progress → Fix Committed
description: updated
description: updated
Margarita Manterola (marga-9) wrote :

I'm running precise. I installed the latest packages from https://launchpad.net/~unity-team/+archive/sru and I still have the same issue (turning off the right monitor causes the windows that were in that screen to move to a different workspace). So this is still not fixed in precise.

Hi Margarita,

That PPA does not contain the Precise version of the Compiz package that has this fix. It looks like this fix for inclusion into a package is still pending and it's hard to tell when that will happen.

Eduards Bezverhijs (mjasnik) wrote :

Hi!

I can share 0.9.7.12-0ubuntu1 packages for Precise (x86_64), if anyone interested.
Default disclaimer applies: packages are built by myself, works for me, otherwise use at own risk :)

regards
Eduards

Stephen M. Webb (bregma) on 2013-07-23
Changed in compiz:
status: Fix Committed → Fix Released
Mohamed Ragab (moragab) wrote :

Hi,

I am on 13.04 with the following compiz versions, this system was upgraded from 12.10 if that makes any difference

Package compiz:
i 1:0.9.10+13.10.20131011-0ubuntu1 saucy

Package compiz-core:
i 1:0.9.10+13.10.20131011-0ubuntu1 saucy

if the applications are *not maximized* they stay in their virtual desktop after connecting or disconnecting an external monitor

but the issue is still valid in case the applications are *maximized*, all maximized applications go to the first virtual desktop once an external monitor is connected or disconnected

Regards,
Mohamed

information type: Public → Public Security
information type: Public Security → Public

On Wed, Nov 20, 2013 at 09:32:06AM -0000, Mohamed Ragab wrote:

> but the issue is still valid in case the applications are *maximized*,
> all maximized applications go to the first virtual desktop once an
> external monitor is connected or disconnected

I believe there is a separate bug report open for this. And no, it's not
"the first virtual desktop", it's "the current virtual desktop".

Mark Russell (marrusl) wrote :

The fullscreen one is LP bug 1171878.

Ritesh Khadgaray (khadgaray) wrote :

Hi Mark

  I have posted a patch for this issue under bug 1171878. Let me know, if this helps.

Jan Groenewald (jan-aims) wrote :

I had this bug from precise, and can confirm it in raring, quantal, saucy, trusty.

Changed in compiz-core:
milestone: none → 0.9.7.14

Attached is the debdiff for the proposed Compiz SRU that fixes this. Also, a branch is linked to this bug for the same fix.

Hello grigori, or anyone else affected,

Accepted compiz into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.7.12-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Bartosz Kosiorek (gang65) wrote :

After install compiz from propose, all problems with multi monitor support (which was described here) was solved for me.

Now it is working perfectly.

Thanks you!

Changed in compiz (Ubuntu Precise):
assignee: nobody → Bartosz Kosiorek (gang65)
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.12-0ubuntu4

---------------
compiz (1:0.9.7.12-0ubuntu4) precise; urgency=low

  * debian/patches/fix_external_monitor_hotplug.patch
    - Cherry-pick fixes upstream for window mismanagement when adding
      and/or removing an external monitor. (LP: #763148) (LP: #1171878)
 -- Chris Townsend <email address hidden> Mon, 07 Jul 2014 15:15:43 -0400

Changed in compiz (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu):
assignee: Steve Langasek (vorlon) → shawn moses (shawnmoses79)
Steve Langasek (vorlon) on 2014-07-30
Changed in compiz (Ubuntu):
assignee: shawn moses (shawnmoses79) → Steve Langasek (vorlon)
Michisteiner (michisteiner) wrote :

I guess this bug seems to be fixed for most folks post-raring and late changes restricted to Precise. However, even in Trusty &0.9.11 (to which "upstream" is probably referring?) add/removing monitor still consistently causes for me some windows to move from one workspace to the other and, in particular, also causes windows inside a workspace to move even if the windows were on the the not-removed monitor. Not sure whether relevant, but this is with the nvidia drivers on a ThinkPad W530 connecting to various external monitors...

Josh Hill (ingenium) wrote :

This bug is still affecting me on Trusty, version 1:0.9.11.2+14.04.20140714-0ubuntu1

Robert Hrovat (robi-hipnos) wrote :

Yes, me too. is there any workaround since I can't get deluge window to show no metter what I do?

Manuel Seelaus (seelaman) wrote :

same here, 14.04 with 1:0.9.11+14.04.20140409-0ubuntu.
Adding or removing an external display will drop windows on random workspaces (not all on the first one)

Eduards Bezverhijs (mjasnik) wrote :

Hi, it's not really fixed... I created new user recently and it seems that patch which fixed problem a while ago is gone. Windowses move "somewhere" after I disconnect external display.
Ubuntu 14.04.1
compiz 0.9.11.2+14.04.20140714-0ubuntu1
unity 7.2.3+14.04.20140826-0ubuntu1

schu (schuio) wrote :

Problem still exists.

compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
unity 7.2.3+14.04.20140826-0ubuntu1

The problem is fixed for me with these versions:
ii compiz 1:0.9.11.2+1 all OpenGL window and compositing
man
ii unity 7.2.3+14.04. amd64 Interface designed for
efficiency

On 8 November 2014 17:52, schu <email address hidden> wrote:

> Problem still exists.
>
> compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
> unity 7.2.3+14.04.20140826-0ubuntu1
>
> --
> You received this bug notification because you are a member of AIMS,
> which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/763148
>
> Title:
> Adding/Removing an external monitor causes open windows to move to
> another workspace
>
> Status in Compiz:
> Fix Released
> Status in Compiz 0.9.9 series:
> Fix Committed
> Status in Compiz Core:
> Fix Committed
> Status in “compiz” package in Ubuntu:
> Fix Released
> Status in “compiz” source package in Precise:
> Fix Released
>
> Bug description:
> [Impact]
> Many users will put different windows in different workspaces for better
> work flow. If a user connects and/or disconnects an external monitor or
> projector, all of these windows will be put in the first workspace. Having
> to go back and move all of the windows back to their workspaces is very
> frustrating and time consuming.
>
> [Test Case]
> #. Open some applications in different workspaces.
> #. Plug in an external monitor.
>
> [Regression Potential]
> Very low possibility that a window still ends up in the wrong workspace.
>
> --------------------------------------------
>
> Original description:
> well, i plug in my external screen.
>
> expected behaviour would be, if all of my windows would stay in the
> workspaces i aligned them to, and if they'd be on the same screen i
> had them in the first place.
>
> unfortunatly in unity, if i plug-in (or plug-off) my external screen
> the windows are all around, but not where i'd expect them to be
> (namely in the same place they were before). so i always have to
> toggle expo-mode and re-align all of my windows.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/compiz/+bug/763148/+subscriptions
>
> --
> Mailing list: https://launchpad.net/~aims
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~aims
> More help : https://help.launchpad.net/ListHelp
>

--
  .~.
  /V\ Jan Groenewald
 /( )\ www.aims.ac.za
 ^^-^^

Eduards Bezverhijs (mjasnik) wrote :

Jan,
can You please clarify which versions fixed the problem? Output from dpkg seems to be abrupt in Your comment.

Also what I've checked is that windowses do not move randomly when I connect external display, they are going wild after I disconnect the monitor.

Chris, patches for precise - did You picked them from Trusty based fixes or there are specific new fixes as well?
Shouldn't these be forward-ported to next release which is also having problems?

Hi Eduards,

I'm not really sure what is going on. All the fixes should be in Vivid, Utopic, Trusty. and Precise.

Since this was fixed at one time and seems broken for some people, a new bug should be opened. Please do the normal apport-collect stuff. I will try to provision a secondary monitor to give this a look.

Thanks!

Eduards Bezverhijs (mjasnik) wrote :

Thanks for clarification Chris, will try to make a clean test case and will create a new bug for trusty.

Jan Groenewald (jan-aims) wrote :
Download full text (3.8 KiB)

Hi

Clarifying versions not showing bug for me:

0 root@osprey:~#dpkg -l unity
Desired=Unknown/Install/Remove/Purge/Hold
|
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version
Architecture Description
+++-=======================================-========================-========================-===================================================================================
ii unity 7.2.3+14.04.20140826-0ub
amd64 Interface designed for efficiency of space and
interaction.
0 root@osprey:~#dpkg -l compiz
Desired=Unknown/Install/Remove/Purge/Hold
|
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version
Architecture Description
+++-=======================================-========================-========================-===================================================================================
ii compiz 1:0.9.11.2+14.04.2014071
all OpenGL window and compositing manager
0 root@osprey:~#

Regards,
Jan

On 11 November 2014 17:07, Eduards Bezverhijs <email address hidden> wrote:

> Jan,
> can You please clarify which versions fixed the problem? Output from dpkg
> seems to be abrupt in Your comment.
>
> Also what I've checked is that windowses do not move randomly when I
> connect external display, they are going wild after I disconnect the
> monitor.
>
> Chris, patches for precise - did You picked them from Trusty based fixes
> or there are specific new fixes as well?
> Shouldn't these be forward-ported to next release which is also having
> problems?
>
> --
> You received this bug notification because you are a member of AIMS,
> which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/763148
>
> Title:
> Adding/Removing an external monitor causes open windows to move to
> another workspace
>
> Status in Compiz:
> Fix Released
> Status in Compiz 0.9.9 series:
> Fix Committed
> Status in Compiz Core:
> Fix Committed
> Status in "compiz" package in Ubuntu:
> Fix Released
> Status in "compiz" source package in Precise:
> Fix Released
>
> Bug description:
> [Impact]
> Many users will put different windows in different workspaces for better
> work flow. If a user connects and/or disconnects an external monitor or
> projector, all of these windows will be put in the first workspace. Having
> to go back and move all of the windows back to their workspaces is very
> frustrating and time consuming.
>
> [Test Case]
> #. Open some applications in different workspaces.
> #. Plug in an external monitor.
>
> [Regression Potential]
> Very low possibility that a window still ends up in the wrong workspace.
>
> --------------------------------------------
>
> Original description:
> well, i plug in my external screen.
>
> expected behaviour would be, if all of my windows would stay in the
> workspaces i aligned t...

Read more...

Stephen M. Webb (bregma) wrote :

Closing Compiz 0.9.9 task (0.9.9 series is obsolete)

Dirk Seidel (dseidel) wrote :

I'm on utopic with
compiz-core 1:0.9.12+14.10.20140918-0ubuntu1
and still experience the bug.

Bartosz Kosiorek (gang65) wrote :

@Dirk Seidel (dseidel)
Please create new bug report, and add link here.

Dirk Seidel (dseidel) wrote :

Here is the new bug report for utopic:
https://bugs.launchpad.net/compiz/+bug/1418516

Roland Bock (rbock) wrote :

Yeah, this is still/again an issue in 14.04 (with Unity)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints