kde-window-decorator crashes in gutsy

Reported by Mikael Gerdin on 2007-08-01
80
Affects Status Importance Assigned to Milestone
Compiz
Invalid
High
KDE Base
Invalid
High
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz-kde

kde-window-decorator crashes a lot on my laptop, usually several times per day. Usually it is caused by me starting an application, such as kopete or kontact.
I know I don't have a whole lot of info, but feel free to ask about anything you might require.
I have some backtraces from DrKonqi which I'll attach.

Mikael Gerdin (mgerdin) wrote :

Binary package hint: compiz-kde

kde-window-decorator crashes a lot on my laptop, usually several times per day. Usually it is caused by me starting an application, such as kopete or kontact.
I know I don't have a whole lot of info, but feel free to ask about anything you might require.
I have some backtraces from DrKonqi which I'll attach.

Mikael Gerdin (mgerdin) wrote :
Mikael Gerdin (mgerdin) wrote :
Richard van der Veen (rysh) wrote :

I have this crashing from kde-window-decorator also in Gutsy ... not when starting a program but more when i want to change some configuration settings in this new "System settings" program.

I see both of the above bugs. This makes compiz pretty much impossible (or at least very annoying) to use.

Changed in compiz:
importance: Undecided → Low
Daniel Hahler (blueyed) wrote :

The provided backtraces appear to be quite incomplete.
Please see https://wiki.ubuntu.com/DebuggingProgramCrash for generating a better report.
It might be enough to install the packages compiz-core-dbgsym, compiz-kde-dbgsym and compiz-plugins-dbgsym (after having added the appropriate repositories from the wiki page).
Is there a crash file in /var/crash about this?

Changed in compiz:
status: New → Incomplete
Daniel Hahler (blueyed) wrote :
Download full text (4.0 KiB)

For what it's worth, I had kde-window-decorator also just crashing, right after "compiz --replace" from ALT-F2.

I had compiz running before, switched to virtual console 1, back to 7, which was very slow then. So I've tried "compiz --replace" again, which caused this crash then.

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1226815280 (LWP 9149)]
[KCrash handler]
#6 0xb72f386e in QObject::parent (this=0x18) at ../include/qobject.h:154
#7 0xb72f403f in QWidget::parentWidget (this=0x18, sameWindow=false)
    at ../include/qwidget.h:878
#8 0xb740790b in ~QWidget (this=0x814ed78) at kernel/qwidget.cpp:946
#9 0xb7468b33 in ~QButton (this=0x814ed78) at widgets/qbutton.cpp:410
#10 0xb7c6b791 in ~KCommonDecorationButton (this=0x814ed78)
    at /build/buildd/kdebase-3.5.7/./kwin/lib/kcommondecoration.cpp:887
#11 0xb6c03667 in ~QuartzButton (this=0x814ed78)
    at /build/buildd/kdebase-3.5.7/./kwin/clients/quartz/quartz.cpp:393
#12 0xb7c6e3b4 in ~KCommonDecoration (this=0x8161c78)
    at /build/buildd/kdebase-3.5.7/./kwin/lib/kcommondecoration.cpp:55
#13 0xb6c06b3d in ~QuartzClient (this=0x8161c78)
    at /build/buildd/kdebase-3.5.7/./kwin/clients/quartz/quartz.h:71
#14 0x0805980d in KWD::Window::reloadDecoration (this=0x814dbd0)
    at ../../../kde/window-decorator/window.cpp:1503
#15 0x0805499d in KWD::Decorator::changeShadowOptions (this=0x806e0f8,
    opt=0xbfe66f40) at ../../../kde/window-decorator/decorator.cpp:478
#16 0x08054f7c in dbusHandleMessage (connection=0x8162808, message=0x8137f08,
    userData=0x806e0f8) at ../../../kde/window-decorator/decorator.cpp:183
#17 0xb7ed7c22 in dbus_connection_dispatch () from /usr/lib/libdbus-1.so.3
#18 0xb7c58893 in DBusQt::Connection::dispatchRead ()
   from /usr/lib/libdbus-qt-1.so.1
#19 0xb7c59147 in DBusQt::Connection::qt_invoke ()
   from /usr/lib/libdbus-qt-1.so.1
#20 0xb73ca893 in QObject::activate_signal (this=0x8146310, clist=0x81442f8,
    o=0xbfe670ec) at kernel/qobject.cpp:2356
#21 0xb73cb338 in QObject::activate_signal (this=0x8146310, signal=2)
    at kernel/qobject.cpp:2325
#22 0xb7c59b29 in DBusQt::Internal::Integrator::readReady ()
   from /usr/lib/libdbus-qt-1.so.1
#23 0xb7c59c0f in DBusQt::Internal::Integrator::slotRead ()
   from /usr/lib/libdbus-qt-1.so.1
#24 0xb7c59c8a in DBusQt::Internal::Integrator::qt_invoke ()
   from /usr/lib/libdbus-qt-1.so.1
#25 0xb73ca893 in QObject::activate_signal (this=0x8140f48, clist=0x815d050,
    o=0xbfe67238) at kernel/qobject.cpp:2356
#26 0xb73cb1aa in QObject::activate_signal (this=0x8140f48, signal=2,
    param=10) at kernel/qobject.cpp:2449
#27 0xb775767f in QSocketNotifier::activated (this=0x8140f48, t0=10)
    at .moc/debug-shared-mt/moc_qsocketnotifier.cpp:85
#28 0xb73ed46e in QSocketNotifier::event (this=0x8140f48, e=0xbfe67568)
    at kernel/qsocketnotifier.cpp:258
#29 0xb7361af0 in QApplication::internalNotify (this=0x806e0f8,
    receiver=0x8140f48, e=0xbfe67568) at kernel/qapplication.cpp:2635
#30 0xb736391f in QApplication::notify (this=0x806e0f8, receiver=0x8140f48,
    e=0xbfe67568) at kernel/qapplication.cpp:2358
#31 0xb7e3a242 in KApplicati...

Read more...

Changed in kdebase:
status: Unknown → Invalid
Changed in compiz:
status: Unknown → Confirmed
David Lichterman (lavid) wrote :

kde-window-decorator will also crash, without fail when you move the mouse to the edge of a window so the resize window cursor appears and then scrolling using the scroll wheel on the mouse.
Attached is a backtrace.

Daniel Hahler (blueyed) wrote :

lavid, I cannot reproduce your crash, but if you can, please file a new bug about it and include a useful backtrace there.
See my comment above: you'll need the matching -dbgsym packages, so the required info is present in the backtrace.

I think you should file a new bug, because the problem is a) reproducable and b) probably different.

Mikael Gerdin (mgerdin) wrote :

Finally a more complete backtrace from me..
This crash is triggered whenever i change any widget color settings in KDE.

getaceres (getaceres) wrote :

I've just installed the kubuntu packages over a functional Ubuntu Gutsy installation and trying to use Compiz in KDE is almost impossible since KDE Window Decorator keeps crashing randomly and frequently.
Is there a way to use emerald or Gnome Window Decorator instead?

Bohan (bohan) wrote :

emerald is more stable, install emerald and emerald-themes then start compiz using:

compiz ccp emerald --replace &

.Ru (vodarus) wrote :

I have the same problem:

Installed compiz-kde.
After login to kde - screen become black, then i think x-server decide to run compiz - starting compiz instead of some kde manager.

Experiencing 3 - 4 crashes an hour. No backtrace available as it keeps restarting itself. Nothing from KDE ever goes into /var/crash. output of lspci at the end. I've found the rate of crashes happens the same with and without the 915 extension to the video driver. The following does make it crash nearly every time.

1. Update of settings.
2. Install of any new kde app.
3. Startup music (about 3/4 of the way through every time.)

Occasionally I can get this to make it crash

1. Right click on kicker and choose to lock/unlock the panel
2. Add or remove an applet.
3. Open the menu.
4. loging in (results in lockups and/or partial screen draws.)

Basically Gutsy is almost unusable. Sorry to say that but I'm really frustrated with it.

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
03:01.0 CardBus bridge: Texas Instruments PCI6515 Cardbus Controller
03:01.5 Communication controller: Texas Instruments PCI6515 SmartCard Controller
03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

Christophe Giboudeaux (krop) wrote :

Hello,

Here's my contribution to this bug :
compiz --replace,
then kde-window-decorator --replace.

and kde-window-decorator immediately crashes if I try to manipulate the window. In the attached trace, I just tried to use the mousewheel on the window border.

Christophe Giboudeaux (krop) wrote :

Wrong file, sorry

m4v (m4v) wrote :

kde-window-decorator crashes quite often when I open amarok, here is a backtrace with the debugging packages mentioned adobe

Daniel Hahler (blueyed) on 2007-11-02
Changed in compiz:
status: Incomplete → Confirmed
Travis Watkins (amaranth) wrote :

This should be fixed in the 0.6.2+git20071101-0ubuntu1 package in hardy.

Changed in compiz:
status: Confirmed → Fix Released
Nicolas Piguet (npiguet) wrote :

Will this bug also be fixed for 0.6.0, so that we KDE users have a chance of using compiz as our main window manager on Gutsy?

If not, would it be possible to get a backport of compiz 0.6.2?

Konrad Materka (kmaterka) wrote :

I can confirm too - kde-window-decorator (known as kwd) crashes: startup, setting changing (shadow, colors etc) and many more, but I couldn't try it, because.... it crashed.

Travis Watkins (amaranth) wrote :

There should be a backport available that fixes this problem.

Konrad Materka (kmaterka) wrote :

I lates Hurdy, kde-window-decorator crashen when I make changes in KDE Look & Apperance setting, for example: colors, fonts, antialiasing and much more. In fact, it crashen on almost avery change. Beside this, it is quite stable. Changing Compiz setting (add efects etc) works in most cases (but some settings crash kwd).

Daniel Hahler (blueyed) wrote :

Konrad, please file a new bug report for it.
If the crash gets caught by apport, you can report it from clicking the corresponding .crash file in /var/crash.
Otherwise, a full backtrace would be helpful.
And you may want to look at the upstream/compiz bugtracker, if it's already reported.
Thank you.

Sukoshi (blarghmania) wrote :

I found a simple fix to this, at least when running compiz --replace in session. Run compiz --replace, then after kde-window-decorator crashes, start it again using "kde-window-decorator --replace". If you want to change Compiz settings, it'll crash again, but using that line again should start it up with your new settings.

Konrad Materka (kmaterka) wrote :

But it not solves a problem. I know that I can restart KWD....

I confirm a *lot* of kde-window-decorator crashes in a fresh Kubuntu Hardy install, Intel graphics card. That makes the use of compiz a real pain.

I am seeing this too, under a fresh Hardy install with latest updates and backports. I too have an Intel card (not sure it's specifically relevant).

The decorator is solid, unless I use system settings to change any KDE GUI effects like drop shadow, etc. Then it crashes. This is reproducible on command.

I have installed fusion icon as a way to reload the WM, but it is only a bandaid.

Konrad Materka (kmaterka) wrote :

It is not relevant to intel. i tested it on two nvidia cards and one ati. On ati I had more issues, but not releted to this bug.

KevinM (kevbert1) wrote :

I've just had this crash on Hardy. I'm using Kubuntu 64 bit on an AMD64 +3800 with nVidia Geoforce 7600GS video card. I went to System Settings - Appearance - Windows Decorations and selected the buttons tab. On the pulldown menu just under the buttons tab Kubuntu Edgy or Feisty was selected, so I selected Kubuntu Hardy and pressed Apply. The SIGSEGV error was immediately displayed and my minimise, maximise, and close buttons on the main Appearance -System Settings window disappeared (top righthand corner). Opening up any other window also did not have these three buttons. After a reboot the change looks like it has taken effect.

Xammer (xammer) on 2008-10-11
Changed in compiz:
status: Fix Released → New
Andres Mujica (andres.mujica) wrote :

Kevin, this was previously fixed sometime ago. But it seems that you were affected by this bug again.

Would it be possible for you to confirm if this is still the case with latest Intrepid or Jaunty?

Thanks in advance

Changed in compiz:
status: New → Incomplete
KevinM (kevbert1) wrote :

Hi. I can confirm that this error does not occur in Intrepid 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux kernel with all the latest patches installed. The menu structure has changed slightly and there is no pull-down menu available. No SIGSEGV error occurred if I changed any settings. Tested on same PC as before.

Andres Mujica (andres.mujica) wrote :

Kevin that's great news, thanks for reporting back

Changed in compiz:
status: Incomplete → Fix Released

This code has been changed a bit since this bug report. Please reopen this bug at bugs.opencompositing.org if you still experience it. Sorry for the inconvenience.

Changed in compiz:
status: Confirmed → Invalid
Changed in compiz:
importance: Unknown → High
Changed in compiz:
importance: High → Unknown
Changed in compiz:
importance: Unknown → High
Changed in kdebase:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.