Compiz Configuration Library

GConf backend steals glib events from compiz

Reported by Sam Spilsbury on 2012-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Configuration Library
Critical
Sam Spilsbury
Unity
Critical
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned

Bug Description

   if (CompPlugin::find ("glib"))
       flags |= ProcessEventsNoGlibMainLoopMask;

Since we don't ship the glib plugin by default and compiz uses the glib main loop by default this flag should always be on.

Changed in compiz-core:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.7.4
Changed in compiz-libcompizconfig:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.7.2
Omer Akram (om26er) on 2012-03-26
Changed in unity:
importance: Undecided → Critical
status: New → Confirmed
milestone: none → 5.10.0
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-libcompizconfig at revision 430

Changed in compiz-libcompizconfig:
status: Confirmed → Fix Committed
no longer affects: compiz-core
Changed in unity:
status: Confirmed → Fix Committed
Tim Penhey (thumper) on 2012-04-04
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers