kilo openstack-dashboard fails to install due to missing packages on ubuntu 14.04

Bug #1439837 reported by Roman Lenskij on 2015-04-02
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
horizon (Ubuntu)
High
James Page

Bug Description

Hello,
I'm testing the latest kilo packages and it looks like there are some missing packages.

The following packages have unmet dependencies:
 python-django-horizon : Depends: python-xstatic-term.js but it is not installable
                         Depends: python-xstatic-angular-irdragndrop but it is not installable
E: Unable to correct problems, you have held broken packages.

python-xstatic-angular-irdragndrop this looks to be related to https://bugs.launchpad.net/horizon/+bug/1438543

Roman Lenskij (romanlenskij) wrote :

I'm using Ubuntu Cloud Archive for OpenStack Kilo

Simonas Kareiva (simonask) wrote :

Steps how to reproduce this on a fresh Ubuntu 14.04 instance:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install software-properties-common
sudo add-apt-repository cloud-archive:kilo
sudo apt-get install python-django-horizon

David Lyle (david-lyle) wrote :

I think this is a problem with the package archives for 14.04 rather than, horizon.

Changed in horizon:
status: New → Incomplete
affects: horizon → cloud-archive
Chris Sibbitt (csibbitt) wrote :

It looks like this was fixed in vivid: https://launchpad.net/ubuntu/+source/horizon/1:2015.1~b3-0ubuntu2

If I install the ubuntu2 version of the packages, or just the existing ones with --force-depends I end up with this common django/simplejson problem:

Setting up openstack-dashboard (1:2015.1~b3-0ubuntu1~cloud0) ...
Collecting and compressing static assets...
Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 385, in execute_from_command_line
    utility.execute()
  File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 377, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 238, in fetch_command
    klass = load_command_class(app_name, subcommand)
  File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 41, in load_command_class
    module = import_module('%s.management.commands.%s' % (app_name, name))
  File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/usr/lib/python2.7/dist-packages/compressor/management/commands/compress.py", line 28, in <module>
    from compressor.cache import get_offline_hexdigest, write_offline_manifest
  File "/usr/lib/python2.7/dist-packages/compressor/cache.py", line 8, in <module>
    from django.utils import simplejson
ImportError: cannot import name simplejson
dpkg: error processing package openstack-dashboard (--install):

Chris Sibbitt (csibbitt) wrote :

The packages are in trusty-updates now, but the simplejson issue remains. See: https://bugs.launchpad.net/ubuntu/+source/horizon/+bug/1443787

Chris Sibbitt (csibbitt) wrote :

Confirming that latest trusty-updates including python-compressor_1.4-2ubuntu3~cloud0_all.deb fixed this for me

James Page (james-page) wrote :

Hmm - looks like there is a still a problem - one of the xstatic deps is not being ignored correctly.

Changed in horizon (Ubuntu):
importance: Undecided → High
status: New → In Progress
assignee: nobody → James Page (james-page)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 1:2015.1~rc1-0ubuntu2

---------------
horizon (1:2015.1~rc1-0ubuntu2) vivid; urgency=medium

  * d/pydist-overrides: Amend typo xstatic-angular-irdragndrop ->
    xstatic-angular-lrdragndrop to ensure that embedded xstatic deps are
    correctly ignored when generating dependencies (LP: #1439837).
 -- James Page <email address hidden> Mon, 20 Apr 2015 08:54:52 +0100

Changed in horizon (Ubuntu):
status: In Progress → Fix Released
James Page (james-page) on 2015-04-22
Changed in cloud-archive:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers